Do the sed directly on /usr/bin/wget, making patch-aa redundant.
Suggested by Thomas Klausner.
This commit is contained in:
parent
61406cccd2
commit
9b4ca3400f
3 changed files with 3 additions and 17 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.7 2005/01/11 21:49:33 ppostma Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2005/01/18 15:02:08 ppostma Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tcllib-1.7
|
||||
|
@ -17,7 +17,7 @@ NO_BUILD= yes
|
|||
SUBST_CLASSES= fix
|
||||
SUBST_STAGE.fix= post-patch
|
||||
SUBST_FILES.fix= modules/doctools/mpformats/_html.tcl
|
||||
SUBST_SED.fix= -e "s,@FETCH_CMD@,${FETCH_CMD},g"
|
||||
SUBST_SED.fix= -e "s,/usr/bin/wget -q -O,${FETCH_CMD} -V -o,g"
|
||||
SUBST_MESSAGE.fix= "Fixing hardcoded ftp binary"
|
||||
|
||||
post-patch:
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.3 2005/01/11 21:49:33 ppostma Exp $
|
||||
$NetBSD: distinfo,v 1.4 2005/01/18 15:02:08 ppostma Exp $
|
||||
|
||||
SHA1 (tcllib-1.7.tar.bz2) = 7eb56e0958f66b97a880f9c24bc1ac35955b05df
|
||||
Size (tcllib-1.7.tar.bz2) = 1544908 bytes
|
||||
SHA1 (patch-aa) = b7c093b8f750927dc4a019ae5dde1a55610d0547
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2004/06/13 18:21:25 ppostma Exp $
|
||||
|
||||
--- modules/doctools/mpformats/_html.tcl.orig 2004-05-24 08:20:28.000000000 +0200
|
||||
+++ modules/doctools/mpformats/_html.tcl 2004-06-13 20:06:33.000000000 +0200
|
||||
@@ -86,7 +86,7 @@
|
||||
|
||||
|
||||
proc tcl_cmd {cmd} {return "[markup <b>]\[$cmd][markup </b>]"}
|
||||
-proc wget {url} {exec /usr/bin/wget -q -O - $url 2>/dev/null}
|
||||
+proc wget {url} {exec @FETCH_CMD@ -V -o - $url 2>/dev/null}
|
||||
|
||||
proc url {tag text url} {
|
||||
set body {
|
Loading…
Reference in a new issue