Fix problem with gcc-4.7:

The original sed script eats space chars around '-lpthread',
getting g++: unrecognized option '-pthread-lrt'.
 -- verified on DragonFlyBSD-3.2.2 with gcc-4.7.2
Thanks gdt@ and jmmv@.
This commit is contained in:
Makoto Fujiwara 2012-12-25 13:54:22 +00:00 committed by Thomas Klausner
parent c866dec4df
commit 9cd3cbf2aa
3 changed files with 39 additions and 1 deletions

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.10 2012/12/20 02:05:50 lexort Exp $
$NetBSD: distinfo,v 1.11 2012/12/25 13:54:22 makoto Exp $
SHA1 (fldigi-3.21.63.tar.gz) = a9e59426e0ffc3dbfb50c20109e000992efc7b81
RMD160 (fldigi-3.21.63.tar.gz) = 89bfce19e4a61369f6f811730e345b11baee4fb2
Size (fldigi-3.21.63.tar.gz) = 2122998 bytes
SHA1 (patch-configure) = 7688007c234124257aae8628d237120182765e1f
SHA1 (patch-src_misc_newinstall.cxx) = 2c215e9423d27dd4f4657221b17cf4ed3f12355c
SHA1 (patch-xmlrpc.m4) = c5fa6105663b534a18f2dc3a4860f76297337bb1

View file

@ -0,0 +1,19 @@
$NetBSD: patch-configure,v 1.1 2012/12/25 13:54:22 makoto Exp $
The original sed script eats space chars around '-lpthread',
getting g++: unrecognized option '-pthread-lrt'.
Thus work arround:
--- configure.orig 2012-10-21 05:31:25.000000000 +0900
+++ configure 2012-12-25 20:10:40.816648000 +0900
@@ -9938,8 +9938,8 @@
ac_cv_xmlrpc=yes
test "x$XMLRPC_CFLAGS" = "x" && XMLRPC_CFLAGS=`$XMLRPC_C_CONFIG c++2 abyss-server --cflags`
if test "x$XMLRPC_LIBS" = "x"; then
- XMLRPC_LIBS=`$XMLRPC_C_CONFIG c++2 abyss-server --ldadd | sed s/.-lpthread.//`
+ XMLRPC_LIBS=`$XMLRPC_C_CONFIG c++2 abyss-server --ldadd | sed 's/.-lpthread./ /'`
test "$ac_cv_static" = "yes" && XMLRPC_LIBS="-Wl,-Bstatic $XMLRPC_LIBS -Wl,-Bdynamic"
fi
fi

View file

@ -0,0 +1,17 @@
$NetBSD: patch-xmlrpc.m4,v 1.1 2012/12/25 13:54:23 makoto Exp $
The original sed script eats space chars around '-lpthread',
getting g++: unrecognized option '-pthread-lrt'.
Thus work arround:
--- m4/xmlrpc.m4.orig 2012-12-25 08:59:11.337607000 +0900
+++ m4/xmlrpc.m4 2012-12-25 09:20:27.797219000 +0900
@@ -12,7 +12,7 @@
test "x$XMLRPC_CFLAGS" = "x" && XMLRPC_CFLAGS=`$XMLRPC_C_CONFIG c++2 abyss-server --cflags`
if test "x$XMLRPC_LIBS" = "x"; then
- XMLRPC_LIBS=`$XMLRPC_C_CONFIG c++2 abyss-server --ldadd | sed s/.-lpthread.//`
+ XMLRPC_LIBS=`$XMLRPC_C_CONFIG c++2 abyss-server --ldadd | sed 's/.-lpthread./ /'`
test "$ac_cv_static" = "yes" && XMLRPC_LIBS="-Wl,-Bstatic $XMLRPC_LIBS -Wl,-Bdynamic"
fi
fi