Update libXt to 0.1.5.
Changes: - Merge from X11R6.7. - Various cleanups to Makefile.ams. - Install Shell.h into include/X11 so it can be found. - Adjusted BUILT_SOURCES and CLEANFILES to match. - Move ObjectP.h to include/X11 so it can be found by #includes. - Link with libSM.
This commit is contained in:
parent
fd5ee29efa
commit
9ce83cef8a
4 changed files with 10 additions and 56 deletions
|
@ -1,18 +1,19 @@
|
|||
# $NetBSD: Makefile,v 1.8 2004/05/14 00:54:04 minskim Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2004/06/13 06:53:59 minskim Exp $
|
||||
#
|
||||
|
||||
DISTNAME= libXt-0.1.4
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME}
|
||||
DISTNAME= libXt-0.1.5
|
||||
CATEGORIES= x11 devel
|
||||
MASTER_SITES= http://freedesktop.org/~xlibs/release/xlibs-1.0/
|
||||
MASTER_SITES= http://freedesktop.org/~xlibs/release/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= reed@reedmedia.net
|
||||
HOMEPAGE= http://www.freedesktop.org/Software/X11
|
||||
HOMEPAGE= http://xlibs.freedesktop.org/
|
||||
COMMENT= X Toolkit Intrinsics library
|
||||
|
||||
CONFLICTS+= XFree86-libs-[0-9]*
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
# now includes and builds makestrs
|
||||
|
@ -27,9 +28,7 @@ USE_LIBTOOL= yes
|
|||
|
||||
PKGCONFIG_OVERRIDE+= xt.pc.in
|
||||
|
||||
post-extract:
|
||||
${MV} ${WRKSRC}/ObjectP.h ${WRKSRC}/include/X11/
|
||||
|
||||
.include "../../devel/pkgconfig/buildlink3.mk"
|
||||
.include "../../wip/libICE/buildlink3.mk"
|
||||
.include "../../wip/libSM/buildlink3.mk"
|
||||
.include "../../wip/libX11/buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.3 2004/02/09 18:27:34 jeremy-c-reed Exp $
|
||||
$NetBSD: distinfo,v 1.4 2004/06/13 06:53:59 minskim Exp $
|
||||
|
||||
SHA1 (libXt-0.1.4.tar.bz2) = 316685a1c7c07eceb1b2c063583336f3b358cd36
|
||||
Size (libXt-0.1.4.tar.bz2) = 407934 bytes
|
||||
SHA1 (libXt-0.1.5.tar.bz2) = e4367b8c742defabcbc53ad5091fef688e575166
|
||||
Size (libXt-0.1.5.tar.bz2) = 415938 bytes
|
||||
SHA1 (patch-aa) = a938cabdd5f977393fc06cbe7ce201561fc53eb3
|
||||
SHA1 (patch-ab) = 65633280b8bac053e3a17ce898c22f8b48af2dea
|
||||
SHA1 (patch-ad) = 6489be73fc8010f28c35c69416ee7679b32df52e
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2004/01/31 08:50:48 jeremy-c-reed Exp $
|
||||
|
||||
--- Makefile.in.orig Fri Jan 16 20:14:05 2004
|
||||
+++ Makefile.in
|
||||
@@ -163,7 +163,8 @@ target_alias = @target_alias@
|
||||
|
||||
SUBDIRS = include util
|
||||
|
||||
-AM_CFLAGS = $(RENDER_CFLAGS) $(X_CFLAGS) -I$(top_srcdir)/include/X11
|
||||
+AM_CFLAGS = $(RENDER_CFLAGS) $(X_CFLAGS) -I$(top_srcdir)/include/X11 \
|
||||
+ -I$(top_srcdir)/include
|
||||
|
||||
lib_LTLIBRARIES = libXt.la
|
||||
|
||||
@@ -895,10 +896,11 @@ uninstall-info: uninstall-info-recursive
|
||||
|
||||
|
||||
$(BUILT_SOURCES): $(top_builddir)/util/makestrs
|
||||
- -install $(top_srcdir)/util/*.ht $(top_srcdir)/util/*.ct $(top_builddir)/util/
|
||||
+# -install $(top_srcdir)/util/*.ht $(top_srcdir)/util/*.ct $(top_builddir)/util/
|
||||
$(top_builddir)/util/makestrs $(STRINGSABIOPTIONS) < $(STRING_LIST) > StringDefs.c
|
||||
install -d include/X11/
|
||||
- install -m644 $(top_builddir)/StringDefs.h include/X11/
|
||||
+ install -c -m644 $(top_builddir)/StringDefs.h include/X11/
|
||||
+ install -c -m644 $(top_builddir)/Shell.h include/X11/
|
||||
|
||||
$(top_builddir)/util/makestrs$(EXEEXT): force
|
||||
cd util; $(MAKE)
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2004/01/31 08:50:48 jeremy-c-reed Exp $
|
||||
|
||||
--- include/Makefile.in.orig 2004-01-16 20:14:05.000000000 -0800
|
||||
+++ include/Makefile.in
|
||||
@@ -148,8 +148,10 @@ xtinclude_HEADERS = \
|
||||
X11/Intrinsic.h \
|
||||
X11/IntrinsicP.h \
|
||||
X11/Object.h \
|
||||
+ X11/ObjectP.h \
|
||||
X11/RectObj.h \
|
||||
X11/RectObjP.h \
|
||||
+ X11/Shell.h \
|
||||
X11/ShellP.h \
|
||||
X11/Vendor.h \
|
||||
X11/VendorP.h
|
Loading…
Reference in a new issue