corefx-git: Disable the missing errno symbols

This commit is contained in:
jasonwilliams200ok 2016-02-09 02:30:30 +00:00
parent 45147e5111
commit 9d714db6db
5 changed files with 45 additions and 32 deletions

View file

@ -1,9 +1,10 @@
$NetBSD$
SHA1 (patch-src_Native_CMakeLists.txt) = 07568f980cad506f0c3e3c40448f164dcdd4fcb4
SHA1 (patch-src_Native_CMakeLists.txt) = adc83b19e793491b1c6ea0fd8b46cd9f32e592fc
SHA1 (patch-src_Native_Common_pal__config.h.in) = 37fa257faf95a5da68f9dfa2e609afdaddd1ed9a
SHA1 (patch-src_Native_System.Native_pal__errno.cpp) = 75f34599240aa87699320c6b2fee6c2a8bac2a16
SHA1 (patch-src_Native_System.Native_pal__errno.cpp) = 6a91c84439fe8d8d3d73de5ac7dbba70c929e186
SHA1 (patch-src_Native_System.Native_pal__errno.h) = 809103a7fb2378d936fa6bcea431bc108b7f9d5f
SHA1 (patch-src_Native_System.Native_pal__interfaceaddresses.cpp) = 4f82e6f028fe2b9826ba6afb62869e42a0b6ee3d
SHA1 (patch-src_Native_System.Native_pal__mount.cpp) = 7858f5ff60fcb0d60452648aef1b1034698e2c85
SHA1 (patch-src_Native_System.Native_pal__networking.cpp) = 71183f8f7c68697401468c49216fb249fe0df099
SHA1 (patch-src_Native_System.Native_pal__networking.cpp) = 4f8ef34ed37564978e9370c6f07114b72ef36bd3
SHA1 (patch-src_Native_configure.cmake) = c4d12c3a55c97804fd053c6923df08fe72c4d91d
SHA1 (patch-src_Native_gen-buildsys-clang.sh) = efc34b0da3d11b1c66625336bb4d3c7ac5273b60

View file

@ -1,13 +1,2 @@
$NetBSD$
--- src/Native/CMakeLists.txt.orig 2016-02-07 13:49:29.000000000 +0000
+++ src/Native/CMakeLists.txt
@@ -19,6 +19,8 @@ add_compile_options(-fPIC)
add_compile_options(-I${CMAKE_CURRENT_SOURCE_DIR}/Common)
add_compile_options(-I${CMAKE_CURRENT_BINARY_DIR}/Common)
add_compile_options(-Wno-c99-extensions)
+add_compile_options(-Wno-switch-enum)
+add_compile_options(-Wno-covered-switch-default)
if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS 3.5)
add_compile_options(-Wno-unreachable-code)

View file

@ -46,14 +46,3 @@ $NetBSD$
case PAL_EPERM:
return EPERM;
case PAL_EPIPE:
@@ -339,9 +347,9 @@ extern "C" int32_t SystemNative_ConvertE
case PAL_EXDEV:
return EXDEV;
case PAL_ENONSTANDARD:
+ default:
break; // fall through to assert
}
-
// We should not use this function to round-trip platform -> pal
// -> platform. It's here only to synthesize a platform number
// from the fixed set above. Note that the assert is outside the

View file

@ -0,0 +1,22 @@
$NetBSD$
--- src/Native/System.Native/pal_errno.h.orig 2016-02-07 13:49:29.000000000 +0000
+++ src/Native/System.Native/pal_errno.h
@@ -84,13 +84,17 @@ enum Error : int32_t
PAL_ENOTCONN = 0x10038, // The socket is not connected.
PAL_ENOTDIR = 0x10039, // Not a directory or a symbolic link to a directory.
PAL_ENOTEMPTY = 0x1003A, // Directory not empty.
+#ifdef ENOTRECOVERABLE
PAL_ENOTRECOVERABLE = 0x1003B, // State not recoverable.
+#endif
PAL_ENOTSOCK = 0x1003C, // Not a socket.
PAL_ENOTSUP = 0x1003D, // Not supported (same value as EOPNOTSUP).
PAL_ENOTTY = 0x1003E, // Inappropriate I/O control operation.
PAL_ENXIO = 0x1003F, // No such device or address.
PAL_EOVERFLOW = 0x10040, // Value too large to be stored in data type.
+#ifdef EOWNERDEAD
PAL_EOWNERDEAD = 0x10041, // Previous owner died.
+#endif
PAL_EPERM = 0x10042, // Operation not permitted.
PAL_EPIPE = 0x10043, // Broken pipe.
PAL_EPROTO = 0x10044, // Protocol error.

View file

@ -262,19 +262,31 @@ $NetBSD$
assert(currentEvents != newEvents);
@@ -2337,7 +2494,11 @@ static Error TryChangeSocketEventRegistr
(newEvents & PAL_SA_READ) == 0 ? RemoveFlags : AddFlags,
0,
0,
@@ -2331,6 +2488,15 @@ static Error TryChangeSocketEventRegistr
int i = 0;
if (readChanged)
{
+#if KEVENT_HAS_NUMERIC_DATA
+ EV_SET(&events[i++],
+ static_cast<uint64_t>(socket),
+ EVFILT_READ,
+ (newEvents & PAL_SA_READ) == 0 ? RemoveFlags : AddFlags,
+ 0,
+ 0,
+ data);
+#else
EV_SET(&events[i++],
static_cast<uint64_t>(socket),
EVFILT_READ,
@@ -2338,6 +2504,7 @@ static Error TryChangeSocketEventRegistr
0,
0,
reinterpret_cast<void*>(data));
+#endif
}
if (writeChanged)
@@ -2348,11 +2509,15 @@ static Error TryChangeSocketEventRegistr
@@ -2348,11 +2515,15 @@ static Error TryChangeSocketEventRegistr
(newEvents & PAL_SA_WRITE) == 0 ? RemoveFlags : AddFlags,
0,
0,
@ -291,7 +303,7 @@ $NetBSD$
return err == 0 ? PAL_SUCCESS : SystemNative_ConvertErrorPlatformToPal(errno);
}
@@ -2364,7 +2529,11 @@ static Error WaitForSocketEventsInner(in
@@ -2364,7 +2535,11 @@ static Error WaitForSocketEventsInner(in
auto* events = reinterpret_cast<struct kevent*>(buffer);
int numEvents;
@ -303,7 +315,7 @@ $NetBSD$
if (numEvents == -1)
{
*count = -1;
@@ -2382,7 +2551,11 @@ static Error WaitForSocketEventsInner(in
@@ -2382,7 +2557,11 @@ static Error WaitForSocketEventsInner(in
{
// This copy is made deliberately to avoid overwriting data.
struct kevent evt = events[i];