Move clisp-current to clisp.

Steal maintainership. Johann, when you return, talk to me!
This commit is contained in:
Aleksej Saushev 2009-01-17 09:19:23 +00:00 committed by Thomas Klausner
parent 3aec582b8f
commit 9dcb741a91
12 changed files with 25 additions and 346 deletions

View file

@ -1,4 +1,4 @@
# $Id: Makefile,v 1.3208 2009/01/15 23:03:26 phonohawk Exp $
# $Id: Makefile,v 1.3209 2009/01/17 09:19:23 asau Exp $
#
COMMENT= WIP pkgsrc packages
@ -206,7 +206,6 @@ SUBDIR+= clamassassin
SUBDIR+= clhep
SUBDIR+= clips
SUBDIR+= clisp
SUBDIR+= clisp-current
SUBDIR+= clockspeed
SUBDIR+= clustalx
SUBDIR+= codeblocks

View file

@ -1,14 +0,0 @@
Common Lisp is a high-level, general-purpose programming language. GNU
CLISP is a Common Lisp implementation by Bruno Haible of Karlsruhe
University and Michael Stoll of Munich University, both in Germany.
It mostly supports the Lisp described in the ANSI Common Lisp standard.
It runs on microcomputers (Windows NT/2000/XP, Windows 95/98/ME) as well
as on Unix workstations (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, BeOS,
NeXTstep, SGI, AIX and others) and needs only 2 MB of RAM.
The user interface comes in German, English, French, Spanish, Dutch and
Russian. GNU CLISP includes an interpreter, a compiler, a debugger,
CLOS, a foreign language interface, sockets, i18n, fast bignums and
more. An X11 interface is available through CLX, Garnet, CLUE/CLIO. GNU
CLISP runs Maxima, ACL2 and many other Common Lisp packages.

View file

@ -1,63 +0,0 @@
# $NetBSD: Makefile,v 1.28 2008/12/31 13:43:38 asau Exp $
#
DISTNAME= clisp-2.47
PKGNAME= clisp-2.47.99 # needed because of cvs-package.mk
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=clisp/}
MAINTAINER= jfranz@bsdprojects.net
HOMEPAGE= http://clisp.cons.org/
COMMENT= CLISP, a Common Lisp implementation
CVS_REPOSITORIES= clisp
CVS_ROOT.clisp= :pserver:anonymous:@clisp.cvs.sourceforge.net:/cvsroot/clisp
WRKSRC= ${WRKDIR}/clisp
# Sparc64 has assembler code problems, see
# http://sourceforge.net/tracker/index.php?func=detail&aid=952681&group_id=1355&atid=101355
NOT_FOR_PLATFORM= *-*-sparc64
NOT_FOR_PLATFORM+= *-*-arm
PKG_INSTALLATION_TYPES= overwrite pkgviews
PKG_DESTDIR_SUPPORT= user-destdir
MAKE_JOBS_SAFE= no
CONFIGURE_DIRS= .
USE_GNU_CONFIGURE_HOST= NO # work around broken reasoning: "configure --host=..." => cross-building
BUILD_DIRS= src
GNU_CONFIGURE= YES
USE_LIBTOOL= YES
USE_PKGLOCALEDIR= YES
USE_TOOLS+= dvipdf
UNLIMIT_RESOURCES= stacksize
CONFIGURE_ARGS+= --disable-maintainer-mode
CONFIGURE_ARGS+= --fsstnd=netbsd
#CONFIGURE_ARGS+= --without-included-regex # see options
CONFIGURE_ARGS+= --with-gettext
MAKE_FLAGS+= docdir=${PREFIX}/share/doc/${PKGBASE}
MAKE_FLAGS+= mandir=${PREFIX}/${PKGMANDIR}
MAKE_FLAGS+= elispdir="${PREFIX}/share/${PKGBASE}/emacs"
MAKE_FLAGS+= vimdir="${PREFIX}/share/${PKGBASE}/vim"
TEST_TARGET= check mod-check
.include "../../mk/bsd.prefs.mk"
.if ${MACHINE_ARCH:Malpha} || ${MACHINE_ARCH:Mamd64} || ${MACHINE_ARCH:Mx86_64} || ${OPSYS} == "DragonFly"
CONFIGURE_ARGS+= --disable-mmap
.endif
.include "options.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
BUILDLINK_API_DEPENDS.libsigsegv+= libsigsegv>=2.4
.include "../../devel/libsigsegv/buildlink3.mk"
.include "../../wip/mk/cvs-package.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,103 +0,0 @@
@comment $NetBSD: PLIST,v 1.8 2008/12/31 13:43:38 asau Exp $
bin/clisp
lib/clisp/base/calls.o
lib/clisp/base/gettext.o
lib/clisp/base/libnoreadline.a
lib/clisp/base/lisp.a
lib/clisp/base/lisp.run
lib/clisp/base/lispinit.mem
lib/clisp/base/localcharset.o
lib/clisp/base/makevars
lib/clisp/base/modules.h
lib/clisp/base/modules.o
lib/clisp/base/readline.o
${PLIST.regexp}lib/clisp/base/regex.o
lib/clisp/base/regexi.o
lib/clisp/base/regexp.dvi
lib/clisp/base/uniname.o
lib/clisp/base/width.o
lib/clisp/clisp-link
lib/clisp/data/Symbol-Table.text
lib/clisp/data/UnicodeDataFull.txt
${PLIST.bdb}lib/clisp/full/bdb.o
lib/clisp/full/calls.o
${PLIST.mit-clx}lib/clisp/full/clx.o
${PLIST.new-clx}lib/clisp/full/clx.o
${PLIST.pcre}lib/clisp/full/cpcre.o
${PLIST.fastcgi}lib/clisp/full/fastcgi.o
${PLIST.fastcgi}lib/clisp/full/fastcgi_wrappers.o
lib/clisp/full/gettext.o
${PLIST.gdbm}lib/clisp/full/gdbm.o
${PLIST.gtk2}lib/clisp/full/gtk.o
lib/clisp/full/libnoreadline.a
lib/clisp/full/lisp.a
lib/clisp/full/lisp.run
lib/clisp/full/lispinit.mem
lib/clisp/full/localcharset.o
lib/clisp/full/makevars
lib/clisp/full/modules.h
lib/clisp/full/modules.o
${PLIST.pgsql}lib/clisp/full/postgresql.o
${PLIST.rawsock}lib/clisp/full/rawsock.o
lib/clisp/full/readline.o
${PLIST.regexp}lib/clisp/full/regex.o
lib/clisp/full/regexi.o
lib/clisp/full/regexp.dvi
lib/clisp/full/uniname.o
lib/clisp/full/width.o
${PLIST.wildcard}lib/clisp/full/wildcard.dvi
${PLIST.wildcard}lib/clisp/full/wildcard.o
${PLIST.zlib}lib/clisp/full/zlib.o
lib/clisp/linkkit/clisp.h
lib/clisp/linkkit/modprep.lisp
lib/clisp/linkkit/modules.c
man/man1/clisp.1
share/clisp/emacs/clhs.el
share/clisp/emacs/clisp-coding.el
share/clisp/emacs/clisp-ffi.el
share/clisp/emacs/clisp-indent.el
share/clisp/emacs/clisp-indent.lisp
share/clisp/vim/lisp.vim
share/doc/clisp/ANNOUNCE
share/doc/clisp/CLOS-guide.txt
share/doc/clisp/COPYRIGHT
share/doc/clisp/GNU-GPL
share/doc/clisp/LISP-tutorial.txt
share/doc/clisp/MAGIC.add
share/doc/clisp/NEWS
share/doc/clisp/README
share/doc/clisp/README.de
share/doc/clisp/README.es
share/doc/clisp/SUMMARY
share/doc/clisp/clisp.1
share/doc/clisp/clisp.dvi
share/doc/clisp/clisp.html
share/doc/clisp/clisp.pdf
share/doc/clisp/clisp.png
share/doc/clisp/clisp.ps
share/doc/clisp/editors.txt
share/doc/clisp/impnotes.css
share/doc/clisp/impnotes.html
share/locale/da/LC_MESSAGES/clisp.mo
share/locale/da/LC_MESSAGES/clisplow.mo
share/locale/de/LC_MESSAGES/clisp.mo
share/locale/de/LC_MESSAGES/clisplow.mo
share/locale/en/LC_MESSAGES/clisp.mo
share/locale/en/LC_MESSAGES/clisplow.mo
share/locale/es/LC_MESSAGES/clisp.mo
share/locale/es/LC_MESSAGES/clisplow.mo
share/locale/fr/LC_MESSAGES/clisp.mo
share/locale/fr/LC_MESSAGES/clisplow.mo
share/locale/nl/LC_MESSAGES/clisp.mo
share/locale/nl/LC_MESSAGES/clisplow.mo
share/locale/ru/LC_MESSAGES/clisp.mo
share/locale/ru/LC_MESSAGES/clisplow.mo
@dirrm share/doc/clisp
@dirrm share/clisp/vim
@dirrm share/clisp/emacs
@dirrm share/clisp
@dirrm lib/clisp/linkkit
@dirrm lib/clisp/full
@dirrm lib/clisp/data
@dirrm lib/clisp/base
@dirrm lib/clisp

View file

@ -1,3 +0,0 @@
$NetBSD: distinfo,v 1.6 2008/05/28 10:27:50 asau Exp $
SHA1 (patch-aa) = d2f1de2e0f3e02ccf4ece2a7b1ed0ce6ba025af2

View file

@ -1,128 +0,0 @@
# $NetBSD: options.mk,v 1.16 2008/12/31 13:43:38 asau Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.clisp
# this option is essential for some others to work:
PKG_SUPPORTED_OPTIONS+= ffcall
# some regular expression libraries don't pass tests:
PKG_SUPPORTED_OPTIONS+= regexp
PKG_SUPPORTED_OPTIONS+= pgsql gdbm bdb pcre rawsock pari fastcgi wildcard gtk2 zlib
PKG_SUPPORTED_OPTIONS+= readline
PKG_OPTIONS_OPTIONAL_GROUPS= x11-bindings
PKG_OPTIONS_GROUP.x11-bindings= mit-clx new-clx
PKG_SUPPORTED_OPTIONS+= gmalloc
PKG_SUGGESTED_OPTIONS+= ffcall pcre rawsock readline zlib
# CLISP doesn't work with jemalloc:
.if ${OPSYS} == "NetBSD"
PKG_SUGGESTED_OPTIONS+= gmalloc
PKG_SUGGESTED_OPTIONS+= regexp
.elif ${OPSYS} == "FreeBSD" && !empty(OS_VERSION:N[0-6].*)
PKG_SUGGESTED_OPTIONS+= gmalloc
.endif
.include "../../mk/bsd.prefs.mk"
.include "../../mk/bsd.options.mk"
PLIST_VARS+= ${PKG_SUPPORTED_OPTIONS}
.for option in ${PKG_SUPPORTED_OPTIONS}
. if !empty(PKG_OPTIONS:M${option})
PLIST.${option}= yes
. endif
.endfor
.if !empty(PKG_OPTIONS:Mgmalloc)
CONFIGURE_ARGS+= --with-gmalloc
.endif
# ffcall is required for other options to work
.if !empty(PKG_OPTIONS:Mpgsql) && empty(PKG_OPTIONS:Mffcall)
PKG_OPTIONS+= ffcall
.endif
.if !empty(PKG_OPTIONS:Mffcall)
CONFIGURE_ARGS+= --with-dynamic-ffi
. include "../../devel/ffcall/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mregexp)
CONFIGURE_ARGS+= --with-included-regex
.else
CONFIGURE_ARGS+= --without-included-regex
.endif
.if !empty(PKG_OPTIONS:Mpgsql)
CONFIGURE_ARGS+= --with-module=postgresql
. include "../../mk/pgsql.buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mgdbm)
CONFIGURE_ARGS+= --with-module=gdbm
. include "../../databases/gdbm/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mbdb)
# it requires version 4, not anything older
CONFIGURE_ARGS+= --with-module=berkeley-db
BUILDLINK_TRANSFORM+= l:db:db46
. include "../../databases/db46/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mpcre)
CONFIGURE_ARGS+= --with-module=pcre
. include "../../devel/pcre/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mrawsock)
CONFIGURE_ARGS+= --with-module=rawsock
.endif
.if !empty(PKG_OPTIONS:Mpari)
CONFIGURE_ARGS+= --with-module=pari
. include "../../math/pari/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mfastcgi)
CONFIGURE_ARGS+= --with-module=fastcgi
. include "../../www/fcgi/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mnew-clx)
CONFIGURE_ARGS+= --with-module=clx/new-clx
. include "../../x11/libX11/buildlink3.mk"
. include "../../x11/libXau/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mmit-clx)
CONFIGURE_ARGS+= --with-module=clx/mit-clx
. include "../../x11/libX11/buildlink3.mk"
. include "../../x11/libXau/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mgtk2)
CONFIGURE_ARGS+= --with-module=gtk2
. include "../../devel/libglade/buildlink3.mk"
. include "../../x11/gtk2/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mwildcard)
CONFIGURE_ARGS+= --with-module=wildcard
.endif
.if !empty(PKG_OPTIONS:Mzlib)
CONFIGURE_ARGS+= --with-module=zlib
BUILDLINK_API_DEPENDS.zlib+= zlib>=1.2
.include "../../devel/zlib/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mreadline)
USE_GNU_READLINE= YES
CONFIGURE_ARGS+= --with-readline
.include "../../devel/readline/buildlink3.mk"
.endif

View file

@ -1,23 +0,0 @@
$NetBSD: patch-aa,v 1.2 2008/01/06 13:22:17 netcap Exp $
Don't use cache file to avoid trailing space problem.
--- src/makemake.in.orig 2008-01-03 20:28:49.000000000 +0100
+++ src/makemake.in
@@ -1881,6 +1881,7 @@ echol "psdir = ${PSDIR}"
echol "pdfdir = ${PDFDIR}"
echol "libdir = ${LIBDIR}"
echol "lisplibdir = \$(libdir)${NEXT_}\$(TOPDIR)"
+echol "lisplibdir = \$(libdir)${NEXT_}clisp"
if [ -n "$USE_GETTEXT" ] ; then
echol "localedir = ${LOCALEDIR}"
fi
@@ -3342,7 +3343,7 @@ echotab " if test \"\$\${ac_cv_env_
echotab " if test \"\$\${ac_cv_env_CFLAGS_set}\" = set; then CFLAGS=\"\$\${ac_cv_env_CFLAGS_value}\"; export CFLAGS; fi; \\"
# we must use $(SHELL) for sub-configures because when the top CONFIG_SHELL
# is bash, config.cache may be unparsable with sh on Solaris
-echotab " \$(SHELL) ./configure --cache-file=\$\${cache} --srcdir=\$\$m \$(MODULE_CONFIGURE_FLAGS);\\"
+echotab " \$(SHELL) ./configure --srcdir=\$\$m \$(MODULE_CONFIGURE_FLAGS);\\"
echotab " else \$(SHELL) ./configure --srcdir=\$\$m \$(MODULE_CONFIGURE_FLAGS); \\"
echotab " fi ) ;\\"
echotab "fi"

View file

@ -1,15 +1,19 @@
# $NetBSD: Makefile,v 1.17 2008/10/26 16:26:08 asau Exp $
# $NetBSD: Makefile,v 1.18 2009/01/17 09:19:24 asau Exp $
#
DISTNAME= clisp-2.47
PKGNAME= clisp-2.47.99 # needed because of cvs-package.mk
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=clisp/}
#EXTRACT_SUFX= .tar.bz2
MAINTAINER= asau@inbox.ru
HOMEPAGE= http://clisp.cons.org/
COMMENT= CLISP, a Common Lisp implementation
CVS_REPOSITORIES= clisp
CVS_ROOT.clisp= :pserver:anonymous:@clisp.cvs.sourceforge.net:/cvsroot/clisp
WRKSRC= ${WRKDIR}/clisp
# Sparc64 has assembler code problems, see
# http://sourceforge.net/tracker/index.php?func=detail&aid=952681&group_id=1355&atid=101355
NOT_FOR_PLATFORM= *-*-sparc64
@ -32,7 +36,7 @@ UNLIMIT_RESOURCES= stacksize
CONFIGURE_ARGS+= --disable-maintainer-mode
CONFIGURE_ARGS+= --fsstnd=netbsd
CONFIGURE_ARGS+= --without-included-regex
#CONFIGURE_ARGS+= --without-included-regex # see options
CONFIGURE_ARGS+= --with-gettext
MAKE_FLAGS+= docdir=${PREFIX}/share/doc/${PKGBASE}
MAKE_FLAGS+= mandir=${PREFIX}/${PKGMANDIR}
@ -55,4 +59,5 @@ CONFIGURE_ARGS+= --disable-mmap
BUILDLINK_API_DEPENDS.libsigsegv+= libsigsegv>=2.4
.include "../../devel/libsigsegv/buildlink3.mk"
.include "../../wip/mk/cvs-package.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.5 2008/10/26 14:31:45 asau Exp $
@comment $NetBSD: PLIST,v 1.6 2009/01/17 09:19:24 asau Exp $
bin/clisp
lib/clisp/base/calls.o
lib/clisp/base/gettext.o
@ -11,6 +11,7 @@ lib/clisp/base/makevars
lib/clisp/base/modules.h
lib/clisp/base/modules.o
lib/clisp/base/readline.o
${PLIST.regexp}lib/clisp/base/regex.o
lib/clisp/base/regexi.o
lib/clisp/base/regexp.dvi
lib/clisp/base/uniname.o
@ -39,6 +40,7 @@ lib/clisp/full/modules.o
${PLIST.pgsql}lib/clisp/full/postgresql.o
${PLIST.rawsock}lib/clisp/full/rawsock.o
lib/clisp/full/readline.o
${PLIST.regexp}lib/clisp/full/regex.o
lib/clisp/full/regexi.o
lib/clisp/full/regexp.dvi
lib/clisp/full/uniname.o

View file

@ -1,6 +1,3 @@
$NetBSD: distinfo,v 1.11 2008/10/26 16:26:08 asau Exp $
$NetBSD: distinfo,v 1.12 2009/01/17 09:19:24 asau Exp $
SHA1 (clisp-2.47.tar.gz) = 537222b2633a09847bd9864bcfe68e69a856f08b
RMD160 (clisp-2.47.tar.gz) = e084fbd9b77266f36655789c42f91653cb06365c
Size (clisp-2.47.tar.gz) = 9175929 bytes
SHA1 (patch-aa) = d2f1de2e0f3e02ccf4ece2a7b1ed0ce6ba025af2

View file

@ -1,10 +1,13 @@
# $NetBSD: options.mk,v 1.7 2008/10/26 14:23:59 asau Exp $
# $NetBSD: options.mk,v 1.8 2009/01/17 09:19:24 asau Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.clisp
# this option is essential for some others to work:
PKG_SUPPORTED_OPTIONS+= ffcall
# some regular expression libraries don't pass tests:
PKG_SUPPORTED_OPTIONS+= regexp
PKG_SUPPORTED_OPTIONS+= pgsql gdbm bdb pcre rawsock pari fastcgi wildcard gtk2 zlib
PKG_SUPPORTED_OPTIONS+= readline
@ -18,6 +21,7 @@ PKG_SUGGESTED_OPTIONS+= ffcall pcre rawsock readline zlib
# CLISP doesn't work with jemalloc:
.if ${OPSYS} == "NetBSD"
PKG_SUGGESTED_OPTIONS+= gmalloc
PKG_SUGGESTED_OPTIONS+= regexp
.elif ${OPSYS} == "FreeBSD" && !empty(OS_VERSION:N[0-6].*)
PKG_SUGGESTED_OPTIONS+= gmalloc
.endif
@ -47,6 +51,12 @@ CONFIGURE_ARGS+= --with-dynamic-ffi
. include "../../devel/ffcall/buildlink3.mk"
.endif
.if !empty(PKG_OPTIONS:Mregexp)
CONFIGURE_ARGS+= --with-included-regex
.else
CONFIGURE_ARGS+= --without-included-regex
.endif
.if !empty(PKG_OPTIONS:Mpgsql)
CONFIGURE_ARGS+= --with-module=postgresql
. include "../../mk/pgsql.buildlink3.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: patch-aa,v 1.3 2008/05/18 13:51:47 asau Exp $
$NetBSD: patch-aa,v 1.4 2009/01/17 09:19:24 asau Exp $
Don't use cache file to avoid trailing space problem.