Synchronize with upstream.

1.13
  - binary editing (bit toggling)
  - minor interface improvments
This commit is contained in:
Lubomir Rintel 2007-02-16 11:55:20 +00:00 committed by Thomas Klausner
parent ea3f4f8834
commit 9eeec74cdd
4 changed files with 22 additions and 16 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.2 2006/07/16 16:08:39 shattered Exp $
# $NetBSD: Makefile,v 1.3 2007/02/16 11:55:20 lkundrak Exp $
DISTNAME= shed-1.12
DISTNAME= shed-1.13
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=shed/}

View file

@ -1,3 +1,7 @@
Some escape-sequencies are different on BSD and Linux (and probably other
unices). Notably, number constants for pgup and pgdn, and, very likely,
many other.
ncurses -> curses?
=== Candidate for removal ===
If you feel this package would be usable, please take it.

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1 2005/12/11 11:15:13 lkundrak Exp $
$NetBSD: distinfo,v 1.2 2007/02/16 11:55:20 lkundrak Exp $
SHA1 (shed-1.12.tar.gz) = 26818d0d4c5710886ca1ef12dd741572d4893dae
RMD160 (shed-1.12.tar.gz) = f43c7db2f626969ac4db0aaeb86b5f7ca0205eaf
Size (shed-1.12.tar.gz) = 57934 bytes
SHA1 (patch-aa) = 4efc4ab3822cd3f11874780982ece4aec6cfeaf8
SHA1 (shed-1.13.tar.gz) = 09421d55caa1cb3b3becc8a58a8fbc63a2399d32
RMD160 (shed-1.13.tar.gz) = 6b6445a2da3df151673c6fa16602d7ad5d236e2f
Size (shed-1.13.tar.gz) = 78699 bytes
SHA1 (patch-aa) = de42c2d9974f3305c6824bb802efb2d58fcb0749

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.1 2005/12/11 11:15:13 lkundrak Exp $
$NetBSD: patch-aa,v 1.2 2007/02/16 11:55:20 lkundrak Exp $
--- shed.c.orig 2005-09-06 00:41:00.000000000 +0200
--- shed.c.orig 2007-02-16 12:50:09.000000000 +0100
+++ shed.c
@@ -231,8 +231,8 @@ int mainloop(int getstrmode) {
@@ -231,8 +231,9 @@ int mainloop() {
case 8: /* ^H */
if(strlen(reply)) {
reply[strlen(reply)-1] = 0;
@ -10,17 +10,19 @@ $NetBSD: patch-aa,v 1.1 2005/12/11 11:15:13 lkundrak Exp $
- move(stdscr->_cury,stdscr->_curx-1);
+ mvaddch(getcury(stdscr),getcurx(stdscr)-1,' ');
+ move(getcury(stdscr),getcurx(stdscr)-1);
+
}
break;
@@ -271,7 +271,9 @@ int mainloop(int getstrmode) {
default:
@@ -264,7 +265,10 @@ int mainloop() {
}
}
redraw();
- key = toupper(getch());
+ key = getch();
+ if (isalpha (key))
+ key = toupper(key);
+
switch(key) {
case KEY_UP:
cursorup(1);