Update to 5.3

* regen patch

Changelog:
2011-04-26 Erwin Waterlander <waterlan@xs4all.nl>
	* Version 5.3

2011-04-23 Erwin Waterlander <waterlan@xs4all.nl>
	* Don't report an error when unlink() fails because a file
	  doesn't exist.

2011-04-13 Erwin Waterlander <waterlan@xs4all.nl>
	* Print system error when input file can't be openened.
	  For instance "Permission denied"
	* Update manuals.
	* Update translations.

2011-04-04 Erwin Waterlander <waterlan@xs4all.nl>
	* Always print and return an error when wrong command-line
	  options are used. Also in quiet mode.
	* New option '--': Treat all following options as file names.

2011-04-03 Erwin Waterlander <waterlan@xs4all.nl>
	* Improved error reporting. Return system error when an error occurs.
	* Don't quit after first error (like rm, ls, grep, tar).
	* In quiet mode the return value is always zero.

2011-03-27 Erwin Waterlander <waterlan@xs4all.nl>
	* dos2unix.c/unix2dos.c: Check if symbolic links point to
	  regular files.
	* dos2unix.c/unix2dos.c: Added short options -F, -R, -S.
	* po: update translations.

2011-03-24 Erwin Waterlander <waterlan@xs4all.nl>
	* dos2unix.c/unix2dos.c: Changed options --follow, --no-follow,
	  to  --follow-symlink,  --replace-symlink,  --skip-symlink.
	* dos2unix.c/unix2dos.c: Options --force and --safe are only to
	  covert binary files or skip them.
	* dos2unix.c/unix2dos.c: Non-regular files that are not symbolic
	  links are never converted.

2011-03-23 Chris Wilson <cygwin@cwilson.fastmail.fm>
	* dos2unix.c/unix2dos.c: New options --follow and --no-follow.
	  In follow mode dos2unix writes to the symlink target, instead
	  of replacing the symbolic link with an output file.

2011-03-22 Chris Wilson <cygwin@cwilson.fastmail.fm>
	* querycp.c: Behave on Cygwin same as on Linux. Default
	  code page in ISO mode is CP437.

2011-03-21 Chris Wilson <cygwin@cwilson.fastmail.fm>
	* dos2unix.c/unix2dos.c:
	  - Cygwin may define WIN32 (via include files).
	  - bugfix: Cygwin: set mode to binary in stdio mode conversion.
	    Needed in case non-Cygwin program launches dos2unix.
	  - bugfix: set failure mode if rename fails in quiet mode.
	  - New option: -s, --safe. Opposite of -f, --force.
	* Makefile: Cleanup for Cygwin.

2011-03-19 Erwin Waterlander <waterlan@xs4all.nl>
	* Makefile: Install links instead of binary/manpage copies on Cygwin.

2011-03-05 Erwin Waterlander <waterlan@xs4all.nl>
	* man/man1/dos2unix.pod: Replace GPL with FreeBSD license.
	* man/nl/man1/dos2unix.pod: Replace GPL with FreeBSD license.
This commit is contained in:
Ryo ONODERA 2011-04-29 22:54:29 +00:00 committed by Thomas Klausner
parent bcca218295
commit 9f287d5e13
3 changed files with 10 additions and 10 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.2 2011/03/06 09:51:23 ryo-on Exp $
# $NetBSD: Makefile,v 1.3 2011/04/29 22:54:29 ryo-on Exp $
#
DISTNAME= dos2unix-5.2.1
DISTNAME= dos2unix-5.3
CATEGORIES= converters
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=dos2unix/}

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2011/03/06 09:51:23 ryo-on Exp $
$NetBSD: distinfo,v 1.3 2011/04/29 22:54:29 ryo-on Exp $
SHA1 (dos2unix-5.2.1.tar.gz) = 79e1dbb3753e029d2a5b0d65f3f512d09cbc6f79
RMD160 (dos2unix-5.2.1.tar.gz) = 0bcce6e16dd94fa85a6cbcb44dc72d5c30db062a
Size (dos2unix-5.2.1.tar.gz) = 52877 bytes
SHA1 (dos2unix-5.3.tar.gz) = c12d59761ebd7c82f79672ce99465dd924a66628
RMD160 (dos2unix-5.3.tar.gz) = ab963cda802474b0519e18f6f6db10cc350c4bda
Size (dos2unix-5.3.tar.gz) = 62325 bytes
SHA1 (patch-Makefile) = 54cc5f3e3cc5f2e67c0f8464fbf853150cce6b1a

View file

@ -1,11 +1,11 @@
$NetBSD: patch-Makefile,v 1.2 2011/03/06 09:51:23 ryo-on Exp $
$NetBSD: patch-Makefile,v 1.3 2011/04/29 22:54:29 ryo-on Exp $
* install man pages to ${PREFIX}/man
* do not generate ps, pdf, and html documents
--- Makefile.orig 2011-03-02 16:35:32.000000000 +0000
--- Makefile.orig 2011-03-21 18:42:27.000000000 +0000
+++ Makefile
@@ -73,7 +73,7 @@ datadir = $(datarootdir)
@@ -70,7 +70,7 @@ datadir = $(datarootdir)
docsubdir = $(PACKAGE)-$(DOS2UNIX_VERSION)
docdir = $(datarootdir)/doc/$(docsubdir)
localedir = $(datarootdir)/locale
@ -14,7 +14,7 @@ $NetBSD: patch-Makefile,v 1.2 2011/03/06 09:51:23 ryo-on Exp $
man1dir = $(mandir)/man1
manext = .1
man1ext = .1
@@ -313,11 +313,11 @@ else
@@ -318,11 +318,11 @@ else
cd $(DESTDIR)$(man1dir); $(LINK_MAN) $(PACKAGE).1 $(UNIX2DOS).1
cd $(DESTDIR)$(man1dir); $(LINK_MAN) $(PACKAGE).1 $(UNIX2MAC).1
endif