Initial import of p5-Authen-SASL-Cyrus, version 0.07. Perls are forever.

SASL is a generic mechanism for authentication used by several
network protocols. Authen::SASL provides an implementation
framework that all protocols should be able to share.

The XS framework makes calls into the existing libsasl.so
shared library to perform SASL client connection functionality,
including loading existing shared library mechanisms.

Authen::SASL::Cyrus implements XS SASL Authentication.
This commit is contained in:
Quentin Garnier 2003-06-16 12:23:01 +00:00
parent 53fa5d2cb3
commit 9f3168830a
5 changed files with 47 additions and 0 deletions

View file

@ -0,0 +1,9 @@
SASL is a generic mechanism for authentication used by several
network protocols. Authen::SASL provides an implementation
framework that all protocols should be able to share.
The XS framework makes calls into the existing libsasl.so
shared library to perform SASL client connection functionality,
including loading existing shared library mechanisms.
Authen::SASL::Cyrus implements XS SASL Authentication.

View file

@ -0,0 +1,19 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/06/16 12:23:01 cubidou Exp $
DISTNAME= Authen-SASL-Cyrus-0.07
PKGNAME= p5-${DISTNAME}
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Authen/}
MAINTAINER= cube@cubidou.net
HOMEPAGE= http://search.cpan.org/dist/Authen-SASL-Cyrus/
COMMENT= Perl module to handle Cyrus protocol for SASL authentication
DEPENDS+= p5-Authen-SASL-[0-9]*:../../wip/p5-Authen-SASL
USE_BUILDLINK2= YES
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Authen/SASL/Cyrus/.packlist
.include "../../security/cyrus-sasl2/buildlink2.mk"
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/06/16 12:23:01 cubidou Exp $

View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/06/16 12:23:01 cubidou Exp $
SHA1 (Authen-SASL-Cyrus-0.07.tar.gz) = 5e3c58ecdffc6647ea51a654e6ac478cd88a0abd
Size (Authen-SASL-Cyrus-0.07.tar.gz) = 9467 bytes
SHA1 (patch-aa) = 96923faa41955f2fa8149d6ac3a7fa76c4773802

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/06/16 12:23:01 cubidou Exp $
--- Cyrus.xs.orig 2003-02-03 22:02:03.000000000 +0100
+++ Cyrus.xs
@@ -10,7 +10,7 @@
#include <EXTERN.h>
#include <perl.h>
#include <XSUB.h>
-#include <sasl.h>
+#include <sasl/sasl.h>