Upgrade to latest stable

This commit is contained in:
Jason Bacon 2015-04-20 13:08:37 +00:00 committed by Thomas Klausner
parent 9bbb98d55f
commit 9fa42b0ebb
18 changed files with 215 additions and 171 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.6 2015/04/02 20:58:07 outpaddling Exp $
# $NetBSD: Makefile,v 1.7 2015/04/20 13:08:37 outpaddling Exp $
DISTNAME= slurm-2.6.4
PKGREVISION= 5
DISTNAME= slurm-14.11.5
CATEGORIES= parallel
MASTER_SITES= http://www.schedmd.com/download/archive/ \
http://www.schedmd.com/download/latest/ \
@ -31,26 +30,20 @@ PKG_SHELL.slurm= $(NOLOGIN)
RCD_SCRIPTS+= slurmd slurmctld
SUBST_CLASSES+= htmldir
SUBST_STAGE.htmldir= post-patch
SUBST_FILES.htmldir= ${WRKSRC}/doc/man/man5/Makefile.am \
${WRKSRC}/doc/html/Makefile.am \
${WRKSRC}/doc/man/man5/Makefile.in \
${WRKSRC}/doc/html/Makefile.in \
${WRKSRC}/doc/man/man8/Makefile.am \
${WRKSRC}/doc/man/man1/Makefile.am \
${WRKSRC}/doc/man/man8/Makefile.in \
${WRKSRC}/doc/man/man1/Makefile.in
SUBST_SED.htmldir= -e 's|$${datadir}/doc/@PACKAGE@-@VERSION@/html|@htmldir@|g'
SUBST_CLASSES+= linuxinit
SUBST_STAGE.linuxinit= post-patch
SUBST_FILES.linuxinit= ${WRKSRC}/etc/init.d.slurm.in
SUBST_SED.linuxinit= -e "/^BINDIR=/ i exec_prefix=$(PREFIX)\nprefix=$(PREFIX)\n"
SUBST_SED.linuxinit= -e 's|^exec_prefix=|&$(PREFIX)|' \
-e 's|^prefix=|&$(PREFIX)|' \
-e 's|@bindir@|$${exec_prefix}/bin|' \
-e 's|@sbindir@|$${exec_prefix}/sbin|' \
-e 's|@libdir@|$${exec_prefix}/lib|' \
-e 's|@sysconfdir@|$${prefix}/etc|'
post-install:
$(INSTALL_DATA_DIR) $(DESTDIR)$(PREFIX)/share/examples/$(PKGBASE)
$(INSTALL_DATA) $(WRKSRC)/etc/* $(DESTDIR)$(PREFIX)/share/examples/$(PKGBASE)/
chmod 755 $(DESTDIR)$(PREFIX)/share/examples/slurm/init.d.slurm
.include "../../lang/python/tool.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST.Linux,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
@comment $NetBSD: PLIST.Linux,v 1.2 2015/04/20 13:08:37 outpaddling Exp $
bin/sacct
bin/sacctmgr
bin/salloc
@ -8,6 +8,7 @@ bin/sbcast
bin/scancel
bin/scontrol
bin/sdiag
bin/sh5util
bin/sinfo
bin/smap
bin/sprio
@ -21,6 +22,7 @@ include/slurm/pmi.h
include/slurm/slurmdb.h
include/slurm/slurm_errno.h
include/slurm/slurm.h
include/slurm/smd_ns.h
include/slurm/spank.h
lib/libpmi.la
lib/libslurmdb.la
@ -33,11 +35,14 @@ lib/slurm/acct_gather_energy_rapl.la
lib/slurm/acct_gather_filesystem_lustre.la
lib/slurm/acct_gather_filesystem_none.la
lib/slurm/acct_gather_infiniband_none.la
lib/slurm/acct_gather_profile_hdf5.la
lib/slurm/acct_gather_profile_none.la
lib/slurm/auth_munge.la
lib/slurm/auth_none.la
lib/slurm/checkpoint_none.la
lib/slurm/checkpoint_ompi.la
lib/slurm/core_spec_cray.la
lib/slurm/core_spec_none.la
lib/slurm/crypto_munge.la
lib/slurm/crypto_openssl.la
lib/slurm/ext_sensors_none.la
@ -51,13 +56,17 @@ lib/slurm/jobacct_gather_none.la
lib/slurm/jobcomp_filetxt.la
lib/slurm/jobcomp_none.la
lib/slurm/jobcomp_script.la
lib/slurm/job_container_cncu.la
lib/slurm/job_container_none.la
lib/slurm/job_submit_all_partitions.la
lib/slurm/job_submit_cnode.la
lib/slurm/job_submit_cray.la
lib/slurm/job_submit_defaults.la
lib/slurm/job_submit_logging.la
lib/slurm/job_submit_partition.la
lib/slurm/job_submit_pbs.la
lib/slurm/job_submit_require_timelimit.la
lib/slurm/job_submit_throttle.la
lib/slurm/launch_slurm.la
lib/slurm/mpi_lam.la
lib/slurm/mpi_mpich1_p4.la
@ -68,6 +77,7 @@ lib/slurm/mpi_mvapich.la
lib/slurm/mpi_none.la
lib/slurm/mpi_openmpi.la
lib/slurm/mpi_pmi2.la
lib/slurm/preempt_job_prio.la
lib/slurm/preempt_none.la
lib/slurm/preempt_partition_prio.la
lib/slurm/preempt_qos.la
@ -76,21 +86,28 @@ lib/slurm/priority_multifactor.la
lib/slurm/proctrack_cgroup.la
lib/slurm/proctrack_linuxproc.la
lib/slurm/proctrack_pgid.la
lib/slurm/route_default.la
lib/slurm/route_topology.la
lib/slurm/sched_backfill.la
lib/slurm/sched_builtin.la
lib/slurm/sched_hold.la
lib/slurm/sched_wiki2.la
lib/slurm/sched_wiki.la
lib/slurm/select_alps.la
lib/slurm/select_cons_res.la
lib/slurm/select_cray.la
lib/slurm/select_linear.la
lib/slurm/select_serial.la
lib/slurm/slurmctld_nonstop.la
lib/slurm/spank_pbs.la
lib/slurm/src/sattach/sattach.wrapper.c
lib/slurm/src/srun/srun.wrapper.c
lib/slurm/switch_cray.la
lib/slurm/switch_generic.la
lib/slurm/switch_none.la
lib/slurm/task_affinity.la
lib/slurm/task_cgroup.la
lib/slurm/task_cray.la
lib/slurm/task_none.la
lib/slurm/topology_3d_torus.la
lib/slurm/topology_node_rank.la
@ -147,6 +164,7 @@ man/man3/slurm_delete_reservation.3
man/man3/slurm_free_ctl_conf.3
man/man3/slurm_free_front_end_info_msg.3
man/man3/slurm_free_job_alloc_info_response_msg.3
man/man3/slurm_free_job_array_resp.3
man/man3/slurm_free_job_info_msg.3
man/man3/slurm_free_job_step_create_response_msg.3
man/man3/slurm_free_job_step_info_response_msg.3
@ -215,7 +233,9 @@ man/man3/slurm_print_reservation_info_msg.3
man/man3/slurm_print_slurmd_status.3
man/man3/slurm_read_hostfile.3
man/man3/slurm_reconfigure.3
man/man3/slurm_requeue2.3
man/man3/slurm_requeue.3
man/man3/slurm_resume2.3
man/man3/slurm_resume.3
man/man3/slurm_set_debug_level.3
man/man3/slurm_set_trigger.3
@ -242,11 +262,13 @@ man/man3/slurm_step_launch_wait_finish.3
man/man3/slurm_step_launch_wait_start.3
man/man3/slurm_strerror.3
man/man3/slurm_submit_batch_job.3
man/man3/slurm_suspend2.3
man/man3/slurm_suspend.3
man/man3/slurm_takeover.3
man/man3/slurm_terminate_job.3
man/man3/slurm_terminate_job_step.3
man/man3/slurm_update_front_end.3
man/man3/slurm_update_job2.3
man/man3/slurm_update_job.3
man/man3/slurm_update_node.3
man/man3/slurm_update_partition.3
@ -258,6 +280,7 @@ man/man5/cgroup.conf.5
man/man5/cray.conf.5
man/man5/ext_sensors.conf.5
man/man5/gres.conf.5
man/man5/nonstop.conf.5
man/man5/slurm.conf.5
man/man5/slurmdbd.conf.5
man/man5/topology.conf.5
@ -295,7 +318,10 @@ share/doc/${PKGNAME}/html/configurator.html
share/doc/${PKGNAME}/html/cons_res.html
share/doc/${PKGNAME}/html/cons_res_share.html
share/doc/${PKGNAME}/html/contributor.html
share/doc/${PKGNAME}/html/core_spec.html
share/doc/${PKGNAME}/html/core_spec_plugins.html
share/doc/${PKGNAME}/html/cpu_management.html
share/doc/${PKGNAME}/html/cray_alps.html
share/doc/${PKGNAME}/html/cray.conf.html
share/doc/${PKGNAME}/html/cray.html
share/doc/${PKGNAME}/html/crypto_plugins.html
@ -309,6 +335,7 @@ share/doc/${PKGNAME}/html/entities.gif
share/doc/${PKGNAME}/html/example_usage.gif
share/doc/${PKGNAME}/html/ext_sensors.conf.html
share/doc/${PKGNAME}/html/ext_sensorsplugins.html
share/doc/${PKGNAME}/html/fair_tree.html
share/doc/${PKGNAME}/html/faq.html
share/doc/${PKGNAME}/html/gang_scheduling.html
share/doc/${PKGNAME}/html/gres.conf.html
@ -318,7 +345,6 @@ share/doc/${PKGNAME}/html/gres_plugins.html
share/doc/${PKGNAME}/html/hdf5_job_outline.png
share/doc/${PKGNAME}/html/hdf5_profile_user_guide.html
share/doc/${PKGNAME}/html/hdf5_task_attr.png
share/doc/${PKGNAME}/html/help.html
share/doc/${PKGNAME}/html/high_throughput.html
share/doc/${PKGNAME}/html/ibm.html
share/doc/${PKGNAME}/html/ibm_pe_fig1.png
@ -327,10 +353,13 @@ share/doc/${PKGNAME}/html/ibm-pe.html
share/doc/${PKGNAME}/html/jobacct_gatherplugins.html
share/doc/${PKGNAME}/html/job_array.html
share/doc/${PKGNAME}/html/jobcompplugins.html
share/doc/${PKGNAME}/html/job_container_plugins.html
share/doc/${PKGNAME}/html/job_exit_code.html
share/doc/${PKGNAME}/html/job_launch.html
share/doc/${PKGNAME}/html/job_submit_plugins.html
share/doc/${PKGNAME}/html/k_function.gif
share/doc/${PKGNAME}/html/launch_plugins.html
share/doc/${PKGNAME}/html/licenses.html
share/doc/${PKGNAME}/html/linuxstyles.css
share/doc/${PKGNAME}/html/lll.gif
share/doc/${PKGNAME}/html/mail.html
@ -344,6 +373,7 @@ share/doc/${PKGNAME}/html/mpi_guide.html
share/doc/${PKGNAME}/html/mpiplugins.html
share/doc/${PKGNAME}/html/multi_cluster.html
share/doc/${PKGNAME}/html/news.html
share/doc/${PKGNAME}/html/nonstop.conf.html
share/doc/${PKGNAME}/html/overview.html
share/doc/${PKGNAME}/html/plane_ex1.gif
share/doc/${PKGNAME}/html/plane_ex2.gif
@ -358,6 +388,7 @@ share/doc/${PKGNAME}/html/power_save.html
share/doc/${PKGNAME}/html/preempt.html
share/doc/${PKGNAME}/html/preemption_plugins.html
share/doc/${PKGNAME}/html/priority_multifactor2.html
share/doc/${PKGNAME}/html/priority_multifactor3.html
share/doc/${PKGNAME}/html/priority_multifactor.html
share/doc/${PKGNAME}/html/priority_plugins.html
share/doc/${PKGNAME}/html/proctrack_plugins.html
@ -370,6 +401,8 @@ share/doc/${PKGNAME}/html/quickstart.html
share/doc/${PKGNAME}/html/reservations.html
share/doc/${PKGNAME}/html/resource_limits.html
share/doc/${PKGNAME}/html/rosetta.html
share/doc/${PKGNAME}/html/route_plugin.html
share/doc/${PKGNAME}/html/rpc.html
share/doc/${PKGNAME}/html/sacct.html
share/doc/${PKGNAME}/html/sacctmgr.html
share/doc/${PKGNAME}/html/salloc.html
@ -377,6 +410,7 @@ share/doc/${PKGNAME}/html/sattach.html
share/doc/${PKGNAME}/html/sbatch.html
share/doc/${PKGNAME}/html/sbcast.html
share/doc/${PKGNAME}/html/scancel.html
share/doc/${PKGNAME}/html/sched_config.html
share/doc/${PKGNAME}/html/schedmd.png
share/doc/${PKGNAME}/html/schedplugins.html
share/doc/${PKGNAME}/html/scontrol.html
@ -427,15 +461,23 @@ share/doc/${PKGNAME}/html/troubleshoot.html
share/doc/${PKGNAME}/html/tutorial_intro_files.tar
share/doc/${PKGNAME}/html/tutorials.html
share/doc/${PKGNAME}/html/usage_pies.gif
share/doc/${PKGNAME}/html/wckey.html
share/doc/${PKGNAME}/html/wiki.conf.html
share/examples/slurm/bluegene.conf.example
share/examples/slurm/cgroup_allowed_devices_file.conf.example
share/examples/slurm/cgroup.conf.example
share/examples/slurm/cgroup.release_common.example
share/examples/slurm/cgroup.release_common.example.in
share/examples/slurm/init.d.slurm
share/examples/slurm/init.d.slurmdbd
share/examples/slurm/init.d.slurmdbd.in
share/examples/slurm/init.d.slurm.in
share/examples/slurm/slurm.conf.example
share/examples/slurm/slurmctld.service
share/examples/slurm/slurmctld.service.in
share/examples/slurm/slurmdbd.conf.example
share/examples/slurm/slurmdbd.service
share/examples/slurm/slurmdbd.service.in
share/examples/slurm/slurmd.service
share/examples/slurm/slurmd.service.in
share/examples/slurm/slurm.epilog.clean

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST.NetBSD,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
@comment $NetBSD: PLIST.NetBSD,v 1.2 2015/04/20 13:08:37 outpaddling Exp $
bin/sacct
bin/sacctmgr
bin/salloc
@ -22,6 +22,7 @@ include/slurm/pmi.h
include/slurm/slurm.h
include/slurm/slurm_errno.h
include/slurm/slurmdb.h
include/slurm/smd_ns.h
include/slurm/spank.h
lib/libpmi.la
lib/libslurm.la
@ -40,19 +41,25 @@ lib/slurm/auth_munge.la
lib/slurm/auth_none.la
lib/slurm/checkpoint_none.la
lib/slurm/checkpoint_ompi.la
lib/slurm/core_spec_cray.la
lib/slurm/core_spec_none.la
lib/slurm/crypto_munge.la
lib/slurm/crypto_openssl.la
lib/slurm/ext_sensors_none.la
lib/slurm/gres_gpu.la
lib/slurm/gres_mic.la
lib/slurm/gres_nic.la
lib/slurm/job_container_cncu.la
lib/slurm/job_container_none.la
lib/slurm/job_submit_all_partitions.la
lib/slurm/job_submit_cnode.la
lib/slurm/job_submit_cray.la
lib/slurm/job_submit_defaults.la
lib/slurm/job_submit_logging.la
lib/slurm/job_submit_partition.la
lib/slurm/job_submit_pbs.la
lib/slurm/job_submit_require_timelimit.la
lib/slurm/job_submit_throttle.la
lib/slurm/jobacct_gather_aix.la
lib/slurm/jobacct_gather_cgroup.la
lib/slurm/jobacct_gather_linux.la
@ -70,6 +77,7 @@ lib/slurm/mpi_mvapich.la
lib/slurm/mpi_none.la
lib/slurm/mpi_openmpi.la
lib/slurm/mpi_pmi2.la
lib/slurm/preempt_job_prio.la
lib/slurm/preempt_none.la
lib/slurm/preempt_partition_prio.la
lib/slurm/preempt_qos.la
@ -78,20 +86,27 @@ lib/slurm/priority_multifactor.la
lib/slurm/proctrack_cgroup.la
lib/slurm/proctrack_linuxproc.la
lib/slurm/proctrack_pgid.la
lib/slurm/route_default.la
lib/slurm/route_topology.la
lib/slurm/sched_backfill.la
lib/slurm/sched_builtin.la
lib/slurm/sched_hold.la
lib/slurm/sched_wiki.la
lib/slurm/sched_wiki2.la
lib/slurm/select_alps.la
lib/slurm/select_cons_res.la
lib/slurm/select_cray.la
lib/slurm/select_linear.la
lib/slurm/select_serial.la
lib/slurm/slurmctld_nonstop.la
lib/slurm/spank_pbs.la
lib/slurm/src/sattach/sattach.wrapper.c
lib/slurm/src/srun/srun.wrapper.c
lib/slurm/switch_cray.la
lib/slurm/switch_generic.la
lib/slurm/switch_none.la
lib/slurm/task_cgroup.la
lib/slurm/task_cray.la
lib/slurm/task_none.la
lib/slurm/topology_3d_torus.la
lib/slurm/topology_node_rank.la
@ -148,6 +163,7 @@ man/man3/slurm_delete_reservation.3
man/man3/slurm_free_ctl_conf.3
man/man3/slurm_free_front_end_info_msg.3
man/man3/slurm_free_job_alloc_info_response_msg.3
man/man3/slurm_free_job_array_resp.3
man/man3/slurm_free_job_info_msg.3
man/man3/slurm_free_job_step_create_response_msg.3
man/man3/slurm_free_job_step_info_response_msg.3
@ -217,7 +233,9 @@ man/man3/slurm_print_slurmd_status.3
man/man3/slurm_read_hostfile.3
man/man3/slurm_reconfigure.3
man/man3/slurm_requeue.3
man/man3/slurm_requeue2.3
man/man3/slurm_resume.3
man/man3/slurm_resume2.3
man/man3/slurm_set_debug_level.3
man/man3/slurm_set_trigger.3
man/man3/slurm_shutdown.3
@ -244,11 +262,13 @@ man/man3/slurm_step_launch_wait_start.3
man/man3/slurm_strerror.3
man/man3/slurm_submit_batch_job.3
man/man3/slurm_suspend.3
man/man3/slurm_suspend2.3
man/man3/slurm_takeover.3
man/man3/slurm_terminate_job.3
man/man3/slurm_terminate_job_step.3
man/man3/slurm_update_front_end.3
man/man3/slurm_update_job.3
man/man3/slurm_update_job2.3
man/man3/slurm_update_node.3
man/man3/slurm_update_partition.3
man/man3/slurm_update_reservation.3
@ -259,6 +279,7 @@ man/man5/cgroup.conf.5
man/man5/cray.conf.5
man/man5/ext_sensors.conf.5
man/man5/gres.conf.5
man/man5/nonstop.conf.5
man/man5/slurm.conf.5
man/man5/slurmdbd.conf.5
man/man5/topology.conf.5
@ -295,8 +316,11 @@ share/doc/${PKGNAME}/html/configurator.html
share/doc/${PKGNAME}/html/cons_res.html
share/doc/${PKGNAME}/html/cons_res_share.html
share/doc/${PKGNAME}/html/contributor.html
share/doc/${PKGNAME}/html/core_spec.html
share/doc/${PKGNAME}/html/core_spec_plugins.html
share/doc/${PKGNAME}/html/cpu_management.html
share/doc/${PKGNAME}/html/cray.html
share/doc/${PKGNAME}/html/cray_alps.html
share/doc/${PKGNAME}/html/crypto_plugins.html
share/doc/${PKGNAME}/html/disclaimer.html
share/doc/${PKGNAME}/html/dist_plane.html
@ -307,6 +331,7 @@ share/doc/${PKGNAME}/html/elastic_computing.html
share/doc/${PKGNAME}/html/entities.gif
share/doc/${PKGNAME}/html/example_usage.gif
share/doc/${PKGNAME}/html/ext_sensorsplugins.html
share/doc/${PKGNAME}/html/fair_tree.html
share/doc/${PKGNAME}/html/faq.html
share/doc/${PKGNAME}/html/gang_scheduling.html
share/doc/${PKGNAME}/html/gres.html
@ -315,19 +340,21 @@ share/doc/${PKGNAME}/html/gres_plugins.html
share/doc/${PKGNAME}/html/hdf5_job_outline.png
share/doc/${PKGNAME}/html/hdf5_profile_user_guide.html
share/doc/${PKGNAME}/html/hdf5_task_attr.png
share/doc/${PKGNAME}/html/help.html
share/doc/${PKGNAME}/html/high_throughput.html
share/doc/${PKGNAME}/html/ibm-pe.html
share/doc/${PKGNAME}/html/ibm.html
share/doc/${PKGNAME}/html/ibm_pe_fig1.png
share/doc/${PKGNAME}/html/ibm_pe_fig2.png
share/doc/${PKGNAME}/html/job_array.html
share/doc/${PKGNAME}/html/job_container_plugins.html
share/doc/${PKGNAME}/html/job_exit_code.html
share/doc/${PKGNAME}/html/job_launch.html
share/doc/${PKGNAME}/html/job_submit_plugins.html
share/doc/${PKGNAME}/html/jobacct_gatherplugins.html
share/doc/${PKGNAME}/html/jobcompplugins.html
share/doc/${PKGNAME}/html/k_function.gif
share/doc/${PKGNAME}/html/launch_plugins.html
share/doc/${PKGNAME}/html/licenses.html
share/doc/${PKGNAME}/html/linuxstyles.css
share/doc/${PKGNAME}/html/lll.gif
share/doc/${PKGNAME}/html/mail.html
@ -356,6 +383,7 @@ share/doc/${PKGNAME}/html/preempt.html
share/doc/${PKGNAME}/html/preemption_plugins.html
share/doc/${PKGNAME}/html/priority_multifactor.html
share/doc/${PKGNAME}/html/priority_multifactor2.html
share/doc/${PKGNAME}/html/priority_multifactor3.html
share/doc/${PKGNAME}/html/priority_plugins.html
share/doc/${PKGNAME}/html/proctrack_plugins.html
share/doc/${PKGNAME}/html/programmer_guide.html
@ -367,6 +395,9 @@ share/doc/${PKGNAME}/html/quickstart_admin.html
share/doc/${PKGNAME}/html/reservations.html
share/doc/${PKGNAME}/html/resource_limits.html
share/doc/${PKGNAME}/html/rosetta.html
share/doc/${PKGNAME}/html/route_plugin.html
share/doc/${PKGNAME}/html/rpc.html
share/doc/${PKGNAME}/html/sched_config.html
share/doc/${PKGNAME}/html/schedmd.png
share/doc/${PKGNAME}/html/schedplugins.html
share/doc/${PKGNAME}/html/select_design.html
@ -393,14 +424,23 @@ share/doc/${PKGNAME}/html/troubleshoot.html
share/doc/${PKGNAME}/html/tutorial_intro_files.tar
share/doc/${PKGNAME}/html/tutorials.html
share/doc/${PKGNAME}/html/usage_pies.gif
share/doc/${PKGNAME}/html/wckey.html
share/examples/slurm/bluegene.conf.example
share/examples/slurm/cgroup.conf.example
share/examples/slurm/cgroup.release_common.example
share/examples/slurm/cgroup.release_common.example.in
share/examples/slurm/cgroup_allowed_devices_file.conf.example
share/examples/slurm/init.d.slurm
share/examples/slurm/init.d.slurm.in
share/examples/slurm/init.d.slurm.in.orig
share/examples/slurm/init.d.slurmdbd
share/examples/slurm/init.d.slurmdbd.in
share/examples/slurm/slurm.conf.example
share/examples/slurm/slurm.epilog.clean
share/examples/slurm/slurmctld.service
share/examples/slurm/slurmctld.service.in
share/examples/slurm/slurmd.service
share/examples/slurm/slurmd.service.in
share/examples/slurm/slurmdbd.conf.example
share/examples/slurm/slurmdbd.service
share/examples/slurm/slurmdbd.service.in

View file

@ -1,15 +1,8 @@
$NetBSD: distinfo,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
$NetBSD: distinfo,v 1.2 2015/04/20 13:08:37 outpaddling Exp $
SHA1 (slurm-2.6.4.tar.bz2) = 6a5850b53201d506a86ab23d13318be34395d237
RMD160 (slurm-2.6.4.tar.bz2) = a6b4ab6782b0db0822acb2fd7efe6c1464b8a87c
Size (slurm-2.6.4.tar.bz2) = 5954130 bytes
SHA1 (patch-src_common_net.c) = 6a53ef7ef94afa1e48d929c635e900c9999e381b
SHA1 (patch-src_common_slurm__jobacct__gather.c) = abcb7c117c3efa95509d047ff7243fc98cfc00b7
SHA1 (patch-src_common_xcgroup.c) = fd49ee490fc663635b0b5a3ce54ede7e6166b897
SHA1 (patch-src_common_xcgroup.h) = 78e9021a725692c8a980556c000c4501c8009a75
SHA1 (patch-src_plugins_acct__gather__filesystem_lustre_acct__gather__filesystem__lustre.c) = 3544b07d4266476b2038a39a91166a6a1c802e18
SHA1 (patch-src_slurmctld_reservation.c) = c02eb31c2b9dee32e1b68bb9ecf63acd34a987ca
SHA1 (patch-src_slurmd_common_setproctitle.c) = 1ac0cccd1f889a8a3e3d998bdb6392cfbca932e5
SHA1 (patch-src_slurmd_slurmstepd_task.c) = b7afd7c2ed58b8423490e1117d6e82d7b0f3294b
SHA1 (patch-src_srun_libsrun_debugger.c) = 1d10d883c2f9931af3166980c70730ab9fa1df96
SHA1 (patch-src_srun_libsrun_launch.c) = ff3cbfced383206f86f33c3a511334b95da9edc7
SHA1 (slurm-14.11.5.tar.bz2) = 468bfcdcac83810776a768aed5cfd20c15cd74fd
RMD160 (slurm-14.11.5.tar.bz2) = d53d25ded2b2c4ee93323a9920c564628cc48d3d
Size (slurm-14.11.5.tar.bz2) = 6332854 bytes
SHA1 (patch-etc_init.d.slurm.in) = f29d2c603b8d62df80aec4ac77f2e9bc218f55fc
SHA1 (patch-src_plugins_switch_generic_switch__generic.c) = b91f4cbb253a1c93c83edc8e5f0d2b4606f96735
SHA1 (patch-src_slurmd_slurmstepd_task.c) = 9d0a2384655301c0f00e2c291a767d9f4f4d0102

View file

@ -0,0 +1,64 @@
#!/bin/sh -e
##########################################################################
# Script description:
#
# Arguments:
#
# Returns:
#
# History:
# Date Name Modification
# 2013-12-26 root Begin
##########################################################################
usage()
{
printf "Usage: $0 node-type\n"
exit 1
}
##########################################################################
# Main
##########################################################################
if [ $# != 1 ]; then
usage
fi
node_type=$1
#./munge-enable $node_type
case $node_type in
'head')
prefix='/usr/pkg-1'
;;
'compute')
prefix='/sharedapps/pkg-1'
;;
*)
printf "$0 is only for head and compute nodes.\n"
exit 1
;;
esac
# slurm.conf
if [ ! -e $prefix/etc/slurm.conf ]; then
printf "Missing $prefix/etc/slurm.conf. Copy it from head node.\n"
exit 1
fi
# Init script
#if [ ! -e /etc/init.d/slurm ]; then
printf "exec_prefix=/$prefix\nprefix=$prefix\n\n" \
> /etc/init.d/slurm
chmod 750 /etc/init.d/slurm
cat $prefix/share/examples/slurm/init.d.slurm >> /etc/init.d/slurm
chkconfig slurm on
service slurm restart
#fi
mkdir -p /var/log/slurm
chown slurm:slurm /var/log/slurm

View file

@ -1,5 +1,5 @@
#!@RCD_SCRIPTS_SHELL@
# $NetBSD: slurmd.sh,v 1.1 2015/03/27 20:09:56 outpaddling Exp $
# $NetBSD: slurmd.sh,v 1.2 2015/04/20 13:08:37 outpaddling Exp $
#
# PROVIDE: slurmd
# REQUIRE: DAEMON munge
@ -11,7 +11,7 @@ name="slurmd"
rcvar=${name}
command="@PREFIX@/sbin/slurmd"
slurmd_user="slurm"
slurmd_user="root"
load_rc_config $name
run_rc_command "$1"

View file

@ -0,0 +1,14 @@
$NetBSD: patch-etc_init.d.slurm.in,v 1.1 2015/04/20 13:08:37 outpaddling Exp $
--- etc/init.d.slurm.in.orig 2015-03-19 19:38:01.000000000 +0000
+++ etc/init.d.slurm.in
@@ -25,6 +25,9 @@
# Description: Start slurm to provide resource management
### END INIT INFO
+exec_prefix=
+prefix=
+
BINDIR="@bindir@"
CONFDIR="@sysconfdir@"
LIBDIR="@libdir@"

View file

@ -1,22 +0,0 @@
$NetBSD: patch-src_common_net.c,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
--- src/common/net.c.orig 2013-11-04 21:19:15.000000000 +0000
+++ src/common/net.c
@@ -52,7 +52,7 @@
#include <errno.h>
#include <stdint.h>
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__)
#define SOL_TCP IPPROTO_TCP
#endif
@@ -216,7 +216,7 @@ extern int net_set_keep_alive(int sock)
* Removing this call might decrease the robustness of communications,
* but will probably have no noticable effect.
*/
-#if ! defined(__FreeBSD__) || (__FreeBSD_version > 900000)
+#if (! defined(__FreeBSD__) || (__FreeBSD_version > 900000)) && ! defined(__APPLE__)
opt_int = keep_alive_time;
if (setsockopt(sock, SOL_TCP, TCP_KEEPIDLE, &opt_int, opt_len) < 0) {
error("Unable to set keep alive socket time: %m");

View file

@ -1,13 +0,0 @@
$NetBSD: patch-src_common_slurm__jobacct__gather.c,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
--- src/common/slurm_jobacct_gather.c.orig 2013-11-04 21:19:15.000000000 +0000
+++ src/common/slurm_jobacct_gather.c
@@ -47,7 +47,7 @@
* Morris Jette, et al.
\*****************************************************************************/
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__)
#include <signal.h>
#endif
#include <pthread.h>

View file

@ -1,13 +0,0 @@
$NetBSD: patch-src_common_xcgroup.c,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
--- src/common/xcgroup.c.orig 2013-11-04 21:19:15.000000000 +0000
+++ src/common/xcgroup.c
@@ -217,7 +217,7 @@ int xcgroup_ns_mount(xcgroup_ns_t* cgns)
options = opt_combined;
}
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__APPLE__)
if (mount("cgroup", cgns->mnt_point,
MS_NOSUID|MS_NOEXEC|MS_NODEV, options))
#else

View file

@ -1,13 +0,0 @@
$NetBSD: patch-src_common_xcgroup.h,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
--- src/common/xcgroup.h.orig 2013-11-04 21:19:15.000000000 +0000
+++ src/common/xcgroup.h
@@ -49,7 +49,7 @@
#define XCGROUP_SUCCESS 0
// http://lists.debian.org/debian-boot/2012/04/msg00047.html
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__)
#define MS_NOSUID MNT_NOSUID
#define MS_NOEXEC MNT_NOEXEC
#define MS_NODEV 0

View file

@ -1,14 +0,0 @@
$NetBSD: patch-src_plugins_acct__gather__filesystem_lustre_acct__gather__filesystem__lustre.c,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
--- src/plugins/acct_gather_filesystem/lustre/acct_gather_filesystem_lustre.c.orig 2013-11-04 21:19:15.000000000 +0000
+++ src/plugins/acct_gather_filesystem/lustre/acct_gather_filesystem_lustre.c
@@ -49,6 +49,9 @@
#include <getopt.h>
#include <netinet/in.h>
+#if defined(__NetBSD__)
+#include <limits.h> /* PATH_MAX */
+#endif
#include "src/common/slurm_xlator.h"
#include "src/common/slurm_acct_gather_filesystem.h"

View file

@ -0,0 +1,21 @@
$NetBSD: patch-src_plugins_switch_generic_switch__generic.c,v 1.1 2015/04/20 13:08:37 outpaddling Exp $
--- src/plugins/switch/generic/switch_generic.c.orig 2015-03-19 19:38:01.000000000 +0000
+++ src/plugins/switch/generic/switch_generic.c
@@ -40,12 +40,13 @@
# include "config.h"
#endif
-#if !defined(__FreeBSD__)
-#include <net/if.h>
-#endif
#include <netinet/in.h>
#include <arpa/inet.h>
#include <sys/types.h>
+/* net/if.h must come after sys/types.h on NetBSD */
+#if !defined(__FreeBSD__)
+#include <net/if.h>
+#endif
#include <sys/socket.h>
#include <ifaddrs.h>
#include <netdb.h>

View file

@ -1,13 +0,0 @@
$NetBSD: patch-src_slurmctld_reservation.c,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
--- src/slurmctld/reservation.c.orig 2013-11-04 21:19:15.000000000 +0000
+++ src/slurmctld/reservation.c
@@ -44,7 +44,7 @@
# include <pthread.h>
#endif /* WITH_PTHREADS */
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__)
#include <signal.h>
#endif

View file

@ -1,13 +0,0 @@
$NetBSD: patch-src_slurmd_common_setproctitle.c,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
--- src/slurmd/common/setproctitle.c.orig 2013-11-04 21:19:15.000000000 +0000
+++ src/slurmd/common/setproctitle.c
@@ -90,7 +90,7 @@
#include <stdlib.h>
#include <string.h>
#endif
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__)
#include <stdio.h>
#endif
#ifndef HAVE_SETPROCTITLE

View file

@ -1,18 +1,22 @@
$NetBSD: patch-src_slurmd_slurmstepd_task.c,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
$NetBSD: patch-src_slurmd_slurmstepd_task.c,v 1.2 2015/04/20 13:08:37 outpaddling Exp $
--- src/slurmd/slurmstepd/task.c.orig 2013-11-04 21:19:15.000000000 +0000
--- src/slurmd/slurmstepd/task.c.orig 2015-03-19 19:38:01.000000000 +0000
+++ src/slurmd/slurmstepd/task.c
@@ -501,7 +501,12 @@ _make_tmpdir(slurmd_job_t *job)
@@ -540,6 +540,17 @@ _make_tmpdir(stepd_step_rec_t *job)
* still work with older systems we include this check.
*/
-#if defined(__FreeBSD__)
+/* FIXME: Come up with a real solution for EUID instead of substituting RUID */
+#if defined(__NetBSD__)
+#define eaccess(p,m) (access((p),(m)))
+#define HAVE_EACCESS 1
+#endif
+
+#if defined(__FreeBSD__) || defined(__NetBSD__)
+#define __GLIBC__ (1)
+#define __GLIBC_PREREQ(a,b) (1)
+#endif
+
+#if defined(__FreeBSD__) || defined(__NetBSD__)
#define __GLIBC__ (1)
#define __GLIBC_PREREQ(a,b) (1)
#endif
#if defined(HAVE_FACCESSAT)
else if (faccessat(AT_FDCWD, tmpdir, X_OK|W_OK, AT_EACCESS))
#elif defined(HAVE_EACCESS)

View file

@ -1,13 +0,0 @@
$NetBSD: patch-src_srun_libsrun_debugger.c,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
--- src/srun/libsrun/debugger.c.orig 2013-11-04 21:19:15.000000000 +0000
+++ src/srun/libsrun/debugger.c
@@ -38,7 +38,7 @@
* 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
\*****************************************************************************/
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__)
#include <signal.h>
#endif

View file

@ -1,13 +0,0 @@
$NetBSD: patch-src_srun_libsrun_launch.c,v 1.1 2013/11/29 17:57:03 outpaddling Exp $
--- src/srun/libsrun/launch.c.orig 2013-11-04 21:19:15.000000000 +0000
+++ src/srun/libsrun/launch.c
@@ -36,7 +36,7 @@
#include <stdlib.h>
#include <fcntl.h>
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__)
#include <signal.h>
#endif