Additional patches to permit compilation with gcc 3.4
This commit is contained in:
parent
cc776f8164
commit
9fb1cc0257
9 changed files with 138 additions and 1 deletions
|
@ -1,10 +1,18 @@
|
|||
$NetBSD: distinfo,v 1.2 2004/01/06 21:09:55 johnrshannon Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/01/08 23:28:54 johnrshannon Exp $
|
||||
|
||||
SHA1 (florist-3.15p-src.tgz) = 1f901f25e4d3d450fa75cd8b0a200e3690282cd7
|
||||
Size (florist-3.15p-src.tgz) = 264898 bytes
|
||||
SHA1 (patch-c-posix.c) = 622d42742a78bad89f8367f92d4931450ec365e5
|
||||
SHA1 (patch-configure.in) = b6e182ae9db5960378c047bf84b3a3fe979027a7
|
||||
SHA1 (patch-posix-implementation.gpb) = 2b5c58039a2254e36aa450b9b1f69bd9f6d513b4
|
||||
SHA1 (patch-posix-io.adb) = 7a9d761e139c0265239cd56bc97366f60b03c80f
|
||||
SHA1 (patch-posix-message_queues.adb) = 5ef23709667be534df25de79fee5d9e1f59b537f
|
||||
SHA1 (patch-posix-permissions.adb) = 962377e3d5eb17da9e08c5a5448bdc76ee8d4bb9
|
||||
SHA1 (patch-posix-process_environment.adb) = 6b0227ef192134adcb78360a15b9cf1a465576f9
|
||||
SHA1 (patch-posix-process_identification.gpb) = c5f45e058e805ff576d8984f50e783dd77d9bd5b
|
||||
SHA1 (patch-posix-process_primitives.gpb) = 9bdba9b09b855c5a46ea3a2329a4c7a952314a18
|
||||
SHA1 (patch-posix-process_scheduling.adb) = 112cec272ebaf54d61547b13a421a59ac8130705
|
||||
SHA1 (patch-posix-process_times.adb) = 5f8468ae9fa9c1384fa75a7d4f1f3f469ba9409a
|
||||
SHA1 (patch-posix-signals.adb) = 1b6c29b51cbebb0970f9c0ee376d38fdf8dd4153
|
||||
SHA1 (patch-posix-supplement_to_ada_io.adb) = accafdb30808b498dfbaf6128227daa1dc71db65
|
||||
SHA1 (patch-posix-unsafe_process_primitives.gpb) = 4da2f7f5738500d68a5510f6016f4cc17683e83e
|
||||
|
|
12
florist/patches/patch-posix-io.adb
Normal file
12
florist/patches/patch-posix-io.adb
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-posix-io.adb,v 1.1 2004/01/08 23:28:54 johnrshannon Exp $
|
||||
|
||||
--- posix-io.adb.orig 2002-10-24 02:03:52.000000000 -0600
|
||||
+++ posix-io.adb
|
||||
@@ -631,6 +631,7 @@ package body POSIX.IO is
|
||||
To : in Boolean := True) is
|
||||
Flags : Bits;
|
||||
Result : int;
|
||||
+ pragma Warnings (Off, Result);
|
||||
begin
|
||||
Begin_Critical_Section;
|
||||
Flags := To_Bits (fcntl (int (File), F_GETFD));
|
13
florist/patches/patch-posix-message_queues.adb
Normal file
13
florist/patches/patch-posix-message_queues.adb
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-posix-message_queues.adb,v 1.1 2004/01/08 23:28:54 johnrshannon Exp $
|
||||
|
||||
--- posix-message_queues.adb.orig 2002-10-24 02:03:52.000000000 -0600
|
||||
+++ posix-message_queues.adb
|
||||
@@ -350,7 +350,7 @@ package body POSIX.Message_Queues is
|
||||
size_t ((Message'Size + char'Size - 1) / char'Size),
|
||||
unsigned (Priority));
|
||||
Check_NNeg_And_Restore_Signals
|
||||
- (int (Result), Masked_Signals, Old_Mask'Unchecked_Access);
|
||||
+ (Result, Masked_Signals, Old_Mask'Unchecked_Access);
|
||||
end Send;
|
||||
|
||||
---------------
|
13
florist/patches/patch-posix-permissions.adb
Normal file
13
florist/patches/patch-posix-permissions.adb
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-posix-permissions.adb,v 1.1 2004/01/08 23:28:54 johnrshannon Exp $
|
||||
|
||||
--- posix-permissions.adb.orig 2002-10-24 02:03:52.000000000 -0600
|
||||
+++ posix-permissions.adb
|
||||
@@ -105,7 +105,7 @@ package body POSIX.Permissions is
|
||||
procedure Set_Allowed_Process_Permissions
|
||||
(Permissions : in Permission_Set;
|
||||
Old_Perms : out Permission_Set) is
|
||||
- Mask : mode_t :=
|
||||
+ Mask : constant mode_t :=
|
||||
not (Form_C_Permission (Permissions) and File_Access_Permission_Bits);
|
||||
begin
|
||||
Cached_Umask := Mask;
|
32
florist/patches/patch-posix-process_environment.adb
Normal file
32
florist/patches/patch-posix-process_environment.adb
Normal file
|
@ -0,0 +1,32 @@
|
|||
$NetBSD: patch-posix-process_environment.adb,v 1.1 2004/01/08 23:28:54 johnrshannon Exp $
|
||||
|
||||
--- posix-process_environment.adb.orig 2002-10-24 02:03:52.000000000 -0600
|
||||
+++ posix-process_environment.adb
|
||||
@@ -443,7 +443,7 @@ package body POSIX.Process_Environment i
|
||||
procedure Copy_Environment
|
||||
(Source : in Environment;
|
||||
Target : in out Environment) is
|
||||
- T_Source : POSIX_String_List := To_POSIX_String_List (Source);
|
||||
+ T_Source : constant POSIX_String_List := To_POSIX_String_List (Source);
|
||||
T_Target : POSIX_String_List;
|
||||
procedure Copy_One (Str : POSIX_String; Done : in out Boolean);
|
||||
procedure Copy_One (Str : POSIX_String; Done : in out Boolean) is
|
||||
@@ -490,7 +490,8 @@ package body POSIX.Process_Environment i
|
||||
Undefined : POSIX.POSIX_String := "")
|
||||
return POSIX.POSIX_String is
|
||||
c_name : POSIX_String := Name & NUL;
|
||||
- Result : char_ptr := Getenv (c_name (c_name'First)'Unchecked_Access);
|
||||
+ Result : constant char_ptr :=
|
||||
+ Getenv (c_name (c_name'First)'Unchecked_Access);
|
||||
begin
|
||||
Validate (Name);
|
||||
if Result = null then return Undefined; end if;
|
||||
@@ -568,7 +569,7 @@ package body POSIX.Process_Environment i
|
||||
while P.all /= null loop
|
||||
-- .... concise but inefficient
|
||||
declare
|
||||
- S : POSIX_String := Form_POSIX_String (P.all);
|
||||
+ S : constant POSIX_String := Form_POSIX_String (P.all);
|
||||
J : constant Integer := Split_Point (S);
|
||||
begin
|
||||
Append (Strings, S (1 .. J - 1));
|
13
florist/patches/patch-posix-process_identification.gpb
Normal file
13
florist/patches/patch-posix-process_identification.gpb
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-posix-process_identification.gpb,v 1.1 2004/01/08 23:28:54 johnrshannon Exp $
|
||||
|
||||
--- posix-process_identification.gpb.orig 2002-10-24 02:03:52.000000000 -0600
|
||||
+++ posix-process_identification.gpb
|
||||
@@ -213,7 +213,7 @@ package body POSIX.Process_Identificatio
|
||||
Name_Ptr : char_ptr;
|
||||
begin
|
||||
Name_Ptr := getlogin;
|
||||
- if (Name_Ptr = null) then Raise_POSIX_Error; end if;
|
||||
+ if Name_Ptr = null then Raise_POSIX_Error; end if;
|
||||
return Form_POSIX_String (Name_Ptr);
|
||||
end Get_Login_Name;
|
||||
|
13
florist/patches/patch-posix-process_scheduling.adb
Normal file
13
florist/patches/patch-posix-process_scheduling.adb
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-posix-process_scheduling.adb,v 1.1 2004/01/08 23:28:54 johnrshannon Exp $
|
||||
|
||||
--- posix-process_scheduling.adb.orig 2002-10-24 02:03:52.000000000 -0600
|
||||
+++ posix-process_scheduling.adb
|
||||
@@ -104,7 +104,7 @@ package body POSIX.Process_Scheduling is
|
||||
begin
|
||||
Check (sched_getparam
|
||||
(To_pid_t (Process), Params.Param'Unchecked_Access));
|
||||
- return Scheduling_Parameters (Params);
|
||||
+ return Params;
|
||||
end Get_Scheduling_Parameters;
|
||||
|
||||
-----------------------------
|
13
florist/patches/patch-posix-process_times.adb
Normal file
13
florist/patches/patch-posix-process_times.adb
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-posix-process_times.adb,v 1.1 2004/01/08 23:28:54 johnrshannon Exp $
|
||||
|
||||
--- posix-process_times.adb.orig 2002-10-24 02:03:52.000000000 -0600
|
||||
+++ posix-process_times.adb
|
||||
@@ -64,7 +64,7 @@ package body POSIX.Process_Times is
|
||||
t : Process_Times;
|
||||
begin
|
||||
t.Elapsed_Real_Time := times (t.tms'Unchecked_Access);
|
||||
- return Process_Times (t);
|
||||
+ return t;
|
||||
end Get_Process_Times;
|
||||
|
||||
----------------------------
|
20
florist/patches/patch-posix-supplement_to_ada_io.adb
Normal file
20
florist/patches/patch-posix-supplement_to_ada_io.adb
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-posix-supplement_to_ada_io.adb,v 1.1 2004/01/08 23:28:54 johnrshannon Exp $
|
||||
|
||||
--- posix-supplement_to_ada_io.adb.orig 2002-10-24 02:03:52.000000000 -0600
|
||||
+++ posix-supplement_to_ada_io.adb
|
||||
@@ -113,6 +113,7 @@ package body POSIX.Supplement_to_Ada_IO
|
||||
|
||||
F : System_File_Type;
|
||||
Ret : int;
|
||||
+ pragma Warnings (Off, Ret);
|
||||
|
||||
begin
|
||||
F := To_SFT (File);
|
||||
@@ -126,6 +127,7 @@ package body POSIX.Supplement_to_Ada_IO
|
||||
|
||||
F : System_File_Type;
|
||||
Ret : int;
|
||||
+ pragma Warnings (Off, Ret);
|
||||
|
||||
begin
|
||||
F := To_SFT (File);
|
Loading…
Reference in a new issue