initial version of sdict conversion tool (compiler/decompiler/...)

This commit is contained in:
Aleksey Cheusov 2007-06-30 22:20:33 +00:00 committed by Thomas Klausner
parent 71a15d2f82
commit a09018fad3
5 changed files with 75 additions and 0 deletions

1
sdict-tools/DESCR Normal file
View file

@ -0,0 +1 @@
SDict conversion tools

52
sdict-tools/Makefile Normal file
View file

@ -0,0 +1,52 @@
# $NetBSD: Makefile,v 1.1 2007/06/30 22:20:33 cheusov Exp $
#
DISTNAME= ptksdict-1.2.1
PKGNAME= ${DISTNAME:S/ptksdict/sdict-tools/}
CATEGORIES= textproc
MASTER_SITES= http://sdict.com/rsc/files/
MAINTAINER= Aleksey Cheusov <cheusov@tut.by>
HOMEPAGE= http://sdict.com/
COMMENT= SDict conversion tools
#DEPENDS+= p5-DBI-[0-9]*:../../databases/p5-DBI
#DEPENDS+= p5-Crypt-Blowfish-[0-9]*:../../security/p5-Crypt-Blowfish
#DEPENDS+= p5-Digest-MD5-[0-9]*:../../security/p5-Digest-MD5
DEPENDS+= p5-Tk-[0-9]*:../../x11/p5-Tk
DEPENDS+= p5-Compress-Zlib-[0-9]*:../../devel/p5-Compress-Zlib
#DEPENDS+= p5-IO-File-[0-9]*:../../devel/p5-IO-File
#DEPENDS+= p5-IO-All-[0-9]*:../../devel/p5-IO-All
DEPENDS+= p5-Getopt-Long-[0-9]*:../../devel/p5-Getopt-Long
#DEPENDS+= p5-Data-Dump-[0-9]*:../../devel/p5-Data-Dump
NO_BUILD= yes
REPLACE_PERL+= bin/sdict-tools.plx
REPLACE_PERL+= bin/ptksdict.plx
REPLACE_PERL+= bin/sdict.plx
REPLACE_PERL+= bin/jotter.plx
REPLACE_PERL+= bin/data.plx
REPLACE_PERL+= bin/dctinfo.plx
SDICT_BINDIR= ${PREFIX}/bin/ptksdict
SDICT_LIBDIR= ${PREFIX}/bin/ptksdict
INSTALLATION_DIRS= ${SDICT_LIBDIR} ${SDICT_BINDIR}
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_LANGUAGES= # none
do-extract:
set -e; \
mkdir ${WRKSRC}; \
cd ${WRKSRC}; \
gzip -dc ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | tar -xf-
do-install:
set -e; \
cd ${WRKSRC}; \
${INSTALL_SCRIPT} bin/sdict-tools.plx ${SDICT_BINDIR}; \
${INSTALL_DATA} lib/Sdict.pm ${SDICT_LIBDIR}
.include "../../mk/bsd.pkg.mk"

3
sdict-tools/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2007/06/30 22:20:33 cheusov Exp $
bin/ptksdict/sdict-tools.plx
bin/ptksdict/Sdict.pm

6
sdict-tools/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2007/06/30 22:20:33 cheusov Exp $
SHA1 (ptksdict-1.2.1.tar.gz) = af9f2185140bca481f36f99b33db7237b9e43467
RMD160 (ptksdict-1.2.1.tar.gz) = b5282b0af7f1773da2e5676dec53146cb56d323a
Size (ptksdict-1.2.1.tar.gz) = 286561 bytes
SHA1 (patch-aa) = 3a00095b1c2827e351103c54db08d1d5d869bbbf

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2007/06/30 22:20:33 cheusov Exp $
--- bin/sdict-tools.plx.orig 2006-09-05 08:53:42.000000000 +0300
+++ bin/sdict-tools.plx
@@ -19,7 +19,7 @@ use warnings;
BEGIN {
$_=$0;
s|^(.+)/.*|$1|;
- push @INC, ($_, "$_/lib", "$_/../lib", "$_/..") ;
+ push @INC, ($_);
};