Add a patch in print/teTeX3-bin:

make sure teTeX3 compiles even if floor is defined by the OS (which is
the case on Mac OS 10.4 at least)
This commit is contained in:
Min Sik Kim 2009-02-23 19:29:19 +00:00 committed by Thomas Klausner
parent 4dac55437b
commit a1478de4a9
2 changed files with 19 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2009/02/23 08:46:54 minskim Exp $
$NetBSD: distinfo,v 1.3 2009/02/23 19:29:19 minskim Exp $
SHA1 (xdvik-22.84.14.tar.gz) = 1ca7f0c7930d24c3e10cc1d7115abed7dd39e95e
RMD160 (xdvik-22.84.14.tar.gz) = a19920fcc9e4e5d2878b16e65fa95bab5f034b74
Size (xdvik-22.84.14.tar.gz) = 2016256 bytes
SHA1 (patch-aa) = 878d51f49647160c6f75acb1ca386fefb7fd778b
SHA1 (patch-ab) = bbbeb011aa888f2ee7dab84c1602fb3e1127cdb1

17
xdvik/patches/patch-ab Normal file
View file

@ -0,0 +1,17 @@
$NetBSD: patch-ab,v 1.1 2009/02/23 19:29:19 minskim Exp $
Make sure teTeX3 compiles even if floor is defined by the OS (which is
the case on Mac OS 10.4 at least)
--- special.c.orig 2008-05-03 12:45:10.000000000 -0700
+++ special.c
@@ -181,7 +181,9 @@ static Boolean parse_color (const char *
#define MAX_PEN_SIZE 7 /* Max pixels of pen width */
#define TWOPI (3.14159265359 * 2.0)
+#ifndef floor
extern double floor(double);
+#endif
#define rint(x) floor((x) + 0.5)
static int xx[MAXPOINTS], yy[MAXPOINTS]; /* Path in milli-inches */