SMTPScan is a tool to guess which MTA is used, by sending several "special"

SMTP requests and by comparing error codes returned with those in the 
fingerprint database. It does not take into account banners and other 
text information, that cannot be trusted, only error code.
This commit is contained in:
Adrian Portelli 2003-07-08 15:04:48 +00:00
parent 05b1d0f336
commit a21b7a5a47
7 changed files with 107 additions and 0 deletions

4
smtpscan/DESCR Normal file
View file

@ -0,0 +1,4 @@
SMTPScan is a tool to guess which MTA is used, by sending several "special"
SMTP requests and by comparing error codes returned with those in the
fingerprint database. It does not take into account banners and other
text information, that cannot be trusted, only error code.

37
smtpscan/Makefile Normal file
View file

@ -0,0 +1,37 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/07/08 15:04:48 adrian_p Exp $
DISTNAME= smtpscan-${SSVERSION}
WRKSRC= ${WRKDIR}/smtpscan
CATEGORIES= net mail
MASTER_SITES= http://www.greyhats.org/outils/smtpscan/
MAINTAINER= adrianp@stindustries.net
HOMEPAGE= http://www.greyhats.org/outils/smtpscan/
COMMENT= Remote SMTP version checker
DEPENDS+= p5-Net-DNS-[0-9]*:../../net/p5-Net-DNS
USE_PERL5= YES
REPLACE_PERL= src/smtpscan
SSVERSION?= 0.5
SSSHARE?= ${PREFIX}/share/smtpscan
do-build:
@${SED} -e 's#@SSVERSION@#${SSVERSION}#g' \
-e 's#@SSSHARE@#${SSSHARE}#g' \
< ${WRKSRC}/docs/man/smtpscan.1 > ${WRKSRC}/docs/smtpscan.1
@${SED} -e 's#@SSVERSION@#${SSVERSION}#g' \
-e 's#@PREFIX@#${PREFIX}#g' \
< ${WRKSRC}/src/smtpscan > ${WRKSRC}/smtpscan
do-install:
${INSTALL_DATA_DIR} ${SSSHARE}
${INSTALL_DATA} ${WRKSRC}/src/fingerprints ${SSSHARE}
${INSTALL_DATA} ${WRKSRC}/src/tests ${SSSHARE}
${INSTALL_SCRIPT} ${WRKSRC}/smtpscan ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/docs/smtpscan.1 ${PREFIX}/man/man1
.include "../../mk/bsd.pkg.mk"

6
smtpscan/PLIST Normal file
View file

@ -0,0 +1,6 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/07/08 15:04:48 adrian_p Exp $
bin/smtpscan
man/man1/smtpscan.1
share/smtpscan/fingerprints
share/smtpscan/tests
@dirrm share/smtpscan

12
smtpscan/TODO Normal file
View file

@ -0,0 +1,12 @@
$NetBSD: TODO,v 1.1.1.1 2003/07/08 15:04:48 adrian_p Exp $
This package uses a database of SMTP server signatures to identify remote SMTP
servers.
Please test and let me know if there are any issues.
Tested on NetBSD 1.6 i386.
Regards,
Adrian.

6
smtpscan/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2003/07/08 15:04:48 adrian_p Exp $
SHA1 (smtpscan-0.5.tar.gz) = 958bbc5fdf6932fae40ea6e8258fc5c3fa91bc49
Size (smtpscan-0.5.tar.gz) = 162643 bytes
SHA1 (patch-aa) = 353e7966cc221dc8ec62f0e34c5d77f1aa63ba4b
SHA1 (patch-ab) = ddaf1fff98d29136cb53f6006e0045ac69009a52

26
smtpscan/patches/patch-aa Normal file
View file

@ -0,0 +1,26 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/07/08 15:04:48 adrian_p Exp $
--- docs/man/smtpscan.1.orig Thu Jun 19 11:27:53 2003
+++ docs/man/smtpscan.1 Thu Jun 19 11:28:31 2003
@@ -1,6 +1,6 @@
-.TH SMTPSCAN "1" "20020821" "smtpscan @VERSION@"
+.TH SMTPSCAN "1" "20020821" "smtpscan @SSVERSION@"
.SH NAME
-.B smtpscan @VERSION@
+.B smtpscan @SSVERSION@
.SH SYNOPSIS
.B smtpscan
@@ -88,10 +88,10 @@
at 15 seconds
.SH FILES
-.I @prefix@/smtpscan/fingerprints
+.I @SSSHARE@/fingerprints
- fingerprints file
-.I @prefix@/smtpscan/tests
+.I @SSSHARE@/tests
- tests file
.SH AUTHOR

16
smtpscan/patches/patch-ab Normal file
View file

@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/07/08 15:04:48 adrian_p Exp $
--- src/smtpscan.orig Mon May 5 23:49:07 2003
+++ src/smtpscan Thu Jun 19 11:46:45 2003
@@ -32,9 +32,9 @@
# characters
my $mail_user = '';
-$LOCAL_SHARE = '/usr/local/share';
+$LOCAL_SHARE = '@PREFIX@/share';
-$VERSION = '@VERSION@';
+$VERSION = '@SSVERSION@';
@VALID_CHARS = ( 'A' .. 'Z', 'a' .. 'z', '0' .. '9', '_');