Update to HPLIP 3.12.4:
Changes: - Uninstall Support: User can uninstall complete HPLIP package by running "hp-uninstall" command - Upgrade Support: Settings can be configured using "hp-systray - > settings - > Update settings" for notification of newer version of HPLIP release. User can also upgrade to latest version by running "hp-upgrade" command - Queue Analyzer: Print/Fax queues can be analyzed by running "hp-diagnose-queues" command or by clicking on "Diagnose Queues" from toolbox - Set the fax-type = 4 for hp laserjet 1522nf mfp printer - Added the code check for separating the black and color data from the ghostscript's raster output for devices supporting CMYK color space to fix the blurry printing issue on HP LaserJet CP1025 and CP1025nw - Added three new features : Uninstallation , Upgradation, Print/Fax queue Analysis - Fixed the issue of digital signature mismatch for the plugin download by switching off the cache while downloading the plugin from the server New Printers: - HP LaserJet Pro 300 color MFP M375nw - HP LaserJet Pro 400 color MFP M475dn - HP LaserJet Pro 400 color MFP M475dw - HP LaserJet Pro 300 color M351a - HP LaserJet Pro 400 color M451nw - HP LaserJet Pro 400 color M451dn - HP LaserJet Pro 400 color M451dw - HP Color LaserJet CP1217 - HP LaserJet Pro P1108 Printer - HP LaserJet Pro P1106 Printer - HP LaserJet Pro P1102s Printer - HP LaserJet Pro CP 1025nw Color Printer - HP LaserJet Pro CP 1025 Color Printer - HP OfficeJet 6100 ePrinter - H611a - HP Officejet 6600 e-All-in-One Printer - H711a - HP Officejet 6700 Premium e-All-in-One Printer - H711n - HP LaserJet Pro P1102s Printer - HP LaserJet Pro M1132s Multifunction Printer Bugs: (from Launchpad) 180555 - Duplex scanning support for HP OfficeJet Pro 8500 a910g HP OfficeJet Pro 8600 e-AiO N911a HP OfficeJet Pro 8600 Plus e-AiO N911g 934180,707655 - Fixed the fax setup issue in HP OfficeJet Pro 8600 Officejet 6500 889306,931006 - Fixed the blurry printing issue on HP LaserJet CP1025 and CP1025nw 191165 - Updated the manual installation instructions for CentOS,OpenSUSE,Fedora,Mandriva and LinuxMint 790238 - Added fax support for HP LaserJet 1522nf MFP 192334 - Added Envelop C5 Paper Size for envy 110 942281 - Batch-scan supported for scanimage 927708 - Attribute Error: ScanDevice instance has no attribute 'last_opt' 905962,923887,962297 - Wireless configuration using hp-wificonfig command is fixed in HP Deskjet 3000 J310 series HP Deskjet 3050 J610 series
This commit is contained in:
parent
42749e88ba
commit
a51d6a223d
5 changed files with 165 additions and 98 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.38 2011/12/02 02:46:34 schnoebe Exp $
|
||||
# $NetBSD: Makefile,v 1.39 2012/05/14 15:10:39 schnoebe Exp $
|
||||
#
|
||||
|
||||
DISTNAME= hplip-3.11.10
|
||||
DISTNAME= hplip-3.12.4
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=hplip/}
|
||||
|
||||
|
@ -14,7 +14,13 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
|
||||
CONFLICTS+= hpijs-[0-9]*
|
||||
|
||||
BUILD_DEFS+= VARBASE
|
||||
FILES_SUBST+= CUPS_USER=${CUPS_USER}
|
||||
FILES_SUBST+= CUPS_GROUP=${CUPS_GROUP}
|
||||
|
||||
PKG_GROUPS_VARS+= CUPS_GROUP
|
||||
PKG_USERS_VARS+= CUPS_USER
|
||||
|
||||
BUILD_DEFS+= CUPS_USER CUPS_GROUP VARBASE
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
@ -48,6 +54,9 @@ INSTALL_MAKE_FLAGS+= mimedir=${EGDIR}/cups
|
|||
|
||||
OWN_DIRS+= ${PKG_SYSCONFDIR}/hp
|
||||
OWN_DIRS+= ${VARBASE}/lib/hp
|
||||
OWN_DIRS+= ${PREFIX}/share/examples/hplip/log/hp
|
||||
|
||||
OWN_DIRS_PERMS+= ${PREFIX}/share/examples/hplip/log/hp ${CUPS_USER} ${CUPS_GROUP} 0774
|
||||
|
||||
PLIST_SRC= PLIST.base
|
||||
|
||||
|
@ -56,7 +65,7 @@ PLIST_SRC= PLIST.base
|
|||
.for file in ${EGFILES}
|
||||
CONF_FILES+= ${EGDIR}/${file} ${PKG_SYSCONFDIR}/${file}
|
||||
.endfor
|
||||
CONF_FILES+= ${EGDIR}/lib/hp/hplip.state ${VARBASE}/lib/hp/hplip.state
|
||||
CONF_FILES+=
|
||||
|
||||
REPLACE_PYTHON= *.py */*.py */*/*.py
|
||||
REPLACE_PYTHON+= fax/filters/pstotiff
|
||||
|
@ -64,6 +73,12 @@ REPLACE_PERL= prnt/filters/hpcac prnt/hpijs/foomatic-rip-hplip
|
|||
|
||||
PY_PATCHPLIST= yes
|
||||
|
||||
SUBST_CLASSES+= strip-cr
|
||||
SUBST_STAGE.strip-cr= post-extract
|
||||
SUBST_MESSAGE.strip-cr= Strip trailing carriage returns
|
||||
SUBST_FILES.strip-cr= prnt/hpcups/HPCupsFilter.cpp
|
||||
SUBST_FILTER_CMD.strip-cr= ${TR} -d '\r'
|
||||
|
||||
SUBST_CLASSES+= fix-python
|
||||
SUBST_STAGE.fix-python= post-configure
|
||||
SUBST_MESSAGE.fix-python= Fixing python invocations in Python files.
|
||||
|
|
|
@ -1,9 +1,13 @@
|
|||
@comment $NetBSD: PLIST.base,v 1.1 2011/11/17 22:09:36 schnoebe Exp $
|
||||
@comment $NetBSD: PLIST.base,v 1.2 2012/05/14 15:10:39 schnoebe Exp $
|
||||
bin/hp-align
|
||||
bin/hp-check
|
||||
bin/hp-check-plugin
|
||||
bin/hp-clean
|
||||
bin/hp-colorcal
|
||||
bin/hp-config_usb_printer
|
||||
bin/hp-devicesettings
|
||||
bin/hp-diagnose_plugin
|
||||
bin/hp-diagnose_queues
|
||||
bin/hp-fab
|
||||
bin/hp-faxsetup
|
||||
bin/hp-firmware
|
||||
|
@ -26,7 +30,9 @@ bin/hp-setup
|
|||
bin/hp-systray
|
||||
bin/hp-testpage
|
||||
bin/hp-timedate
|
||||
bin/hp-uninstall
|
||||
bin/hp-unload
|
||||
bin/hp-upgrade
|
||||
bin/hp-wificonfig
|
||||
bin/hpijs
|
||||
lib/libhpip.la
|
||||
|
@ -80,9 +86,10 @@ share/doc/${PKGNAME}/troubleshooting.html
|
|||
share/doc/${PKGNAME}/uninstalling.html
|
||||
share/doc/${PKGNAME}/upgrading.html
|
||||
share/examples/hplip/hp/hplip.conf
|
||||
share/examples/hplip/lib/hp/hplip.state
|
||||
share/examples/hplip/udev/rules.d/55-hpmud.rules
|
||||
share/examples/hplip/udev/rules.d/56-hpmud_add_printer.rules
|
||||
share/examples/hplip/udev/rules.d/56-hpmud_support.rules
|
||||
share/examples/hplip/udev/rules.d/86-hpmud_plugin.rules
|
||||
share/examples/hplip/xdg/autostart/hplip-systray.desktop
|
||||
share/hal/fdi/preprobe/10osvendor/20-hplip-devices.fdi
|
||||
share/hplip/__init__.py
|
||||
|
@ -141,12 +148,16 @@ share/hplip/base/vcard.py
|
|||
share/hplip/base/vcard.pyc
|
||||
share/hplip/base/wifi.py
|
||||
share/hplip/base/wifi.pyc
|
||||
share/hplip/check-plugin.py
|
||||
share/hplip/check-plugin.pyc
|
||||
share/hplip/check.py
|
||||
share/hplip/check.pyc
|
||||
share/hplip/clean.py
|
||||
share/hplip/clean.pyc
|
||||
share/hplip/colorcal.py
|
||||
share/hplip/colorcal.pyc
|
||||
share/hplip/config_usb_printer.py
|
||||
share/hplip/config_usb_printer.pyc
|
||||
share/hplip/copier/__init__.py
|
||||
share/hplip/copier/__init__.pyc
|
||||
share/hplip/copier/copier.py
|
||||
|
@ -188,6 +199,10 @@ share/hplip/data/ps/clean_page.pdf.gz
|
|||
share/hplip/data/ps/testpage.ps.gz
|
||||
share/hplip/devicesettings.py
|
||||
share/hplip/devicesettings.pyc
|
||||
share/hplip/diagnose_plugin.py
|
||||
share/hplip/diagnose_plugin.pyc
|
||||
share/hplip/diagnose_queues.py
|
||||
share/hplip/diagnose_queues.pyc
|
||||
share/hplip/fab.py
|
||||
share/hplip/fab.pyc
|
||||
share/hplip/faxsetup.py
|
||||
|
@ -403,6 +418,8 @@ share/hplip/ppd/HP/hp-color_laserjet_cm6049_mfp-ps.ppd.gz
|
|||
share/hplip/ppd/HP/hp-color_laserjet_cm6049_mfp.ppd.gz
|
||||
share/hplip/ppd/HP/hp-color_laserjet_cp1215-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-color_laserjet_cp1215.ppd.gz
|
||||
share/hplip/ppd/HP/hp-color_laserjet_cp1217-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-color_laserjet_cp1217.ppd.gz
|
||||
share/hplip/ppd/HP/hp-color_laserjet_cp1514n-hpijs-pcl3.ppd.gz
|
||||
share/hplip/ppd/HP/hp-color_laserjet_cp1514n-pcl3.ppd.gz
|
||||
share/hplip/ppd/HP/hp-color_laserjet_cp1514n-ps.ppd.gz
|
||||
|
@ -884,6 +901,7 @@ share/hplip/ppd/HP/hp-laserjet_1320nw.ppd.gz
|
|||
share/hplip/ppd/HP/hp-laserjet_1320tn-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_1320tn-ps.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_1320tn.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_200_colormfp_m275-ps.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_2100-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_2100-ps.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_2100.ppd.gz
|
||||
|
@ -1035,6 +1053,7 @@ share/hplip/ppd/HP/hp-laserjet_5si-ps.ppd.gz
|
|||
share/hplip/ppd/HP/hp-laserjet_5si_mopier-hpijs-pcl3.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_5si_mopier-pcl3.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_5si_mopier-ps.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_600_m601_m602_m603-ps.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_6l-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_6l.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_6mp-hpijs-pcl3.ppd.gz
|
||||
|
@ -1101,21 +1120,15 @@ share/hplip/ppd/HP/hp-laserjet_cm1417fnw-hpijs-pcl3.ppd.gz
|
|||
share/hplip/ppd/HP/hp-laserjet_cm1417fnw-pcl3.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cm1418fnw-hpijs-pcl3.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cm1418fnw-pcl3.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1021-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1021.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1022-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1022.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1023-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1023.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1025-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1025.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1025nw-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1025nw.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1027nw-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1027nw.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1028nw-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1028nw.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp1520_series-ps.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp_1025-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp_1025.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp_1025nw-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_cp_1025nw.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_m1005-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_m1005.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_m1120_mfp-hpijs.ppd.gz
|
||||
|
@ -1279,12 +1292,18 @@ share/hplip/ppd/HP/hp-laserjet_professional_p1102-hpijs.ppd.gz
|
|||
share/hplip/ppd/HP/hp-laserjet_professional_p1102.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1102w-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1102w.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1106-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1106.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1108-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1108.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1566-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1566.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1606dn-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p1606dn.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p_1102w-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-laserjet_professional_p_1102w.ppd.gz
|
||||
share/hplip/ppd/HP/hp-lj_300_400_color_m351_m451-ps.ppd.gz
|
||||
share/hplip/ppd/HP/hp-lj_300_400_color_mfp_m375_m475-ps.ppd.gz
|
||||
share/hplip/ppd/HP/hp-mopier_240-hpijs-pcl3.ppd.gz
|
||||
share/hplip/ppd/HP/hp-mopier_240-pcl3.ppd.gz
|
||||
share/hplip/ppd/HP/hp-mopier_240-ps.ppd.gz
|
||||
|
@ -1335,6 +1354,8 @@ share/hplip/ppd/HP/hp-officejet_6000_e609a-hpijs.ppd.gz
|
|||
share/hplip/ppd/HP/hp-officejet_6000_e609a.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6000_e609n-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6000_e609n.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6100-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6100.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6100_series-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6100_series.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6150_series-hpijs.ppd.gz
|
||||
|
@ -1351,6 +1372,10 @@ share/hplip/ppd/HP/hp-officejet_6500_e710a-f-hpijs.ppd.gz
|
|||
share/hplip/ppd/HP/hp-officejet_6500_e710a-f.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6500_e710n-z-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6500_e710n-z.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6600-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6600.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6700-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_6700.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_7000_e809a-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_7000_e809a.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_7000_e809a_series-hpijs.ppd.gz
|
||||
|
@ -1472,8 +1497,6 @@ share/hplip/ppd/HP/hp-officejet_series_330-hpijs.ppd.gz
|
|||
share/hplip/ppd/HP/hp-officejet_series_330.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_series_350-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_series_350.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_series_500-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_series_500.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_series_520-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_series_520.ppd.gz
|
||||
share/hplip/ppd/HP/hp-officejet_series_570-hpijs.ppd.gz
|
||||
|
@ -1550,6 +1573,8 @@ share/hplip/ppd/HP/hp-photosmart_470_series-hpijs.ppd.gz
|
|||
share/hplip/ppd/HP/hp-photosmart_470_series.ppd.gz
|
||||
share/hplip/ppd/HP/hp-photosmart_5510_series-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-photosmart_5510_series.ppd.gz
|
||||
share/hplip/ppd/HP/hp-photosmart_5510d_series-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-photosmart_5510d_series.ppd.gz
|
||||
share/hplip/ppd/HP/hp-photosmart_6510_series-hpijs.ppd.gz
|
||||
share/hplip/ppd/HP/hp-photosmart_6510_series.ppd.gz
|
||||
share/hplip/ppd/HP/hp-photosmart_7150-hpijs.ppd.gz
|
||||
|
@ -1806,15 +1831,12 @@ share/hplip/timedate.py
|
|||
share/hplip/timedate.pyc
|
||||
share/hplip/toolbox.py
|
||||
share/hplip/toolbox.pyc
|
||||
share/hplip/uninstall.py
|
||||
share/hplip/uninstall.pyc
|
||||
share/hplip/unload.py
|
||||
share/hplip/unload.pyc
|
||||
share/hplip/upgrade.py
|
||||
share/hplip/upgrade.pyc
|
||||
share/hplip/wificonfig.py
|
||||
share/hplip/wificonfig.pyc
|
||||
@pkgdir share/hplip/data/images/other
|
||||
@pkgdir share/hplip/data/images/devices
|
||||
@pkgdir share/hplip/data/images/64x64
|
||||
@pkgdir share/hplip/data/images/32x32
|
||||
@pkgdir share/hplip/data/images/256x256
|
||||
@pkgdir share/hplip/data/images/24x24
|
||||
@pkgdir share/hplip/data/images/16x16
|
||||
@pkgdir share/hplip/data/images/128x128
|
||||
@pkgdir share/examples/hplip/log/hp
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST.gui,v 1.1 2011/11/17 22:09:36 schnoebe Exp $
|
||||
@comment $NetBSD: PLIST.gui,v 1.2 2012/05/14 15:10:39 schnoebe Exp $
|
||||
bin/hp-toolbox
|
||||
share/PolicyKit/policy/com.hp.hplip.policy
|
||||
share/dbus-1/system-services/com.hp.hplip.service
|
||||
|
@ -172,6 +172,7 @@ share/hplip/data/images/devices/LASERJET_5550DTN.png
|
|||
share/hplip/data/images/devices/OFFICEJET_PRO_1150C.png
|
||||
share/hplip/data/images/devices/OfficeJet_5105.png
|
||||
share/hplip/data/images/devices/OfficeJet_6100_Series.png
|
||||
share/hplip/data/images/devices/OfficeJet_8500_a910.png
|
||||
share/hplip/data/images/devices/OfficeJet_G85.png
|
||||
share/hplip/data/images/devices/OfficeJet_Series_300.png
|
||||
share/hplip/data/images/devices/Officejet_6150_Series.png
|
||||
|
@ -386,6 +387,10 @@ share/hplip/ui4/nodevicesdialog.py
|
|||
share/hplip/ui4/nodevicesdialog.pyc
|
||||
share/hplip/ui4/nodevicesdialog_base.py
|
||||
share/hplip/ui4/nodevicesdialog_base.pyc
|
||||
share/hplip/ui4/plugindiagnose.py
|
||||
share/hplip/ui4/plugindiagnose.pyc
|
||||
share/hplip/ui4/plugindiagnose_base.py
|
||||
share/hplip/ui4/plugindiagnose_base.pyc
|
||||
share/hplip/ui4/plugindialog.py
|
||||
share/hplip/ui4/plugindialog.pyc
|
||||
share/hplip/ui4/plugindialog_base.py
|
||||
|
@ -414,6 +419,8 @@ share/hplip/ui4/printtestpagedialog.py
|
|||
share/hplip/ui4/printtestpagedialog.pyc
|
||||
share/hplip/ui4/printtestpagedialog_base.py
|
||||
share/hplip/ui4/printtestpagedialog_base.pyc
|
||||
share/hplip/ui4/queuesconf.py
|
||||
share/hplip/ui4/queuesconf.pyc
|
||||
share/hplip/ui4/readonlyradiobutton.py
|
||||
share/hplip/ui4/readonlyradiobutton.pyc
|
||||
share/hplip/ui4/sendfaxdialog.py
|
||||
|
@ -436,8 +443,11 @@ share/hplip/ui4/systrayframe_base.py
|
|||
share/hplip/ui4/systrayframe_base.pyc
|
||||
share/hplip/ui4/ui_utils.py
|
||||
share/hplip/ui4/ui_utils.pyc
|
||||
share/hplip/ui4/upgradedialog.py
|
||||
share/hplip/ui4/upgradedialog.pyc
|
||||
share/hplip/ui4/upgradedialog_base.py
|
||||
share/hplip/ui4/upgradedialog_base.pyc
|
||||
share/hplip/ui4/wifisetupdialog.py
|
||||
share/hplip/ui4/wifisetupdialog.pyc
|
||||
share/hplip/ui4/wifisetupdialog_base.py
|
||||
share/hplip/ui4/wifisetupdialog_base.pyc
|
||||
@pkgdir share/hplip/ui4/plugins
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.17 2011/12/02 02:46:34 schnoebe Exp $
|
||||
$NetBSD: distinfo,v 1.18 2012/05/14 15:10:39 schnoebe Exp $
|
||||
|
||||
SHA1 (hplip-3.11.10.tar.gz) = 716dea09c1570356b359e5b6d4a50f8b2654d760
|
||||
RMD160 (hplip-3.11.10.tar.gz) = d5e7bd065f1fea5f536b4bf47c8962374de95591
|
||||
Size (hplip-3.11.10.tar.gz) = 21419965 bytes
|
||||
SHA1 (hplip-3.12.4.tar.gz) = 6c095321fac3a06c508531e193dcdd83c30ea99b
|
||||
RMD160 (hplip-3.12.4.tar.gz) = 616d23a39db65d1590e6cbd821f130a53c2743c2
|
||||
Size (hplip-3.12.4.tar.gz) = 20603723 bytes
|
||||
SHA1 (patch-aa) = 6487ae3ccfd73d40e7f48e9d65f165d2e283056a
|
||||
SHA1 (patch-ab) = ce2775ef74746aefd942bda49c4e548f7c771ff5
|
||||
SHA1 (patch-ac) = 82e2951ec3edf44dd78dae9ac6abb307eb60b9fc
|
||||
SHA1 (patch-ad) = 468fbf167e1f20bb8617e444977969e46b19f3be
|
||||
SHA1 (patch-ae) = cd7499667e20aa42d13fb83f783895c910a191cf
|
||||
SHA1 (patch-ae) = 39138102e490f32045f361b2a8d66d7a6598e520
|
||||
SHA1 (patch-io_hpmud_pml.c) = 9bd341140afbc9ddb8eb8dff7eee05365231f94f
|
||||
SHA1 (patch-scan.py) = 3db0f55a915812fa9535fcf1fa2eaebd9daa93e3
|
||||
|
|
|
@ -1,72 +1,92 @@
|
|||
$NetBSD: patch-ae,v 1.7 2011/03/10 19:08:46 gregoire Exp $
|
||||
$NetBSD: patch-ae,v 1.8 2012/05/14 15:10:39 schnoebe Exp $
|
||||
|
||||
# Conform to autoconf's standard variable usage, making it easier
|
||||
# to install on pkgsrc platforms
|
||||
|
||||
# reported upstream as https://bugs.launchpad.net/hplip/+bug/726218
|
||||
|
||||
--- Makefile.am.orig 2011-01-19 05:18:26.000000000 +0000
|
||||
--- Makefile.am.orig 2012-04-10 08:35:14.000000000 +0000
|
||||
+++ Makefile.am
|
||||
@@ -91,18 +91,18 @@ hp_mkuri_LDADD = -ldl libhpmud.la
|
||||
hp_mkuri_CFLAGS = -DCONFDIR=\"$(hplip_confdir)\"
|
||||
|
||||
# hpmud.rules
|
||||
-rulesdir = /etc/udev/rules.d
|
||||
+rulesdir = $(sysconfdir)/udev/rules.d
|
||||
dist_rules_DATA = data/rules/56-hpmud_support.rules
|
||||
if UDEV_ACL_RULES
|
||||
dist_rules_DATA += data/rules/40-hplip.rules
|
||||
else
|
||||
dist_rules_DATA += data/rules/55-hpmud.rules
|
||||
endif
|
||||
-halpredir = /usr/share/hal/fdi/preprobe/10osvendor
|
||||
+halpredir = $(datadir)/hal/fdi/preprobe/10osvendor
|
||||
dist_halpre_DATA = data/rules/20-hplip-devices.fdi
|
||||
|
||||
# hplip.conf
|
||||
-hplip_confdir = /etc/hp
|
||||
+hplip_confdir = $(sysconfdir)/hp
|
||||
hplip_conf_DATA = hplip.conf
|
||||
|
||||
#pstotiff filter
|
||||
@@ -110,7 +110,7 @@ pstotiffdir = $(cupsfilterdir)
|
||||
pstotiff_SCRIPTS = fax/filters/pstotiff
|
||||
|
||||
# hplip.state
|
||||
-hplip_statedir = /var/lib/hp
|
||||
+hplip_statedir = $(localstatedir)/lib/hp
|
||||
dist_hplip_state_DATA = hplip.state
|
||||
|
||||
if FULL_BUILD
|
||||
@@ -317,9 +317,9 @@ endif
|
||||
|
||||
# PolicyKit
|
||||
if POLICYKIT_INSTALL
|
||||
-policykit_dbus_etcdir = /etc/dbus-1/system.d
|
||||
+policykit_dbus_etcdir = $(sysconfdir)/dbus-1/system.d
|
||||
dist_policykit_dbus_etc_DATA = data/policykit/com.hp.hplip.conf
|
||||
-policykit_dbus_sharedir = /usr/share/dbus-1/system-services
|
||||
+policykit_dbus_sharedir = $(datadir)/dbus-1/system-services
|
||||
dist_policykit_dbus_share_DATA = data/policykit/com.hp.hplip.service
|
||||
policykit_policydir = $(policykit_dir)
|
||||
dist_policykit_policy_DATA = data/policykit/com.hp.hplip.policy
|
||||
@@ -495,13 +495,13 @@ install-data-hook:
|
||||
if HPLIP_BUILD
|
||||
# If scanner build, add hpaio entry to sane dll.conf.
|
||||
if [ "$(scan_build)" = "yes" ]; then \
|
||||
- $(mkinstalldirs) $(DESTDIR)/etc/sane.d; \
|
||||
- if [ ! -f $(DESTDIR)/etc/sane.d/dll.conf ]; then \
|
||||
- touch $(DESTDIR)/etc/sane.d/dll.conf; \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)/sane.d; \
|
||||
+ if [ ! -f $(DESTDIR)$(sysconfdir)/sane.d/dll.conf ]; then \
|
||||
+ touch $(DESTDIR)$(sysconfdir)/sane.d/dll.conf; \
|
||||
fi; \
|
||||
- if ! grep ^hpaio $(DESTDIR)/etc/sane.d/dll.conf >/dev/null 2>/dev/null ; then \
|
||||
- echo "Adding hpaio entry to /etc/sane.d/dll.conf." ; \
|
||||
- echo hpaio >>$(DESTDIR)/etc/sane.d/dll.conf ; \
|
||||
+ if ! grep ^hpaio $(DESTDIR)$(sysconfdir)/sane.d/dll.conf >/dev/null 2>/dev/null ; then \
|
||||
+ echo "Adding hpaio entry to $(sysconfdir)/sane.d/dll.conf." ; \
|
||||
+ echo hpaio >>$(DESTDIR)$(sysconfdir)/sane.d/dll.conf ; \
|
||||
fi \
|
||||
fi
|
||||
if FULL_BUILD
|
||||
@@ -91,7 +91,7 @@ hp_mkuri_LDADD = -ldl libhpmud.la
|
||||
hp_mkuri_CFLAGS = -DCONFDIR=\"$(hplip_confdir)\"
|
||||
|
||||
# hpmud.rules
|
||||
-rulesdir = /etc/udev/rules.d
|
||||
+rulesdir = $(sysconfdir)/udev/rules.d
|
||||
dist_rules_DATA = data/rules/56-hpmud_support.rules
|
||||
dist_rules_DATA += data/rules/86-hpmud_plugin.rules
|
||||
dist_rules_DATA += data/rules/56-hpmud_add_printer.rules
|
||||
@@ -100,11 +100,11 @@ dist_rules_DATA += data/rules/40-hplip.r
|
||||
else
|
||||
dist_rules_DATA += data/rules/55-hpmud.rules
|
||||
endif
|
||||
-halpredir = /usr/share/hal/fdi/preprobe/10osvendor
|
||||
+halpredir = $(datadir)/hal/fdi/preprobe/10osvendor
|
||||
dist_halpre_DATA = data/rules/20-hplip-devices.fdi
|
||||
|
||||
# hplip.conf
|
||||
-hplip_confdir = /etc/hp
|
||||
+hplip_confdir = $(sysconfdir)/hp
|
||||
hplip_conf_DATA = hplip.conf
|
||||
|
||||
#pstotiff filter
|
||||
@@ -112,12 +112,12 @@ pstotiffdir = $(cupsfilterdir)
|
||||
pstotiff_SCRIPTS = fax/filters/pstotiff
|
||||
|
||||
# hplip.state
|
||||
-hplip_statedir = /var/lib/hp
|
||||
+hplip_statedir = $(localstatedir)/lib/hp
|
||||
dist_hplip_state_DATA =
|
||||
#dist_hplip_state_DATA = hplip.state
|
||||
|
||||
# Log Files
|
||||
-hplip_Logdir=/var/log/hp
|
||||
+hplip_Logdir=$(localstatedir)/log/hp
|
||||
|
||||
if FULL_BUILD
|
||||
|
||||
@@ -326,9 +326,9 @@ endif
|
||||
|
||||
# PolicyKit
|
||||
if POLICYKIT_INSTALL
|
||||
-policykit_dbus_etcdir = /etc/dbus-1/system.d
|
||||
+policykit_dbus_etcdir = $(sysconfdir)/dbus-1/system.d
|
||||
dist_policykit_dbus_etc_DATA = data/policykit/com.hp.hplip.conf
|
||||
-policykit_dbus_sharedir = /usr/share/dbus-1/system-services
|
||||
+policykit_dbus_sharedir = $(datadir)/dbus-1/system-services
|
||||
dist_policykit_dbus_share_DATA = data/policykit/com.hp.hplip.service
|
||||
policykit_policydir = $(policykit_dir)
|
||||
dist_policykit_policy_DATA = data/policykit/com.hp.hplip.policy
|
||||
@@ -509,26 +509,22 @@ endif
|
||||
install-dist_hplip_LogDATA:
|
||||
if FULL_BUILD
|
||||
test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
|
||||
- chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
- chmod 774 $(DESTDIR)$(hplip_Logdir)
|
||||
endif #FULL_BUILD
|
||||
if HPLIP_BUILD
|
||||
test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
|
||||
- chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
- chmod 774 $(DESTDIR)$(hplip_Logdir)
|
||||
endif #FULL_BUILD
|
||||
|
||||
install-data-hook:
|
||||
if HPLIP_BUILD
|
||||
# If scanner build, add hpaio entry to sane dll.conf.
|
||||
if [ "$(scan_build)" = "yes" ]; then \
|
||||
- $(mkinstalldirs) $(DESTDIR)/etc/sane.d; \
|
||||
- if [ ! -f $(DESTDIR)/etc/sane.d/dll.conf ]; then \
|
||||
- touch $(DESTDIR)/etc/sane.d/dll.conf; \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)/sane.d; \
|
||||
+ if [ ! -f $(DESTDIR)$(sysconfdir)/sane.d/dll.conf ]; then \
|
||||
+ touch $(DESTDIR)$(sysconfdir)/sane.d/dll.conf; \
|
||||
fi; \
|
||||
- if ! grep ^hpaio $(DESTDIR)/etc/sane.d/dll.conf >/dev/null 2>/dev/null ; then \
|
||||
- echo "Adding hpaio entry to /etc/sane.d/dll.conf." ; \
|
||||
- echo hpaio >>$(DESTDIR)/etc/sane.d/dll.conf ; \
|
||||
+ if ! grep ^hpaio $(DESTDIR)$(sysconfdir)/sane.d/dll.conf >/dev/null 2>/dev/null ; then \
|
||||
+ echo "Adding hpaio entry to $(sysconfdir)/sane.d/dll.conf." ; \
|
||||
+ echo hpaio >>$(DESTDIR)$(sysconfdir)/sane.d/dll.conf ; \
|
||||
fi \
|
||||
fi
|
||||
if FULL_BUILD
|
||||
|
|
Loading…
Reference in a new issue