Initial import of xdkcal - X Desktop Calendar.

X Desktop Calendar (xdkcal) is a Calendar for X Window System.  It
draws calendar on your desktop.  You can customize, fontset, color
drawing style.  This application is completely internationalized
so it reads locale database and draw locale specific strings, such
as name of months or weeks.
This commit is contained in:
Mike M. Volokhov 2004-04-01 12:45:05 +00:00 committed by Thomas Klausner
parent 02f77bdc91
commit a8135fe5c6
5 changed files with 57 additions and 0 deletions

5
xdkcal/DESCR Normal file
View file

@ -0,0 +1,5 @@
X Desktop Calendar (xdkcal) is a Calendar for X Window System. It
draws calendar on your desktop. You can customize, fontset, color
drawing style. This application is completely internationalized
so it reads locale database and draw locale specific strings, such
as name of months or weeks.

18
xdkcal/Makefile Normal file
View file

@ -0,0 +1,18 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/04/01 12:45:05 bubuchka Exp $
DISTNAME= xdkcal-0.9d
CATEGORIES= wip time
MASTER_SITES= http://www.shiratori.riec.tohoku.ac.jp/~jir/linux/products/xdkcal/
MAINTAINER= mishka@apk.od.ua
HOMEPAGE= http://www.shiratori.riec.tohoku.ac.jp/~jir/linux/products/xdkcal/index-e.html
COMMENT= X Desktop Calendar
GNU_CONFIGURE= yes
USE_X11= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xdkcal ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xdkcal.1x ${PREFIX}/man/man1/xdkcal.1
.include "../../mk/bsd.pkg.mk"

3
xdkcal/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/04/01 12:45:05 bubuchka Exp $
bin/xdkcal
man/man1/xdkcal.1

5
xdkcal/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/04/01 12:45:05 bubuchka Exp $
SHA1 (xdkcal-0.9d.tar.gz) = 8ac5a63170b90d77f22569eecb5592177c06365e
Size (xdkcal-0.9d.tar.gz) = 48533 bytes
SHA1 (patch-aa) = d497a13d636b54ad779ad1aceb2a3e97a3ac5b61

26
xdkcal/patches/patch-aa Normal file
View file

@ -0,0 +1,26 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/04/01 12:45:05 bubuchka Exp $
--- xdkcal.c.orig 2000-02-24 14:11:20.000000000 +0200
+++ xdkcal.c
@@ -218,9 +218,9 @@ int read_property()
void short_usage()
{
fprintf(stderr,
-"Usage: %s [-h][-x window_x][-y window_y][-f fontset][-C default_color]
- [-H holiday_color][-T today_color][-M month_color][-t on/off]
- [-p padding][-s style_num][-m on/off][-y on/off]
+"Usage: %s [-h][-x window_x][-y window_y][-f fontset][-C default_color]\n\
+ [-H holiday_color][-T today_color][-M month_color][-t on/off]\n\
+ [-p padding][-s style_num][-m on/off][-y on/off]\n\
[-n num_week] [month [year]]\n",PACKAGE);
}
@@ -283,7 +283,7 @@ void init_args(int argc, char *argv[])
while(1)
{
- c = getopt_long_only(argc,argv,
+ c = getopt_long(argc,argv,
"hx:y:f:C:H:S:T:M:t:p:s:m:w:n:Nv",
long_opts,&opt_index);
if(c == -1)