first commit, gambac 4.4 line
This commit is contained in:
parent
ce9e1a42a6
commit
aa34ca6978
8 changed files with 196 additions and 0 deletions
12
gambc/DESCR
Normal file
12
gambc/DESCR
Normal file
|
@ -0,0 +1,12 @@
|
|||
This package the Gambit-C Scheme programming system. Gambit-C
|
||||
includes a Scheme interpreter and a Scheme compiler which can be used
|
||||
to build standalone executables. Because the compiler generates
|
||||
portable C code it is fairly easy to port to any platform with a
|
||||
decent C compiler.
|
||||
|
||||
The Gambit-C system conforms to the R4RS, R5RS and IEEE Scheme standards.
|
||||
The full numeric tower is implemented, including: infinite precision
|
||||
integers (bignums), rationals, inexact reals (floating point numbers),
|
||||
and complex numbers. Gambit-C supports a number of extensions to the
|
||||
standards. Please see the <http://gambit.uri.umontreal.ca/~gambit/wiki>
|
||||
for more information: there is simply not enough room here to elaborate!
|
81
gambc/Makefile
Normal file
81
gambc/Makefile
Normal file
|
@ -0,0 +1,81 @@
|
|||
# $NetBSD: Makefile,v 1.1 2009/03/10 15:01:25 fulviociriaco Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gambc-${GAMBC_DIST_VERSION}
|
||||
PKGNAME= gambc-${GAMBC_VERSION}
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://www.iro.umontreal.ca/~gambit/download/gambit/v4.4/source/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= bjs@NetBSD.org
|
||||
HOMEPAGE= http://www.iro.umontreal.ca/~gambit/
|
||||
COMMENT= GambitC Scheme System
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
NOT_FOR_BULK_PLATFORM+= SunOS-*-*
|
||||
|
||||
# bin/scheme-r5rs
|
||||
CONFLICTS+= scheme48>=1.2
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
CONFIGURE_ARGS+= --enable-single-host
|
||||
CONFIGURE_ARGS+= --enable-cplusplus
|
||||
CONFIGURE_ARGS+= --enable-shared
|
||||
###
|
||||
### XXX On NetBSD/amd64 4.99.61, gcc had a resident memory size of over 384MB
|
||||
### while building this and ultimately exhausted all 1GB of swap I had.
|
||||
### See the documentation for more information. (This was due to using
|
||||
### -fmodulo-sched, gcc 4.1.3).
|
||||
###
|
||||
CONFIGURE_ARGS+= --disable-gcc-opts
|
||||
|
||||
INFO_FILES= yes
|
||||
MAKE_FILE= makefile
|
||||
|
||||
BUILD_TARGET+= bootstrap
|
||||
TEST_TARGET= check
|
||||
|
||||
CHECK_PORTABILITY_SKIP= prebuilt/*/*
|
||||
DLOPEN_REQUIRE_PTHREADS=no
|
||||
|
||||
TEST_TARGET= check
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
GAMBC_MAKE_FLAGS= prefix=${PREFIX}
|
||||
GAMBC_MAKE_FLAGS+= includedir=${PREFIX}/include
|
||||
GAMBC_MAKE_FLAGS+= bindir=${PREFIX}/bin
|
||||
GAMBC_MAKE_FLAGS+= infodir=${PREFIX}/${PKGINFODIR}
|
||||
GAMBC_MAKE_FLAGS+= libdir=${PREFIX}/lib/
|
||||
GAMBC_MAKE_FLAGS+= mandir=${PREFIX}/${PKGMANDIR}
|
||||
GAMBC_MAKE_FLAGS+= docdir=${PREFIX}/share/doc/${PKGBASE}
|
||||
GAMBC_MAKE_FLAGS+= infodir=${PREFIX}/${PKGINFODIR}
|
||||
GAMBC_MAKE_FLAGS+= emacsdir=${PREFIX}/share/emacs/site-lisp
|
||||
|
||||
MAKE_FLAGS+= ${GAMBC_MAKE_FLAGS}
|
||||
INSTALL_MAKE_FLAGS+= ${GAMBC_MAKE_FLAGS:@.f.@\
|
||||
${.f.:C|${PREFIX}|${DESTDIR}&|}\
|
||||
@:M*}
|
||||
|
||||
SUBST_CLASSES+= build
|
||||
SUBST_FILES.build= configure
|
||||
SUBST_FILES.build+= makefile.in */makefile.in */*/makefile.in
|
||||
SUBST_MESSAGE.build= Preparing build-time and installation configuration.
|
||||
SUBST_SED.build= -e 's|v${GAMBC_DIST_VERSION}||'
|
||||
SUBST_SED.build+= -e 's|@target_vendor@|The NetBSD Foundation, Inc.|g'
|
||||
SUBST_STAGE.build= pre-configure
|
||||
SUBST_VARS.build+= PACKAGE_SUBDIR PACKAGE_VERSION
|
||||
SUBST_VARS.build+= PACKAGE_STRING
|
||||
|
||||
PACKAGE_SUBDIR= # empty
|
||||
PACKAGE_VERSION= ${PKGVERSION}
|
||||
PACKAGE_STRING= ${${PKGBASE} ${PKGVERSION}:L}
|
||||
|
||||
.include "version.mk"
|
||||
|
||||
.include "../../mk/dlopen.buildlink3.mk"
|
||||
.include "../../mk/termcap.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
38
gambc/PLIST
Normal file
38
gambc/PLIST
Normal file
|
@ -0,0 +1,38 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2009/03/10 15:01:25 fulviociriaco Exp $
|
||||
bin/gambc-doc.bat
|
||||
bin/gsc-cc-o.bat
|
||||
bin/gsc-script
|
||||
bin/gsi-script
|
||||
bin/scheme-ieee-1178-1990
|
||||
bin/scheme-r4rs
|
||||
bin/scheme-r5rs
|
||||
bin/scheme-srfi-0
|
||||
bin/six
|
||||
bin/six-script
|
||||
include/gambit-not.h
|
||||
include/gambit.h
|
||||
info/gambit-c.info
|
||||
lib/_eval#.scm
|
||||
lib/_gambc.c
|
||||
lib/_gambcgsc.c
|
||||
lib/_gambcgsi.c
|
||||
lib/_gambit#.scm
|
||||
lib/_io#.scm
|
||||
lib/_kernel#.scm
|
||||
lib/_nonstd#.scm
|
||||
lib/_num#.scm
|
||||
lib/_repl#.scm
|
||||
lib/_std#.scm
|
||||
lib/_system#.scm
|
||||
lib/_thread#.scm
|
||||
lib/digest#.scm
|
||||
lib/digest.scm
|
||||
lib/gambit#.scm
|
||||
lib/libgambc.so
|
||||
lib/r4rs#.scm
|
||||
lib/r5rs#.scm
|
||||
lib/syntax-case.scm
|
||||
share/doc/gambc/gambit-c.html
|
||||
share/doc/gambc/gambit-c.pdf
|
||||
share/doc/gambc/gambit-c.txt
|
||||
@dirrm share/doc/gambc
|
21
gambc/buildlink3.mk
Normal file
21
gambc/buildlink3.mk
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2009/03/10 15:01:25 fulviociriaco Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
GAMBC_BUILDLINK3_MK:= ${GAMBC_BUILDLINK3_MK}+
|
||||
|
||||
.if ${BUILDLINK_DEPTH} == "+"
|
||||
BUILDLINK_DEPENDS+= gambc
|
||||
.endif
|
||||
|
||||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Ngambc}
|
||||
BUILDLINK_PACKAGES+= gambc
|
||||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}gambc
|
||||
|
||||
.if ${GAMBC_BUILDLINK3_MK} == "+"
|
||||
BUILDLINK_API_DEPENDS.gambc+= gambc>=4.2.6
|
||||
BUILDLINK_PKGSRCDIR.gambc?= ../../lang/gambc
|
||||
.endif # GAMBC_BUILDLINK3_MK
|
||||
|
||||
.include "../../mk/dlopen.buildlink3.mk"
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
|
6
gambc/distinfo
Normal file
6
gambc/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2009/03/10 15:01:25 fulviociriaco Exp $
|
||||
|
||||
SHA1 (gambc-v4_4_1.tgz) = 80ed43702024320c20065871c909377745c154b8
|
||||
RMD160 (gambc-v4_4_1.tgz) = 8f126b5a54cf7fba4f80afbe3d9b917db98e5779
|
||||
Size (gambc-v4_4_1.tgz) = 8016716 bytes
|
||||
SHA1 (patch-aa) = 2f3ed753556217020dd10c407d989d59c315f909
|
15
gambc/hacks.mk
Normal file
15
gambc/hacks.mk
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: hacks.mk,v 1.1 2009/03/10 15:01:25 fulviociriaco Exp $
|
||||
###
|
||||
.if !defined(GAMBC_HACKS_MK)
|
||||
GAMBC_HACKS_MK= # empty
|
||||
. include "../../mk/compiler.mk"
|
||||
###
|
||||
### It looks as if the developers don't think O2 is a win. Considering how
|
||||
### much memory and time this package takes to build the more optimization
|
||||
### is enabled, let's let the configure script do its job.
|
||||
###
|
||||
. if !empty(CC_VERSION:Mgcc-*)
|
||||
BUILDLINK_TRANSFORM+= rm:-O[2-9s]*
|
||||
. endif
|
||||
BUILDLINK_TRANSFORM+= rm:-pipe # XXX takes up too much memory
|
||||
.endif
|
13
gambc/patches/patch-aa
Normal file
13
gambc/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1 2009/03/10 15:01:25 fulviociriaco Exp $
|
||||
|
||||
--- makefile.in.orig 2008-12-23 15:08:52.000000000 +0100
|
||||
+++ makefile.in
|
||||
@@ -70,7 +70,7 @@ includedir=$(includedir) libdir=$(libdir
|
||||
bindir=$(bindir) docdir=$(docdir) \
|
||||
infodir=$(infodir) emacsdir=$(emacsdir)
|
||||
|
||||
-SUBDIRS = include lib gsi gsc bin misc doc tests examples prebuilt
|
||||
+SUBDIRS = include lib gsi gsc bin doc tests examples
|
||||
|
||||
RCFILES = README INSTALL.txt LICENSE-2.0.txt LGPL.txt \
|
||||
makefile.in configure configure.ac config.guess config.sub install-sh mkidirs \
|
10
gambc/version.mk
Normal file
10
gambc/version.mk
Normal file
|
@ -0,0 +1,10 @@
|
|||
# $NetBSD: version.mk,v 1.1 2009/03/10 15:01:25 fulviociriaco Exp $
|
||||
###
|
||||
.if !defined(GAMBC_VERSION_MK)
|
||||
GAMBC_VERSION_MK= # empty
|
||||
###
|
||||
### The package version sets the distribution version.
|
||||
###
|
||||
GAMBC_VERSION= 4.4.1
|
||||
GAMBC_DIST_VERSION= ${GAMBC_VERSION:C|^.*|v&|:S|.|_|g}
|
||||
.endif
|
Loading…
Reference in a new issue