Remove StepMania 3.9. Reasons:

- is not usable without hardware 3D acceleration
- strictly depends on lua 5.0 (we provide 5.1 now)

Minor patches were accepted by upstream, though.
This commit is contained in:
Sergey Svishchev 2006-10-25 17:56:38 +00:00 committed by Thomas Klausner
parent 1bc7fabf64
commit aa36784203
27 changed files with 0 additions and 865 deletions

View file

@ -1,4 +0,0 @@
StepMania is a music/rhythm game. The player presses different buttons
in time to the music and to note patterns that scroll across the
screen. Features 3D graphics, visualizations, support for gamepads/dance
pads, a step recording mode, and more!

View file

@ -1,33 +0,0 @@
# $NetBSD: Makefile,v 1.7 2006/08/14 22:46:23 thomasklausner Exp $
#
DISTNAME= StepMania-3.9-src
PKGNAME= stepmania-3.9
PKGREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=stepmania/}
MAINTAINER= shattered@users.sourceforge.net
HOMEPAGE= http://www.stepmania.com/stepmania/
COMMENT= Music/rhythm game (Dance Dance Revolution) simulator
WRKSRC= ${WRKDIR}/StepMania-3.9-src
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-tests
USE_LANGUAGES= c c++
USE_TOOLS+= gmake autoconf pkg-config
post-extract:
${CP} ${FILESDIR}/arch_bsd.h ${WRKSRC}/src/arch
.include "../../audio/libmad/buildlink3.mk"
.include "../../audio/libvorbis/buildlink3.mk"
.include "../../devel/SDL/buildlink3.mk"
.include "../../graphics/Mesa/buildlink3.mk"
.include "../../graphics/jpeg/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../lang/lua/buildlink3.mk"
.include "../../multimedia/ffmpeg/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/x11.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
bin/stepmania
bin/GtkModule.so

View file

@ -1,26 +0,0 @@
$NetBSD: distinfo,v 1.5 2006/01/08 17:58:52 shattered Exp $
SHA1 (StepMania-3.9-src.tar.gz) = b2d2c3a50c23506844ba7e22289e59d270bb8b2e
RMD160 (StepMania-3.9-src.tar.gz) = e7451192fe67f53a7a93baf99bf9a20bc3d1f7cf
Size (StepMania-3.9-src.tar.gz) = 3090223 bytes
SHA1 (patch-aa) = a3dce2eaa37bb8714ad794b2f5a88844c6ae4a2e
SHA1 (patch-ab) = 4b6c38aa12bcde51c2edc11240cb2d215a4a6c98
SHA1 (patch-ac) = 431d2c3800fc87a3eea5d86a599de2b989a20a97
SHA1 (patch-ad) = aad0979bf472260f5e1492e2e61436693ec343f6
SHA1 (patch-ae) = f9766e14ebc0f8403daded65d3029f69792ea53b
SHA1 (patch-ag) = 78dcdf3cb46467da376084a2e0fb0c70b495651b
SHA1 (patch-ah) = 0c0f54947654d613257684a2ca6af906553d3c72
SHA1 (patch-ai) = 499a79c361752fa45aaebd3bd711b988240dd2be
SHA1 (patch-aj) = 6dee3da73ffe62b74c023a55738ba9d5fb5e67c7
SHA1 (patch-ak) = b1c818df5bd056c2b9b5e963a8bfd88ee7f1db82
SHA1 (patch-al) = 0092bdb555a92e14fcd05b2b5d40a26611aab222
SHA1 (patch-am) = 6df9845194ccf61d61f44a47b47bd10cb6f0cff7
SHA1 (patch-an) = 0fb70a2042547580d340dbf0f7829894c84cc0e1
SHA1 (patch-ao) = e2fb3953e52e4044e9d811162648061784b6748e
SHA1 (patch-ap) = bdcde5f4e260cb8d9b58b176266b2a0ce0d325d3
SHA1 (patch-aq) = be17697568219ec8d046644c3f22bbcbf6b4e57a
SHA1 (patch-ar) = c131cd4394a38c4f6d88b999e37d3ce8026578eb
SHA1 (patch-as) = 3b9c4f6048857381b034160ef285f36ef16a25aa
SHA1 (patch-at) = b96dc72036e264cd1f51e1305684d1b533d7b88a
SHA1 (patch-au) = 5f991164f96ba0e759f8a071e7de9ce392901359
SHA1 (patch-av) = 379c28c74fc99af5826d45ff9159b7976964a60a

View file

@ -1,56 +0,0 @@
#include "global.h"
#include "LinuxThreadHelpers.h"
#include "RageUtil.h"
#include "RageThreads.h"
#include "Backtrace.h"
#include "archutils/Unix/RunningUnderValgrind.h"
#include <pthread.h>
#include <signal.h>
CString ThreadsVersion()
{
return "(unknown)";
}
PTHREAD_T GetCurrentThreadId()
{
return pthread_self();
}
int SuspendThread( PTHREAD_T ThreadID )
{
return pthread_kill( ThreadID, SIGSTOP );
}
int ResumeThread( PTHREAD_T ThreadID )
{
return pthread_kill( ThreadID, SIGCONT );
}
#endif
/*
* (c) 2004 Glenn Maynard
* All rights reserved.
*
* Permission is hereby granted, free of charge, to any person obtaining a
* copy of this software and associated documentation files (the
* "Software"), to deal in the Software without restriction, including
* without limitation the rights to use, copy, modify, merge, publish,
* distribute, and/or sell copies of the Software, and to permit persons to
* whom the Software is furnished to do so, provided that the above
* copyright notice(s) and this permission notice appear in all copies of
* the Software and that both the above copyright notice(s) and this
* permission notice appear in supporting documentation.
*
* THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
* OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
* MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF
* THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS
* INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT
* OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
* OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR
* OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
* PERFORMANCE OF THIS SOFTWARE.
*/

View file

@ -1,44 +0,0 @@
#ifndef BSD_ARCH_H
#define BSD_ARCH_H
#include "Sound/RageSoundDriver_OSS.h"
#ifdef HAVE_GTK
#include "LoadingWindow/LoadingWindow_Gtk.h"
#endif
/* Load this even if we have GTK, since we can fall back if GTK is missing. */
#include "LoadingWindow/LoadingWindow_SDL.h"
#include "ArchHooks/ArchHooks_Unix.h"
#include "Lights/LightsDriver_Null.h"
#include "Lights/LightsDriver_SystemMessage.h"
#include "MemoryCard/MemoryCardDriver_Null.h"
#endif
/*
* (c) 2002-2003 Glenn Maynard
* All rights reserved.
*
* Permission is hereby granted, free of charge, to any person obtaining a
* copy of this software and associated documentation files (the
* "Software"), to deal in the Software without restriction, including
* without limitation the rights to use, copy, modify, merge, publish,
* distribute, and/or sell copies of the Software, and to permit persons to
* whom the Software is furnished to do so, provided that the above
* copyright notice(s) and this permission notice appear in all copies of
* the Software and that both the above copyright notice(s) and this
* permission notice appear in supporting documentation.
*
* THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
* OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
* MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF
* THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS
* INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT
* OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
* OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR
* OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
* PERFORMANCE OF THIS SOFTWARE.
*/

View file

@ -1,14 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- src/config.h.in.orig 2004-10-23 02:22:39.000000000 +0400
+++ src/config.h.in
@@ -18,6 +18,9 @@
/* Define backtrace type */
#undef BACKTRACE_METHOD_X86_LINUX
+/* *BSD */
+#undef BSD
+
/* PPC */
#undef CPU_PPC

View file

@ -1,24 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- configure.ac.orig 2004-11-07 10:26:53.000000000 +0300
+++ configure.ac
@@ -57,11 +57,19 @@ case $host in
unix=yes
;;
+*-freebsd*|*-netbsd*)
+ AC_DEFINE(BSD, 1, [BSD])
+ AC_DEFINE(UNIX, 1, [Unix])
+ BSD=yes
+ unix=yes
+ ;;
+
*)
AC_DEFINE(UNIX, 1, [Unix])
unix=yes
;;
esac
+AM_CONDITIONAL(BSD, test "$bsd" = "yes" )
AM_CONDITIONAL(UNIX, test "$unix" = "yes" )
AM_CONDITIONAL(LINUX, test "$linux" = "yes" )

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ac,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- src/arch/arch.h.orig 2004-07-08 00:11:29.000000000 +0400
+++ src/arch/arch.h
@@ -24,6 +24,8 @@ RageSoundDriver *MakeRageSoundDriver(CSt
* OK to list drivers that may not be available. */
#if defined(LINUX)
#define DEFAULT_SOUND_DRIVER_LIST "ALSA,ALSA-sw,OSS"
+#elif defined(BSD)
+ #define DEFAULT_SOUND_DRIVER_LIST "OSS"
#elif defined(DARWIN)
#define DEFAULT_SOUND_DRIVER_LIST "CoreAudio,QT1"
#elif defined(_WINDOWS)

View file

@ -1,25 +0,0 @@
$NetBSD: patch-ad,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- src/arch/ArchHooks/ArchHooks_Unix.cpp.orig 2004-09-20 10:12:51.000000000 +0400
+++ src/arch/ArchHooks/ArchHooks_Unix.cpp
@@ -78,9 +78,11 @@ static int TestTLSThread( void *p )
static void TestTLS()
{
+#if defined(LINUX)
/* TLS won't work on older threads libraries, and may crash. */
if( !UsingNPTL() )
return;
+#endif
/* TLS won't work on older Linux kernels. Do a simple check. */
g_iTestTLS = 1;
@@ -110,7 +112,7 @@ ArchHooks_Unix::ArchHooks_Unix()
* This might blow up, so be sure to do it after the crash handler. */
SignalHandler::OnClose( EmergencyShutdown );
-#if defined(HAVE_TLS)
+#if defined(HAVE_TLS) && !defined(__NetBSD__)
TestTLS();
#endif
}

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ae,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- src/arch/arch_platform.h.orig 2005-05-16 00:18:31.000000000 +0400
+++ src/arch/arch_platform.h
@@ -9,6 +9,8 @@
/* Override them with arch-specific drivers, as available. */
#if defined(LINUX)
#include "arch_linux.h"
+#elif defined(BSD)
+#include "arch_bsd.h"
#elif defined(DARWIN)
#include "arch_darwin.h"
#elif defined(_XBOX)

View file

@ -1,47 +0,0 @@
$NetBSD: patch-ag,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- src/archutils/Unix/LinuxThreadHelpers.cpp.orig 2004-10-23 02:23:38.000000000 +0400
+++ src/archutils/Unix/LinuxThreadHelpers.cpp
@@ -7,6 +7,8 @@
#include "Backtrace.h"
#include "archutils/Unix/RunningUnderValgrind.h"
+#if defined(LINUX)
+
#include <unistd.h>
#include <stdlib.h>
#include <fcntl.h>
@@ -238,6 +240,33 @@ bool GetThreadBacktraceContext( uint64_t
}
#endif
+#elif defined(BSD)
+
+#include <pthread.h>
+#include <signal.h>
+
+CString ThreadsVersion()
+{
+ return "(unknown)";
+}
+
+PTHREAD_T GetCurrentThreadId()
+{
+ return pthread_self();
+}
+
+int SuspendThread( PTHREAD_T ThreadID )
+{
+ return pthread_kill( ThreadID, SIGSTOP );
+}
+
+int ResumeThread( PTHREAD_T ThreadID )
+{
+ return pthread_kill( ThreadID, SIGCONT );
+}
+
+#endif
+
/*
* (c) 2004 Glenn Maynard
* All rights reserved.

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ah,v 1.2 2005/11/05 22:07:59 shattered Exp $
--- src/RageSurface_Load_PNG.cpp.orig 2005-10-01 03:32:44.000000000 +0000
+++ src/RageSurface_Load_PNG.cpp 2005-11-01 00:31:57.000000000 +0000
@@ -17,7 +17,7 @@
#if defined(_XBOX)
# include <malloc.h> // for alloca
-#elif !defined(WIN32) && !defined(__MACOSX__)
+#elif !defined(WIN32) && !defined(__MACOSX__) && !defined(BSD)
# include <alloca.h>
#endif

View file

@ -1,138 +0,0 @@
$NetBSD: patch-ai,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- configure.orig 2004-11-07 10:26:53.000000000 +0300
+++ configure
@@ -309,7 +309,7 @@
# include <unistd.h>
#endif"
-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE am__leading_dot MAINTAINER_MODE_TRUE MAINTAINER_MODE_FALSE MAINT CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE RANLIB ac_ct_RANLIB UNIX_TRUE UNIX_FALSE LINUX_TRUE LINUX_FALSE CPP XCFLAGS XLIBS SDL_CONFIG SDL_CFLAGS SDL_LIBS HAVE_SDL_TRUE HAVE_SDL_FALSE EGREP WITHOUT_NETWORKING_TRUE WITHOUT_NETWORKING_FALSE LUA_CONFIG LUA_CFLAGS LUA_LIBS HAVE_VORBIS_TRUE HAVE_VORBIS_FALSE AUDIO_LIBS HAVE_MP3_TRUE HAVE_MP3_FALSE HAVE_FFMPEG_TRUE HAVE_FFMPEG_FALSE ALSA_CFLAGS ALSA_LIBS PKG_CONFIG GTK_CFLAGS GTK_LIBS HAVE_ALSA_TRUE HAVE_ALSA_FALSE HAVE_GTK_TRUE HAVE_GTK_FALSE HAVE_OSS_TRUE HAVE_OSS_FALSE USE_CRASH_HANDLER_TRUE USE_CRASH_HANDLER_FALSE BUILD_TESTS_TRUE BUILD_TESTS_FALSE LIBOBJS LTLIBOBJS'
+ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE am__leading_dot MAINTAINER_MODE_TRUE MAINTAINER_MODE_FALSE MAINT CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE RANLIB ac_ct_RANLIB BSD_TRUE BSD_FALSE UNIX_TRUE UNIX_FALSE LINUX_TRUE LINUX_FALSE CPP XCFLAGS XLIBS SDL_CONFIG SDL_CFLAGS SDL_LIBS HAVE_SDL_TRUE HAVE_SDL_FALSE EGREP WITHOUT_NETWORKING_TRUE WITHOUT_NETWORKING_FALSE LUA_CONFIG LUA_CFLAGS LUA_LIBS HAVE_VORBIS_TRUE HAVE_VORBIS_FALSE AUDIO_LIBS HAVE_MP3_TRUE HAVE_MP3_FALSE HAVE_FFMPEG_TRUE HAVE_FFMPEG_FALSE ALSA_CFLAGS ALSA_LIBS PKG_CONFIG GTK_CFLAGS GTK_LIBS HAVE_ALSA_TRUE HAVE_ALSA_FALSE HAVE_GTK_TRUE HAVE_GTK_FALSE HAVE_OSS_TRUE HAVE_OSS_FALSE USE_CRASH_HANDLER_TRUE USE_CRASH_HANDLER_FALSE BUILD_TESTS_TRUE BUILD_TESTS_FALSE LIBOBJS LTLIBOBJS'
ac_subst_files=''
# Initialize some variables set by options.
@@ -3541,6 +3551,21 @@
unix=yes
;;
+*-freebsd*|*-netbsd*)
+
+cat >>confdefs.h <<\_ACEOF
+#define BSD 1
+_ACEOF
+
+
+cat >>confdefs.h <<\_ACEOF
+#define UNIX 1
+_ACEOF
+
+ BSD=yes
+ unix=yes
+ ;;
+
*)
cat >>confdefs.h <<\_ACEOF
@@ -3552,6 +3577,16 @@
esac
+if test "$bsd" = "yes" ; then
+ BSD_TRUE=
+ BSD_FALSE='#'
+else
+ BSD_TRUE='#'
+ BSD_FALSE=
+fi
+
+
+
if test "$unix" = "yes" ; then
UNIX_TRUE=
UNIX_FALSE='#'
@@ -4471,7 +4471,7 @@ if test "${ac_cv_lib_GL_glPushMatrix+set
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lGL $XLIBS $LIBS"
+LIBS="-lm -lGL $XLIBS $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -4542,7 +4542,7 @@ if test "${ac_cv_lib_GLU_gluGetString+se
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lGLU $XLIBS $LIBS"
+LIBS="-lm -lGLU $XLIBS $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -5867,7 +5867,7 @@ if test "${ac_cv_lib_lualib_luaopen_base
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-llualib $LIB_LUA -ldl $LIBS"
+LIBS="-llualib $LIB_LUA $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -5936,7 +5936,7 @@ if test "${ac_cv_lib_lualib50_luaopen_ba
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-llualib50 $LIB_LUA -ldl $LIBS"
+LIBS="-llualib50 $LIB_LUA $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -7813,9 +7813,8 @@ if test "$alsa_prefix" != "" ; then
LDFLAGS="$LDFLAGS $ALSA_LIBS"
fi
-ALSA_LIBS="$ALSA_LIBS -lasound -lm -ldl -lpthread"
+ALSA_LIBS="$ALSA_LIBS -lasound -lm -lpthread"
ALSA_LIBS=`echo $ALSA_LIBS | sed 's/-lm//'`
-ALSA_LIBS=`echo $ALSA_LIBS | sed 's/-ldl//'`
ALSA_LIBS=`echo $ALSA_LIBS | sed 's/-lpthread//'`
ALSA_LIBS=`echo $ALSA_LIBS | sed 's/ / /g'`
LIBS="$ALSA_LIBS $LIBS"
@@ -9746,6 +9771,7 @@ fi
ac_config_files="$ac_config_files Makefile"
ac_config_files="$ac_config_files src/Makefile"
+ ac_config_files="$ac_config_files src/libresample/Makefile"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -9867,6 +9952,13 @@
Usually this means the macro was only invoked conditionally." >&2;}
{ (exit 1); exit 1; }; }
fi
+if test -z "${BSD_TRUE}" && test -z "${BSD_FALSE}"; then
+ { { echo "$as_me:$LINENO: error: conditional \"BSD\" was never defined.
+Usually this means the macro was only invoked conditionally." >&5
+echo "$as_me: error: conditional \"BSD\" was never defined.
+Usually this means the macro was only invoked conditionally." >&2;}
+ { (exit 1); exit 1; }; }
+fi
if test -z "${UNIX_TRUE}" && test -z "${UNIX_FALSE}"; then
{ { echo "$as_me:$LINENO: error: conditional \"UNIX\" was never defined.
Usually this means the macro was only invoked conditionally." >&5
@@ -10396,6 +10429,7 @@ do
# Handling of arguments.
"Makefile" ) CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"src/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
+ "src/libresample/Makefile" ) CONFIG_FILES="$CONFIG_FILES src/libresample/Makefile" ;;
"depfiles" ) CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
"src/config.h" ) CONFIG_HEADERS="$CONFIG_HEADERS src/config.h" ;;
*) { { echo "$as_me:$LINENO: error: invalid argument: $ac_config_target" >&5
@@ -10542,6 +10634,8 @@
s,@am__fastdepCXX_FALSE@,$am__fastdepCXX_FALSE,;t t
s,@RANLIB@,$RANLIB,;t t
s,@ac_ct_RANLIB@,$ac_ct_RANLIB,;t t
+s,@BSD_TRUE@,$BSD_TRUE,;t t
+s,@BSD_FALSE@,$BSD_FALSE,;t t
s,@UNIX_TRUE@,$UNIX_TRUE,;t t
s,@UNIX_FALSE@,$UNIX_FALSE,;t t
s,@LINUX_TRUE@,$LINUX_TRUE,;t t

View file

@ -1,46 +0,0 @@
$NetBSD: patch-aj,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- src/arch/Threads/Threads_Pthreads.cpp.orig 2004-09-09 01:58:47.000000000 +0400
+++ src/arch/Threads/Threads_Pthreads.cpp
@@ -4,7 +4,7 @@
#include <sys/time.h>
#include <errno.h>
-#if defined(LINUX)
+#if defined(LINUX) || defined(BSD)
#include "archutils/Unix/LinuxThreadHelpers.h"
#include "archutils/Unix/RunningUnderValgrind.h"
#endif
@@ -32,7 +32,7 @@ void ThreadImpl_Pthreads::Resume()
ResumeThread( threadHandle );
}
-uint64_t ThreadImpl_Pthreads::GetThreadId() const
+PTHREAD_T ThreadImpl_Pthreads::GetThreadId() const
{
return threadHandle;
}
@@ -70,7 +70,7 @@ static void *StartThread( void *pData )
return (void *) pThis->m_pFunc( pThis->m_pData );
}
-ThreadImpl *MakeThread( int (*pFunc)(void *pData), void *pData, uint64_t *piThreadID )
+ThreadImpl *MakeThread( int (*pFunc)(void *pData), void *pData, PTHREAD_T *piThreadID )
{
ThreadImpl_Pthreads *thread = new ThreadImpl_Pthreads;
thread->m_pFunc = pFunc;
@@ -188,12 +188,12 @@ void MutexImpl_Pthreads::Unlock()
pthread_mutex_unlock( &mutex );
}
-uint64_t GetThisThreadId()
+PTHREAD_T GetThisThreadId()
{
return GetCurrentThreadId();
}
-uint64_t GetInvalidThreadId()
+PTHREAD_T GetInvalidThreadId()
{
return 0;
}

View file

@ -1,55 +0,0 @@
$NetBSD: patch-ak,v 1.3 2005/10/23 23:52:51 absd Exp $
--- src/RageUtil.h.orig 2004-10-07 21:56:16.000000000 +0400
+++ src/RageUtil.h 2005-05-03 23:09:00.000000000 +0400
@@ -4,6 +4,7 @@
#define RAGEUTIL_H
#include <map>
+#include <string>
#define SAFE_DELETE(p) { if(p) { delete (p); (p)=NULL; } }
#define SAFE_DELETE_ARRAY(p) { if(p) { delete[] (p); (p)=NULL; } }
diff -ru -x 'config.*' work.i386/StepMania-3.9-rc2a-src/src/arch/Sound/RageSoundDriver_OSS.cpp src/arch/Sound/RageSoundDriver_OSS.cpp
--- src/arch/Sound/RageSoundDriver_OSS.cpp.orig 2004-05-24 01:16:22.000000000 +0400
+++ src/arch/Sound/RageSoundDriver_OSS.cpp 2005-05-03 23:09:01.000000000 +0400
@@ -90,8 +90,10 @@
ASSERT( fd != -1 );
int delay;
+#if defined(SNDCTL_DSP_GETODELAY)
if(ioctl(fd, SNDCTL_DSP_GETODELAY, &delay) == -1)
RageException::ThrowNonfatal("RageSound_OSS: ioctl(SNDCTL_DSP_GETODELAY): %s", strerror(errno));
+#endif
return last_cursor_pos - (delay / bytes_per_frame);
}
diff -ru -x 'config.*' work.i386/StepMania-3.9-rc2a-src/src/archutils/Unix/SignalHandler.cpp src/archutils/Unix/SignalHandler.cpp
--- src/archutils/Unix/SignalHandler.cpp.orig 2004-05-27 08:57:15.000000000 +0400
+++ src/archutils/Unix/SignalHandler.cpp 2005-05-03 23:09:02.000000000 +0400
@@ -16,6 +16,8 @@
#if defined(DARWIN)
extern "C" int sigaltstack( const struct sigaltstack *ss, struct sigaltstack *oss );
+#endif
+#if !defined(MAP_ANONYMOUS) && defined(MAP_ANON)
#define MAP_ANONYMOUS MAP_ANON
#endif
--- src/archutils/Unix/arch_setup.h.orig 2004-06-15 00:31:12.000000000 +0000
+++ src/archutils/Unix/arch_setup.h
@@ -5,6 +5,14 @@
#include <stdint.h>
#endif
+#ifdef __NetBSD__
+#include <sys/param.h>
+#define NEED_STRTOF
+#if __NetBSD_Version__ < 299000900
+#define lrintf(x) ((int)rint(x))
+#endif
+#endif
+
#if defined(CPU_X86)
inline uint32_t ArchSwap32( uint32_t n )

View file

@ -1,25 +0,0 @@
$NetBSD: patch-al,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- src/arch/LoadingWindow/LoadingWindow_SDL.cpp.orig 2004-08-28 22:38:49.000000000 +0400
+++ src/arch/LoadingWindow/LoadingWindow_SDL.cpp
@@ -16,7 +16,7 @@ LoadingWindow_SDL::LoadingWindow_SDL()
{
/* There's no consistent way to hint SDL that we want a centered
* window. X11 way: */
-#if defined(unix)
+#if defined(UNIX)
static char center[]="SDL_VIDEO_CENTERED=1";
putenv( center );
#endif
--- src/arch/LowLevelWindow/LowLevelWindow_SDL.cpp.orig 2004-09-17 01:30:09.000000000 +0400
+++ src/arch/LowLevelWindow/LowLevelWindow_SDL.cpp
@@ -169,7 +169,7 @@ CString LowLevelWindow_SDL::TryVideoMode
/* Recreating the window changes the hwnd. */
SDL_UpdateHWnd();
-#if defined(unix)
+#if defined(UNIX)
{
SDL_SysWMinfo info;
SDL_VERSION(&info.version);

View file

@ -1,15 +0,0 @@
$NetBSD: patch-am,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- src/Makefile.am.orig 2004-09-08 10:48:45.000000000 +0400
+++ src/Makefile.am
@@ -140,8 +140,10 @@ endif
if UNIX
ArchHooks += arch/ArchHooks/ArchHooks_Unix.cpp arch/ArchHooks/ArchHooks_Unix.h
Threads += arch/Threads/Threads_Pthreads.cpp arch/Threads/Threads_Pthreads.h
+if LINUX
Lights += arch/Lights/LightsDriver_LinuxWeedTech.cpp arch/Lights/LightsDriver_LinuxWeedTech.h
Lights += arch/Lights/LightsDriver_LinuxParallel.cpp arch/Lights/LightsDriver_LinuxParallel.h
+endif
ArchUtils += archutils/Unix/AssertionHandler.cpp \
archutils/Unix/GetSysInfo.cpp archutils/Unix/GetSysInfo.h \

View file

@ -1,24 +0,0 @@
$NetBSD: patch-an,v 1.1.1.1 2005/06/23 04:00:38 shattered Exp $
--- src/Makefile.in.orig 2004-10-23 02:21:52.000000000 +0400
+++ src/Makefile.in
@@ -51,7 +51,7 @@ host_triplet = @host@
@HAVE_SDL_TRUE@am__append_9 = SDL_utils.cpp SDL_utils.h
@UNIX_TRUE@am__append_10 = arch/ArchHooks/ArchHooks_Unix.cpp arch/ArchHooks/ArchHooks_Unix.h
@UNIX_TRUE@am__append_11 = arch/Threads/Threads_Pthreads.cpp arch/Threads/Threads_Pthreads.h
-@UNIX_TRUE@am__append_12 = arch/Lights/LightsDriver_LinuxWeedTech.cpp arch/Lights/LightsDriver_LinuxWeedTech.h arch/Lights/LightsDriver_LinuxParallel.cpp arch/Lights/LightsDriver_LinuxParallel.h
+@LINUX_TRUE@am__append_12 = arch/Lights/LightsDriver_LinuxWeedTech.cpp arch/Lights/LightsDriver_LinuxWeedTech.h arch/Lights/LightsDriver_LinuxParallel.cpp arch/Lights/LightsDriver_LinuxParallel.h
@UNIX_TRUE@am__append_13 = archutils/Unix/AssertionHandler.cpp \
@UNIX_TRUE@ archutils/Unix/GetSysInfo.cpp archutils/Unix/GetSysInfo.h \
@UNIX_TRUE@ archutils/Unix/SignalHandler.cpp archutils/Unix/SignalHandler.h \
@@ -899,8 +899,8 @@ am__objects_15 = InputHandler.$(OBJEXT)
@HAVE_FFMPEG_TRUE@am__objects_16 = MovieTexture_FFMpeg.$(OBJEXT)
am__objects_17 = MovieTexture.$(OBJEXT) MovieTexture_Null.$(OBJEXT) \
$(am__objects_16)
-@UNIX_TRUE@am__objects_18 = LightsDriver_LinuxWeedTech.$(OBJEXT) \
-@UNIX_TRUE@ LightsDriver_LinuxParallel.$(OBJEXT)
+@LINUX_TRUE@am__objects_18 = LightsDriver_LinuxWeedTech.$(OBJEXT) \
+@LINUX_TRUE@ LightsDriver_LinuxParallel.$(OBJEXT)
am__objects_19 = LightsDriver.$(OBJEXT) \
LightsDriver_SystemMessage.$(OBJEXT) $(am__objects_18)
@LINUX_TRUE@am__objects_20 = MemoryCardDriverThreaded_Linux.$(OBJEXT)

View file

@ -1,22 +0,0 @@
$NetBSD: patch-ao,v 1.1 2005/08/26 22:33:48 shattered Exp $
--- src/RageSound.h.orig 2004-08-21 11:01:54.000000000 +0400
+++ src/RageSound.h 2005-05-15 18:36:07.000000000 +0400
@@ -109,7 +109,7 @@
bool SetPositionSeconds( float fSeconds );
CString GetLoadedFilePath() const { return m_sFilePath; }
bool IsPlaying() const { return playing; }
- uint64_t GetPlayingThread() const { return playing_thread; }
+ PTHREAD_T GetPlayingThread() const { return playing_thread; }
/* Lock and unlock this sound. */
void LockSound();
@@ -157,7 +157,7 @@
mutable int64_t max_driver_frame;
/* If playing, record the thread that called Play(). */
- uint64_t playing_thread;
+ PTHREAD_T playing_thread;
/* Unique ID number for this instance of RageSound. */
int ID;

View file

@ -1,85 +0,0 @@
$NetBSD: patch-ap,v 1.1 2005/08/26 22:33:48 shattered Exp $
--- src/RageThreads.cpp.orig 2004-09-09 06:28:05.000000000 +0400
+++ src/RageThreads.cpp 2005-05-15 18:36:07.000000000 +0400
@@ -44,7 +44,7 @@
char ThreadFormattedOutput[1024];
bool used;
- uint64_t id;
+ PTHREAD_T id;
ThreadImpl *pImpl;
@@ -165,7 +165,7 @@
}
-static ThreadSlot *GetThreadSlotFromID( uint64_t iID )
+static ThreadSlot *GetThreadSlotFromID( PTHREAD_T iID )
{
InitThreads();
@@ -263,7 +263,7 @@
return GetThreadNameByID( GetCurrentThreadID() );
}
-const char *RageThread::GetThreadNameByID( uint64_t iID )
+const char *RageThread::GetThreadNameByID( PTHREAD_T iID )
{
ThreadSlot *slot = GetThreadSlotFromID( iID );
if( slot == NULL )
@@ -272,7 +272,7 @@
return slot->GetThreadName();
}
-bool RageThread::EnumThreadIDs( int n, uint64_t &iID )
+bool RageThread::EnumThreadIDs( int n, PTHREAD_T &iID )
{
if( n >= MAX_THREADS )
return false;
@@ -307,7 +307,7 @@
void RageThread::HaltAllThreads( bool Kill )
{
- const uint64_t ThisThreadID = GetThisThreadId();
+ const PTHREAD_T ThisThreadID = GetThisThreadId();
for( int entry = 0; entry < MAX_THREADS; ++entry )
{
if( !g_ThreadSlots[entry].used )
@@ -320,7 +320,7 @@
void RageThread::ResumeAllThreads()
{
- const uint64_t ThisThreadID = GetThisThreadId();
+ const PTHREAD_T ThisThreadID = GetThisThreadId();
for( int entry = 0; entry < MAX_THREADS; ++entry )
{
if( !g_ThreadSlots[entry].used )
@@ -332,7 +332,7 @@
}
}
-uint64_t RageThread::GetCurrentThreadID()
+PTHREAD_T RageThread::GetCurrentThreadID()
{
return GetThisThreadId();
}
@@ -554,7 +554,7 @@
void RageMutex::Lock()
{
- if( m_LockedBy == (uint64_t) GetThisThreadId() )
+ if( m_LockedBy == GetThisThreadId() )
{
++m_LockCnt;
return;
@@ -596,7 +596,7 @@
bool RageMutex::TryLock()
{
- if( m_LockedBy == (uint64_t) GetThisThreadId() )
+ if( m_LockedBy == GetThisThreadId() )
{
++m_LockCnt;
return true;

View file

@ -1,28 +0,0 @@
$NetBSD: patch-aq,v 1.1 2005/08/26 22:33:48 shattered Exp $
--- src/RageThreads.h.orig 2004-09-09 06:28:05.000000000 +0400
+++ src/RageThreads.h 2005-05-15 18:36:07.000000000 +0400
@@ -23,11 +23,11 @@
/* If HaltAllThreads was called (with Kill==false), resume. */
static void ResumeAllThreads();
- static uint64_t GetCurrentThreadID();
+ static PTHREAD_T GetCurrentThreadID();
static const char *GetCurThreadName();
- static const char *GetThreadNameByID( uint64_t iID );
- static bool EnumThreadIDs( int n, uint64_t &iID );
+ static const char *GetThreadNameByID( PTHREAD_T iID );
+ static bool EnumThreadIDs( int n, PTHREAD_T &iID );
int Wait();
bool IsCreated() const { return m_pSlot != NULL; }
@@ -62,7 +62,7 @@
int m_UniqueID;
- uint64_t m_LockedBy;
+ PTHREAD_T m_LockedBy;
int m_LockCnt;
void MarkLockedMutex();

View file

@ -1,32 +0,0 @@
$NetBSD: patch-ar,v 1.1 2005/08/26 22:33:48 shattered Exp $
--- src/arch/Threads/Threads.h.orig 2004-09-07 07:05:56.000000000 +0400
+++ src/arch/Threads/Threads.h 2005-05-15 18:36:07.000000000 +0400
@@ -15,7 +15,7 @@
/* Get the identifier for this thread. The actual meaning of this is implementation-
* defined, except that each thread has exactly one ID and each ID corresponds to
* one thread. (This means that Win32 thread handles are not acceptable as ThreadIds.) */
- virtual uint64_t GetThreadId() const = 0;
+ virtual PTHREAD_T GetThreadId() const = 0;
virtual int Wait() = 0;
};
@@ -53,15 +53,15 @@
};
/* These functions must be implemented by the thread implementation. */
-ThreadImpl *MakeThread( int (*fn)(void *), void *data, uint64_t *piThreadID );
+ThreadImpl *MakeThread( int (*fn)(void *), void *data, PTHREAD_T *piThreadID );
ThreadImpl *MakeThisThread();
MutexImpl *MakeMutex( RageMutex *pParent );
SemaImpl *MakeSemaphore( int iInitialValue );
-uint64_t GetThisThreadId();
+PTHREAD_T GetThisThreadId();
/* Since ThreadId is implementation-defined, we can't define a universal invalid
* value. Return the invalid value for this implementation. */
-uint64_t GetInvalidThreadId();
+PTHREAD_T GetInvalidThreadId();
#endif

View file

@ -1,25 +0,0 @@
$NetBSD: patch-as,v 1.1 2005/08/26 22:33:48 shattered Exp $
--- src/arch/Threads/Threads_Pthreads.h.orig 2004-09-07 16:49:49.000000000 +0400
+++ src/arch/Threads/Threads_Pthreads.h 2005-05-15 18:36:07.000000000 +0400
@@ -16,17 +16,17 @@
* added bonus: if this is corrupted, we'll just send signals and they'll
* fail; we won't blow up (unless we're root).
*/
- uint64_t threadHandle;
+ PTHREAD_T threadHandle;
/* These are only used during initialization. */
int (*m_pFunc)( void *pData );
void *m_pData;
- uint64_t *m_piThreadID;
+ PTHREAD_T *m_piThreadID;
SemaImpl *m_StartFinishedSem;
void Halt( bool Kill );
void Resume();
- uint64_t GetThreadId() const;
+ PTHREAD_T GetThreadId() const;
int Wait();
};

View file

@ -1,13 +0,0 @@
$NetBSD: patch-at,v 1.1 2005/08/26 22:33:48 shattered Exp $
--- src/archutils/Unix/Backtrace.h.orig 2004-10-23 02:20:04.000000000 +0400
+++ src/archutils/Unix/Backtrace.h 2005-05-15 18:36:07.000000000 +0400
@@ -11,7 +11,7 @@
#endif
#if defined(LINUX)
- pid_t pid;
+ PTHREAD_T pid;
#endif
#if defined(DARWIN)

View file

@ -1,25 +0,0 @@
$NetBSD: patch-au,v 1.1 2005/08/26 22:33:48 shattered Exp $
--- src/archutils/Unix/LinuxThreadHelpers.h.orig 2004-09-08 08:45:16.000000000 +0400
+++ src/archutils/Unix/LinuxThreadHelpers.h 2005-05-15 18:36:07.000000000 +0400
@@ -4,16 +4,16 @@
CString ThreadsVersion();
/* Get the current thread's ThreadID. */
-uint64_t GetCurrentThreadId();
+PTHREAD_T GetCurrentThreadId();
/* Return true if NPTL libraries are in use, false if linuxthreads. */
bool UsingNPTL();
-int SuspendThread( uint64_t ThreadID );
-int ResumeThread( uint64_t ThreadID );
+int SuspendThread( PTHREAD_T ThreadID );
+int ResumeThread( PTHREAD_T ThreadID );
struct BacktraceContext;
-int GetThreadContext( uint64_t ThreadID, BacktraceContext *ctx );
+int GetThreadContext( PTHREAD_T ThreadID, BacktraceContext *ctx );
#endif

View file

@ -1,17 +0,0 @@
$NetBSD: patch-av,v 1.1 2005/08/26 22:33:48 shattered Exp $
--- src/global.h.orig 2004-08-10 23:12:03.000000000 +0400
+++ src/global.h 2005-05-15 18:36:07.000000000 +0400
@@ -173,6 +173,12 @@
inline float strtof( const char *s, char **se ) { return (float) strtod( s, se ); }
#endif
+#ifdef __NetBSD__
+#define PTHREAD_T pthread_t
+#else
+#define PTHREAD_T uint64_t
+#endif
+
/* Don't include our own headers here, since they tend to change often. */
#endif