(Candidate for updating wm/sawfish from 1.10 to 1.11)

Import sawfish-1.11 as wip/sawfish.

Sawfish is an extensible window manager using an Emacs Lisp-like
scripting language--all window decorations are configurable, the basic
idea is to have as much user-interface policy as possible controlled
through the Lisp language. This is no layer on top of twm, but a wholly
new architecture.

Despite this extensibility its policy is currently very minimal
compared to most window managers. Its aim is simply to manage windows
in the most flexible and attractive manner possible. As such it does
not implement desktop backgrounds, applications docks, or other things
that may be achieved through separate applications.

All high-level wm functions are implemented in Lisp for future
extensibility or redefinition. Currently this includes menus (using
GTK2+), interactive window moving and resizing, virtual workspaces,
iconification, focus/transient window policies, frame theme definitions
and much more.
This commit is contained in:
Makoto Fujiwara 2015-01-16 01:57:35 +00:00 committed by Thomas Klausner
parent 62ff7b8274
commit abee5ebc2c
8 changed files with 2368 additions and 0 deletions

17
sawfish/DESCR Normal file
View file

@ -0,0 +1,17 @@
Sawfish is an extensible window manager using an Emacs Lisp-like
scripting language--all window decorations are configurable, the basic
idea is to have as much user-interface policy as possible controlled
through the Lisp language. This is no layer on top of twm, but a wholly
new architecture.
Despite this extensibility its policy is currently very minimal
compared to most window managers. Its aim is simply to manage windows
in the most flexible and attractive manner possible. As such it does
not implement desktop backgrounds, applications docks, or other things
that may be achieved through separate applications.
All high-level wm functions are implemented in Lisp for future
extensibility or redefinition. Currently this includes menus (using
GTK2+), interactive window moving and resizing, virtual workspaces,
iconification, focus/transient window policies, frame theme definitions
and much more.

55
sawfish/Makefile Normal file
View file

@ -0,0 +1,55 @@
# $NetBSD: Makefile,v 1.1 2015/01/16 01:57:35 makoto Exp $
DISTNAME= sawfish_1.11
PKGNAME= ${DISTNAME:S/_/-/}
CATEGORIES= x11 wm
MASTER_SITES= http://download.tuxfamily.org/sawfish/
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://sawfish.wikia.com/
COMMENT= Extensible window manager that is fully configurable in Lisp
LICENSE= gnu-gpl-v2 AND artistic-2.0
CONFLICTS+= sawfish-replibs-[0-9]*
CONFLICTS+= sawfish-themes-[0-9]*
GNU_CONFIGURE= yes
INFO_FILES= YES
PKGCONFIG_OVERRIDE+= sawfish.pc.in
USE_TOOLS+= gmake makeinfo msgfmt pkg-config xgettext
USE_TOOLS+= gtar:run # for librep run-time theme extraction
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
CONFIGURE_ARGS+= --localedir=${PREFIX}/${PKGLOCALEDIR}/locale
CONFIGURE_ARGS+= --mandir=${PREFIX}/${PKGMANDIR}
CONFIGURE_ENV+= REP_ENV_PKGSRC=${REP_ENV_PKGSRC:Q}
MAKE_ENV+= REP_ENV_PKGSRC=${REP_ENV_PKGSRC:Q}
SUBST_CLASSES+= env
SUBST_STAGE.env= pre-configure
SUBST_FILES.env= lisp/sawfish/ui/main.jl.in po/sawfish-xgettext
SUBST_FILES.env+= scripts/sawfish-*.jl*
SUBST_SED.env= -e 's,exec rep,exec env ${REP_ENV_PKGSRC} rep,g'
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "NetBSD" && empty(${OS_VERSION:M1.*})
REP_ENV_PKGSRC= LD_PRELOAD=/usr/lib/libpthread.so
.else
REP_ENV_PKGSRC=
.endif
.include "../../graphics/gdk-pixbuf2-xlib/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../devel/pango/buildlink3.mk"
.include "../../devel/pangox-compat/buildlink3.mk"
.include "../../lang/librep/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/gtk2/buildlink3.mk"
BUILDLINK_DEPMETHOD.libXt+= build
.include "../../x11/libXt/buildlink3.mk"
.include "../../x11/libXtst/buildlink3.mk"
.include "../../x11/rep-gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2227
sawfish/PLIST Normal file

File diff suppressed because it is too large Load diff

1
sawfish/TODO Normal file
View file

@ -0,0 +1 @@
- review PLIST changes

8
sawfish/distinfo Normal file
View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1 2015/01/16 01:57:37 makoto Exp $
SHA1 (sawfish_1.11.tar.xz) = a2a0190ed11c5e3e8d0ca30a6a3d533efaa1b470
RMD160 (sawfish_1.11.tar.xz) = 185a54b8a683d7c608519eeb468bad9ac3074b4b
Size (sawfish_1.11.tar.xz) = 2751904 bytes
SHA1 (patch-aa) = 4ab1def3b142d3eb2a56385b2a3e39819290e36b
SHA1 (patch-ab) = 21a89c87afa9cb5fdf3b028109b0db9c5991fb1e
SHA1 (patch-themes_Makefile.in) = 6484654d6d1fc9126f989a075b6fbf4b5ffb045d

32
sawfish/patches/patch-aa Normal file
View file

@ -0,0 +1,32 @@
$NetBSD: patch-aa,v 1.1 2015/01/16 01:57:37 makoto Exp $
Fix PKGLOCALEDIR
--- configure.orig 2014-11-03 04:09:51.000000000 +0900
+++ configure 2015-01-16 10:36:15.000000000 +0900
@@ -10864,7 +10864,7 @@ SUBDIRS="src lisp scripts themes sounds
sawfishdir='${datadir}/sawfish'
lispdir='${sawfishdir}/lisp'
-localedir='${datadir}/locale'
+#localedir='${datadir}/locale'
sawfishexecdir='${libdir}/sawfish'
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for an ANSI C-conforming const" >&5
@@ -13531,12 +13531,12 @@ fi
KDE4_SESSION="$with_kde4session"
-if test "$with_kde4session" = "yes"; then
- KDEDIR="`kde4-config --install data`"
-fi
+#if test "$with_kde4session" = "yes"; then
+# KDEDIR="`kde4-config --install data`"
+#fi
if test "x$KDEDIR" = x; then
- KDEDIR="${datadir}/kde4/apps/"
+ KDEDIR="${datadir}/kde/apps/"
fi

13
sawfish/patches/patch-ab Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2015/01/16 01:57:37 makoto Exp $
--- Makedefs.in.orig 2003-01-12 21:30:40.000000000 +0100
+++ Makedefs.in
@@ -98,7 +98,7 @@ REP_MSGFMT=@REP_MSGFMT@
# used when compiling/running lisp code
REP_ENVIRON=REP_DL_LOAD_PATH=$(top_builddir)/src/.libexec \
- REP_GTK_DONT_INITIALIZE=1
+ REP_GTK_DONT_INITIALIZE=1 $(REP_ENV_PKGSRC)
%.mo : %.po
$(REP_MSGFMT) $(MSGFMTFLAGS) -o $@ $<

View file

@ -0,0 +1,15 @@
$NetBSD: patch-themes_Makefile.in,v 1.1 2015/01/16 01:57:37 makoto Exp $
* StyleTab.tar.gz is compressed by gzip
--- themes/Makefile.in.orig 2013-09-25 18:50:08.000000000 +0000
+++ themes/Makefile.in
@@ -55,7 +55,7 @@ install : all installdirs
done
@# Don't use tar for StyleTab. It's not compression, but tar
@# itself slows in librep.
- cd $(DESTDIR)$(themedir) && tar xf StyleTab.tar.gz && rm StyleTab.tar.gz
+ cd $(DESTDIR)$(themedir) && tar zxf StyleTab.tar.gz && rm StyleTab.tar.gz
installdirs : $(top_srcdir)/mkinstalldirs
$(SHELL) $< $(DESTDIR)$(themedir)