Remove unneeded include from patch-screen.c.
This commit is contained in:
parent
7d2afe02d1
commit
ae82b7e6b2
3 changed files with 4 additions and 12 deletions
|
@ -2,6 +2,6 @@ fish is a user friendly command line shell for UNIX-like operating systems,
|
|||
written mainly with interactive use in mind.
|
||||
It differs from other shells in that it only provides as few commands as
|
||||
built-ins as possible and has a daemon which allows it to have shared variables
|
||||
between shell instances.
|
||||
and commandline history between shell instances.
|
||||
It also features feature-rich tab-completion and has commandline syntax
|
||||
hilighting.
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.3 2012/08/17 13:53:50 mwilhelmy Exp $
|
||||
$NetBSD: distinfo,v 1.4 2012/08/17 16:03:03 mwilhelmy Exp $
|
||||
|
||||
SHA1 (fish-1.23.1.tar.gz) = 7b839ffc5b260f1bd1782e4adf84300f5438f833
|
||||
RMD160 (fish-1.23.1.tar.gz) = b77fe7ffec4ae52b82c1c86b2dc7037306c5fede
|
||||
|
@ -6,4 +6,4 @@ Size (fish-1.23.1.tar.gz) = 1152997 bytes
|
|||
SHA1 (patch-Makefile.in) = d92c531cb15e511f1a712d98a64e222b3316fcdd
|
||||
SHA1 (patch-configure) = 3d4cd5ed6cff65768f4f99ae196449e01d3f7ef1
|
||||
SHA1 (patch-proc.h) = 7ac0b704f6ee1b1e966f0bfdc87dfa1e23e9c338
|
||||
SHA1 (patch-screen.c) = 3f9afd7927d0669ac597e3b79b0ff78bd5da801e
|
||||
SHA1 (patch-screen.c) = eae536bb965bd2a236a5cd3ff44e5ddbeb24f519
|
||||
|
|
|
@ -1,17 +1,9 @@
|
|||
$NetBSD: patch-screen.c,v 1.1 2012/08/17 13:53:51 mwilhelmy Exp $
|
||||
$NetBSD: patch-screen.c,v 1.2 2012/08/17 16:03:04 mwilhelmy Exp $
|
||||
|
||||
Fix compilation on NetBSD, where init_tabs is not suitable for assignment.
|
||||
|
||||
--- screen.c.orig 2009-03-08 14:46:47.000000000 +0000
|
||||
+++ screen.c
|
||||
@@ -16,6 +16,7 @@ efficient way for transforming that to t
|
||||
#include <sys/types.h>
|
||||
|
||||
#ifdef HAVE_SYS_TERMIOS_H
|
||||
+#include <termios.h>
|
||||
#include <sys/termios.h>
|
||||
#endif
|
||||
|
||||
@@ -92,13 +93,14 @@ static int try_sequence( char *seq, wcha
|
||||
*/
|
||||
static int next_tab_stop( int in )
|
||||
|
|
Loading…
Reference in a new issue