pwlib already exists in pkgsrc

This commit is contained in:
David 2004-12-02 21:52:38 +00:00 committed by Thomas Klausner
parent 1cb49fe196
commit aeb531094a
16 changed files with 0 additions and 850 deletions

View file

@ -1,15 +0,0 @@
PWLib is a moderately large class library that has its genesis
many years ago as a method to produce applications to run on
both Microsoft Windows and Unix X-Windows systems. It also was
to have a Macintosh port as well but this never eventuated.
Since then the system has grown to having quite good application
to areas other than mere Windows GUI portability. Classes for
I/O portability, multi-threading portability, aid in producing
unix daemons and NT services portably and all sorts of internet
protocols were added over the years.
The library was used extensively for all our in-house products.
Then we decided to support the open H323 project by throwing in
some of the code written for one of our products. Thus, required
PWLib so it got thrown into the open source world as well.

View file

@ -1,57 +0,0 @@
# $NetBSD: Makefile,v 1.2 2004/12/02 16:39:06 thomasklausner Exp $
#
DISTNAME= pwlib_1.5.2
PKGNAME= pwlib-1.5.2
CATEGORIES= devel
MASTER_SITES= http://www.openh323.org/bin/
MAINTAINER= psham@cs.nmsu.edu
HOMEPAGE= http://www.openh323.org/
COMMENT= Multi-platform class library
BUILD_DEPENDS= bison-[0-9]*:../../devel/bison
WRKSRC= ${WRKDIR}/pwlib
USE_BUILDLINK3= yes
USE_PKGINSTALL= yes
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_GNU_TOOLS+= make
PTHREAD_OPTS+= require
MAKE_ENV+= PWLIBDIR="${WRKSRC}"
MAKE_ENV+= CC="${CC}"
MAKE_ENV+= CPLUS="${CXX}"
BUILD_TARGET= opt
FILES_SUBST+= LIBTOOL="${LIBTOOL}"
FILES_SUBST+= PTHREADS_PREFIX="${BUILDLINK_PREFIX.pthread}"
post-patch:
${_PKG_SILENT}cd ${WRKSRC}/make; \
for f in unix.mak lib.mak common.mak; do \
${SED} ${FILES_SUBST_SED} $$f > $$f.sed; \
${MV} -f $$f.sed $$f; \
done
${LN} -sf ${WRKDIR} ${WRKSRC}/share
do-install:
${_PKG_SILENT}cd ${WRKSRC}/src/ptlib/unix && ${MAKE_ENV} ${GMAKE} ${INSTALL}
${_PKG_SILENT}cd ${WRKSRC}/tools/asnparser && ${MAKE_ENV} ${GMAKE} ${INSTALL}
${INSTALL_DATA_DIR} ${PREFIX}/include/ptclib
${INSTALL_DATA_DIR} ${PREFIX}/include/ptlib/unix/ptlib
cd ${WRKSRC}/include; \
for f in `${FIND} . -type f -print | ${GREP} -v '/CVS/'`; do \
${INSTALL_DATA} $$f ${PREFIX}/include/`${DIRNAME} $$f`; \
done
${INSTALL_DATA_DIR} ${PREFIX}/share/pwlib/make
cd ${WRKSRC}/make; \
for f in *.mak; do \
${INSTALL_DATA} $$f ${PREFIX}/share/pwlib/make; \
done
${CP} -rf ${WRKSRC}/make/ptlib-config ${PREFIX}/bin
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,153 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
bin/asnparser
bin/ptlib-config
include/ptbuildopts.h
include/ptbuildopts.h.in
include/ptclib/asnber.h
include/ptclib/asner.h
include/ptclib/asnper.h
include/ptclib/asnxer.h
include/ptclib/cypher.h
include/ptclib/delaychan.h
include/ptclib/dtmf.h
include/ptclib/ftp.h
include/ptclib/html.h
include/ptclib/http.h
include/ptclib/httpform.h
include/ptclib/httpsvc.h
include/ptclib/inetmail.h
include/ptclib/inetprot.h
include/ptclib/ipacl.h
include/ptclib/memfile.h
include/ptclib/mime.h
include/ptclib/modem.h
include/ptclib/pasn.h
include/ptclib/pdns.h
include/ptclib/pils.h
include/ptclib/pldap.h
include/ptclib/psnmp.h
include/ptclib/psoap.h
include/ptclib/pssl.h
include/ptclib/pstun.h
include/ptclib/ptts.h
include/ptclib/pwavfile.h
include/ptclib/pxml.h
include/ptclib/pxmlrpc.h
include/ptclib/pxmlrpcs.h
include/ptclib/qchannel.h
include/ptclib/random.h
include/ptclib/shttpsvc.h
include/ptclib/socks.h
include/ptclib/telnet.h
include/ptclib/url.h
include/ptclib/vsdl.h
include/ptclib/vxml.h
include/ptlib.h
include/ptlib/MacMainIf.h
include/ptlib/args.h
include/ptlib/array.h
include/ptlib/channel.h
include/ptlib/conchan.h
include/ptlib/config.h
include/ptlib/contain.h
include/ptlib/contain.inl
include/ptlib/dict.h
include/ptlib/dynalink.h
include/ptlib/ethsock.h
include/ptlib/file.h
include/ptlib/filepath.h
include/ptlib/icmpsock.h
include/ptlib/indchan.h
include/ptlib/ipdsock.h
include/ptlib/ipsock.h
include/ptlib/ipxsock.h
include/ptlib/lists.h
include/ptlib/mail.h
include/ptlib/mutex.h
include/ptlib/object.h
include/ptlib/osutil.inl
include/ptlib/pdirect.h
include/ptlib/pipechan.h
include/ptlib/pprocess.h
include/ptlib/pstring.h
include/ptlib/ptime.h
include/ptlib/remconn.h
include/ptlib/safecoll.h
include/ptlib/semaphor.h
include/ptlib/serchan.h
include/ptlib/sfile.h
include/ptlib/socket.h
include/ptlib/sockets.h
include/ptlib/sound.h
include/ptlib/spxsock.h
include/ptlib/svcproc.h
include/ptlib/syncpoint.h
include/ptlib/syncthrd.h
include/ptlib/tcpsock.h
include/ptlib/textfile.h
include/ptlib/thread.h
include/ptlib/timeint.h
include/ptlib/timer.h
include/ptlib/udpsock.h
include/ptlib/unix/ptlib/channel.h
include/ptlib/unix/ptlib/conchan.h
include/ptlib/unix/ptlib/config.h
include/ptlib/unix/ptlib/contain.h
include/ptlib/unix/ptlib/dynalink.h
include/ptlib/unix/ptlib/ethsock.h
include/ptlib/unix/ptlib/file.h
include/ptlib/unix/ptlib/filepath.h
include/ptlib/unix/ptlib/icmpsock.h
include/ptlib/unix/ptlib/ipdsock.h
include/ptlib/unix/ptlib/ipsock.h
include/ptlib/unix/ptlib/mutex.h
include/ptlib/unix/ptlib/pdirect.h
include/ptlib/unix/ptlib/pipechan.h
include/ptlib/unix/ptlib/pmachdep.h
include/ptlib/unix/ptlib/pprocess.h
include/ptlib/unix/ptlib/ptime.h
include/ptlib/unix/ptlib/ptlib.inl
include/ptlib/unix/ptlib/remconn.h
include/ptlib/unix/ptlib/semaphor.h
include/ptlib/unix/ptlib/serchan.h
include/ptlib/unix/ptlib/sfile.h
include/ptlib/unix/ptlib/socket.h
include/ptlib/unix/ptlib/sound.h
include/ptlib/unix/ptlib/svcproc.h
include/ptlib/unix/ptlib/syncpoint.h
include/ptlib/unix/ptlib/tcpsock.h
include/ptlib/unix/ptlib/textfile.h
include/ptlib/unix/ptlib/thread.h
include/ptlib/unix/ptlib/timeint.h
include/ptlib/unix/ptlib/timer.h
include/ptlib/unix/ptlib/udpsock.h
include/ptlib/unix/ptlib/video.h
include/ptlib/unix/ptlib/videoio.h
include/ptlib/unix/ptlib/videoio1394avc.h
include/ptlib/vconvert.h
include/ptlib/vfakeio.h
include/ptlib/video.h
include/ptlib/videoio.h
include/ptlib/videoio1394dc.h
lib/libpt.a
lib/libpt.la
lib/libpt.so
lib/libpt.so.1
lib/libpt.so.1.5
share/pwlib/make/common.mak
share/pwlib/make/defaultgui.mak
share/pwlib/make/gui.mak
share/pwlib/make/lib.mak
share/pwlib/make/motif.mak
share/pwlib/make/ptbuildopts.mak
share/pwlib/make/ptlib.mak
share/pwlib/make/pwlib.mak
share/pwlib/make/qt.mak
share/pwlib/make/unix.mak
share/pwlib/make/xlib.mak
@dirrm share/pwlib/make
@dirrm share/pwlib
@dirrm include/ptlib/unix/ptlib
@dirrm include/ptlib/unix
@dirrm include/ptlib
@dirrm include/ptclib

View file

@ -1,151 +0,0 @@
# $NetBSD: buildlink2.mk,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
#
# This Makefile fragment is included by packages that use pwlib.
#
# This file was created automatically using createbuildlink 2.6.
#
.if !defined(PWLIB_BUILDLINK2_MK)
PWLIB_BUILDLINK2_MK= # defined
BUILDLINK_PACKAGES+= pwlib
BUILDLINK_DEPENDS.pwlib?= pwlib>=1.5.2
BUILDLINK_PKGSRCDIR.pwlib?= ../../local/pwlib-trial
EVAL_PREFIX+= BUILDLINK_PREFIX.pwlib=pwlib
BUILDLINK_PREFIX.pwlib_DEFAULT= ${LOCALBASE}
BUILDLINK_FILES.pwlib+= include/ptbuildopts.h
BUILDLINK_FILES.pwlib+= include/ptbuildopts.h.in
BUILDLINK_FILES.pwlib+= include/ptclib/asnber.h
BUILDLINK_FILES.pwlib+= include/ptclib/asner.h
BUILDLINK_FILES.pwlib+= include/ptclib/asnper.h
BUILDLINK_FILES.pwlib+= include/ptclib/asnxer.h
BUILDLINK_FILES.pwlib+= include/ptclib/cypher.h
BUILDLINK_FILES.pwlib+= include/ptclib/delaychan.h
BUILDLINK_FILES.pwlib+= include/ptclib/dtmf.h
BUILDLINK_FILES.pwlib+= include/ptclib/ftp.h
BUILDLINK_FILES.pwlib+= include/ptclib/html.h
BUILDLINK_FILES.pwlib+= include/ptclib/http.h
BUILDLINK_FILES.pwlib+= include/ptclib/httpform.h
BUILDLINK_FILES.pwlib+= include/ptclib/httpsvc.h
BUILDLINK_FILES.pwlib+= include/ptclib/inetmail.h
BUILDLINK_FILES.pwlib+= include/ptclib/inetprot.h
BUILDLINK_FILES.pwlib+= include/ptclib/ipacl.h
BUILDLINK_FILES.pwlib+= include/ptclib/memfile.h
BUILDLINK_FILES.pwlib+= include/ptclib/mime.h
BUILDLINK_FILES.pwlib+= include/ptclib/modem.h
BUILDLINK_FILES.pwlib+= include/ptclib/pasn.h
BUILDLINK_FILES.pwlib+= include/ptclib/pdns.h
BUILDLINK_FILES.pwlib+= include/ptclib/pils.h
BUILDLINK_FILES.pwlib+= include/ptclib/pldap.h
BUILDLINK_FILES.pwlib+= include/ptclib/psnmp.h
BUILDLINK_FILES.pwlib+= include/ptclib/psoap.h
BUILDLINK_FILES.pwlib+= include/ptclib/pssl.h
BUILDLINK_FILES.pwlib+= include/ptclib/pstun.h
BUILDLINK_FILES.pwlib+= include/ptclib/ptts.h
BUILDLINK_FILES.pwlib+= include/ptclib/pwavfile.h
BUILDLINK_FILES.pwlib+= include/ptclib/pxml.h
BUILDLINK_FILES.pwlib+= include/ptclib/pxmlrpc.h
BUILDLINK_FILES.pwlib+= include/ptclib/pxmlrpcs.h
BUILDLINK_FILES.pwlib+= include/ptclib/qchannel.h
BUILDLINK_FILES.pwlib+= include/ptclib/random.h
BUILDLINK_FILES.pwlib+= include/ptclib/shttpsvc.h
BUILDLINK_FILES.pwlib+= include/ptclib/socks.h
BUILDLINK_FILES.pwlib+= include/ptclib/telnet.h
BUILDLINK_FILES.pwlib+= include/ptclib/url.h
BUILDLINK_FILES.pwlib+= include/ptclib/vsdl.h
BUILDLINK_FILES.pwlib+= include/ptclib/vxml.h
BUILDLINK_FILES.pwlib+= include/ptlib.h
BUILDLINK_FILES.pwlib+= include/ptlib/MacMainIf.h
BUILDLINK_FILES.pwlib+= include/ptlib/args.h
BUILDLINK_FILES.pwlib+= include/ptlib/array.h
BUILDLINK_FILES.pwlib+= include/ptlib/channel.h
BUILDLINK_FILES.pwlib+= include/ptlib/conchan.h
BUILDLINK_FILES.pwlib+= include/ptlib/config.h
BUILDLINK_FILES.pwlib+= include/ptlib/contain.h
BUILDLINK_FILES.pwlib+= include/ptlib/contain.inl
BUILDLINK_FILES.pwlib+= include/ptlib/dict.h
BUILDLINK_FILES.pwlib+= include/ptlib/dynalink.h
BUILDLINK_FILES.pwlib+= include/ptlib/ethsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/file.h
BUILDLINK_FILES.pwlib+= include/ptlib/filepath.h
BUILDLINK_FILES.pwlib+= include/ptlib/icmpsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/indchan.h
BUILDLINK_FILES.pwlib+= include/ptlib/ipdsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/ipsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/ipxsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/lists.h
BUILDLINK_FILES.pwlib+= include/ptlib/mail.h
BUILDLINK_FILES.pwlib+= include/ptlib/mutex.h
BUILDLINK_FILES.pwlib+= include/ptlib/object.h
BUILDLINK_FILES.pwlib+= include/ptlib/osutil.inl
BUILDLINK_FILES.pwlib+= include/ptlib/pdirect.h
BUILDLINK_FILES.pwlib+= include/ptlib/pipechan.h
BUILDLINK_FILES.pwlib+= include/ptlib/pprocess.h
BUILDLINK_FILES.pwlib+= include/ptlib/pstring.h
BUILDLINK_FILES.pwlib+= include/ptlib/ptime.h
BUILDLINK_FILES.pwlib+= include/ptlib/remconn.h
BUILDLINK_FILES.pwlib+= include/ptlib/safecoll.h
BUILDLINK_FILES.pwlib+= include/ptlib/semaphor.h
BUILDLINK_FILES.pwlib+= include/ptlib/serchan.h
BUILDLINK_FILES.pwlib+= include/ptlib/sfile.h
BUILDLINK_FILES.pwlib+= include/ptlib/socket.h
BUILDLINK_FILES.pwlib+= include/ptlib/sockets.h
BUILDLINK_FILES.pwlib+= include/ptlib/sound.h
BUILDLINK_FILES.pwlib+= include/ptlib/spxsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/svcproc.h
BUILDLINK_FILES.pwlib+= include/ptlib/syncpoint.h
BUILDLINK_FILES.pwlib+= include/ptlib/syncthrd.h
BUILDLINK_FILES.pwlib+= include/ptlib/tcpsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/textfile.h
BUILDLINK_FILES.pwlib+= include/ptlib/thread.h
BUILDLINK_FILES.pwlib+= include/ptlib/timeint.h
BUILDLINK_FILES.pwlib+= include/ptlib/timer.h
BUILDLINK_FILES.pwlib+= include/ptlib/udpsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/channel.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/conchan.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/config.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/contain.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/dynalink.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/ethsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/file.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/filepath.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/icmpsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/ipdsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/ipsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/mutex.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/pdirect.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/pipechan.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/pmachdep.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/pprocess.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/ptime.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/ptlib.inl
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/remconn.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/semaphor.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/serchan.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/sfile.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/socket.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/sound.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/svcproc.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/syncpoint.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/tcpsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/textfile.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/thread.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/timeint.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/timer.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/udpsock.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/video.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/videoio.h
BUILDLINK_FILES.pwlib+= include/ptlib/unix/ptlib/videoio1394avc.h
BUILDLINK_FILES.pwlib+= include/ptlib/vconvert.h
BUILDLINK_FILES.pwlib+= include/ptlib/vfakeio.h
BUILDLINK_FILES.pwlib+= include/ptlib/video.h
BUILDLINK_FILES.pwlib+= include/ptlib/videoio.h
BUILDLINK_FILES.pwlib+= include/ptlib/videoio1394dc.h
BUILDLINK_FILES.pwlib+= lib/libpt.*
BUILDLINK_TARGETS+= pwlib-buildlink
pwlib-buildlink: _BUILDLINK_USE
.endif # PWLIB_BUILDLINK2_MK

View file

@ -1,28 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
# XXX
# XXX This file was created automatically using createbuildlink-3.4.
# XXX After this file as been verified as correct, the comment lines
# XXX beginning with "XXX" should be removed. Please do not commit
# XXX unverified buildlink[23].mk files.
# XXX
# XXX Packages that only install static libraries or headers should
# XXX include the following line:
# XXX
# XXX BUILDLINK_DEPMETHOD.pwlib?= build
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
PWLIB_BUILDLINK3_MK:= ${PWLIB_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= pwlib
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Npwlib}
BUILDLINK_PACKAGES+= pwlib
.if !empty(PWLIB_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.pwlib+= pwlib>=1.5.2
BUILDLINK_PKGSRCDIR.pwlib?= ../../wip/pwlib-trial
.endif # PWLIB_BUILDLINK3_MK
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,15 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
SHA1 (pwlib_1.5.2.tar.gz) = cbf9170dfe727d2423e312ca701cdf263c42ac86
Size (pwlib_1.5.2.tar.gz) = 1085203 bytes
SHA1 (patch-aa) = 1b51c48d1354f9e331e2967a66657a6cfc4dedbf
SHA1 (patch-ab) = be51c38451d19cdc155fd02373c01de8b83f2f65
SHA1 (patch-ac) = b8295346788f65d8353b1025b78e485c1974f2f6
SHA1 (patch-ad) = f8e839ad610f1e4a78197f41d40a539f97dc37d3
SHA1 (patch-ae) = caad0826e7dc6b65879c9844c04cd96a0cb4719c
SHA1 (patch-af) = 0038e7e62a999765edb346c9f1d74e810c8b5f35
SHA1 (patch-ag) = ea264668f6585989a0ce988ab0e3b78b4719dc51
SHA1 (patch-ah) = 1477b1d22025fe995e57492899d8070534760d0a
SHA1 (patch-ai) = f30ed46009d4b8f9e906f1a713b7d8cb074881c4
SHA1 (patch-aj) = 5e4b69dbb9d60ee2f7f24b1d90a0ac2496f39073
SHA1 (patch-ak) = 26b8bae32d1b625a3b5f3ce5dd42c783d64e4843

View file

@ -1,30 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- configure.in.orig Tue Aug 5 15:49:43 2003
+++ configure.in
@@ -166,6 +166,8 @@ $CC $CFLAGS -Wl,--gc-sections conftest.c
if test $? = 0 ; then
AC_MSG_RESULT(yes)
+
+ if $OSTYPE != netbsd ; then
AC_MSG_CHECKING(if compiler accepts -ffunction-sections)
AC_LANG_CONFTEST([[int main(int ac,char **av) { return 0; }]])
$CC $CFLAGS -ffunction-sections -c conftest.c > /dev/null 2>&1
@@ -176,7 +178,7 @@ if test $? = 0 ; then
else
AC_MSG_RESULT(no)
fi
-
+
AC_MSG_CHECKING(if compiler accepts -fdata-sections)
AC_LANG_CONFTEST([[int main(int ac,char **av) { return 0; }]])
$CC $CFLAGS -fdata-sections -c conftest.c > /dev/null 2>&1
@@ -186,6 +188,7 @@ if test $? = 0 ; then
GCSECTIONS=1
else
AC_MSG_RESULT(no)
+ fi
fi
AC_MSG_CHECKING(if compiler accepts -fvtable-gc)

View file

@ -1,40 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- configure.orig Tue Jul 29 11:23:56 2003
+++ configure
@@ -2606,6 +2606,7 @@ if test $? = 0 ; then
echo "$as_me:$LINENO: result: yes" >&5
echo "${ECHO_T}yes" >&6
+ if $OSTYPE != netbsd ; then
echo "$as_me:$LINENO: checking if compiler accepts -ffunction-sections" >&5
echo $ECHO_N "checking if compiler accepts -ffunction-sections... $ECHO_C" >&6
cat >conftest.$ac_ext <<_ACEOF
@@ -2621,8 +2622,8 @@ echo "${ECHO_T}yes" >&6
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6
fi
-
- echo "$as_me:$LINENO: checking if compiler accepts -fdata-sections" >&5
+
+ echo "$as_me:$LINENO: checking if compiler accepts -fdata-sections" >&5
echo $ECHO_N "checking if compiler accepts -fdata-sections... $ECHO_C" >&6
cat >conftest.$ac_ext <<_ACEOF
int main(int ac,char **av) { return 0; }
@@ -2637,6 +2638,7 @@ echo "${ECHO_T}yes" >&6
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6
fi
+ fi
echo "$as_me:$LINENO: checking if compiler accepts -fvtable-gc" >&5
echo $ECHO_N "checking if compiler accepts -fvtable-gc... $ECHO_C" >&6
@@ -2810,7 +2812,7 @@ cat >>confdefs.h <<\_ACEOF
#define P_PTHREADS 1
_ACEOF
-if test ${OSTYPE} != Darwin ; then
+if test ${OSTYPE} != Darwin && ${OSTYPE} != NetBSD; then
cat >>confdefs.h <<\_ACEOF
#define P_HAS_SEMAPHORES 1

View file

@ -1,51 +0,0 @@
$NetBSD: patch-ac,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- make/common.mak.orig Tue Jul 29 11:25:23 2003
+++ make/common.mak
@@ -273,11 +273,11 @@ SOURCES := $(strip $(SOURCES))
#
$(OBJDIR)/%.o : %.cxx
@if [ ! -d $(OBJDIR) ] ; then mkdir -p $(OBJDIR) ; fi
- $(CPLUS) $(STDCCFLAGS) $(OPTCCFLAGS) $(CFLAGS) -x c++ -c $< -o $@
+ /usr/pkg/bin/libtool --tag=CXX $(CPLUS) $(STDCCFLAGS) $(OPTCCFLAGS) $(CFLAGS) -c $< -o $@
$(OBJDIR)/%.o : %.c
@if [ ! -d $(OBJDIR) ] ; then mkdir -p $(OBJDIR) ; fi
- $(CC) $(STDCCFLAGS) $(OPTCCFLAGS) $(CFLAGS) -x c -c $< -o $@
+ /usr/pkg/bin/libtool --tag=CC $(CC) $(STDCCFLAGS) $(OPTCCFLAGS) $(CFLAGS) -c $< -o $@
#
# create list of object files
@@ -300,12 +300,12 @@ DEPS := $(patsubst %.dep, $(DEPDIR)/%.d
$(DEPDIR)/%.dep : %.cxx
@if [ ! -d $(DEPDIR) ] ; then mkdir -p $(DEPDIR) ; fi
@printf %s $(OBJDIR) > $@
- $(CPLUS) $(STDCCFLAGS) -M $< >> $@
+ /usr/pkg/bin/libtool --tag=CXX $(CPLUS) $(STDCCFLAGS) -M $< >> $@
$(DEPDIR)/%.dep : %.c
@if [ ! -d $(DEPDIR) ] ; then mkdir -p $(DEPDIR) ; fi
@printf %s $(OBJDIR) > $@
- $(CC) $(STDCCFLAGS) -M $< >> $@
+ /usr/pkg/bin/libtool --tag=CC $(CC) $(STDCCFLAGS) -M $< >> $@
#
# add in good files to delete
@@ -344,7 +344,7 @@ ifeq ($(OSTYPE),beos)
# directory
@if [ ! -L $(OBJDIR)/lib ] ; then cd $(OBJDIR); ln -s $(PW_LIBDIR) lib; fi
endif
- $(CPLUS) -o $@ $(CFLAGS) $(LDFLAGS) $(OBJS) $(LDLIBS) $(ENDLDLIBS) $(ENDLDFLAGS)
+ /usr/pkg/bin/libtool --tag=CXX $(CPLUS) -o $@ $(CFLAGS) $(LDFLAGS) $(OBJS) $(LDLIBS) $(ENDLDLIBS) $(ENDLDFLAGS)
ifeq ($(OSTYPE),VxWorks)
$(LD) --split-by-reloc 65535 -r $(OBJS) -o $@
endif
@@ -380,7 +380,7 @@ CLEAN_FILES += $(TARGET)
ifndef INSTALL_OVERRIDE
install: $(TARGET)
- $(INSTALL) $(TARGET) $(INSTALLBIN_DIR)
+ /usr/pkg/bin/libtool $(BSD_INSTALL_PROGRAM) $(TARGET) $(INSTALLBIN_DIR)
endif
# ifdef PROG

View file

@ -1,18 +0,0 @@
$NetBSD: patch-ad,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- make/gui.mak.orig Fri Jun 15 00:58:00 2001
+++ make/gui.mak
@@ -64,11 +64,11 @@
#
-include $(PWLIBDIR)/make/defaultgui.mak
+include $(PWLIBDIR)/share/pwlib/make/defaultgui.mak
ifneq (,$(GUI_TYPE))
-include $(PWLIBDIR)/make/$(GUI_TYPE).mak
+include $(PWLIBDIR)/share/pwlib/make/$(GUI_TYPE).mak
ifndef GUI_SRC_NAME
GUI_SRC_NAME = $(GUI_TYPE)

View file

@ -1,66 +0,0 @@
$NetBSD: patch-ae,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- make/lib.mak.orig Tue Jul 29 12:33:34 2003
+++ make/lib.mak
@@ -110,6 +110,8 @@
# Added copyright notice
#
+
+
ifneq ($(OSTYPE),Darwin)
LIBNAME_MAJ = $(LIB_FILENAME).$(MAJOR_VERSION)
LIBNAME_MIN = $(LIBNAME_MAJ).$(MINOR_VERSION)
@@ -135,14 +137,8 @@ CLEAN_FILES += $(LIBDIR)/$(LIBNAME_PAT)
ifneq ($(P_SHAREDLIB),1)
STATIC_LIB_FILE = $(LIBDIR)/$(LIB_FILENAME)
else
- STATIC_LIB_FILE = $(LIBDIR)/$(subst .$(LIB_SUFFIX),_s.$(STATICLIBEXT),$(LIB_FILENAME))
-endif
+ STATIC_LIB_FILE = $(LIBDIR)/lib$(LIB_BASENAME)_s.a
-$(LIBDIR)/$(LIB_FILENAME) : $(TARGETLIB)
-
-ifeq ($(P_SHAREDLIB),1)
-
- ENDLDLIBS := $(SYSLIBS) $(ENDLDLIBS)
ifeq ($(OSTYPE),beos)
# BeOS requires different options when building shared libraries
# Also, when building a shared library x that references symbols in libraries y,
@@ -181,28 +177,22 @@ ifeq ($(P_SHAREDLIB),1)
LDSOOPTS = -Bdynamic -G -h $(LIB_SONAMEN)
LD = ld
else
- ifneq ($(OSTYPE),Darwin)
LDSOOPTS += -Wl,-soname,$(LIB_SONAME)
- endif
- LD = $(CPLUS)
+ LD = $(CPLUS)
endif
- $(LIBDIR)/$(LIB_FILENAME): $(LIBDIR)/$(LIBNAME_PAT)
- cd $(LIBDIR) ; rm -f $(LIB_FILENAME) ; ln -sf $(LIBNAME_PAT) $(LIB_FILENAME)
- cd $(LIBDIR) ; rm -f $(LIBNAME_MAJ) ; ln -sf $(LIBNAME_PAT) $(LIBNAME_MAJ)
- cd $(LIBDIR) ; rm -f $(LIBNAME_MIN) ; ln -sf $(LIBNAME_PAT) $(LIBNAME_MIN)
+ ENDLDLIBS += -L$(PREFIX)/lib -lpthread -lossaudio
- $(LIBDIR)/$(LIBNAME_PAT): $(STATIC_LIB_FILE)
+ $(LIBDIR)/$(LIB_FILENAME): $(OBJS)
@echo EXTLIBS = $(EXTLIBS)
@echo SYSLIBS = $(SYSLIBS)
@if [ ! -d $(LIBDIR) ] ; then mkdir $(LIBDIR) ; fi
- $(LD) $(LDSOOPTS) -o $(LIBDIR)/$(LIBNAME_PAT) $(LDFLAGS) $(EXTLIBS) $(OBJS) $(ENDLDLIBS)
+ /usr/pkg/bin/libtool --tag=CXX $(CPLUS) -o $(LIBDIR)/$(LIB_FILENAME) \
+ $(OBJS:.o=.lo) $(ENDLDLIBS) -rpath $(INSTALLLIB_DIR) \
+ -version-info $(MAJOR_VERSION):$(MINOR_VERSION)
- install: $(LIBDIR)/$(LIBNAME_PAT)
- $(INSTALL) $(LIBDIR)/$(LIBNAME_PAT) $(INSTALLLIB_DIR)/$(LIBNAME_PAT)
- ln -sf $(LIBNAME_PAT) $(INSTALLLIB_DIR)/$(LIB_FILENAME)
- ln -sf $(LIBNAME_PAT) $(INSTALLLIB_DIR)/$(LIBNAME_MAJ)
- ln -sf $(LIBNAME_PAT) $(INSTALLLIB_DIR)/$(LIBNAME_MIN)
+ install: $(LIBDIR)/$(LIB_FILENAME)
+ /usr/pkg/bin/libtool $(BSD_INSTALL_DATA) $(LIBDIR)/$(LIB_FILENAME) $(INSTALLLIB_DIR)
endif # P_SHAREDLIB

View file

@ -1,14 +0,0 @@
$NetBSD: patch-af,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- make/ptlib.mak.orig Wed Dec 2 02:37:31 1998
+++ make/ptlib.mak
@@ -38,7 +38,7 @@ ifndef PWLIBDIR
PWLIBDIR=$(HOME)/pwlib
endif
-include $(PWLIBDIR)/make/unix.mak
-include $(PWLIBDIR)/make/common.mak
+include $(PWLIBDIR)/share/pwlib/make/unix.mak
+include $(PWLIBDIR)/share/pwlib/make/common.mak
# End of ptlib.mak

View file

@ -1,20 +0,0 @@
$NetBSD: patch-ag,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- make/pwlib.mak.orig Wed Dec 2 02:39:53 1998
+++ make/pwlib.mak
@@ -44,11 +44,11 @@
#
ifndef PWLIBDIR
-PWLIBDIR=$(HOME)/pwlib
+PWLIBDIR= @PREFIX@
endif
-include $(PWLIBDIR)/make/unix.mak
-include $(PWLIBDIR)/make/gui.mak
-include $(PWLIBDIR)/make/common.mak
+include $(PWLIBDIR)/share/pwlib/make/unix.mak
+include $(PWLIBDIR)/share/pwlib/make/gui.mak
+include $(PWLIBDIR)/share/pwlib/make/common.mak
# End of pwlib.mak

View file

@ -1,138 +0,0 @@
$NetBSD: patch-ah,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- make/unix.mak.orig Thu Jul 24 22:01:42 2003
+++ make/unix.mak
@@ -66,13 +66,13 @@
#
ifndef PWLIBDIR
-PWLIBDIR = $(HOME)/pwlib
+PWLIBDIR = /usr/pkg
endif
####################################################
# include generated build options file, then include it
-include $(PWLIBDIR)/make/ptbuildopts.mak
+include $(PWLIBDIR)/share/pwlib/make/ptbuildopts.mak
###############################################################################
#
@@ -404,9 +404,7 @@ endif # OpenBSD
ifeq ($(OSTYPE),NetBSD)
-ifeq ($(MACHTYPE),x86)
-STDCCFLAGS += -m486
-endif
+P_PTHREADS := 1
ifndef OSRELASE
OSRELEASE := $(shell /sbin/sysctl -n kern.osrevision)
@@ -415,37 +413,19 @@ endif
STDCCFLAGS += -DP_NETBSD=$(OSRELEASE)
LDLIBS += -lossaudio
-STDCCFLAGS += -I$(UNIX_INC_DIR) -I$(PWLIBDIR)/include
-
-# enable the USE_PTH line to compile using pth
-# enable the USE_NATIVE_THREADS line to compile using native threads
-# enable the USE_UNPROVEN_THREADS line to compile using unproven threads
-#USE_PTH_THREADS := 1
-#USE_UNPROVEN_THREADS := 1
-USE_NATIVE_THREADS := 1
-
ifdef P_PTHREADS
-ifdef USE_NATIVE_THREADS
-LDLIBS += -lpthread
-else
-ifdef USE_PTH_THREADS
-STDCCFLAGS += -DP_GNU_PTH
-STDCCFLAGS += -I/usr/pkg/include
-LDFLAGS += -L/usr/pkg/lib
-LDLIBS += -lpthread
-else
-STDCCFLAGS += -DP_NO_CANCEL
-STDCCFLAGS += -I/usr/pkg/pthreads/include
-LDFLAGS += -L/usr/pkg/pthreads/lib
-LDLIBS += -lpthread
-CC := /usr/pkg/pthreads/bin/pgcc
-CPLUS := /usr/pkg/pthreads/bin/pg++
-endif
-endif
+# need to put $(PREFIX)/include after library includes, so that
+# the build wouldn't pick up potential intalled pwlib headers
+# from $(PREFIX)
+STDCCFLAGS += -I$(UNIX_INC_DIR) -I$(PWLIBDIR)/include -I/usr/pkg/include
+LDFLAGS += -L/usr/pkg/lib -lpthread
endif
+
+
+
P_USE_RANLIB := 1
-STDCCFLAGS += -DP_USE_PRAGMA
+STDCCFLAGS += -DP_USE_PRAGMA
endif # NetBSD
@@ -853,8 +833,8 @@ STATICLIBEXT = a
endif
ifeq ($(P_SHAREDLIB),1)
-LIB_SUFFIX = $(SHAREDLIBEXT)
-else
+LIB_SUFFIX = la
+else
LIB_SUFFIX = a
ifndef DEBUG
LIB_TYPE = _s
@@ -865,8 +845,10 @@ ifndef LIB_TYPE
LIB_TYPE =
endif
+INSTALL_DIR = ${PREFIX}
+
ifndef INSTALL_DIR
-INSTALL_DIR = /usr/local
+INSTALL_DIR = /usr/pkg
endif
ifndef INSTALLBIN_DIR
@@ -891,12 +873,7 @@ SHELL := /bin/sh
# Directories
-ifdef PREFIX
-UNIX_INC_DIR = $(PREFIX)/include/ptlib/unix
-else
UNIX_INC_DIR = $(PWLIBDIR)/include/ptlib/unix
-endif
-
ifndef UNIX_SRC_DIR
UNIX_SRC_DIR = $(PWLIBDIR)/src/ptlib/unix
endif
@@ -904,7 +881,7 @@ endif
PW_LIBDIR = $(PWLIBDIR)/lib
# set name of the PT library
-PTLIB_BASE = pt_$(PLATFORM_TYPE)_$(OBJ_SUFFIX)
+PTLIB_BASE = pt
PTLIB_FILE = lib$(PTLIB_BASE)$(LIB_TYPE).$(LIB_SUFFIX)
PT_OBJBASE = obj_$(PLATFORM_TYPE)_$(OBJDIR_SUFFIX)
PT_OBJDIR = $(PW_LIBDIR)/$(PT_OBJBASE)
@@ -966,12 +943,12 @@ endif
#STDCCFLAGS += -fno-implement-inlines
# add OS directory to include path
-STDCCFLAGS += -I$(UNIX_INC_DIR) -I/usr/include/pwlib
+STDCCFLAGS += -I$(UNIX_INC_DIR)
# add library directory to library path and include the library
LDFLAGS += -L$(PW_LIBDIR)
-LDLIBS += -l$(PTLIB_BASE)$(LIB_TYPE)
+LDLIBS += $(PW_LIBDIR)/$(PTLIB_FILE)
# End of unix.mak

View file

@ -1,37 +0,0 @@
$NetBSD: patch-aj,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- src/ptlib/unix/Makefile.orig Mon Jul 28 18:44:01 2003
+++ src/ptlib/unix/Makefile
@@ -622,26 +622,26 @@ alllibs:
$(OBJDIR)/regcomp.o: $(COMMON_SRC_DIR)/regex/regcomp.c
- $(CC) $(CFLAGS) $(DEBUG_FLAG) $(OPTCCFLAGS) -c -DPOSIX_MISTAKE -I$(COMMON_SRC_DIR)/regex -o $@ -c $<
+ $(LIBTOOL) --tag=CC $(CC) $(CFLAGS) $(DEBUG_FLAG) $(OPTCCFLAGS) -c -DPOSIX_MISTAKE -I$(COMMON_SRC_DIR)/regex -o $@ -c $<
$(OBJDIR)/regexec.o: $(COMMON_SRC_DIR)/regex/regexec.c
- $(CC) $(CFLAGS) $(DEBUG_FLAG) $(OPTCCFLAGS) -c -DPOSIX_MISTAKE -I$(COMMON_SRC_DIR)/regex -o $@ -c $<
+ $(LIBTOOL) --tag=CC $(CC) $(CFLAGS) $(DEBUG_FLAG) $(OPTCCFLAGS) -c -DPOSIX_MISTAKE -I$(COMMON_SRC_DIR)/regex -o $@ -c $<
$(OBJDIR)/regerror.o: $(COMMON_SRC_DIR)/regex/regerror.c
- $(CC) $(CFLAGS) $(DEBUG_FLAG) $(OPTCCFLAGS) -c -DPOSIX_MISTAKE -I$(COMMON_SRC_DIR)/regex -o $@ -c $<
+ $(LIBTOOL) --tag=CC $(CC) $(CFLAGS) $(DEBUG_FLAG) $(OPTCCFLAGS) -c -DPOSIX_MISTAKE -I$(COMMON_SRC_DIR)/regex -o $@ -c $<
$(OBJDIR)/regfree.o: $(COMMON_SRC_DIR)/regex/regfree.c
- $(CC) $(CFLAGS) $(DEBUG_FLAG) $(OPTCCFLAGS) -c -DPOSIX_MISTAKE -I$(COMMON_SRC_DIR)/regex -o $@ -c $<
+ $(LIBTOOL) --tag=CC $(CC) $(CFLAGS) $(DEBUG_FLAG) $(OPTCCFLAGS) -c -DPOSIX_MISTAKE -I$(COMMON_SRC_DIR)/regex -o $@ -c $<
ifdef REQUIRES_SEPARATE_SWITCH
$(OBJDIR)/switch.o: ./switch.cxx
@if [ ! -d $(OBJDIR) ] ; then mkdir -p $(OBJDIR) ; fi
- $(CPLUS) $(CFLAGS) $(STDCCFLAGS) -c $< -o $@
+ $(LIBTOOL) --tag=CXX $(CPLUS) $(CFLAGS) $(STDCCFLAGS) -c $< -o $@
endif
$(OBJDIR)/getdate.tab.o: $(GETDATE_SOURCE)
- $(CC) $(CFLAGS) $(STDCCFLAGS) -c $< -o $@
+ $(LIBTOOL) --tag=CC $(CC) $(CFLAGS) $(STDCCFLAGS) -c $< -o $@
$(DEPDIR)/getdate.tab.dep: $(GETDATE_SOURCE)
$(CC) $(STDCCFLAGS) -M $< >> $@

View file

@ -1,17 +0,0 @@
$NetBSD: patch-ak,v 1.1.1.1 2004/11/29 18:02:26 daprice Exp $
--- src/ptlib/unix/switch.cxx.orig Mon Jan 6 18:41:08 2003
+++ src/ptlib/unix/switch.cxx
@@ -91,10 +91,10 @@
#if defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)
#define SET_STACK context[0]._jb[2] = (int)stackTop-16;
-#if defined(P_NETBSD)
+//#if defined(P_NETBSD)
#include <sys/mman.h>
#define USE_MMAP MAP_ANON | MAP_PRIVATE
-#endif
+//#endif
#endif
#ifdef __BEOS__