Initial import of chmlib 0.31

CHMLIB is a library for dealing with Microsoft ITSS/CHM format files. Right 
now, it is a very simple library, but sufficient for dealing with all of the 
.chm files I've come across. Due to the fairly well-designed indexing built 
into this particular file format, even a small library is able to gain 
reasonably good performance indexing into ITSS archives. Since the last 
version there have been major bugfixes, portability improvements, and minor 
feature additions. 

Suggested by kdehl on IRC
This commit is contained in:
Juan Romero Pardines 2003-09-05 02:34:33 +00:00
parent c7bddfd11a
commit aecb913eb7
6 changed files with 82 additions and 0 deletions

7
chmlib/DESCR Normal file
View file

@ -0,0 +1,7 @@
CHMLIB is a library for dealing with Microsoft ITSS/CHM format files. Right
now, it is a very simple library, but sufficient for dealing with all of the
.chm files I've come across. Due to the fairly well-designed indexing built
into this particular file format, even a small library is able to gain
reasonably good performance indexing into ITSS archives. Since the last
version there have been major bugfixes, portability improvements, and minor
feature additions.

20
chmlib/Makefile Normal file
View file

@ -0,0 +1,20 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/09/05 02:34:33 xtraeme Exp $
#
DISTNAME= chmlib-0.31
CATEGORIES= devel
MASTER_SITES= http://66.93.236.84/%7Ejedwin/projects/chmlib/
EXTRACT_SUFX= .tbz
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://66.93.236.84/%7Ejedwin/projects/chmlib/
COMMENT= Library for dealing with Microsoft ITSS/CHM format files
USE_BUILDLINK2= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
PTHREAD_OPTS= require
.include "../../mk/pthread.buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

7
chmlib/PLIST Normal file
View file

@ -0,0 +1,7 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/09/05 02:34:33 xtraeme Exp $
include/chm_lib.h
lib/libchm.a
lib/libchm.la
lib/libchm.so
lib/libchm.so.0
lib/libchm.so.0.0

24
chmlib/buildlink2.mk Normal file
View file

@ -0,0 +1,24 @@
# $NetBSD: buildlink2.mk,v 1.1.1.1 2003/09/05 02:34:33 xtraeme Exp $
#
# This Makefile fragment is included by packages that use chmlib.
#
# This file was created automatically using createbuildlink 2.6.
#
.if !defined(CHMLIB_BUILDLINK2_MK)
CHMLIB_BUILDLINK2_MK= # defined
BUILDLINK_PACKAGES+= chmlib
BUILDLINK_DEPENDS.chmlib?= chmlib>=0.31
BUILDLINK_PKGSRCDIR.chmlib?= ../../wip/chmlib
EVAL_PREFIX+= BUILDLINK_PREFIX.chmlib=chmlib
BUILDLINK_PREFIX.chmlib_DEFAULT= ${LOCALBASE}
BUILDLINK_FILES.chmlib+= include/chm_lib.h
BUILDLINK_FILES.chmlib+= lib/libchm.*
BUILDLINK_TARGETS+= chmlib-buildlink
chmlib-buildlink: _BUILDLINK_USE
.endif # CHMLIB_BUILDLINK2_MK

5
chmlib/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/09/05 02:34:33 xtraeme Exp $
SHA1 (chmlib-0.31.tbz) = 4d6be22cb408695c7e8ef6933b46e5cd46d13048
Size (chmlib-0.31.tbz) = 40810 bytes
SHA1 (patch-aa) = a76776c05e95c09e455556bdb6d6dbda97d677ac

19
chmlib/patches/patch-aa Normal file
View file

@ -0,0 +1,19 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/09/05 02:34:33 xtraeme Exp $
--- Makefile.orig 2003-09-05 04:10:40.000000000 +0200
+++ Makefile 2003-09-05 04:11:50.000000000 +0200
@@ -7,11 +7,9 @@
# Note: LDFLAGS must contain -lpthread if you are using -DCHM_MT.
#
#CFLAGS=-DCHM_MT -DCHM_USE_PREAD -DCHM_USE_IO64
-CFLAGS=-DCHM_MT -DCHM_USE_PREAD -DCHM_USE_IO64 -g -DDMALLOC_DISABLE
-LDFLAGS=-lpthread
-INSTALLPREFIX=/usr/local/
-CC=gcc-3.2
-LD=gcc-3.2
+CFLAGS+=-DCHM_MT -DDMALLOC_DISABLE
+INSTALLPREFIX=${PREFIX}
+LD=${CC}
LIBTOOL=libtool
CP=/bin/cp
EXAMPLES=test_chmLib enum_chmLib enumdir_chmLib chm_http extract_chmLib