Initial import. Needs some minimal patching ("documentation" directory),
but is in useable state. DrPython is a highly customizable cross-platform ide to aid programming in Python. It was developed with teaching in mind, and has a clean, simple interface. It is written in Python, using wxPython as the gui. Features: * Cross Platform - works anywhere wxPython works * Highly Customizable - customize Look and Feel, Behavior, Shortcuts and more * Clean, Simple Interface * Built In Prompt * Quick Access to Python Documentation * Switcheroo - switch all occurances of X with Y, and Y with X. * DrScript - write custom python scripts with access to DrPython internals, and access them from the menu. * Themes * Bookmarks * Python Debugger Support * Class Browser * Printing * Built using wxStyledTextControl (Scintilla) - Syntax Highlighting and Styling Built In Folding, Drag and Drop, Brace Matching * Uses a Custom FindReplace Dialog that supports (beyond the default wxWindows dialogs): In Selection, From Cursor, Prompt on Replace, Regular Expressions
This commit is contained in:
parent
b6a4e4d642
commit
b143b78bba
5 changed files with 75 additions and 0 deletions
23
drpython/DESCR
Normal file
23
drpython/DESCR
Normal file
|
@ -0,0 +1,23 @@
|
|||
DrPython is a highly customizable cross-platform ide to aid programming in
|
||||
Python. It was developed with teaching in mind, and has a clean, simple
|
||||
interface. It is written in Python, using wxPython as the gui.
|
||||
|
||||
Features:
|
||||
* Cross Platform - works anywhere wxPython works
|
||||
* Highly Customizable - customize Look and Feel, Behavior, Shortcuts and more
|
||||
* Clean, Simple Interface
|
||||
* Built In Prompt
|
||||
* Quick Access to Python Documentation
|
||||
* Switcheroo - switch all occurances of X with Y, and Y with X.
|
||||
* DrScript - write custom python scripts with access to DrPython
|
||||
internals, and access them from the menu.
|
||||
* Themes
|
||||
* Bookmarks
|
||||
* Python Debugger Support
|
||||
* Class Browser
|
||||
* Printing
|
||||
* Built using wxStyledTextControl (Scintilla) - Syntax Highlighting and
|
||||
Styling Built In Folding, Drag and Drop, Brace Matching
|
||||
* Uses a Custom FindReplace Dialog that supports (beyond the default
|
||||
wxWindows dialogs): In Selection, From Cursor, Prompt on Replace, Regular
|
||||
Expressions
|
32
drpython/Makefile
Normal file
32
drpython/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/02/05 11:59:43 mpasternak Exp $
|
||||
#
|
||||
|
||||
DISTNAME= drpython-2.1.9
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=drpython/}
|
||||
EXTRACT_SUFX= .zip
|
||||
|
||||
MAINTAINER= dotz@irc.pl
|
||||
HOMEPAGE= http://drpython.sourceforge.net/
|
||||
COMMENT= Source code editor, written in Python, for Python
|
||||
|
||||
USE_BUILDLINK2= yes
|
||||
NO_CONFIGURE=
|
||||
NO_BUILD=
|
||||
|
||||
DRPYTHON_DIR= share/drpython
|
||||
PLIST_SRC= ${WRKDIR}/.PLIST_SRC
|
||||
PYTHON_PATCH_SCRIPTS= drpython.py
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/${DRPYTHON_DIR}
|
||||
${CAT} ${PKGDIR}/PLIST.pre >${PLIST_SRC}
|
||||
cd ${WRKSRC} && ${PAX} -rw -pe [a-z]* ${PREFIX}/${DRPYTHON_DIR}
|
||||
cd ${PREFIX} && ${FIND} ${DRPYTHON_DIR} -type f -print >>${PLIST_SRC}
|
||||
cd ${PREFIX} && ${FIND} -d ${DRPYTHON_DIR} -type d -print | \
|
||||
${SED} -e "s/^/@dirrm /" >>${PLIST_SRC}
|
||||
${LN} -s ${PREFIX}/${DRPYTHON_DIR}/drpython.py ${PREFIX}/bin
|
||||
|
||||
.include "../../x11/py-wxWindows/buildlink2.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
drpython/PLIST.pre
Normal file
2
drpython/PLIST.pre
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST.pre,v 1.1.1.1 2004/02/05 11:59:43 mpasternak Exp $
|
||||
bin/drpython.py
|
5
drpython/distinfo
Normal file
5
drpython/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/02/05 11:59:43 mpasternak Exp $
|
||||
|
||||
SHA1 (drpython-2.1.9.zip) = fe9e4985cc3b94f875271bf2235e7371f98d8488
|
||||
Size (drpython-2.1.9.zip) = 244990 bytes
|
||||
SHA1 (patch-aa) = c7a4eb180e32415b3442bbe9cc619b963c4fe596
|
13
drpython/patches/patch-aa
Normal file
13
drpython/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/02/05 11:59:43 mpasternak Exp $
|
||||
|
||||
--- drpython.py~ Thu Feb 5 12:54:47 2004
|
||||
+++ drpython.py Thu Feb 5 12:56:07 2004
|
||||
@@ -224,7 +224,7 @@
|
||||
#Thanks to Guillermo Fernandez.
|
||||
#Thanks Bjorn Breid
|
||||
programdirectory = os.path.dirname(os.path.abspath(sys.argv[0])).replace("\\", "/") + "/"
|
||||
-bitmapdirectory = programdirectory + "bitmaps"
|
||||
+bitmapdirectory = programdirectory + "../share/drpython/bitmaps"
|
||||
|
||||
#*******************************************************************************************************
|
||||
|
Loading…
Reference in a new issue