First go at a major reworking of the isc-dhcp package and components
Grab MAINTAINER Update TODO Fix build on OS/X
This commit is contained in:
parent
5fc06d7ed0
commit
b55dce0468
29 changed files with 396 additions and 174 deletions
|
@ -1,9 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/12/06 08:38:43 jeremy-c-reed Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2007/12/02 18:34:10 adrian_p Exp $
|
||||
#
|
||||
|
||||
ISC_DHCP_TYPE= dhclient
|
||||
COMMENT= ISC Dynamic Host Configuration Protocol (DHCP) Client
|
||||
COMPONENT= client
|
||||
SUBDIR= client
|
||||
|
||||
COMMENT= ISC Dynamic Host Configuration Protocol (DHCP) Client
|
||||
CONF_FILES+= ${EGDIR}/dhclient.conf ${PKG_SYSCONFDIR}/dhclient.conf
|
||||
|
||||
.include "../../wip/isc-dhcpd/Makefile.common"
|
||||
DEPENDS+= isc-dhcp-base-3.0.6:../../wip/isc-dhcp
|
||||
|
||||
RCD_SCRIPTS= isc_dhclient
|
||||
MAN_FILES= man5/dhclient.conf.5 man5/dhclient.leases.5 \
|
||||
man8/dhclient-script.8 man8/dhclient.8
|
||||
FILES_SUBST+= DHCP_HOME=${DHCP_HOME}
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/client/dhclient.conf ${EGDIR}
|
||||
|
||||
.include "../../wip/isc-dhcp/Makefile.common"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2005/05/02 20:33:58 jeremy-c-reed Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2007/12/02 18:34:10 adrian_p Exp $
|
||||
man/man5/dhclient.conf.5
|
||||
man/man5/dhclient.leases.5
|
||||
man/man8/dhclient-script.8
|
||||
man/man8/dhclient.8
|
||||
sbin/dhclient
|
||||
sbin/dhclient-script
|
||||
share/doc/isc-dhclient/README
|
||||
share/examples/rc.d/isc_dhclient
|
||||
@dirrm share/doc/isc-dhclient
|
||||
share/examples/isc-dhcp-client/dhclient.conf
|
||||
@dirrm share/examples/isc-dhcp-client
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
$Id: TODO,v 1.4 2004/07/07 19:55:04 jeremy-c-reed Exp $
|
||||
|
||||
make this build under NetBSD:
|
||||
includes/cf/netbsd.h
|
||||
and common/bpf.c and common/fddi.c to use NETBSD_FDDI
|
||||
(see NetBSD's /usr/src/dist/dhcp)
|
||||
|
||||
Use MAKE_DIRS_PERMS for /var/db/dhcp
|
||||
maybe should be named /var/db/isc-dhcp ?
|
||||
does that conflict with other dhcp?
|
||||
|
||||
define in site.conf?
|
||||
INSTALL
|
||||
MANINSTALL
|
||||
|
||||
patch the Makefile.dist files to change all target to use SEDMANPAGES instead
|
||||
(so nroff is not done)
|
||||
|
||||
about rc.d script comments, see TODO of wip/isc-dhcpd, as there are the same
|
||||
questions/issues (mpasternak)
|
||||
|
||||
maybe modify dhclient-script to not hard-code /etc/ directory for dhclient
|
||||
related scripts
|
||||
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.3 2006/08/15 18:23:10 ondratu Exp $
|
||||
$NetBSD: distinfo,v 1.4 2007/12/02 18:34:10 adrian_p Exp $
|
||||
|
||||
SHA1 (dhcp-3.0.4.tar.gz) = 2efe316d69563bf2440cbb4efc2bc06ef9445db3
|
||||
RMD160 (dhcp-3.0.4.tar.gz) = f5636d87e1e2138bd239157f54d8f73c73af73ac
|
||||
Size (dhcp-3.0.4.tar.gz) = 883245 bytes
|
||||
SHA1 (patch-aa) = 24e752b3cd4275f9636eab71d310028db92de901
|
||||
SHA1 (dhcp-3.0.6.tar.gz) = 204e509580d57d0cfff23529274612ca8c710efb
|
||||
RMD160 (dhcp-3.0.6.tar.gz) = 6b7dbad413f83f9bce4ed92a8abc60394a06c6ad
|
||||
Size (dhcp-3.0.6.tar.gz) = 891513 bytes
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2006/08/15 18:23:10 ondratu Exp $
|
||||
|
||||
--- Makefile.dist.orig 2004-06-10 19:59:10.000000000 +0200
|
||||
+++ Makefile.dist
|
||||
@@ -22,7 +22,7 @@
|
||||
# http://www.isc.org/
|
||||
|
||||
|
||||
-SUBDIRS= common $(MINIRES) dst omapip server client relay dhcpctl
|
||||
+SUBDIRS= common $(MINIRES) dst omapip client
|
||||
|
||||
all:
|
||||
@for dir in ${SUBDIRS}; do \
|
||||
@@ -31,7 +31,7 @@ all:
|
||||
done
|
||||
|
||||
install:
|
||||
- @for dir in ${SUBDIRS}; do \
|
||||
+ @for dir in client ; do \
|
||||
echo "Installing in $$dir"; \
|
||||
(cd $$dir; $(MAKE) install) || exit 1; \
|
||||
done
|
7
isc-dhcp/DESCR
Normal file
7
isc-dhcp/DESCR
Normal file
|
@ -0,0 +1,7 @@
|
|||
This package provides the ISC Dynamic Host Configuration Protocol (DHCP)
|
||||
server and DHCP relay agent.
|
||||
|
||||
It includes an DHCP (and BOOTP) server daemon used to distribute network
|
||||
information, an Object Management API command shell for querying and
|
||||
modifying DHCP server attributes (while it is running), and an agent
|
||||
for relaying DHCP and BOOTP requests between subnets.
|
26
isc-dhcp/Makefile
Normal file
26
isc-dhcp/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# $NetBSD: Makefile,v 1.1 2007/12/02 18:34:09 adrian_p Exp $
|
||||
#
|
||||
|
||||
COMMENT= ISC Dynamic Host Configuration Protocol (DHCP) Base
|
||||
COMPONENT= base
|
||||
SUBDIR= common minires dst
|
||||
|
||||
MAN_FILES= man5/dhcp-eval.5 man5/dhcp-options.5
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/isc-dhcp-${COMPONENT}
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/include/isc-dhcp
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/include/omapip
|
||||
|
||||
${INSTALL_DATA} ${WRKSRC}/README \
|
||||
${PREFIX}/share/doc/isc-dhcp-${COMPONENT}
|
||||
${INSTALL_DATA} ${WRKSRC}/includes/isc-dhcp/*.h \
|
||||
${PREFIX}/include/isc-dhcp
|
||||
${INSTALL_DATA} ${WRKSRC}/includes/omapip/*.h \
|
||||
${PREFIX}/include/omapip
|
||||
${INSTALL_LIB} \
|
||||
${WRKSRC}/work.`${WRKSRC}/configure --print-sysname`/dst/*.a \
|
||||
${PREFIX}/lib
|
||||
|
||||
.include "../../wip/isc-dhcp/Makefile.common"
|
||||
.include "../../mk/bsd.pkg.mk"
|
62
isc-dhcp/Makefile.common
Normal file
62
isc-dhcp/Makefile.common
Normal file
|
@ -0,0 +1,62 @@
|
|||
# $NetBSD: Makefile.common,v 1.1 2007/12/02 18:34:09 adrian_p Exp $
|
||||
#
|
||||
|
||||
DISTNAME= dhcp-3.0.6
|
||||
PKGNAME= ${DISTNAME:S/dhcp/isc-dhcp-${COMPONENT}/}
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.isc.org/isc/dhcp/ \
|
||||
http://ftp.isc.org/isc/dhcp/dhcp-3.0-history/ \
|
||||
http://archive.progeny.com/isc/dhcp/ \
|
||||
ftp://ftp.freenet.de/pub/ftp.isc.org/isc/dhcp/ \
|
||||
ftp://ftp2.tw.freebsd.org/isc/dhcp/ \
|
||||
http://public.planetmirror.com/pub/isc/dhcp/
|
||||
|
||||
MAINTAINER= adrianp@NetBSD.org
|
||||
HOMEPAGE= http://www.isc.org/sw/dhcp/
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
DHCP_HOME?= ${VARBASE}/db/isc-dhcp
|
||||
DHCP_SYSLOG_LEVEL?= 1
|
||||
PKG_SYSCONFSUBDIR= dhcp
|
||||
USE_TOOLS+= nroff
|
||||
|
||||
FILESDIR= ${.CURDIR}/../isc-dhcp/files
|
||||
EGDIR= ${PREFIX}/share/examples/isc-dhcp-${COMPONENT}
|
||||
BUILD_DEFS+= VARBASE DHCP_HOME DHCP_SYSLOG_LEVEL
|
||||
|
||||
#MAN_FILES= man1/omshell.1 man3/dhcpctl.3 man3/omapi.3 \
|
||||
# man3/omshell.3 man5/dhcp-eval.5 man5/dhcp-options.5 \
|
||||
# man5/dhcpd.conf.5 man5/dhcpd.leases.5 \
|
||||
# man8/dhcpd.8 man8/dhcrelay.8
|
||||
|
||||
SUBST_CLASSES+= conf
|
||||
SUBST_STAGE.conf= pre-configure
|
||||
SUBST_MESSAGE.conf= Fixing configuration files.
|
||||
SUBST_FILES.conf= includes/site.h
|
||||
SUBST_SED.conf= -e 's|@@DHCP_SYSLOG_LEVEL@@|${DHCP_SYSLOG_LEVEL}|g'
|
||||
SUBST_SED.conf+= -e 's|@@VARBASE@@|${VARBASE}|g'
|
||||
SUBST_SED.conf+= -e 's|@@SYSCONFDIR@@|${PKG_SYSCONFDIR}|g'
|
||||
SUBST_SED.conf+= -e 's|@@PREFIX@@|${PREFIX}|g'
|
||||
|
||||
post-extract:
|
||||
${CAT} ${FILESDIR}/site.h >> ${WRKSRC}/includes/site.h
|
||||
|
||||
pre-configure:
|
||||
${SED} \
|
||||
-e 's|@@CC@@|${CC:Q}|g' \
|
||||
-e 's|@@CFLAGS@@|${CFLAGS:Q}|g' \
|
||||
-e 's|@@VARBASE@@|${VARBASE}|g' \
|
||||
-e 's|@@SYSCONFDIR@@|${PKG_SYSCONFDIR}|g' \
|
||||
-e 's|@@PREFIX@@|${PREFIX}|g' \
|
||||
-e 's|@@PKGMANDIR@@|${PKGMANDIR}|g' \
|
||||
${FILESDIR}/site.conf >> ${WRKSRC}/site.conf
|
||||
|
||||
do-install:
|
||||
. for d in ${SUBDIR}
|
||||
cd ${WRKSRC}/work.`${WRKSRC}/configure --print-sysname`/${d} \
|
||||
&& ${SETENV} ${MAKE_ENV} ${MAKE} install
|
||||
. endfor
|
||||
|
||||
. for m in ${MAN_FILES}
|
||||
${CHMOD} ${MANMODE} ${PREFIX}/${PKGMANDIR}/${m}
|
||||
. endfor
|
23
isc-dhcp/PLIST
Normal file
23
isc-dhcp/PLIST
Normal file
|
@ -0,0 +1,23 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
include/isc-dhcp/boolean.h
|
||||
include/isc-dhcp/dst.h
|
||||
include/isc-dhcp/int.h
|
||||
include/isc-dhcp/lang.h
|
||||
include/isc-dhcp/list.h
|
||||
include/isc-dhcp/result.h
|
||||
include/isc-dhcp/types.h
|
||||
include/omapip/alloc.h
|
||||
include/omapip/buffer.h
|
||||
include/omapip/convert.h
|
||||
include/omapip/hash.h
|
||||
include/omapip/omapip.h
|
||||
include/omapip/omapip_p.h
|
||||
include/omapip/trace.h
|
||||
include/omapip/trace_mr.h
|
||||
lib/libdst.a
|
||||
man/man5/dhcp-eval.5
|
||||
man/man5/dhcp-options.5
|
||||
share/doc/isc-dhcp-base/README
|
||||
@dirrm share/doc/isc-dhcp-base
|
||||
@dirrm include/isc-dhcp
|
||||
@dirrm include/omapip
|
4
isc-dhcp/TODO
Normal file
4
isc-dhcp/TODO
Normal file
|
@ -0,0 +1,4 @@
|
|||
set up patch for NetBSD, like:
|
||||
includes/cf/netbsd.h
|
||||
and common/bpf.c and common/fddi.c to use NETBSD_FDDI
|
||||
(see NetBSD's /usr/src/dist/dhcp)
|
8
isc-dhcp/distinfo
Normal file
8
isc-dhcp/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
|
||||
SHA1 (dhcp-3.0.6.tar.gz) = 204e509580d57d0cfff23529274612ca8c710efb
|
||||
RMD160 (dhcp-3.0.6.tar.gz) = 6b7dbad413f83f9bce4ed92a8abc60394a06c6ad
|
||||
Size (dhcp-3.0.6.tar.gz) = 891513 bytes
|
||||
SHA1 (patch-ab) = e5d0a682c0228ce1c63533fe361f5649d5dd2c17
|
||||
SHA1 (patch-ac) = 14f834431c1cb97d0b9c11ae43abc7b758bac923
|
||||
SHA1 (patch-ad) = bd10d5f519065ecbd061f3ccff6685c390a1118a
|
33
isc-dhcp/files/isc_dhclient.sh
Executable file
33
isc-dhcp/files/isc_dhclient.sh
Executable file
|
@ -0,0 +1,33 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: isc_dhclient.sh,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
#
|
||||
|
||||
# PROVIDE: dhclient
|
||||
# REQUIRE: network mountcritlocal
|
||||
# BEFORE: NETWORKING
|
||||
#
|
||||
# Note that there no syslog logging of dhclient messages at boot because
|
||||
# dhclient needs to start before services that syslog depends upon do.
|
||||
#
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="dhclient"
|
||||
rcvar="isc_dhclient"
|
||||
command="@PREFIX@/sbin/${name}"
|
||||
pidfile="@VARBASE@/run/isc-dhcp/${name}.pid"
|
||||
start_precmd="isc_dhclient_precmd"
|
||||
|
||||
isc_dhclient_precmd()
|
||||
{
|
||||
if [ ! -d @VARBASE@/run/isc-dhcp ]; then
|
||||
@MKDIR@ @VARBASE@/run/isc-dhcp
|
||||
@CHMOD@ 0770 @VARBASE@/run/isc-dhcp
|
||||
fi
|
||||
}
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
35
isc-dhcp/files/isc_dhcpd.sh
Executable file
35
isc-dhcp/files/isc_dhcpd.sh
Executable file
|
@ -0,0 +1,35 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: isc_dhcpd.sh,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
#
|
||||
|
||||
# PROVIDE: dhcpd
|
||||
# REQUIRE: DAEMON
|
||||
# BEFORE: LOGIN
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="dhcpd"
|
||||
rcvar="isc_dhcpd"
|
||||
command="@PREFIX@/sbin/${name}"
|
||||
pidfile="@VARBASE@/run/isc-dhcp/${name}.pid"
|
||||
required_files="@PKG_SYSCONFDIR@/dhcp/${name}.conf @DHCP_HOME@/${name}.leases"
|
||||
start_precmd="isc_dhcpd_precmd"
|
||||
|
||||
isc_dhcpd_precmd()
|
||||
{
|
||||
if [ ! -d @VARBASE@/run/isc-dhcp ]; then
|
||||
@MKDIR@ @VARBASE@/run/isc-dhcp
|
||||
@CHMOD@ 0770 @VARBASE@/run/isc-dhcp
|
||||
fi
|
||||
|
||||
if [ ! -f @DHCP_HOME@/dhcpd.leases ]; then
|
||||
@TOUCH@ @DHCP_HOME@/dhcpd.leases
|
||||
@CHMOD@ 0640 @DHCP_HOME@/dhcpd.leases
|
||||
fi
|
||||
}
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
33
isc-dhcp/files/isc_dhcrelay.sh
Executable file
33
isc-dhcp/files/isc_dhcrelay.sh
Executable file
|
@ -0,0 +1,33 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: isc_dhcrelay.sh,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
#
|
||||
|
||||
# PROVIDE: dhcrelay
|
||||
# REQUIRE: DAEMON
|
||||
# BEFORE: NETWORKING
|
||||
#
|
||||
# Note that there no syslog logging of dhclient messages at boot because
|
||||
# dhclient needs to start before services that syslog depends upon do.
|
||||
#
|
||||
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
name="dhcrelay"
|
||||
rcvar="isc_dhcrelay"
|
||||
command="@PREFIX@/sbin/${name}"
|
||||
pidfile="@VARBASE@/run/isc-dhcp/${name}.pid"
|
||||
start_precmd="isc_dhcrelay_precmd"
|
||||
|
||||
isc_dhcrelay_precmd()
|
||||
{
|
||||
if [ ! -d @VARBASE@/run/isc-dhcp ]; then
|
||||
@MKDIR@ @VARBASE@/run/isc-dhcp
|
||||
@CHMOD@ 0770 @VARBASE@/run/isc-dhcp
|
||||
fi
|
||||
}
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
24
isc-dhcp/files/site.conf
Normal file
24
isc-dhcp/files/site.conf
Normal file
|
@ -0,0 +1,24 @@
|
|||
CC = @@CC@@
|
||||
CC_OPTIONS = @@CFLAGS@@
|
||||
USERBINDIR = @@PREFIX@@/bin
|
||||
BINDIR = @@PREFIX@@/sbin
|
||||
CLIENTBINDIR = @@PREFIX@@/sbin
|
||||
ADMMANDIR = @@PREFIX@@/@@PKGMANDIR@@/man8
|
||||
FFMANDIR = @@PREFIX@@/@@PKGMANDIR@@/man5
|
||||
LIBMANDIR = @@PREFIX@@/@@PKGMANDIR@@/man3
|
||||
USRMANDIR = @@PREFIX@@/@@PKGMANDIR@@/man1
|
||||
ADMMANEXT = .8
|
||||
FFMANEXT = .5
|
||||
LIBMANEXT = .3
|
||||
USRMANEXT = .1
|
||||
MANCAT = man
|
||||
#ADMMANDIR = @@PREFIX@@/@@PKGMANDIR@@/cat8
|
||||
#FFMANDIR = @@PREFIX@@/@@PKGMANDIR@@/cat5
|
||||
#LIBMANDIR = @@PREFIX@@/@@PKGMANDIR@@/cat3
|
||||
#USRMANDIR = @@PREFIX@@/@@PKGMANDIR@@/cat1
|
||||
ETC = @@SYSCONFDIR@@
|
||||
RRUN = @@VARBASE@@/run/isc-dhcp
|
||||
VARDB = @@VARBASE@@/db/isc-dhcp
|
||||
LIBDIR = @@PREFIX@@/lib
|
||||
INCDIR = @@PREFIX@@/include
|
||||
CLIENT_PATH = '"PATH=@@PREFIX@@/bin:@@PREFIX@@/sbin:/usr/ucb:/usr/bin:/usr/sbin:/bin:/sbin"'
|
6
isc-dhcp/files/site.h
Normal file
6
isc-dhcp/files/site.h
Normal file
|
@ -0,0 +1,6 @@
|
|||
#define _PATH_DHCPD_CONF "@@SYSCONFDIR@@/dhcp/dhcpd.conf"
|
||||
#define _PATH_DHCPD_PID "@@VARBASE@@/run/isc-dhcp/isc-dhcpd.pid"
|
||||
#define _PATH_DHCPD_DB "@@VARBASE@@/db/isc-dhcp/dhcpd.leases"
|
||||
#define _PATH_DHCLIENT_DB "@@VARBASE@@/db/isc-dhcp/dhclient.leases"
|
||||
#define _PATH_DHCLIENT_SCRIPT "@@PREFIX@@/sbin/dhclient-script"
|
||||
#define DHCPD_LOG_FACILITY LOG_LOCAL@@DHCP_SYSLOG_LEVEL@@
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ab,v 1.2 2006/08/15 18:22:18 ondratu Exp $
|
||||
$NetBSD: patch-ab,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
|
||||
--- configure.orig 2004-09-10 23:02:30.000000000 +0200
|
||||
+++ configure
|
38
isc-dhcp/patches/patch-ac
Normal file
38
isc-dhcp/patches/patch-ac
Normal file
|
@ -0,0 +1,38 @@
|
|||
$NetBSD: patch-ac,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
|
||||
--- minires/res_send.c.orig 2004-06-10 18:59:44.000000000 +0100
|
||||
+++ minires/res_send.c
|
||||
@@ -80,15 +80,4 @@ static const char rcsid[] = "$Id: res_se
|
||||
#endif /* LIBC_SCCS and not lint */
|
||||
|
||||
-/* Rename the I/O functions in case we're tracing. */
|
||||
-#define send trace_mr_send
|
||||
-#define recvfrom trace_mr_recvfrom
|
||||
-#define read trace_mr_read
|
||||
-#define connect trace_mr_connect
|
||||
-#define socket trace_mr_socket
|
||||
-#define bind trace_mr_bind
|
||||
-#define close trace_mr_close
|
||||
-#define select trace_mr_select
|
||||
-#define time trace_mr_time
|
||||
-
|
||||
/*
|
||||
* Send query to name server and wait for reply.
|
||||
@@ -112,5 +101,17 @@ static const char rcsid[] = "$Id: res_se
|
||||
#include <unistd.h>
|
||||
|
||||
+/* Rename the I/O functions in case we're tracing. */
|
||||
+#define send trace_mr_send
|
||||
+#define recvfrom trace_mr_recvfrom
|
||||
+#define read trace_mr_read
|
||||
+#define connect trace_mr_connect
|
||||
+#define socket trace_mr_socket
|
||||
+#define bind trace_mr_bind
|
||||
+#define close trace_mr_close
|
||||
+#define select trace_mr_select
|
||||
+#define time trace_mr_time
|
||||
+
|
||||
#include "minires/minires.h"
|
||||
+#include "omapip/trace_mr.h"
|
||||
#include "arpa/nameser.h"
|
||||
|
18
isc-dhcp/patches/patch-ad
Normal file
18
isc-dhcp/patches/patch-ad
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-ad,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
|
||||
--- /dev/null 2007-11-18 12:32:58.000000000 +0000
|
||||
+++ includes/omapip/trace_mr.h 2007-11-18 12:35:30.000000000 +0000
|
||||
@@ -0,0 +1,13 @@
|
||||
+ssize_t trace_mr_send (int, const void *, size_t, int);
|
||||
+ssize_t trace_mr_read_playback (struct sockaddr_in *, void *, size_t);
|
||||
+void trace_mr_read_record (struct sockaddr_in *, void *, ssize_t);
|
||||
+ssize_t trace_mr_recvfrom (int s, void *, size_t, int,
|
||||
+ struct sockaddr *, SOCKLEN_T *);
|
||||
+ssize_t trace_mr_read (int, void *, size_t);
|
||||
+int trace_mr_connect (int s, struct sockaddr *, SOCKLEN_T);
|
||||
+int trace_mr_socket (int, int, int);
|
||||
+int trace_mr_bind (int, struct sockaddr *, SOCKLEN_T);
|
||||
+int trace_mr_close (int);
|
||||
+time_t trace_mr_time (time_t *);
|
||||
+int trace_mr_select (int, fd_set *, fd_set *, fd_set *, struct timeval *);
|
||||
+unsigned int trace_mr_res_randomid (unsigned int);
|
|
@ -1,11 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.2 2003/12/06 08:47:54 jeremy-c-reed Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2007/12/02 18:34:10 adrian_p Exp $
|
||||
#
|
||||
|
||||
ISC_DHCP_TYPE= dhcpd
|
||||
COMMENT= ISC Dynamic Host Configuration Protocol (DHCP) Server
|
||||
COMPONENT= server
|
||||
SUBDIR= omapip dhcpctl server
|
||||
|
||||
COMMENT= ISC Dynamic Host Configuration Protocol (DHCP) Server
|
||||
CONF_FILES+= ${EGDIR}/dhcpd.conf ${PKG_SYSCONFDIR}/dhcpd.conf
|
||||
|
||||
CONFLICTS= cmu-dhcpd-[0-9]* # same manual page filenames
|
||||
DEPENDS+= isc-dhcp-base-3.0.6:../../wip/isc-dhcp
|
||||
|
||||
.include "../../wip/isc-dhcpd/Makefile.common"
|
||||
RCD_SCRIPTS= isc_dhcpd
|
||||
MAN_FILES= man1/omshell.1 man3/dhcpctl.3 man3/omapi.3 man3/omshell.3 \
|
||||
man5/dhcpd.conf.5 man5/dhcpd.leases.5 man8/dhcpd.8
|
||||
FILES_SUBST+= DHCP_HOME=${DHCP_HOME}
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/server/dhcpd.conf ${EGDIR}
|
||||
|
||||
.include "../../wip/isc-dhcp/Makefile.common"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,43 +0,0 @@
|
|||
# $NetBSD: Makefile.common,v 1.8 2006/08/15 18:22:18 ondratu Exp $
|
||||
#
|
||||
|
||||
DISTNAME= dhcp-3.0.4
|
||||
DHCP_VERSION= 3.0.4
|
||||
PKGNAME= isc-${ISC_DHCP_TYPE}-${DHCP_VERSION}
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.isc.org/isc/dhcp/ \
|
||||
http://archive.progeny.com/isc/dhcp/ \
|
||||
ftp://ftp.freenet.de/pub/ftp.isc.org/isc/dhcp/ \
|
||||
ftp://ftp2.tw.freebsd.org/isc/dhcp/ \
|
||||
http://public.planetmirror.com/pub/isc/dhcp/
|
||||
|
||||
MAINTAINER= reed@reedmedia.net
|
||||
HOMEPAGE= http://www.isc.org/sw/dhcp/
|
||||
|
||||
# XXX don't need nroff once patched
|
||||
# XXX BUILD_DEPENDS+= groff-[0-9]*:../../textproc/groff
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
|
||||
FILESDIR= ${.CURDIR}/../isc-dhcpd/files
|
||||
|
||||
RCD_SCRIPTS= isc_${ISC_DHCP_TYPE}
|
||||
|
||||
pre-configure:
|
||||
@${SED} \
|
||||
-e "s|@@CC@@|${CC}|g" \
|
||||
-e "s|@@CFLAGS@@|${CFLAGS}|g" \
|
||||
-e "s|@@VARBASE@@|${VARBASE}|g" \
|
||||
-e "s|@@SYSCONFDIR@@|${PKG_SYSCONFDIR}|g" \
|
||||
-e "s|@@PREFIX@@|${PREFIX}|g" \
|
||||
-e "s|@@PKGMANDIR@@|${PKGMANDIR}|g" \
|
||||
${FILESDIR}/site.conf >> ${WRKSRC}/site.conf
|
||||
@${SED} \
|
||||
-e "s|@@VARBASE@@|${VARBASE}|g" \
|
||||
-e "s|@@SYSCONFDIR@@|${PKG_SYSCONFDIR}|g" \
|
||||
-e "s|@@PREFIX@@|${PREFIX}|g" \
|
||||
${FILESDIR}/site.h >> ${WRKSRC}/includes/site.h
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/isc-${ISC_DHCP_TYPE}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/isc-${ISC_DHCP_TYPE}
|
|
@ -1,32 +1,15 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 2005/05/02 20:33:59 jeremy-c-reed Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 2007/12/02 18:34:10 adrian_p Exp $
|
||||
bin/omshell
|
||||
include/dhcpctl.h
|
||||
include/isc-dhcp/boolean.h
|
||||
include/isc-dhcp/dst.h
|
||||
include/isc-dhcp/int.h
|
||||
include/isc-dhcp/lang.h
|
||||
include/isc-dhcp/list.h
|
||||
include/isc-dhcp/result.h
|
||||
include/isc-dhcp/types.h
|
||||
include/omapip/alloc.h
|
||||
include/omapip/buffer.h
|
||||
include/omapip/omapip.h
|
||||
lib/libdhcpctl.a
|
||||
lib/libomapi.a
|
||||
man/man1/omshell.1
|
||||
man/man3/dhcpctl.3
|
||||
man/man3/omapi.3
|
||||
man/man3/omshell.3
|
||||
man/man5/dhcp-eval.5
|
||||
man/man5/dhcp-options.5
|
||||
man/man5/dhcpd.conf.5
|
||||
man/man5/dhcpd.leases.5
|
||||
man/man8/dhcpd.8
|
||||
man/man8/dhcrelay.8
|
||||
sbin/dhcpd
|
||||
sbin/dhcrelay
|
||||
share/doc/isc-dhcpd/README
|
||||
share/examples/isc-dhcp-server/dhcpd.conf
|
||||
share/examples/rc.d/isc_dhcpd
|
||||
@dirrm share/doc/isc-dhcpd
|
||||
@dirrm include/omapip
|
||||
@dirrm include/isc-dhcp
|
||||
@dirrm share/examples/isc-dhcp-server
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
set up patch for NetBSD, like:
|
||||
includes/cf/netbsd.h
|
||||
and common/bpf.c and common/fddi.c to use NETBSD_FDDI
|
||||
(see NetBSD's /usr/src/dist/dhcp)
|
||||
|
||||
look at http://www.gentoo.org/cgi-bin/viewcvs.cgi/net-misc/dhcp/
|
||||
should I have a "dhcp" user?
|
||||
chroot?
|
||||
what is paranoia patch?
|
||||
|
||||
Use MAKE_DIRS_PERMS for /var/db/dhcp
|
||||
maybe should be named /var/db/isc-dhcp ?
|
||||
does that conflict with other dhcp?
|
||||
|
||||
should this install shared libraries?
|
||||
|
||||
should this document the libraries/headers in DESCR?
|
||||
|
||||
patch the various Makefile.dist to change all target to use SEDMANPAGES instead
|
||||
(so nroff is not done)
|
||||
|
||||
rc.d script:
|
||||
* make it obey VARBASE setting (should be easy) (mpasternak)
|
||||
* should it use name isc_dhcpd ? perhaps one rc.d script could be used
|
||||
to run dhcpd, with optional dhcpd_type set to different types of dhcpd
|
||||
servers (but, by that time, dhcpd servers should be non conflicting at
|
||||
install) (mpasternak)
|
||||
* _TEST_ isc-dhclient rc.d script - I didn't test it too much ;) (mpasternak)
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.4 2006/08/15 18:22:18 ondratu Exp $
|
||||
$NetBSD: distinfo,v 1.5 2007/12/02 18:34:10 adrian_p Exp $
|
||||
|
||||
SHA1 (dhcp-3.0.4.tar.gz) = 2efe316d69563bf2440cbb4efc2bc06ef9445db3
|
||||
RMD160 (dhcp-3.0.4.tar.gz) = f5636d87e1e2138bd239157f54d8f73c73af73ac
|
||||
Size (dhcp-3.0.4.tar.gz) = 883245 bytes
|
||||
SHA1 (patch-aa) = 0cf59ab20985f0bf96f4603bd1aa139fa85f1c19
|
||||
SHA1 (patch-ab) = e5d0a682c0228ce1c63533fe361f5649d5dd2c17
|
||||
SHA1 (dhcp-3.0.6.tar.gz) = 204e509580d57d0cfff23529274612ca8c710efb
|
||||
RMD160 (dhcp-3.0.6.tar.gz) = 6b7dbad413f83f9bce4ed92a8abc60394a06c6ad
|
||||
Size (dhcp-3.0.6.tar.gz) = 891513 bytes
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2006/08/15 18:22:18 ondratu Exp $
|
||||
|
||||
--- Makefile.dist.orig 2006-08-15 19:09:12.000000000 +0200
|
||||
+++ Makefile.dist
|
||||
@@ -22,7 +22,7 @@
|
||||
# http://www.isc.org/
|
||||
|
||||
|
||||
-SUBDIRS= common $(MINIRES) dst omapip server client relay dhcpctl
|
||||
+SUBDIRS= common $(MINIRES) dst omapip server relay dhcpctl
|
||||
|
||||
all:
|
||||
@for dir in ${SUBDIRS}; do \
|
7
isc-dhcrelay/DESCR
Normal file
7
isc-dhcrelay/DESCR
Normal file
|
@ -0,0 +1,7 @@
|
|||
This package provides the ISC Dynamic Host Configuration Protocol (DHCP)
|
||||
Client.
|
||||
|
||||
The Internet Software Consortium DHCP Client, dhclient, provides
|
||||
a means for configuring one or more network interfaces using DHCP
|
||||
or BOOTP, or by statically assigning an address (if these protocols
|
||||
fail). The actual network configuration is done by dhclient-script.
|
15
isc-dhcrelay/Makefile
Normal file
15
isc-dhcrelay/Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: Makefile,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
#
|
||||
|
||||
COMMENT= ISC Dynamic Host Configuration Protocol (DHCP) Relay
|
||||
COMPONENT= relay
|
||||
SUBDIR= relay
|
||||
|
||||
DEPENDS+= isc-dhcp-base-3.0.6:../../wip/isc-dhcp
|
||||
|
||||
RCD_SCRIPTS= isc_dhcrelay
|
||||
MAN_FILES= man8/dhcrelay.8
|
||||
FILES_SUBST+= DHCP_HOME=${DHCP_HOME}
|
||||
|
||||
.include "../../wip/isc-dhcp/Makefile.common"
|
||||
.include "../../mk/bsd.pkg.mk"
|
4
isc-dhcrelay/PLIST
Normal file
4
isc-dhcrelay/PLIST
Normal file
|
@ -0,0 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
man/man8/dhcrelay.8
|
||||
sbin/dhcrelay
|
||||
share/examples/rc.d/isc_dhcrelay
|
5
isc-dhcrelay/distinfo
Normal file
5
isc-dhcrelay/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1 2007/12/02 18:34:10 adrian_p Exp $
|
||||
|
||||
SHA1 (dhcp-3.0.6.tar.gz) = 204e509580d57d0cfff23529274612ca8c710efb
|
||||
RMD160 (dhcp-3.0.6.tar.gz) = 6b7dbad413f83f9bce4ed92a8abc60394a06c6ad
|
||||
Size (dhcp-3.0.6.tar.gz) = 891513 bytes
|
Loading…
Reference in a new issue