(pkgsrc)
Makefile Bump version 2.99.2 to 2.99.3 patches/patch-lisp_tc-recover.el New file. Only for building on Emacs21-22 to provide the function coding-system-from-name patches/patch-BATCH-SORT load above created new function patches/patch-lisp_eelll.el Fix char width - (insert " ") <--- two byte char whited out + (insert " ") <--- two byte char whited out Fix for obsolete function: - (insert (char-to-string last-command-char))) + (insert (char-to-string last-command-event))) patches/patch-etc_Makefile.am Fix typo on comment line
This commit is contained in:
parent
97e8c4979b
commit
b98106b3e3
5 changed files with 87 additions and 6 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.3 2013/11/22 08:30:18 makoto Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2013/12/15 14:21:09 makoto Exp $
|
||||
|
||||
DISTNAME= tc-2.99.2
|
||||
DISTNAME= tc-2.99.3
|
||||
PKGNAME= ${EMACS_PKGNAME_PREFIX}${DISTNAME}
|
||||
CATEGORIES= inputmethod
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.4 2013/11/22 08:30:18 makoto Exp $
|
||||
$NetBSD: distinfo,v 1.5 2013/12/15 14:21:09 makoto Exp $
|
||||
|
||||
SHA1 (patch-BATCH-SORT) = 64a390e3ca3b5031941b45489a155da67e4e59df
|
||||
SHA1 (patch-BATCH-SORT) = fed628d0f512638934ca16b4b7d0906d4be650c9
|
||||
SHA1 (patch-bushu-util_bushu2canna) = 9573de81b6f9ef7a225fc954b618f7905e648821
|
||||
SHA1 (patch-bushu-util_where) = 07bd3faf178ef57b9cc0afae20f56dbf83cc1d6d
|
||||
SHA1 (patch-configure.ac) = 4174e3674e2cc7dbb6daf5de56fa76f24273edf9
|
||||
|
@ -9,7 +9,9 @@ SHA1 (patch-etc_Makefile.in) = 5d17622136ce9960dcc5dc43f4763d3e315241b1
|
|||
SHA1 (patch-etc_bushu.rev) = 53259ef27da2b3e57ff9834957c8ee9b2fe4f833
|
||||
SHA1 (patch-lisp_Makefile.am) = b80c93ae0ed60e8816a7cae452f5d300d9964781
|
||||
SHA1 (patch-lisp_Makefile.in) = 1bf559a29f2b186fa274fc5d7ce4289e6f6c3ba8
|
||||
SHA1 (patch-lisp_eelll.el) = c0fbebc9bfd444eadf5ff183978f618d961bbd8e
|
||||
SHA1 (patch-lisp_tc-pre.el) = 200e958583bfb162df6e57d45d06289813d4cdda
|
||||
SHA1 (patch-lisp_tc-recover.el) = 8426353463fb59723597604e1cbbda30c635ee5a
|
||||
SHA1 (patch-lisp_tc-sysdep.el) = c55322a844fe8a055c3274d5e392918ea360c9e0
|
||||
SHA1 (patch-mazegaki_Makefile.am) = ee718aa68c9947f1a923dcad4211314ae219b0ce
|
||||
SHA1 (patch-mazegaki_mkcertain.pl) = d2b525316863aee93d2072b094adc45aba0fc55a
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-BATCH-SORT,v 1.1 2013/01/22 13:54:22 makoto Exp $
|
||||
$NetBSD: patch-BATCH-SORT,v 1.2 2013/12/15 14:21:09 makoto Exp $
|
||||
|
||||
New file for the function batch-sort-file,
|
||||
for sorting data file in Emacs internal code order
|
||||
|
@ -6,7 +6,7 @@ from shell batch execution.
|
|||
|
||||
--- BATCH-SORT.orig 2012-04-12 23:11:23.000000000 +0900
|
||||
+++ BATCH-SORT 2012-04-12 23:16:56.000000000 +0900
|
||||
@@ -0,0 +1,44 @@
|
||||
@@ -0,0 +1,45 @@
|
||||
+;;; -*- emacs-lisp -*-
|
||||
+;;; BATCH-SORT ---
|
||||
+
|
||||
|
@ -33,6 +33,7 @@ from shell batch execution.
|
|||
+;;; Code:
|
||||
+(provide 'batch-sort-file)
|
||||
+
|
||||
+(load-file "../lisp/tc-recover.el") ; only for this compile
|
||||
+(defun batch-sort-file ( )
|
||||
+ "Just sort file, important thing is: done by emacs internal code order"
|
||||
+ (interactive)
|
||||
|
|
24
tc-git/patches/patch-lisp_eelll.el
Normal file
24
tc-git/patches/patch-lisp_eelll.el
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-lisp_eelll.el,v 1.1 2013/12/15 14:21:09 makoto Exp $
|
||||
|
||||
Replace obsolete variable
|
||||
|
||||
--- lisp/eelll.el.orig 2013-12-15 14:31:48.000000000 +0900
|
||||
+++ lisp/eelll.el 2013-12-15 15:06:25.000000000 +0900
|
||||
@@ -361,7 +361,7 @@
|
||||
(setq j (1+ j) k 0)
|
||||
(while (< k 5)
|
||||
(setq k (1+ k))
|
||||
- (insert "¡¾¡¾¡¾¡¾¡¾ ")
|
||||
+ (insert "°ì°ì°ì°ì°ì ")
|
||||
(if (= k c) (insert " ")))
|
||||
(delete-horizontal-space)
|
||||
(insert "\n"))
|
||||
@@ -1000,7 +1000,7 @@
|
||||
(interactive)
|
||||
(save-excursion
|
||||
(set-buffer " *eelll: strokes*")
|
||||
- (insert (char-to-string last-command-char)))
|
||||
+ (insert (char-to-string last-command-event)))
|
||||
(if eelll-move-cursor
|
||||
(insert " ")))
|
||||
|
54
tc-git/patches/patch-lisp_tc-recover.el
Normal file
54
tc-git/patches/patch-lisp_tc-recover.el
Normal file
|
@ -0,0 +1,54 @@
|
|||
$NetBSD: patch-lisp_tc-recover.el,v 1.1 2013/12/15 14:21:09 makoto Exp $
|
||||
|
||||
Fix following problem
|
||||
Emacs-20 (20.7) -> Symbol's function definition is void: coding-system-from-name
|
||||
Emacs-21 (21.4) -> Symbol's function definition is void: coding-system-from-name
|
||||
Emacs-22 (22.3) -> Symbol's function definition is void: coding-system-from-name
|
||||
This file is used only when byte compile of BATCH-SORT, and not to be installed.
|
||||
|
||||
--- /dev/null 2013-12-15 21:37:29.000000000 +0900
|
||||
+++ lisp/tc-recover.el 2013-12-15 21:42:13.000000000 +0900
|
||||
@@ -0,0 +1,43 @@
|
||||
+;; tc-recover.el
|
||||
+;; For Emacs-23.0-Versions before 2009-01-27.
|
||||
+;; CVSWeb URLs:
|
||||
+;; http://cvs.savannah.gnu.org/viewcvs/emacs/lisp/international/mule-cmds.el?cvsroot=emacs&r1=1.355&r2=1.356
|
||||
+(when (not (and (fboundp 'canonicalize-coding-system-name)
|
||||
+ (fboundp 'coding-system-from-name)))
|
||||
+ ;; Canonicalize the coding system name NAME by removing some prefixes
|
||||
+ ;; and delimiter characters. Support function of
|
||||
+ ;; coding-system-from-name.
|
||||
+ (defun canonicalize-coding-system-name (name)
|
||||
+ (if (string-match "^iso[-_ ]?[0-9]" name)
|
||||
+ ;; "iso-8859-1" -> "8859-1", "iso-2022-jp" ->"2022-jp"
|
||||
+ (setq name (substring name (1- (match-end 0)))))
|
||||
+ (let ((idx (string-match "[-_ /]" name)))
|
||||
+ ;; Delete "-", "_", " ", "/" but do distinguish "16-be" and "16be".
|
||||
+ (while idx
|
||||
+ (if (and (>= idx 2)
|
||||
+ (eq (string-match "16-[lb]e$" name (- idx 2))
|
||||
+ (- idx 2)))
|
||||
+ (setq idx (string-match "[-_ /]" name (match-end 0)))
|
||||
+ (setq name (concat (substring name 0 idx) (substring name (1+ idx)))
|
||||
+ idx (string-match "[-_ /]" name idx))))
|
||||
+ name))
|
||||
+
|
||||
+ (defun coding-system-from-name (name)
|
||||
+ "Return a coding system whose name matches with NAME (string or symbol)."
|
||||
+ (let (sym)
|
||||
+ (if (stringp name) (setq sym (intern name))
|
||||
+ (setq sym name name (symbol-name name)))
|
||||
+ (if (coding-system-p sym)
|
||||
+ sym
|
||||
+ (let ((eol-type
|
||||
+ (if (string-match "-\\(unix\\|dos\\|mac\\)$" name)
|
||||
+ (prog1 (intern (match-string 1 name))
|
||||
+ (setq name (substring name 0 (match-beginning 0)))))))
|
||||
+ (setq name (canonicalize-coding-system-name (downcase name)))
|
||||
+ (catch 'tag
|
||||
+ (dolist (elt (coding-system-list))
|
||||
+ (if (string= (canonicalize-coding-system-name (symbol-name elt))
|
||||
+ name)
|
||||
+ (throw 'tag (if eol-type (coding-system-change-eol-conversion
|
||||
+ elt eol-type)
|
||||
+ elt))))))))))
|
Loading…
Reference in a new issue