Add another Makefile.in patch to work around broken automake handling of

nobase_foo_DATA lines with subdirectories (it doesn't mkdir -p them).
This commit is contained in:
Greg Troxel 2004-10-20 22:13:04 +00:00 committed by Thomas Klausner
parent f9bd07f516
commit ba358d1402
4 changed files with 20 additions and 3 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/10/20 18:16:02 lexort Exp $
# $NetBSD: Makefile,v 1.2 2004/10/20 22:13:04 lexort Exp $
DISTNAME= g-wrap-1.9.3
PKGREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://savannah.nongnu.org/download/g-wrap/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/10/20 18:16:03 lexort Exp $
@comment $NetBSD: PLIST,v 1.2 2004/10/20 22:13:04 lexort Exp $
bin/g-wrap-config
include/ffi.h
include/ffitarget.h
@ -19,6 +19,7 @@ share/guile/site/g-wrap/c-types.scm
share/guile/site/g-wrap/compat.scm
share/guile/site/g-wrap/enumeration.scm
share/guile/site/g-wrap/guile.scm
share/guile/site/g-wrap/guile/ws/standard.scm
share/guile/site/g-wrap/gw-glib-spec.scm
share/guile/site/g-wrap/gw-standard-spec.scm
share/guile/site/g-wrap/gw-wct-spec.scm
@ -30,5 +31,7 @@ share/guile/site/g-wrap/util.scm
share/guile/site/g-wrap/ws/standard.scm
@dirrm share/guile/site/g-wrap/ws
@dirrm share/guile/site/g-wrap/gw
@dirrm share/guile/site/g-wrap/guile/ws
@dirrm share/guile/site/g-wrap/guile
@dirrm share/guile/site/g-wrap
@dirrm include/g-wrap

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2004/10/20 18:16:03 lexort Exp $
$NetBSD: distinfo,v 1.2 2004/10/20 22:13:04 lexort Exp $
SHA1 (g-wrap-1.9.3.tar.gz) = d7b50b3d8d4c97df20141a831f9855119154aba0
Size (g-wrap-1.9.3.tar.gz) = 813945 bytes
SHA1 (patch-aa) = 620c1357a05eb39792c98b1819cbf3d18e542363
SHA1 (patch-ab) = 68ff165ef35d10055dcfb0792c149f92f8638962

12
g-wrap2/patches/patch-ab Normal file
View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1 2004/10/20 22:13:05 lexort Exp $
--- guile/g-wrap/Makefile.in.orig 2004-10-16 12:27:42.000000000 -0400
+++ guile/g-wrap/Makefile.in
@@ -378,6 +378,7 @@ uninstall-info-am:
install-nobase_gwrapmoduleDATA: $(nobase_gwrapmodule_DATA)
@$(NORMAL_INSTALL)
test -z "$(gwrapmoduledir)" || $(mkdir_p) "$(DESTDIR)$(gwrapmoduledir)"
+ test -z "$(gwrapmoduledir)/guile/ws" || $(mkdir_p) "$(DESTDIR)$(gwrapmoduledir)/guile/ws"
@srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
list='$(nobase_gwrapmodule_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \