Unbreak build:

- fix 'test == ...'
- ignore builtin gettext (this package, it seems, requires 0.12)

New feature:
- depend on libusb
This commit is contained in:
Sergey Svishchev 2006-10-27 20:54:28 +00:00 committed by Thomas Klausner
parent 3357da78ae
commit ba373cb20d
3 changed files with 34 additions and 4 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2006/07/16 12:31:12 shattered Exp $
# $NetBSD: Makefile,v 1.3 2006/10/27 20:54:28 shattered Exp $
#
DISTNAME= gnokii-0.6.13
@ -19,10 +19,11 @@ USE_LIBTOOL= yes
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
GNU_CONFIGURE= yes
USE_X11= yes
USE_TOOLS+= gmake
USE_TOOLS+= gmake msgfmt xgettext
USE_BUILTIN.gettext= no
.include "../../mk/pthread.buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/libusb/buildlink3.mk"
.include "../../graphics/xpm/buildlink3.mk"
.include "../../x11/gtk/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2006/07/16 12:31:12 shattered Exp $
$NetBSD: distinfo,v 1.3 2006/10/27 20:54:28 shattered Exp $
SHA1 (gnokii-0.6.13.tar.bz2) = a18719e5bfcaaca6714fd87eb02fe3a77e63c35a
RMD160 (gnokii-0.6.13.tar.bz2) = 4ebda071e05221b904b035a8bd2dc7213a4a005b
@ -6,3 +6,4 @@ Size (gnokii-0.6.13.tar.bz2) = 1543683 bytes
SHA1 (patch-ab) = f0454a4989bc5cede93425d08759607957cac78a
SHA1 (patch-ac) = c9eeac0112b55c0acd55bc2d029a13b2abad1793
SHA1 (patch-ad) = 23050f729b7cd72c721a35004e2f239dd0136e2d
SHA1 (patch-ae) = a1ac0ac96fcb313362b84a2bcb96384b0eb44e1a

28
gnokii/patches/patch-ae Normal file
View file

@ -0,0 +1,28 @@
$NetBSD: patch-ae,v 1.3 2006/10/27 20:54:29 shattered Exp $
--- utils/ppm2nokia.orig 2006-06-18 17:02:00.000000000 +0000
+++ utils/ppm2nokia
@@ -58,9 +58,9 @@ function readline {
}
readline
-if [ "$line" == "P6" ]; then
+if [ "$line" = "P6" ]; then
ppm=true
-elif [ "$line" == "P5" ]; then
+elif [ "$line" = "P5" ]; then
ppm=false
else
echo "ppm2nokia: PPM/PGM marker not found ($line)." >&2
@@ -71,9 +71,9 @@ readline
set -f -- $line
size="${1}x${2}"
pad=$[((($1*$2)+7)/8)*8 - ($1*$2)]
-if [ "$size" == "78x21" ]; then
+if [ "$size" = "78x21" ]; then
hdr='NOL\x00\x01\x00\xF2\x00\x01\x00\x4E\x00\x15\x00\x01\x00\x01\x00\x00\x00'
-elif [ "$size" == "72x14" ]; then
+elif [ "$size" = "72x14" ]; then
hdr='NGG\x00\x01\x00\x48\x00\x0E\x00\x01\x00\x01\x00\x00\x00'
else
echo "ppm2nokia: Invalid size (${size}). Only 78x21 and 72x14 is supported." >&2