Make it install bin/ scripts with PYVERSSUFFIX. Remove TODO.
This commit is contained in:
parent
75c3a29599
commit
bc9e404778
5 changed files with 45 additions and 25 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.12 2004/02/15 05:36:40 mpasternak Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2004/03/29 23:35:41 mpasternak Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ${TWISTED_DISTNAME}
|
||||
|
@ -13,6 +13,8 @@ COMMENT= Framework for writing networked applications
|
|||
USE_BUILDLINK3= yes
|
||||
PY_PATCHPLIST= yes
|
||||
PYDISTUTILSPKG= yes
|
||||
PLIST_SUBST+= PYVERSSUFFIX="-${PYVERSSUFFIX}"
|
||||
MAKE_ENV+= PKGSRC="1" PYVERSSUFFIX="-${PYVERSSUFFIX}"
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 23 22 23pth 22pth
|
||||
|
||||
|
|
|
@ -1,19 +1,19 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2004/02/29 22:30:46 mpasternak Exp $
|
||||
bin/ckeygen
|
||||
bin/conch
|
||||
bin/im
|
||||
bin/lore
|
||||
bin/mailmail
|
||||
bin/manhole
|
||||
bin/mktap
|
||||
bin/t-im
|
||||
bin/tap2deb
|
||||
bin/tapconvert
|
||||
bin/tkconch
|
||||
bin/tkmktap
|
||||
bin/trial
|
||||
bin/twistd
|
||||
bin/websetroot
|
||||
@comment $NetBSD: PLIST,v 1.8 2004/03/29 23:35:41 mpasternak Exp $
|
||||
bin/ckeygen${PYVERSSUFFIX}
|
||||
bin/conch${PYVERSSUFFIX}
|
||||
bin/im${PYVERSSUFFIX}
|
||||
bin/lore${PYVERSSUFFIX}
|
||||
bin/mailmail${PYVERSSUFFIX}
|
||||
bin/manhole${PYVERSSUFFIX}
|
||||
bin/mktap${PYVERSSUFFIX}
|
||||
bin/t-im${PYVERSSUFFIX}
|
||||
bin/tap2deb${PYVERSSUFFIX}
|
||||
bin/tapconvert${PYVERSSUFFIX}
|
||||
bin/tkconch${PYVERSSUFFIX}
|
||||
bin/tkmktap${PYVERSSUFFIX}
|
||||
bin/trial${PYVERSSUFFIX}
|
||||
bin/twistd${PYVERSSUFFIX}
|
||||
bin/websetroot${PYVERSSUFFIX}
|
||||
${PYSITELIB}/twisted/__init__.py
|
||||
${PYSITELIB}/twisted/__init__.pyc
|
||||
${PYSITELIB}/twisted/__init__.pyo
|
||||
|
|
|
@ -1,7 +0,0 @@
|
|||
$Id: TODO,v 1.4 2004/02/29 22:30:46 mpasternak Exp $
|
||||
|
||||
py-twisted should install its binaries (bin/*) with
|
||||
${PYVERSSUFFIX} appended. Like eg. devel/py-checker does. That way
|
||||
py-twisted could be installed for different python versions at the same
|
||||
time.
|
||||
(suggested by recht@netbsd.org)
|
|
@ -1,4 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.6 2004/02/29 22:30:46 mpasternak Exp $
|
||||
$NetBSD: distinfo,v 1.7 2004/03/29 23:35:41 mpasternak Exp $
|
||||
|
||||
SHA1 (Twisted-1.2.0.tar.bz2) = a8112e8d6a78f7f984913f7ca445e96b5dcc796a
|
||||
Size (Twisted-1.2.0.tar.bz2) = 5533436 bytes
|
||||
SHA1 (patch-aa) = c8478bab88d0ade3399bb3bb697020dd3c8ac65c
|
||||
|
|
24
py-twisted/patches/patch-aa
Normal file
24
py-twisted/patches/patch-aa
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-aa,v 1.1 2004/03/29 23:35:42 mpasternak Exp $
|
||||
|
||||
--- setup.py.orig 2004-03-30 01:31:06.000000000 +0200
|
||||
+++ setup.py
|
||||
@@ -51,6 +51,19 @@ class build_scripts_twisted(build_script
|
||||
|
||||
def run(self):
|
||||
build_scripts.run(self)
|
||||
+ # for pkgsrc we install each script with verssuffix, so Twisted
|
||||
+ # can be shared among different Python versions
|
||||
+ if os.getenv("PKGSRC") == "1":
|
||||
+ for f in os.listdir(self.build_dir):
|
||||
+ fpath=os.path.join(self.build_dir, f)
|
||||
+ if not fpath.endswith(os.getenv("PYVERSSUFFIX")):
|
||||
+ try:
|
||||
+ os.unlink(fpath + os.getenv("PYVERSSUFFIX"))
|
||||
+ except EnvironmentError, e:
|
||||
+ if e.args[1]=='No such file or directory':
|
||||
+ pass
|
||||
+ os.rename(fpath, fpath + os.getenv("PYVERSSUFFIX"))
|
||||
+
|
||||
if os.name == "nt":
|
||||
for f in os.listdir(self.build_dir):
|
||||
fpath=os.path.join(self.build_dir, f)
|
Loading…
Reference in a new issue