Use different distfile site (because old mirror was missing).

This changed the distname too.

Check for NetBSD instead of /usr/bin/nroff for depending
on groff.

Add patch-ad and set up Makefile to allow working with db4
(if is BDB_TYPE).

Honor --mandir configure option in patches/patch-ac
so can have custom man directory.
This commit is contained in:
Jeremy C. Reed 2004-05-21 07:27:32 +00:00 committed by Thomas Klausner
parent 6218addb00
commit be840231b5
4 changed files with 44 additions and 12 deletions

View file

@ -1,14 +1,17 @@
# $NetBSD: Makefile,v 1.7 2004/05/14 13:18:46 thomasklausner Exp $ # $NetBSD: Makefile,v 1.8 2004/05/21 07:27:32 jeremy-c-reed Exp $
DISTNAME= man-db-${VERSION} DISTNAME= man-db_${VERSION}.orig
PKGNAME= man-db-${VERSION}
CATEGORIES= misc CATEGORIES= misc
MASTER_SITES= http://savannah.nongnu.org/download/man-db/stable.pkg/${VERSION}/ MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/m/man-db/}
MAINTAINER= reed@reedmedia.net MAINTAINER= reed@reedmedia.net
HOMEPAGE= http://www.chiark.greenend.org.uk/~cjwatson/code/man-db/ HOMEPAGE= http://www.chiark.greenend.org.uk/~cjwatson/code/man-db/
COMMENT= Manual pager and related man page utilities COMMENT= Manual pager and related man page utilities
.if !exists(/usr/bin/nroff) .include "../../mk/bsd.prefs.mk"
.if ${OPSYS} != "NetBSD"
DEPENDS+= groff-[0-9]*:../../textproc/groff DEPENDS+= groff-[0-9]*:../../textproc/groff
.endif .endif
@ -44,7 +47,11 @@ pre-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/man-db ${INSTALL_DATA_DIR} ${PREFIX}/share/examples/man-db
${INSTALL_DATA} ${WRKSRC}/src/man_db.conf ${PREFIX}/share/examples/man-db ${INSTALL_DATA} ${WRKSRC}/src/man_db.conf ${PREFIX}/share/examples/man-db
.include "../../databases/db/buildlink3.mk" USE_DB185= YES
.include "../../devel/gettext-lib/buildlink3.mk" .include "../../mk/bdb.buildlink3.mk"
.if ${BDB_TYPE} != "native"
CONFIGURE_ARGS+= --with-db=${BDB_TYPE}
.endif
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk" .include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.3 2003/10/01 23:52:50 jeremy-c-reed Exp $ $NetBSD: distinfo,v 1.4 2004/05/21 07:27:32 jeremy-c-reed Exp $
SHA1 (man-db-2.4.2.tar.gz) = 2e6ebf1397709648e07c2493571b4165e6a83edc SHA1 (man-db_2.4.2.orig.tar.gz) = 2e6ebf1397709648e07c2493571b4165e6a83edc
Size (man-db-2.4.2.tar.gz) = 730134 bytes Size (man-db_2.4.2.orig.tar.gz) = 730134 bytes
SHA1 (patch-aa) = 99202bb1f378a0bf120284be507c2d87d8968df7 SHA1 (patch-aa) = 99202bb1f378a0bf120284be507c2d87d8968df7
SHA1 (patch-ab) = df42ee19216b7b9de43e252e22688b3d8b8525e8 SHA1 (patch-ab) = df42ee19216b7b9de43e252e22688b3d8b8525e8
SHA1 (patch-ac) = c40b3965734f4ed605628fea2bbaf00f2245ee4a SHA1 (patch-ac) = cf69c4f643d0032ea3eb6f37f34bd85b9750f6e1
SHA1 (patch-ad) = 17ef513b01e1ed165bfc18f9886f10abffeb225b

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ac,v 1.1.1.1 2003/08/20 08:55:21 jeremy-c-reed Exp $ $NetBSD: patch-ac,v 1.2 2004/05/21 07:27:32 jeremy-c-reed Exp $
--- include/manconfig.h.in.orig 2003-04-19 14:40:32.000000000 -0700 --- include/manconfig.h.in.orig 2003-04-19 14:40:32.000000000 -0700
+++ include/manconfig.h.in 2003-04-19 14:40:40.000000000 -0700 +++ include/manconfig.h.in 2003-04-19 14:40:40.000000000 -0700
@ -8,7 +8,7 @@ $NetBSD: patch-ac,v 1.1.1.1 2003/08/20 08:55:21 jeremy-c-reed Exp $
/* FSSTND directories */ /* FSSTND directories */
-#define CAT_ROOT "/var/catman" /* required by fsstnd() */ -#define CAT_ROOT "/var/catman" /* required by fsstnd() */
-#define MAN_ROOT "/usr" /* required by fsstnd() */ -#define MAN_ROOT "/usr" /* required by fsstnd() */
+#define CAT_ROOT "@prefix@/man" +#define CAT_ROOT "@mandir@"
+#define MAN_ROOT "@prefix@" +#define MAN_ROOT "@prefix@"
/* FHS directories */ /* FHS directories */
#define FHS_CAT_ROOT "/var/cache/man" /* required by fsstnd() */ #define FHS_CAT_ROOT "/var/cache/man" /* required by fsstnd() */

24
man-db/patches/patch-ad Normal file
View file

@ -0,0 +1,24 @@
$NetBSD: patch-ad,v 1.3 2004/05/21 07:27:32 jeremy-c-reed Exp $
--- configure.orig 2003-09-20 04:04:29.000000000 -0700
+++ configure
@@ -10737,8 +10737,8 @@ fi
fi
-if test "$db" = "no" || test "$db" = "db3" || test "$db" = "db"; then
-for head in db_185.h db3/db_185.h
+if test "$db" = "no" || test "$db" = "db3" || test "$db" = "db4" || test "$db" = "db"; then
+for head in db4/db_185.h db3/db_185.h db_185.h
do
for ac_header in $head
@@ -10886,7 +10886,7 @@ done
if test "$got" = "yes"
then
- for lib in db3
+ for lib in db4 db3
do
as_man_tr_bdb=`echo "man_cv_bdb_header_${head}_lib_${lib}" | $as_tr_sh`
man_saved_LIBS="$LIBS"