Resolve import conflicts by clobbering with contents from vendor branch.

This commit is contained in:
Todd Vierling 2005-08-19 16:38:26 +00:00 committed by Thomas Klausner
parent c7707159c9
commit bfa8bbee0c
7 changed files with 236 additions and 0 deletions

3
dovecot/DESCR Normal file
View file

@ -0,0 +1,3 @@
Dovecot is a secure and compact IMAP/POP3 server which is in the early stages
of developement. It supports Maildirs and mbox formats and much of the IMAP
v4 protocol including SSL/TLS. IPv6 support is also included.

51
dovecot/Makefile Normal file
View file

@ -0,0 +1,51 @@
# $NetBSD: Makefile,v 1.13 2005/08/19 16:38:26 tvierling Exp $
DISTNAME= dovecot-1.0.alpha1
PKGNAME= ${DISTNAME:S/1.0.alpha/0.99.99./}
CATEGORIES= mail
MASTER_SITES= http://www.dovecot.org/releases/
MAINTAINER= tv@duh.org
HOMEPAGE= http://www.dovecot.org/
COMMENT= Secure IMAP and POP3 server
PKG_INSTALLATION_TYPES= overwrite pkgviews
USE_LIBTOOL= yes
USE_PKGINSTALL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
CONFIGURE_ARGS+= --localstatedir=${VARBASE}
CONFIGURE_ARGS+= --with-ssldir=${SSLCERTS}
.include "../../mk/bsd.prefs.mk"
.include "options.mk"
RCD_SCRIPTS= dovecot
DOVECOT_USER?= dovecot
DOVECOT_GROUP?= dovecot
PKG_GROUPS= ${DOVECOT_GROUP}
PKG_USERS= ${DOVECOT_USER}:${DOVECOT_GROUP}::Dovecot\\ IMAP/POP3\\ user
EGDIR= ${PREFIX}/share/examples/dovecot
CONF_FILES= ${EGDIR}/dovecot.conf.default ${PKG_SYSCONFDIR}/dovecot.conf
INSTALLATION_DIRS= libexec/dovecot sbin share/doc/dovecot \
share/examples/dovecot
post-configure:
@cd ${WRKSRC}; \
for i in dovecot-example.conf; do \
${SED} ${FILES_SUBST_SED} $$i > $$i.new; \
${MV} -f $$i.new $$i; \
done
post-install:
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/dovecot-example.conf \
${EGDIR}/dovecot.conf.default
${INSTALL_DATA} ${WRKSRC}/doc/dovecot-* ${EGDIR}
${INSTALL_SCRIPT} ${WRKSRC}/doc/mkcert.sh ${EGDIR}
.include "../../mk/bsd.pkg.mk"

31
dovecot/PLIST Normal file
View file

@ -0,0 +1,31 @@
@comment $NetBSD: PLIST,v 1.7 2005/08/19 16:38:26 tvierling Exp $
libexec/dovecot/checkpassword-reply
libexec/dovecot/deliver
libexec/dovecot/dovecot-auth
libexec/dovecot/imap
libexec/dovecot/imap-login
libexec/dovecot/pop3
libexec/dovecot/pop3-login
libexec/dovecot/rawlog
sbin/dovecot
sbin/dovecotpw
share/doc/dovecot/USE-WIKI-INSTEAD
share/doc/dovecot/auth-protocol.txt
share/doc/dovecot/auth.txt
share/doc/dovecot/configuration.txt
share/doc/dovecot/design.txt
share/doc/dovecot/index.txt
share/doc/dovecot/mail-storages.txt
share/doc/dovecot/multiaccess.txt
share/doc/dovecot/nfs.txt
share/doc/dovecot/securecoding.txt
share/doc/dovecot/variables.txt
share/examples/dovecot/dovecot-ldap.conf
share/examples/dovecot/dovecot-openssl.cnf
share/examples/dovecot/dovecot-sql.conf
share/examples/dovecot/dovecot.conf.default
share/examples/dovecot/mkcert.sh
share/examples/rc.d/dovecot
@dirrm share/examples/dovecot
@dirrm share/doc/dovecot
@dirrm libexec/dovecot

7
dovecot/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.6 2005/08/19 16:38:26 tvierling Exp $
SHA1 (dovecot-1.0.alpha1.tar.gz) = f1ceb0ce6ec44c3add03605c8570a4936fb786b8
RMD160 (dovecot-1.0.alpha1.tar.gz) = b010e59fc637a2c2f3ecea2aaf0ada0fb937c1fd
Size (dovecot-1.0.alpha1.tar.gz) = 1187972 bytes
SHA1 (patch-aa) = acfe710812fef379ae05dedcfe929cf3028fa408
SHA1 (patch-ab) = 65bd8931c288671137d20b0f9a82cf77cf2ad3f6

17
dovecot/files/dovecot.sh Executable file
View file

@ -0,0 +1,17 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: dovecot.sh,v 1.5 2005/08/19 16:38:26 tvierling Exp $
#
# PROVIDE: dovecot
# REQUIRE: DAEMON LOGIN
. /etc/rc.subr
name="dovecot"
rcvar=$name
command="@PREFIX@/sbin/${name}"
required_files="@PKG_SYSCONFDIR@/$name.conf"
load_rc_config $name
run_rc_command "$1"

13
dovecot/patches/patch-aa Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.3 2005/08/19 16:38:26 tvierling Exp $
--- Makefile.in.orig 2005-07-24 22:01:34.000000000 -0400
+++ Makefile.in
@@ -204,7 +204,7 @@ sysconfdir = @sysconfdir@
target_alias = @target_alias@
SUBDIRS = src doc
confdir = $(sysconfdir)
-conf_DATA = dovecot-example.conf
+conf_DATA =
EXTRA_DIST = \
dovecot.spec \
dovecot.spec.in \

114
dovecot/patches/patch-ab Normal file
View file

@ -0,0 +1,114 @@
$NetBSD: patch-ab,v 1.3 2005/08/19 16:38:26 tvierling Exp $
--- dovecot-example.conf.orig 2005-07-22 14:45:01.000000000 -0400
+++ dovecot-example.conf
@@ -6,16 +6,14 @@
# Default values are shown after each value, it's not required to uncomment
# any of the lines. Exception to this are paths, they're just examples
-# with real defaults being based on configure options. The paths listed here
-# are for configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
-# --with-ssldir=/etc/ssl
+# with real defaults being based on configure options.
# Base directory where to store runtime data.
#base_dir = /var/run/dovecot/
# Protocols we want to be serving:
# imap imaps pop3 pop3s
-#protocols = imap imaps
+protocols = imap pop3
# IP or host address where to listen in for connections. It's not currently
# possible to specify multiple addresses. "*" listens in all IPv4 interfaces.
@@ -31,7 +29,7 @@
#ssl_listen =
# Disable SSL/TLS support.
-#ssl_disable = no
+ssl_disable = yes
# PEM encoded X.509 SSL/TLS certificate and private key. They're opened before
# dropping root privileges, so keep the key file unreadable by anyone but
@@ -389,12 +387,12 @@
protocol imap {
# Login executable location.
- #login_executable = /usr/libexec/dovecot/imap-login
+ #login_executable = @PREFIX@/libexec/dovecot/imap-login
# IMAP executable location
- #mail_executable = /usr/libexec/dovecot/imap
+ #mail_executable = @PREFIX@/libexec/dovecot/imap
# This would write rawlogs into ~/dovecot.rawlog/ directory:
- #mail_executable = /usr/libexec/dovecot/rawlog /usr/libexec/dovecot/imap
+ #mail_executable = @PREFIX@/libexec/dovecot/rawlog @PREFIX@/libexec/dovecot/imap
# Maximum IMAP command line length in bytes. Some clients generate very long
# command lines with huge mailboxes, so you may need to raise this if you get
@@ -403,7 +401,7 @@ protocol imap {
# Support for dynamically loadable modules.
#mail_use_modules = no
- #mail_modules = /usr/lib/dovecot/imap
+ #mail_modules = @PREFIX@/lib/dovecot/imap
# Send IMAP capabilities in greeting message. This makes it unnecessary for
# clients to request it with CAPABILITY command, so it saves one round-trip.
@@ -442,10 +440,10 @@ protocol imap {
protocol pop3 {
# Login executable location.
- #login_executable = /usr/libexec/dovecot/pop3-login
+ #login_executable = @PREFIX@/libexec/dovecot/pop3-login
# POP3 executable location
- #mail_executable = /usr/libexec/dovecot/pop3
+ #mail_executable = @PREFIX@/libexec/dovecot/pop3
# Don't try to set mails non-recent or seen with POP3 sessions. This is
# mostly intended to reduce disk I/O. With maildir it doesn't move files
@@ -489,7 +487,7 @@ protocol pop3 {
# Support for dynamically loadable modules.
#mail_use_modules = no
- #mail_modules = /usr/lib/dovecot/pop3
+ #mail_modules = @PREFIX@/lib/dovecot/pop3
# Workarounds for various client bugs:
# outlook-no-nuls:
@@ -506,7 +504,7 @@ protocol pop3 {
##
# Executable location
-#auth_executable = /usr/libexec/dovecot/dovecot-auth
+#auth_executable = @PREFIX@/libexec/dovecot/dovecot-auth
# Set max. process size in megabytes.
#auth_process_size = 256
@@ -573,7 +571,7 @@ auth default {
# Note that PAM can only be used to verify if user's password is correct,
# so it can't be used as userdb. If you don't want to use a separate user
# database (passwd usually), you can use static userdb.
- passdb pam {
+ #passdb pam {
# [-session] [<service name>]
#
# -session makes Dovecot open and immediately close PAM session. Some
@@ -582,13 +580,13 @@ auth default {
# If service name is "*", it means the authenticating service name
# is used, eg. pop3 or imap.
#args = dovecot
- }
+ #}
# /etc/passwd or similar, using getpwnam()
# In many systems nowadays this uses Name Service Switch, which is
# configured in /etc/nsswitch.conf.
- #passdb passwd {
- #}
+ passdb passwd {
+ }
# /etc/shadow or similiar, using getspnam(). Deprecated by PAM nowadays.
#passdb shadow {