Removed the package, as devel/py-game is newer.

This commit is contained in:
Roland Illig 2005-11-04 07:00:31 +00:00 committed by Thomas Klausner
parent 4972aecf30
commit c00f945b38
7 changed files with 0 additions and 160 deletions

View file

@ -1,4 +0,0 @@
Pygame is a set of Python modules designed for writing games. It is written on
top of the excellent SDL library. This allows you to create fully featured
games and multimedia programs in the python language. Pygame is highly
portable and runs on nearly every platform and operating system.

View file

@ -1,25 +0,0 @@
# $NetBSD: Makefile,v 1.9 2005/04/11 21:15:00 tvierling Exp $
#
DISTNAME= pygame-1.6
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/py//}
CATEGORIES= devel
MASTER_SITES= http://pygame.org/ftp/
MAINTAINER= recht@NetBSD.org
HOMEPAGE= http://pygame.org/
COMMENT= Set of Python modules designed for writing games
PY_PATCHPLIST= yes
PYDISTUTILSPKG= yes
PYTHON_VERSIONS_ACCEPTED= 23 22
.include "../../audio/SDL_mixer/buildlink3.mk"
.include "../../devel/SDL_ttf/buildlink3.mk"
.include "../../graphics/SDL_image/buildlink3.mk"
.include "../../lang/python/extension.mk"
.include "../../multimedia/smpeg/buildlink3.mk"
.include "../../math/py-Numeric/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,61 +0,0 @@
@comment $NetBSD: PLIST,v 1.3 2003/11/18 00:54:40 marc Exp $
${PYINC}/pygame/font.h
${PYINC}/pygame/mixer.h
${PYINC}/pygame/pygame.h
${PYSITELIB}/pygame/__init__.py
${PYSITELIB}/pygame/__init__.pyc
${PYSITELIB}/pygame/__init__.pyo
${PYSITELIB}/pygame/base.so
${PYSITELIB}/pygame/cdrom.so
${PYSITELIB}/pygame/color.py
${PYSITELIB}/pygame/color.pyc
${PYSITELIB}/pygame/color.pyo
${PYSITELIB}/pygame/colordict.py
${PYSITELIB}/pygame/colordict.pyc
${PYSITELIB}/pygame/colordict.pyo
${PYSITELIB}/pygame/constants.so
${PYSITELIB}/pygame/cursors.py
${PYSITELIB}/pygame/cursors.pyc
${PYSITELIB}/pygame/cursors.pyo
${PYSITELIB}/pygame/display.so
${PYSITELIB}/pygame/draw.so
${PYSITELIB}/pygame/event.so
${PYSITELIB}/pygame/font.so
${PYSITELIB}/pygame/freesansbold.ttf
${PYSITELIB}/pygame/image.so
${PYSITELIB}/pygame/imageext.so
${PYSITELIB}/pygame/joystick.so
${PYSITELIB}/pygame/key.so
${PYSITELIB}/pygame/locals.py
${PYSITELIB}/pygame/locals.pyc
${PYSITELIB}/pygame/locals.pyo
${PYSITELIB}/pygame/macosx.py
${PYSITELIB}/pygame/macosx.pyc
${PYSITELIB}/pygame/macosx.pyo
${PYSITELIB}/pygame/mixer.so
${PYSITELIB}/pygame/mixer_music.so
${PYSITELIB}/pygame/mouse.so
${PYSITELIB}/pygame/movie.so
${PYSITELIB}/pygame/pygame.ico
${PYSITELIB}/pygame/pygame_icon.bmp
${PYSITELIB}/pygame/pygame_icon.icns
${PYSITELIB}/pygame/pygame_icon.tiff
${PYSITELIB}/pygame/rect.so
${PYSITELIB}/pygame/rwobject.so
${PYSITELIB}/pygame/sndarray.so
${PYSITELIB}/pygame/sprite.py
${PYSITELIB}/pygame/sprite.pyc
${PYSITELIB}/pygame/sprite.pyo
${PYSITELIB}/pygame/surface.so
${PYSITELIB}/pygame/surfarray.so
${PYSITELIB}/pygame/surflock.so
${PYSITELIB}/pygame/sysfont.py
${PYSITELIB}/pygame/sysfont.pyc
${PYSITELIB}/pygame/sysfont.pyo
${PYSITELIB}/pygame/time.so
${PYSITELIB}/pygame/transform.so
${PYSITELIB}/pygame/version.py
${PYSITELIB}/pygame/version.pyc
${PYSITELIB}/pygame/version.pyo
@dirrm ${PYSITELIB}/pygame
@dirrm ${PYINC}/pygame

View file

@ -1,27 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.2 2004/07/27 22:10:33 thomasklausner Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
PY_GAME_BUILDLINK3_MK:= ${PY_GAME_BUILDLINK3_MK}+
.include "../../lang/python/pyversion.mk"
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= ${PYPKGPREFIX}-game
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:N${PYPKGPREFIX}-game}
BUILDLINK_PACKAGES+= ${PYPKGPREFIX}-game
.if !empty(PY_GAME_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.${PYPKGPREFIX}-game+= ${PYPKGPREFIX}-game>=1.6
BUILDLINK_PKGSRCDIR.${PYPKGPREFIX}-game?= ../../wip/py-game
.include "../../audio/SDL_mixer/buildlink3.mk"
.include "../../devel/SDL_ttf/buildlink3.mk"
.include "../../graphics/SDL_image/buildlink3.mk"
.include "../../multimedia/smpeg/buildlink3.mk"
.include "../../math/py-Numeric/buildlink3.mk"
.endif # PY_GAME_BUILDLINK3_MK
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,7 +0,0 @@
$NetBSD: distinfo,v 1.7 2005/03/31 10:55:22 thomasklausner Exp $
SHA1 (pygame-1.6.tar.gz) = 5b99ca0c923917da9fd0ba1b9ead9175b4a7d970
RMD160 (pygame-1.6.tar.gz) = a3f5369a523708cb4581a230a65f6085cb6e9982
Size (pygame-1.6.tar.gz) = 846095 bytes
SHA1 (patch-aa) = 95c909f3ae167d83c235293435eca0286651f045
SHA1 (patch-ab) = 676d63449df3008960f0c3b6728812a1b4ef0912

View file

@ -1,14 +0,0 @@
$NetBSD: patch-aa,v 1.3 2004/01/04 12:54:08 mpasternak Exp $
--- src/draw.c.orig Thu Oct 16 08:13:22 2003
+++ src/draw.c Sun Jan 4 12:54:16 2004
@@ -28,7 +28,9 @@
#ifdef _MSC_VER
#pragma warning (disable:4244)
+#endif
+#if defined(_MSC_VER) || defined(__NetBSD__) || defined (__FreeBSD__)
float trunc(float d)
{
if (d >= 0)

View file

@ -1,22 +0,0 @@
$NetBSD: patch-ab,v 1.1 2003/11/29 05:46:22 mpasternak Exp $
--- src/event.c.orig Sat Nov 29 06:35:03 2003
+++ src/event.c Sat Nov 29 06:35:35 2003
@@ -664,7 +664,7 @@
/*DOC*/ "queue, this will return an event with type NOEVENT.\n"
/*DOC*/ ;
-static PyObject* poll(PyObject* self, PyObject* args)
+static PyObject* pygame_poll(PyObject* self, PyObject* args)
{
SDL_Event event;
@@ -1042,7 +1042,7 @@
{ "pump", pump, 1, doc_pump },
{ "wait", pygame_wait, 1, doc_wait },
- { "poll", poll, 1, doc_poll },
+ { "poll", pygame_poll, 1, doc_poll },
{ "clear", event_clear, 1, doc_event_clear },
{ "get", event_get, 1, doc_event_get },
{ "peek", event_peek, 1, doc_peek },