Initial import of idesk 0.3.5
Idesk was written by Chris Roberts, and his webpage is http://dramamine.darktech.org/~nikon which might be down for a while. Email: nikon@sc.rr.com, ICQ: 63345004 You can find the current updated Idesk webpage at: http://linuxhelp.hn.org/idesk.php, maintained by Ivan (ivan@xpenguin.com). Idesk is released under the BSD license, which means don't call my code yours, and if you use any of my code, give me credit. -- This package works 100% OK. I put two patches, first one is only for NetBSD, and second is to solve a segfault. njoy ;)
This commit is contained in:
parent
34e3d38262
commit
c0b40475cf
7 changed files with 90 additions and 0 deletions
BIN
idesk/.DESCR.swp
Normal file
BIN
idesk/.DESCR.swp
Normal file
Binary file not shown.
9
idesk/DESCR
Normal file
9
idesk/DESCR
Normal file
|
@ -0,0 +1,9 @@
|
|||
Idesk was written by Chris Roberts, and his webpage is
|
||||
http://dramamine.darktech.org/~nikon which might be down for a while.
|
||||
Email: nikon@sc.rr.com, ICQ: 63345004
|
||||
|
||||
You can find the current updated Idesk webpage at:
|
||||
http://linuxhelp.hn.org/idesk.php, maintained by Ivan (ivan@xpenguin.com).
|
||||
|
||||
Idesk is released under the BSD license, which means don't call my code yours,
|
||||
and if you use any of my code, give me credit.
|
19
idesk/Makefile
Normal file
19
idesk/Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/05/07 21:57:00 poppnk Exp $
|
||||
#
|
||||
|
||||
DISTNAME= idesk-0.3.5
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://linuxhelp.hn.org/
|
||||
|
||||
MAINTAINER= pancake@phreaker.net
|
||||
HOMEPAGE= http://linuxhelp.hn.org/idesk.php
|
||||
COMMENT= Show png icons on your desktop
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_X11= yes
|
||||
USE_BUILDLINK2= yes
|
||||
#MAKE_ENV+= PREFIX=${PREFIX}
|
||||
|
||||
.include "../../graphics/imlib/buildlink2.mk"
|
||||
.include "../../fonts/Xft2/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
2
idesk/PLIST
Normal file
2
idesk/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/05/07 21:57:00 poppnk Exp $
|
||||
bin/idesk
|
6
idesk/distinfo
Normal file
6
idesk/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/05/07 21:57:00 poppnk Exp $
|
||||
|
||||
SHA1 (idesk-0.3.5.tar.gz) = 63c34874bdfe640908e1329955d2ec266589cc27
|
||||
Size (idesk-0.3.5.tar.gz) = 7966 bytes
|
||||
SHA1 (patch-aa) = e307e1cb562c27c1578b0d23294b3ea3d7ebafcb
|
||||
SHA1 (patch-ab) = 5b33e9fe8d9d5faff5eb51a0ae9b782c2bab2683
|
33
idesk/patches/patch-aa
Normal file
33
idesk/patches/patch-aa
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/05/07 21:57:04 poppnk Exp $
|
||||
|
||||
*** Desk.cc Sat Nov 9 19:06:16 2002
|
||||
--- Desk2.cc Sun Apr 27 15:44:47 2003
|
||||
***************
|
||||
*** 1,5 ****
|
||||
#include "Desk.h"
|
||||
-
|
||||
Desk::Desk() {
|
||||
Dpy = XOpenDisplay( NULL );
|
||||
Root = DefaultRootWindow( Dpy );
|
||||
--- 1,4 ----
|
||||
***************
|
||||
*** 119,125 ****
|
||||
|
||||
DirName += "/.idesktop/";
|
||||
FileCount = scandir( DirName.c_str(), &Files, 0, alphasort );
|
||||
!
|
||||
for(int i=0; i<FileCount; i++) {
|
||||
FileName = DirName + Files[i]->d_name;
|
||||
IconDb = new Database(FileName);
|
||||
--- 118,128 ----
|
||||
|
||||
DirName += "/.idesktop/";
|
||||
FileCount = scandir( DirName.c_str(), &Files, 0, alphasort );
|
||||
! if( FileCount < 0 ) {
|
||||
! printf("No %s exist please create it and put your *.lnk files\n"
|
||||
! , DirName.c_str() );
|
||||
! exit(-1);
|
||||
! }
|
||||
for(int i=0; i<FileCount; i++) {
|
||||
FileName = DirName + Files[i]->d_name;
|
||||
IconDb = new Database(FileName);
|
21
idesk/patches/patch-ab
Normal file
21
idesk/patches/patch-ab
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/05/07 21:57:04 poppnk Exp $
|
||||
|
||||
--- Makefile 2003-04-27 17:52:39.000000000 +0000
|
||||
+++ Makefile.old 2003-04-27 17:45:24.000000000 +0000
|
||||
@@ -1,6 +1,6 @@
|
||||
cc = g++
|
||||
#cflags = -g -O2 -W -Wall
|
||||
-cflags = -g -O2
|
||||
+cflags = `imlib-config --cflags` `xft-config --cflags` -O3
|
||||
libs = `imlib-config --libs` -lXft
|
||||
bin = idesk
|
||||
|
||||
@@ -17,7 +17,7 @@
|
||||
$(cc) $(cflags) -c $< -o $@
|
||||
|
||||
install:
|
||||
- install $(bin) /usr/local/bin
|
||||
+ install $(bin) ${PREFIX}/bin
|
||||
|
||||
clean:
|
||||
rm -f $(objs) $(bin) *~ core
|
Loading…
Reference in a new issue