This package is for the Linux kernel. It needs work, but I have been using
it for over 14 months.
This commit is contained in:
parent
b91f442849
commit
c2abee2dcf
7 changed files with 168 additions and 0 deletions
5
linux-kernel/DESCR
Normal file
5
linux-kernel/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
The Linux kernel is the core part of the Linux-based operating system.
|
||||
|
||||
It is a Unix clone and aims to comply with Single UNIX Specification
|
||||
and POSIX. Linux was written from scratch by Linux Torvalds and
|
||||
developed by many programmers around the world.
|
40
linux-kernel/Makefile
Normal file
40
linux-kernel/Makefile
Normal file
|
@ -0,0 +1,40 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/01/27 17:51:08 jeremy-c-reed Exp $
|
||||
|
||||
LINUX_VERSION= 2.4.22
|
||||
DISTNAME= linux-${LINUX_VERSION}
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ftp://ftp.kernel.org/pub/linux/kernel/v2.4/ \
|
||||
http://www.de.kernel.org/pub/linux/kernel/v2.4/ \
|
||||
ftp://ftp.jp.kernel.org/pub/linux/kernel/v2.4/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= reed@reedmedia.net
|
||||
HOMEPAGE= http://www.kernel.org/
|
||||
COMMENT= The Linux kernel
|
||||
|
||||
BUILD_DEPENDS+= linux-modutils-[0-9]*:../../wip/linux-modutils
|
||||
|
||||
PLIST_SUBST+= LINUX_VERSION=${LINUX_VERSION}
|
||||
|
||||
USE_GNU_TOOLS+= make
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && \
|
||||
yes "" | ${GMAKE} config && \
|
||||
${CAT} ${FILESDIR}/extra-configs >> .config && \
|
||||
yes "" | ${GMAKE} oldconfig # regenerate config after appending to it
|
||||
|
||||
pre-build:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} dep
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} bzImage && \
|
||||
${SETENV} ${MAKE_ENV} ${GMAKE} modules
|
||||
|
||||
do-install:
|
||||
${CP} ${WRKSRC}/arch/${LOWER_ARCH}/boot/bzImage /boot/bzImage-${LINUX_VERSION}
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} modules_install
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
||||
CC= ${LOCALBASE}/gcc3/bin/gcc
|
2
linux-kernel/PLIST
Normal file
2
linux-kernel/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/01/27 17:51:08 jeremy-c-reed Exp $
|
||||
boot/bzImage-${LINUX_VERSION}
|
37
linux-kernel/TODO
Normal file
37
linux-kernel/TODO
Normal file
|
@ -0,0 +1,37 @@
|
|||
update to newest version
|
||||
|
||||
FATAL: ldconfig must be used with "||${TRUE}".
|
||||
(that is bug in pkglint.)
|
||||
|
||||
make sure gcc exists (see very bottom of Makefile)
|
||||
|
||||
thread about missing stdarg.h
|
||||
http://www.ussg.iu.edu/hypermail/linux/kernel/0209.3/1015.html
|
||||
For time being I run kernel make like this:
|
||||
GCC_EXEC_PREFIX=/usr/app/gcc/lib/gcc-lib/ make
|
||||
|
||||
make package for linux-kernel-headers too
|
||||
${MAKE} include/linux/version.h
|
||||
glibc provides its own <net/*> and <scsi/*> header files to replace them
|
||||
so just include/asm and include/linux
|
||||
|
||||
message to suggest running lilo if using LILO
|
||||
|
||||
maybe dynamically figure out modules for PLIST
|
||||
|
||||
LOCALBASE should be / for PLIST to be right
|
||||
(need to use LOCLABASE for the install part too.)
|
||||
|
||||
should install .config file too; for example:
|
||||
Knoppix kernel-headers-2.4.22-xfs_10.00.Custom_i386.deb
|
||||
ar p ../kernel-headers-2.4.22-xfs_10.00.Custom_i386.deb data.tar.gz | tar zxf -
|
||||
and found usr/src/kernel-headers-2.4.22-xfs/.config
|
||||
|
||||
try to just install headers with make config followed by make include/linux/version.h
|
||||
|
||||
copy certain directories from include to /usr/include
|
||||
|
||||
look at default /boot/config-2.2.20-idepci
|
||||
|
||||
# cp -i arch/i386/boot/bzImage /bzImage.-- with kernel-version- or other name
|
||||
# maybe copy to boot directory (as lilo also knows it)
|
5
linux-kernel/distinfo
Normal file
5
linux-kernel/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/01/27 17:51:08 jeremy-c-reed Exp $
|
||||
|
||||
SHA1 (linux-2.4.22.tar.bz2) = 27228d42eae4cd1f47153a68e2f7c1b3c3611a70
|
||||
Size (linux-2.4.22.tar.bz2) = 29528612 bytes
|
||||
SHA1 (patch-aa) = 2c24526e45bad14f740194e1967104afe0f713f4
|
46
linux-kernel/files/extra-configs
Normal file
46
linux-kernel/files/extra-configs
Normal file
|
@ -0,0 +1,46 @@
|
|||
CONFIG_USB_PRINTER=m
|
||||
CONFIG_8139TOO=m
|
||||
CONFIG_8139TOO_8129=y
|
||||
CONFIG_NFS_V3=y
|
||||
CONFIG_NFSD_V3=y
|
||||
CONFIG_LOCKD_V4=y
|
||||
CONFIG_SOUND_TRIDENT=m
|
||||
CONFIG_TULIP=m
|
||||
CONFIG_SOUND_OSS=m
|
||||
CONFIG_SOUND_SB=m
|
||||
CONFIG_INET_ECN=y
|
||||
CONFIG_SYN_COOKIES=y
|
||||
CONFIG_IP_ADVANCED_ROUTER=y
|
||||
CONFIG_IP_ROUTE_VERBOSE=y
|
||||
CONFIG_IP_ROUTE_LARGE_TABLES=y
|
||||
CONFIG_PACKET=y
|
||||
CONFIG_NETFILTER=y
|
||||
CONFIG_IP_NF_CONNTRACK=y
|
||||
CONFIG_IP_NF_FTP=y
|
||||
#CONFIG_IP_NF_QUEUE
|
||||
CONFIG_IP_NF_IPTABLES=y
|
||||
CONFIG_IP_NF_MATCH_LIMIT=y
|
||||
#CONFIG_IP_NF_MATCH_MAC
|
||||
#CONFIG_IP_NF_MATCH_MARK
|
||||
CONFIG_IP_NF_MATCH_MULTIPORT=y
|
||||
#CONFIG_IP_NF_MATCH_TOS
|
||||
#CONFIG_IP_NF_MATCH_TCPMSS
|
||||
CONFIG_IP_NF_MATCH_STATE=y
|
||||
CONFIG_IP_NF_MATCH_UNCLEAN=y
|
||||
#CONFIG_IP_NF_MATCH_OWNER
|
||||
CONFIG_IP_NF_FILTER=y
|
||||
CONFIG_IP_NF_TARGET_REJECT=y
|
||||
#CONFIG_IP_NF_TARGET_MIRROR
|
||||
CONFIG_IP_NF_NAT=y
|
||||
CONFIG_IP_NF_NAT_NEEDED=y
|
||||
CONFIG_IP_NF_TARGET_MASQUERADE=y
|
||||
#CONFIG_IP_NF_TARGET_REDIRECT
|
||||
CONFIG_IP_NF_NAT_FTP=y
|
||||
CONFIG_IP_NF_MANGLE=y
|
||||
#CONFIG_IP_NF_TARGET_TOS
|
||||
#CONFIG_IP_NF_TARGET_MARK
|
||||
CONFIG_IP_NF_TARGET_LOG=y
|
||||
#CONFIG_IP_NF_TARGET_TCPMSS
|
||||
#CONFIG_IP_NF_COMPAT_IPCHAINS
|
||||
#CONFIG_IP_NF_COMPAT_IPFWADM
|
||||
|
33
linux-kernel/patches/patch-aa
Normal file
33
linux-kernel/patches/patch-aa
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/01/27 17:51:09 jeremy-c-reed Exp $
|
||||
|
||||
--- Makefile.orig 2003-05-01 10:21:21.000000000 -0700
|
||||
+++ Makefile 2003-05-01 10:21:42.000000000 -0700
|
||||
@@ -16,7 +16,7 @@
|
||||
HPATH = $(TOPDIR)/include
|
||||
FINDHPATH = $(HPATH)/asm $(HPATH)/linux $(HPATH)/scsi $(HPATH)/net $(HPATH)/math-emu
|
||||
|
||||
-HOSTCC = gcc
|
||||
+HOSTCC = $(CC)
|
||||
HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
|
||||
|
||||
CROSS_COMPILE =
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
AS = $(CROSS_COMPILE)as
|
||||
LD = $(CROSS_COMPILE)ld
|
||||
-CC = $(CROSS_COMPILE)gcc
|
||||
+#CC = $(CROSS_COMPILE)gcc
|
||||
CPP = $(CC) -E
|
||||
AR = $(CROSS_COMPILE)ar
|
||||
NM = $(CROSS_COMPILE)nm
|
||||
@@ -35,8 +35,8 @@
|
||||
OBJCOPY = $(CROSS_COMPILE)objcopy
|
||||
OBJDUMP = $(CROSS_COMPILE)objdump
|
||||
MAKEFILES = $(TOPDIR)/.config
|
||||
-GENKSYMS = /sbin/genksyms
|
||||
-DEPMOD = /sbin/depmod
|
||||
+GENKSYMS = $(PREFIX)/sbin/genksyms
|
||||
+DEPMOD = $(PREFIX)/sbin/depmod
|
||||
MODFLAGS = -DMODULE
|
||||
CFLAGS_KERNEL =
|
||||
PERL = perl
|
Loading…
Reference in a new issue