Import triangle-1.6 as wip/triangle.

Two-Dimensional Quality Mesh Generator and Delaunay Triangulator
This commit is contained in:
Kamel Ibn Aziz Derouiche 2011-10-28 16:38:52 +00:00 committed by Thomas Klausner
parent 77ca42a3c5
commit c51b77f7ef
5 changed files with 67 additions and 0 deletions

1
triangle/DESCR Normal file
View file

@ -0,0 +1 @@
Two-Dimensional Quality Mesh Generator and Delaunay Triangulator

27
triangle/Makefile Normal file
View file

@ -0,0 +1,27 @@
# $NetBSD: Makefile,v 1.1.1.1 2011/10/28 16:38:52 jihbed Exp $
#
DISTNAME= triangle
PKGNAME= ${DISTNAME}-${VERSION}
CATEGORIES= math
MASTER_SITES= http://www.netlib.org/voronoi/
EXTRACT_SUFX= .zip
MAINTAINER= jihbed.research@gmail.com
HOMEPAGE= http://www.cs.cmu.edu/~quake/triangle.html
COMMENT= Two-Dimensional Quality Mesh Generator and Delaunay Triangulator
PKG_DESTDIR_SUPPORT= user-destdir
WRKSRC= ${WRKDIR}
VERSION= 1.6
MAKE_FILE= makefile
INSTALLATION_DIRS= bin
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${DESTDIR}${PREFIX}/bin
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
triangle/PLIST Normal file
View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2011/10/28 16:38:52 jihbed Exp $
bin/triangle

6
triangle/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2011/10/28 16:38:52 jihbed Exp $
SHA1 (triangle.zip) = 63d11e0b5bf097eb946a4da4ee18ddf279e16fc4
RMD160 (triangle.zip) = 12be39ae4e34fc14ef3f9982e28a242abe200307
Size (triangle.zip) = 158528 bytes
SHA1 (patch-makefile) = 4c04ae02138d0bbfc1026d8662539d7522f83e0d

View file

@ -0,0 +1,31 @@
$NetBSD: patch-makefile,v 1.1.1.1 2011/10/28 16:38:52 jihbed Exp $
--- makefile.orig 2011-08-07 21:57:54.000000000 +0100
+++ makefile 2011-08-07 22:00:22.000000000 +0100
@@ -18,7 +18,7 @@
# CC should be set to the name of your favorite C compiler.
-CC = cc
+#CC = cc
# CSWITCHES is a list of all switches passed to the C compiler. I strongly
# recommend using the best level of optimization. I also strongly
@@ -73,7 +73,7 @@
#
# CSWITCHES = -O -DNO_TIMER -DLINUX -I/usr/X11R6/include -L/usr/X11R6/lib
-CSWITCHES = -O -DLINUX -I/usr/X11R6/include -L/usr/X11R6/lib
+CSWITCHES = -O -DNETBSD -I/usr/X11R7/include -L/usr/X11R7/lib
# TRILIBDEFS is a list of definitions used to compile an object code version
# of Triangle (triangle.o) to be called by another program. The file
@@ -90,7 +90,7 @@
# RM should be set to the name of your favorite rm (file deletion program).
-RM = /bin/rm
+#RM = /bin/rm
# The action starts here.