update to a snapshot of today
This commit is contained in:
parent
7f1515b163
commit
c87a735d1d
5 changed files with 99 additions and 80 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.2 2010/05/06 16:50:18 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2010/07/22 17:02:35 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= llvm-2.6
|
||||
SVN_TAG= 103176
|
||||
SVN_TAG= 109091
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://llvm.org/releases/${PKGVERSION_NOREV}/
|
||||
|
||||
|
|
126
clang/PLIST
126
clang/PLIST
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2010/05/06 16:50:19 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2010/07/22 17:02:36 drochner Exp $
|
||||
bin/bugpoint
|
||||
bin/c-index-test
|
||||
bin/clang
|
||||
|
@ -13,6 +13,7 @@ bin/llvm-dis
|
|||
bin/llvm-extract
|
||||
bin/llvm-ld
|
||||
bin/llvm-link
|
||||
bin/llvm-mc
|
||||
bin/llvm-nm
|
||||
bin/llvm-prof
|
||||
bin/llvm-ranlib
|
||||
|
@ -29,10 +30,13 @@ include/clang/AST/ASTDiagnostic.h
|
|||
include/clang/AST/ASTImporter.h
|
||||
include/clang/AST/ASTVector.h
|
||||
include/clang/AST/Attr.h
|
||||
include/clang/AST/Attrs.inc
|
||||
include/clang/AST/CXXInheritance.h
|
||||
include/clang/AST/CanonicalType.h
|
||||
include/clang/AST/CharUnits.h
|
||||
include/clang/AST/Debug/StmtNodes.inc.tmp
|
||||
include/clang/AST/Debug+Asserts/Attrs.inc.tmp
|
||||
include/clang/AST/Debug+Asserts/DeclNodes.inc.tmp
|
||||
include/clang/AST/Debug+Asserts/StmtNodes.inc.tmp
|
||||
include/clang/AST/Decl.h
|
||||
include/clang/AST/DeclAccessPair.h
|
||||
include/clang/AST/DeclBase.h
|
||||
|
@ -40,7 +44,7 @@ include/clang/AST/DeclCXX.h
|
|||
include/clang/AST/DeclContextInternals.h
|
||||
include/clang/AST/DeclFriend.h
|
||||
include/clang/AST/DeclGroup.h
|
||||
include/clang/AST/DeclNodes.def
|
||||
include/clang/AST/DeclNodes.inc
|
||||
include/clang/AST/DeclObjC.h
|
||||
include/clang/AST/DeclTemplate.h
|
||||
include/clang/AST/DeclVisitor.h
|
||||
|
@ -55,6 +59,7 @@ include/clang/AST/NestedNameSpecifier.h
|
|||
include/clang/AST/ParentMap.h
|
||||
include/clang/AST/PrettyPrinter.h
|
||||
include/clang/AST/RecordLayout.h
|
||||
include/clang/AST/RecursiveASTVisitor.h
|
||||
include/clang/AST/Redeclarable.h
|
||||
include/clang/AST/Stmt.h
|
||||
include/clang/AST/StmtCXX.h
|
||||
|
@ -75,8 +80,8 @@ include/clang/AST/TypeOrdering.h
|
|||
include/clang/AST/TypeVisitor.h
|
||||
include/clang/AST/UnresolvedSet.h
|
||||
include/clang/AST/UsuallyTinyPtrVector.h
|
||||
include/clang/Analysis/Analyses/FormatString.h
|
||||
include/clang/Analysis/Analyses/LiveVariables.h
|
||||
include/clang/Analysis/Analyses/PrintfFormatString.h
|
||||
include/clang/Analysis/Analyses/ReachableCode.h
|
||||
include/clang/Analysis/Analyses/UninitializedValues.h
|
||||
include/clang/Analysis/AnalysisContext.h
|
||||
|
@ -91,21 +96,26 @@ include/clang/Analysis/Support/SaveAndRestore.h
|
|||
include/clang/Analysis/Visitors/CFGRecStmtDeclVisitor.h
|
||||
include/clang/Analysis/Visitors/CFGRecStmtVisitor.h
|
||||
include/clang/Analysis/Visitors/CFGStmtVisitor.h
|
||||
include/clang/Basic/AttrKinds.h
|
||||
include/clang/Basic/AttrList.inc
|
||||
include/clang/Basic/Builtins.def
|
||||
include/clang/Basic/Builtins.h
|
||||
include/clang/Basic/BuiltinsARM.def
|
||||
include/clang/Basic/BuiltinsPPC.def
|
||||
include/clang/Basic/BuiltinsX86.def
|
||||
include/clang/Basic/ConvertUTF.h
|
||||
include/clang/Basic/Debug/DiagnosticASTKinds.inc.tmp
|
||||
include/clang/Basic/Debug/DiagnosticAnalysisKinds.inc.tmp
|
||||
include/clang/Basic/Debug/DiagnosticCommonKinds.inc.tmp
|
||||
include/clang/Basic/Debug/DiagnosticDriverKinds.inc.tmp
|
||||
include/clang/Basic/Debug/DiagnosticFrontendKinds.inc.tmp
|
||||
include/clang/Basic/Debug/DiagnosticGroups.inc.tmp
|
||||
include/clang/Basic/Debug/DiagnosticLexKinds.inc.tmp
|
||||
include/clang/Basic/Debug/DiagnosticParseKinds.inc.tmp
|
||||
include/clang/Basic/Debug/DiagnosticSemaKinds.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/AttrList.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/DiagnosticASTKinds.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/DiagnosticAnalysisKinds.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/DiagnosticCommonKinds.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/DiagnosticDriverKinds.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/DiagnosticFrontendKinds.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/DiagnosticGroups.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/DiagnosticLexKinds.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/DiagnosticParseKinds.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/DiagnosticSemaKinds.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/Version.inc.tmp
|
||||
include/clang/Basic/Debug+Asserts/arm_neon.inc.tmp
|
||||
include/clang/Basic/Diagnostic.h
|
||||
include/clang/Basic/DiagnosticASTKinds.inc
|
||||
include/clang/Basic/DiagnosticAnalysisKinds.inc
|
||||
|
@ -138,13 +148,18 @@ include/clang/Basic/TokenKinds.def
|
|||
include/clang/Basic/TokenKinds.h
|
||||
include/clang/Basic/TypeTraits.h
|
||||
include/clang/Basic/Version.h
|
||||
include/clang/Basic/Version.inc
|
||||
include/clang/Basic/arm_neon.inc
|
||||
include/clang/Checker/AnalysisConsumer.h
|
||||
include/clang/Checker/BugReporter/BugReporter.h
|
||||
include/clang/Checker/BugReporter/BugType.h
|
||||
include/clang/Checker/BugReporter/PathDiagnostic.h
|
||||
include/clang/Checker/Checkers/DereferenceChecker.h
|
||||
include/clang/Checker/Checkers/LocalCheckers.h
|
||||
include/clang/Checker/DomainSpecific/CocoaConventions.h
|
||||
include/clang/Checker/FrontendActions.h
|
||||
include/clang/Checker/ManagerRegistry.h
|
||||
include/clang/Checker/PathDiagnosticClients.h
|
||||
include/clang/Checker/PathSensitive/AnalysisManager.h
|
||||
include/clang/Checker/PathSensitive/BasicValueFactory.h
|
||||
include/clang/Checker/PathSensitive/Checker.h
|
||||
|
@ -171,16 +186,20 @@ include/clang/Checker/PathSensitive/Store.h
|
|||
include/clang/Checker/PathSensitive/SummaryManager.h
|
||||
include/clang/Checker/PathSensitive/SymbolManager.h
|
||||
include/clang/Checker/PathSensitive/ValueManager.h
|
||||
include/clang/CodeGen/CodeGenOptions.h
|
||||
include/clang/CodeGen/BackendUtil.h
|
||||
include/clang/CodeGen/CodeGenAction.h
|
||||
include/clang/CodeGen/ModuleBuilder.h
|
||||
include/clang/Driver/Action.h
|
||||
include/clang/Driver/Arg.h
|
||||
include/clang/Driver/ArgList.h
|
||||
include/clang/Driver/CC1AsOptions.h
|
||||
include/clang/Driver/CC1AsOptions.inc
|
||||
include/clang/Driver/CC1Options.h
|
||||
include/clang/Driver/CC1Options.inc
|
||||
include/clang/Driver/Compilation.h
|
||||
include/clang/Driver/Debug/CC1Options.inc.tmp
|
||||
include/clang/Driver/Debug/Options.inc.tmp
|
||||
include/clang/Driver/Debug+Asserts/CC1AsOptions.inc.tmp
|
||||
include/clang/Driver/Debug+Asserts/CC1Options.inc.tmp
|
||||
include/clang/Driver/Debug+Asserts/Options.inc.tmp
|
||||
include/clang/Driver/Driver.h
|
||||
include/clang/Driver/DriverDiagnostic.h
|
||||
include/clang/Driver/HostInfo.h
|
||||
|
@ -199,9 +218,9 @@ include/clang/Driver/Util.h
|
|||
include/clang/Frontend/ASTConsumers.h
|
||||
include/clang/Frontend/ASTUnit.h
|
||||
include/clang/Frontend/Analyses.def
|
||||
include/clang/Frontend/AnalysisConsumer.h
|
||||
include/clang/Frontend/AnalyzerOptions.h
|
||||
include/clang/Frontend/ChainedDiagnosticClient.h
|
||||
include/clang/Frontend/CodeGenAction.h
|
||||
include/clang/Frontend/CodeGenOptions.h
|
||||
include/clang/Frontend/CommandLineSourceLoc.h
|
||||
include/clang/Frontend/CompilerInstance.h
|
||||
include/clang/Frontend/CompilerInvocation.h
|
||||
|
@ -211,7 +230,6 @@ include/clang/Frontend/DependencyOutputOptions.h
|
|||
include/clang/Frontend/DiagnosticOptions.h
|
||||
include/clang/Frontend/DocumentXML.def
|
||||
include/clang/Frontend/DocumentXML.h
|
||||
include/clang/Frontend/FixItRewriter.h
|
||||
include/clang/Frontend/FrontendAction.h
|
||||
include/clang/Frontend/FrontendActions.h
|
||||
include/clang/Frontend/FrontendDiagnostic.h
|
||||
|
@ -221,9 +239,9 @@ include/clang/Frontend/HeaderSearchOptions.h
|
|||
include/clang/Frontend/LangStandard.h
|
||||
include/clang/Frontend/LangStandards.def
|
||||
include/clang/Frontend/PCHBitCodes.h
|
||||
include/clang/Frontend/PCHDeserializationListener.h
|
||||
include/clang/Frontend/PCHReader.h
|
||||
include/clang/Frontend/PCHWriter.h
|
||||
include/clang/Frontend/PathDiagnosticClients.h
|
||||
include/clang/Frontend/PreprocessorOptions.h
|
||||
include/clang/Frontend/PreprocessorOutputOptions.h
|
||||
include/clang/Frontend/StmtXML.def
|
||||
|
@ -245,7 +263,6 @@ include/clang/Index/Program.h
|
|||
include/clang/Index/STLExtras.h
|
||||
include/clang/Index/SelectorMap.h
|
||||
include/clang/Index/TranslationUnit.h
|
||||
include/clang/Index/Utils.h
|
||||
include/clang/Lex/DirectoryLookup.h
|
||||
include/clang/Lex/ExternalPreprocessorSource.h
|
||||
include/clang/Lex/HeaderMap.h
|
||||
|
@ -275,10 +292,14 @@ include/clang/Parse/ParseDiagnostic.h
|
|||
include/clang/Parse/Parser.h
|
||||
include/clang/Parse/Scope.h
|
||||
include/clang/Parse/Template.h
|
||||
include/clang/Rewrite/ASTConsumers.h
|
||||
include/clang/Rewrite/DeltaTree.h
|
||||
include/clang/Rewrite/FixItRewriter.h
|
||||
include/clang/Rewrite/FrontendActions.h
|
||||
include/clang/Rewrite/HTMLRewrite.h
|
||||
include/clang/Rewrite/RewriteRope.h
|
||||
include/clang/Rewrite/Rewriter.h
|
||||
include/clang/Rewrite/Rewriters.h
|
||||
include/clang/Rewrite/TokenRewriter.h
|
||||
include/clang/Sema/CodeCompleteConsumer.h
|
||||
include/clang/Sema/ExternalSemaSource.h
|
||||
|
@ -300,6 +321,7 @@ include/llvm/ADT/APFloat.h
|
|||
include/llvm/ADT/APInt.h
|
||||
include/llvm/ADT/APSInt.h
|
||||
include/llvm/ADT/BitVector.h
|
||||
include/llvm/ADT/DAGDeltaAlgorithm.h
|
||||
include/llvm/ADT/DeltaAlgorithm.h
|
||||
include/llvm/ADT/DenseMap.h
|
||||
include/llvm/ADT/DenseMapInfo.h
|
||||
|
@ -351,6 +373,7 @@ include/llvm/Analysis/AliasSetTracker.h
|
|||
include/llvm/Analysis/CFGPrinter.h
|
||||
include/llvm/Analysis/CallGraph.h
|
||||
include/llvm/Analysis/CaptureTracking.h
|
||||
include/llvm/Analysis/CodeMetrics.h
|
||||
include/llvm/Analysis/ConstantFolding.h
|
||||
include/llvm/Analysis/ConstantsScanner.h
|
||||
include/llvm/Analysis/DOTGraphTraitsPass.h
|
||||
|
@ -370,6 +393,7 @@ include/llvm/Analysis/LibCallAliasAnalysis.h
|
|||
include/llvm/Analysis/LibCallSemantics.h
|
||||
include/llvm/Analysis/Lint.h
|
||||
include/llvm/Analysis/LiveValues.h
|
||||
include/llvm/Analysis/Loads.h
|
||||
include/llvm/Analysis/LoopDependenceAnalysis.h
|
||||
include/llvm/Analysis/LoopInfo.h
|
||||
include/llvm/Analysis/LoopPass.h
|
||||
|
@ -382,6 +406,9 @@ include/llvm/Analysis/PostDominators.h
|
|||
include/llvm/Analysis/ProfileInfo.h
|
||||
include/llvm/Analysis/ProfileInfoLoader.h
|
||||
include/llvm/Analysis/ProfileInfoTypes.h
|
||||
include/llvm/Analysis/RegionInfo.h
|
||||
include/llvm/Analysis/RegionIterator.h
|
||||
include/llvm/Analysis/RegionPrinter.h
|
||||
include/llvm/Analysis/ScalarEvolution.h
|
||||
include/llvm/Analysis/ScalarEvolutionExpander.h
|
||||
include/llvm/Analysis/ScalarEvolutionExpressions.h
|
||||
|
@ -412,8 +439,8 @@ include/llvm/CodeGen/AsmPrinter.h
|
|||
include/llvm/CodeGen/BinaryObject.h
|
||||
include/llvm/CodeGen/CalcSpillWeights.h
|
||||
include/llvm/CodeGen/CallingConvLower.h
|
||||
include/llvm/CodeGen/ELFRelocation.h
|
||||
include/llvm/CodeGen/FastISel.h
|
||||
include/llvm/CodeGen/FunctionLoweringInfo.h
|
||||
include/llvm/CodeGen/GCMetadata.h
|
||||
include/llvm/CodeGen/GCMetadataPrinter.h
|
||||
include/llvm/CodeGen/GCStrategy.h
|
||||
|
@ -453,6 +480,7 @@ include/llvm/CodeGen/MachineRelocation.h
|
|||
include/llvm/CodeGen/MachineSSAUpdater.h
|
||||
include/llvm/CodeGen/ObjectCodeEmitter.h
|
||||
include/llvm/CodeGen/Passes.h
|
||||
include/llvm/CodeGen/PostRAHazardRecognizer.h
|
||||
include/llvm/CodeGen/ProcessImplicitDefs.h
|
||||
include/llvm/CodeGen/PseudoSourceValue.h
|
||||
include/llvm/CodeGen/RegAllocRegistry.h
|
||||
|
@ -532,14 +560,18 @@ include/llvm/MC/MCExpr.h
|
|||
include/llvm/MC/MCFixup.h
|
||||
include/llvm/MC/MCInst.h
|
||||
include/llvm/MC/MCInstPrinter.h
|
||||
include/llvm/MC/MCLabel.h
|
||||
include/llvm/MC/MCMachOSymbolFlags.h
|
||||
include/llvm/MC/MCObjectStreamer.h
|
||||
include/llvm/MC/MCObjectWriter.h
|
||||
include/llvm/MC/MCParser/AsmCond.h
|
||||
include/llvm/MC/MCParser/AsmLexer.h
|
||||
include/llvm/MC/MCParser/AsmParser.h
|
||||
include/llvm/MC/MCParser/MCAsmLexer.h
|
||||
include/llvm/MC/MCParser/MCAsmParser.h
|
||||
include/llvm/MC/MCParser/MCAsmParserExtension.h
|
||||
include/llvm/MC/MCParser/MCParsedAsmOperand.h
|
||||
include/llvm/MC/MCSection.h
|
||||
include/llvm/MC/MCSectionCOFF.h
|
||||
include/llvm/MC/MCSectionELF.h
|
||||
include/llvm/MC/MCSectionMachO.h
|
||||
include/llvm/MC/MCStreamer.h
|
||||
|
@ -555,10 +587,12 @@ include/llvm/Pass.h
|
|||
include/llvm/PassAnalysisSupport.h
|
||||
include/llvm/PassManager.h
|
||||
include/llvm/PassManagers.h
|
||||
include/llvm/PassRegistry.h
|
||||
include/llvm/PassSupport.h
|
||||
include/llvm/Support/AlignOf.h
|
||||
include/llvm/Support/Allocator.h
|
||||
include/llvm/Support/CFG.h
|
||||
include/llvm/Support/COFF.h
|
||||
include/llvm/Support/CallSite.h
|
||||
include/llvm/Support/Casting.h
|
||||
include/llvm/Support/CommandLine.h
|
||||
|
@ -647,6 +681,7 @@ include/llvm/Target/Target.td
|
|||
include/llvm/Target/TargetAsmBackend.h
|
||||
include/llvm/Target/TargetAsmLexer.h
|
||||
include/llvm/Target/TargetAsmParser.h
|
||||
include/llvm/Target/TargetCallingConv.h
|
||||
include/llvm/Target/TargetCallingConv.td
|
||||
include/llvm/Target/TargetData.h
|
||||
include/llvm/Target/TargetELFWriterInfo.h
|
||||
|
@ -692,26 +727,27 @@ include/llvm/Use.h
|
|||
include/llvm/User.h
|
||||
include/llvm/Value.h
|
||||
include/llvm/ValueSymbolTable.h
|
||||
lib/clang/2.0/include/altivec.h
|
||||
lib/clang/2.0/include/arm_neon.h
|
||||
lib/clang/2.0/include/emmintrin.h
|
||||
lib/clang/2.0/include/float.h
|
||||
lib/clang/2.0/include/iso646.h
|
||||
lib/clang/2.0/include/limits.h
|
||||
lib/clang/2.0/include/mm_malloc.h
|
||||
lib/clang/2.0/include/mmintrin.h
|
||||
lib/clang/2.0/include/nmmintrin.h
|
||||
lib/clang/2.0/include/pmmintrin.h
|
||||
lib/clang/2.0/include/smmintrin.h
|
||||
lib/clang/2.0/include/stdarg.h
|
||||
lib/clang/2.0/include/stdbool.h
|
||||
lib/clang/2.0/include/stddef.h
|
||||
lib/clang/2.0/include/stdint.h
|
||||
lib/clang/2.0/include/tgmath.h
|
||||
lib/clang/2.0/include/tmmintrin.h
|
||||
lib/clang/2.0/include/varargs.h
|
||||
lib/clang/2.0/include/wmmintrin.h
|
||||
lib/clang/2.0/include/xmmintrin.h
|
||||
lib/LLVMHello.so
|
||||
lib/clang/2.8/include/altivec.h
|
||||
lib/clang/2.8/include/arm_neon.h
|
||||
lib/clang/2.8/include/emmintrin.h
|
||||
lib/clang/2.8/include/float.h
|
||||
lib/clang/2.8/include/iso646.h
|
||||
lib/clang/2.8/include/limits.h
|
||||
lib/clang/2.8/include/mm_malloc.h
|
||||
lib/clang/2.8/include/mmintrin.h
|
||||
lib/clang/2.8/include/nmmintrin.h
|
||||
lib/clang/2.8/include/pmmintrin.h
|
||||
lib/clang/2.8/include/smmintrin.h
|
||||
lib/clang/2.8/include/stdarg.h
|
||||
lib/clang/2.8/include/stdbool.h
|
||||
lib/clang/2.8/include/stddef.h
|
||||
lib/clang/2.8/include/stdint.h
|
||||
lib/clang/2.8/include/tgmath.h
|
||||
lib/clang/2.8/include/tmmintrin.h
|
||||
lib/clang/2.8/include/varargs.h
|
||||
lib/clang/2.8/include/wmmintrin.h
|
||||
lib/clang/2.8/include/xmmintrin.h
|
||||
lib/libCompilerDriver.a
|
||||
lib/libEnhancedDisassembly.a
|
||||
lib/libEnhancedDisassembly.so
|
||||
|
@ -724,13 +760,13 @@ lib/libLLVMBitWriter.a
|
|||
lib/libLLVMCodeGen.a
|
||||
lib/libLLVMCore.a
|
||||
lib/libLLVMExecutionEngine.a
|
||||
lib/libLLVMHello.so
|
||||
lib/libLLVMInstCombine.a
|
||||
lib/libLLVMInstrumentation.a
|
||||
lib/libLLVMInterpreter.a
|
||||
lib/libLLVMJIT.a
|
||||
lib/libLLVMLinker.a
|
||||
lib/libLLVMMC.a
|
||||
lib/libLLVMMCDisassembler.a
|
||||
lib/libLLVMMCParser.a
|
||||
lib/libLLVMScalarOpts.a
|
||||
lib/libLLVMSelectionDAG.a
|
||||
|
@ -764,7 +800,7 @@ lib/libclangRewrite.a
|
|||
lib/libclangSema.a
|
||||
lib/libplugin_llvmc_Base.a
|
||||
lib/libplugin_llvmc_Clang.a
|
||||
lib/libprofile_rt.so
|
||||
lib/profile_rt.so
|
||||
man/man1/bugpoint.1
|
||||
man/man1/clang.1
|
||||
man/man1/lit.1
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1 2010/05/04 15:33:16 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.2 2010/07/22 17:02:36 drochner Exp $
|
||||
|
||||
SHA1 (clang-2.6.tar.gz) = 188f29ad3b2c64fcdc791aa34b323ed06452d7ae
|
||||
RMD160 (clang-2.6.tar.gz) = b7e44abbf28902ff8e3fd4578a5ff9dd34f40817
|
||||
|
@ -6,7 +6,7 @@ Size (clang-2.6.tar.gz) = 3857138 bytes
|
|||
SHA1 (llvm-2.6.tar.gz) = 547471147cbf6d3e49539e01196ffada2c79c250
|
||||
RMD160 (llvm-2.6.tar.gz) = 24d58cb052ab5879aae59eaf4885ec41186ee22a
|
||||
Size (llvm-2.6.tar.gz) = 7790380 bytes
|
||||
SHA1 (patch-ac) = ee96c53dd8aa0436726d5d1bc0e2bea7fe515b76
|
||||
SHA1 (patch-ac) = 875c5221de1c5d19baf1c3fcb2ea21951f85e2a1
|
||||
SHA1 (patch-ad) = b90fa4fa75ef1f7c8cb9475798bf7f8e53e6baa9
|
||||
SHA1 (patch-ae) = 7ace4a3835f5998fbd9582f531237977dc948849
|
||||
SHA1 (patch-af) = 440f939c1f3500e6a96b95f4ba63051c1e3f5f10
|
||||
SHA1 (patch-af) = 2c025961fa1e9e48884bbd135f83df092f8e1cc7
|
||||
|
|
|
@ -1,25 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.1 2010/05/04 15:33:16 drochner Exp $
|
||||
$NetBSD: patch-ac,v 1.2 2010/07/22 17:02:36 drochner Exp $
|
||||
|
||||
--- Makefile.rules.orig 2010-04-27 16:20:34.000000000 +0000
|
||||
--- Makefile.rules.orig 2010-07-16 10:05:42.000000000 +0000
|
||||
+++ Makefile.rules
|
||||
@@ -580,11 +580,11 @@ ifeq ($(TARGET_OS),Darwin)
|
||||
endif
|
||||
endif
|
||||
|
||||
-ifdef SHARED_LIBRARY
|
||||
-ifneq ($(DARWIN_MAJVERS),4)
|
||||
- LD.Flags += $(RPATH) -Wl,$(LibDir)
|
||||
-endif
|
||||
-endif
|
||||
+#ifdef SHARED_LIBRARY
|
||||
+#ifneq ($(DARWIN_MAJVERS),4)
|
||||
+# LD.Flags += $(RPATH) -Wl,$(LibDir)
|
||||
+#endif
|
||||
+#endif
|
||||
|
||||
ifdef TOOL_VERBOSE
|
||||
C.Flags += -v
|
||||
@@ -615,9 +615,9 @@ ifneq ($(DARWIN_MAJVERS),4)
|
||||
@@ -625,9 +625,9 @@ ifneq ($(HOST_OS),Darwin)
|
||||
ifdef TOOLNAME
|
||||
LD.Flags += $(RPATH) -Wl,'$$ORIGIN/../lib'
|
||||
ifdef EXAMPLE_TOOL
|
||||
|
@ -30,8 +13,8 @@ $NetBSD: patch-ac,v 1.1 2010/05/04 15:33:16 drochner Exp $
|
|||
+ LD.Flags += $(RDYNAMIC)
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
@@ -773,9 +773,6 @@ ObjectsBC := $(BaseNameSources:%=$(ObjDi
|
||||
else
|
||||
@@ -787,9 +787,6 @@ ObjectsBC := $(BaseNameSources:%=$(ObjDi
|
||||
# in the file so they get built before dependencies
|
||||
#---------------------------------------------------------
|
||||
|
||||
|
@ -41,7 +24,7 @@ $NetBSD: patch-ac,v 1.1 2010/05/04 15:33:16 drochner Exp $
|
|||
# To create other directories, as needed, and timestamp their creation
|
||||
%/.dir:
|
||||
$(Verb) $(MKDIR) $* > /dev/null
|
||||
@@ -896,7 +893,9 @@ install-local::
|
||||
@@ -915,7 +912,9 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) UnInstall circumvented with NO_INSTALL
|
||||
else
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
$NetBSD: patch-af,v 1.1 2010/05/04 15:33:16 drochner Exp $
|
||||
$NetBSD: patch-af,v 1.2 2010/07/22 17:02:36 drochner Exp $
|
||||
|
||||
--- tools/clang/lib/Frontend/InitHeaderSearch.cpp.orig 2010-05-04 10:43:04.000000000 +0000
|
||||
--- tools/clang/lib/Frontend/InitHeaderSearch.cpp.orig 2010-07-09 10:52:06.000000000 +0000
|
||||
+++ tools/clang/lib/Frontend/InitHeaderSearch.cpp
|
||||
@@ -637,6 +637,9 @@ void InitHeaderSearch::AddDefaultCPlusPl
|
||||
case llvm::Triple::FreeBSD:
|
||||
@@ -723,6 +723,9 @@ AddDefaultCPlusPlusIncludePaths(const ll
|
||||
// FreeBSD 7.3
|
||||
AddGnuCPlusPlusIncludePaths("/usr/include/c++/4.2", "", "", "", triple);
|
||||
break;
|
||||
+ case llvm::Triple::NetBSD:
|
||||
+ AddGnuCPlusPlusIncludePaths("/usr/include/g++", "", "", "", triple);
|
||||
+ break;
|
||||
case llvm::Triple::Solaris:
|
||||
// Solaris - Fall though..
|
||||
case llvm::Triple::AuroraUX:
|
||||
case llvm::Triple::Minix:
|
||||
AddGnuCPlusPlusIncludePaths("/usr/gnu/include/c++/4.4.3",
|
||||
"", "", "", triple);
|
||||
|
|
Loading…
Reference in a new issue