Improve the way how default paths are fixed.
This commit is contained in:
parent
bba95dd29a
commit
c8bc711068
3 changed files with 35 additions and 4 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.8 2014/03/14 08:54:56 fhajny Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2014/03/14 14:26:30 fhajny Exp $
|
||||
|
||||
DISTNAME= graphite-web-0.9.12
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
|
@ -24,10 +24,19 @@ BUILD_DEFS+= VARBASE GRAPHITE_DIR
|
|||
GRAPHITE_DIR?= ${VARBASE}/graphite
|
||||
GRAPHITE_EGDIR?= share/examples/graphite
|
||||
|
||||
REPLACE_SH+= bin/build-index.sh
|
||||
|
||||
SUBST_CLASSES+= dirs
|
||||
SUBST_STAGE.dirs= pre-configure
|
||||
SUBST_MESSAGE.dirs= Patching default storage directory
|
||||
SUBST_FILES.dirs= setup.py
|
||||
SUBST_MESSAGE.dirs= Patching default dirs
|
||||
SUBST_FILES.dirs= bin/build-index.sh
|
||||
SUBST_FILES.dirs+= conf/graphite.wsgi.example
|
||||
SUBST_FILES.dirs+= examples/example-graphite-vhost.conf
|
||||
SUBST_FILES.dirs+= setup.py
|
||||
SUBST_FILES.dirs+= webapp/graphite/local_settings.py.example
|
||||
SUBST_SED.dirs= -e 's,/opt/graphite/conf,${PKG_SYSCONFDIR},g'
|
||||
SUBST_SED.dirs+= -e 's,/opt/graphite/storage,${GRAPHITE_DIR},g'
|
||||
SUBST_SED.dirs+= -e 's,/opt/graphite,${PREFIX}/graphite,g'
|
||||
SUBST_VARS.dirs= GRAPHITE_DIR GRAPHITE_EGDIR PREFIX
|
||||
|
||||
PKG_SYSCONFSUBDIR= graphite
|
||||
|
@ -50,6 +59,7 @@ EGG_NAME= ${DISTNAME:S/graphite-/graphite_/}
|
|||
pre-build:
|
||||
${MKDIR} ${WRKSRC}/graphite/webapp
|
||||
${CP} -LR ${WRKSRC}/webapp/content ${WRKSRC}/graphite/webapp
|
||||
${RM} -f ${WRKSRC}/bin/build-index.sh.orig
|
||||
|
||||
.include "../../lang/python/versioned_dependencies.mk"
|
||||
.include "../../lang/python/distutils.mk"
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2014/03/14 08:54:57 fhajny Exp $
|
||||
$NetBSD: distinfo,v 1.3 2014/03/14 14:26:30 fhajny Exp $
|
||||
|
||||
SHA1 (graphite-web-0.9.12.tar.gz) = 5d69c5a691ee34c3ea5013adaa5a79a243bc2e3e
|
||||
RMD160 (graphite-web-0.9.12.tar.gz) = 25f91ed55eb6858b0ef6de786c21f949b88ff940
|
||||
Size (graphite-web-0.9.12.tar.gz) = 2334147 bytes
|
||||
SHA1 (patch-bin_build-index.sh) = 13ad11086c620bd65a7cf084a88ae0187fdae2d7
|
||||
SHA1 (patch-config.py) = f4501b8aab19ce366b9fd1aa207cac5534e1321a
|
||||
|
|
20
py-graphite-web/patches/patch-bin_build-index.sh
Normal file
20
py-graphite-web/patches/patch-bin_build-index.sh
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-bin_build-index.sh,v 1.1 2014/03/14 14:26:30 fhajny Exp $
|
||||
|
||||
Fix default paths.
|
||||
--- bin/build-index.sh.orig 2013-08-21 17:11:04.000000000 +0000
|
||||
+++ bin/build-index.sh
|
||||
@@ -2,12 +2,12 @@
|
||||
|
||||
if [ "$GRAPHITE_ROOT" = "" ]
|
||||
then
|
||||
- GRAPHITE_ROOT="/opt/graphite"
|
||||
+ GRAPHITE_ROOT="@PREFIX@/graphite"
|
||||
fi
|
||||
|
||||
if [ "$GRAPHITE_STORAGE_DIR" = "" ]
|
||||
then
|
||||
- GRAPHITE_STORAGE_DIR="${GRAPHITE_ROOT}/storage"
|
||||
+ GRAPHITE_STORAGE_DIR="@GRAPHITE_DIR@"
|
||||
fi
|
||||
|
||||
|
Loading…
Reference in a new issue