Fix build with gcc46 and latest boost libs

This commit is contained in:
Mark Davies 2012-02-27 09:36:42 +00:00 committed by Thomas Klausner
parent bc8d8d9e32
commit c8fe01088f
4 changed files with 30 additions and 2 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.26 2012/01/24 11:34:45 mwdavies Exp $
$NetBSD: distinfo,v 1.27 2012/02/27 09:36:42 mwdavies Exp $
SHA1 (kdewebdev-4.8.0.tar.bz2) = 8919c3a272a954c19a4c0a742e3e686e29650aa4
RMD160 (kdewebdev-4.8.0.tar.bz2) = be837f67e0de01d91b32d1c323fda6340b671a00
Size (kdewebdev-4.8.0.tar.bz2) = 2731188 bytes
SHA1 (patch-klinkstatus_src_CMakeLists.txt) = b3698f7edde82552e0395a27df980d0e58ce0994

View file

@ -0,0 +1,13 @@
$NetBSD: patch-klinkstatus_src_CMakeLists.txt,v 1.1 2012/02/27 09:36:42 mwdavies Exp $
--- klinkstatus/src/CMakeLists.txt.orig 2011-09-26 11:26:04.000000000 +0000
+++ klinkstatus/src/CMakeLists.txt
@@ -3,6 +3,8 @@ add_subdirectory(plugins)
set(GENERIC_KLINKSTATUS_LIB_VERSION "4.0.0")
set(GENERIC_KLINKSTATUS_LIB_SOVERSION "4")
+add_definitions(${KDE4_ENABLE_EXCEPTIONS})
+
configure_file(config-tidy.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-tidy.h )

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1 2012/01/22 22:02:16 mwdavies Exp $
$NetBSD: distinfo,v 1.2 2012/02/27 09:42:34 mwdavies Exp $
SHA1 (pykde4-4.8.0.tar.bz2) = cf204efebc1eda6de7f4405dbf5037bdaffd30e9
RMD160 (pykde4-4.8.0.tar.bz2) = 1933aca61f0f29a7d3622d891137425278820c51
Size (pykde4-4.8.0.tar.bz2) = 2109081 bytes
SHA1 (patch-CMakeLists.txt) = 6981a91671511739e63568d7bc2ee8899d28f8a9
SHA1 (patch-__init__.py) = 721287a0ec82b79ea4a502526ed98ba44c6d979f

View file

@ -0,0 +1,13 @@
$NetBSD: patch-CMakeLists.txt,v 1.1 2012/02/27 09:42:34 mwdavies Exp $
--- CMakeLists.txt.orig 2010-11-02 12:51:11.000000000 +0000
+++ CMakeLists.txt
@@ -15,6 +15,8 @@ endif(${CMAKE_SOURCE_DIR} STREQUAL ${CMA
# This module can be built independant from the rest of kdebindings.
SET(CMAKE_MODULE_PATH ${pykde4_SOURCE_DIR}/cmake/modules ${CMAKE_MODULE_PATH})
+add_definitions(${KDE4_ENABLE_EXCEPTIONS})
+
# Fix output file conflict with the Ruby bindings
IF(CMAKE_MAJOR_VERSION EQUAL 2 AND CMAKE_MINOR_VERSION LESS 6)
SET(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/lib/pykde)