Removing docker. (Imported to pkgsrc)

This commit is contained in:
Adam Hoka 2008-08-13 11:44:44 +00:00 committed by Thomas Klausner
parent 8bba664ffe
commit c9745e699a
6 changed files with 1 additions and 62 deletions

View file

@ -1,4 +1,4 @@
# $Id: Makefile,v 1.2999 2008/08/12 16:56:22 othyro Exp $
# $Id: Makefile,v 1.3000 2008/08/13 11:44:44 hoka_adam Exp $
#
COMMENT= WIP pkgsrc packages
@ -259,7 +259,6 @@ SUBDIR+= dmxproto
SUBDIR+= dnrd
SUBDIR+= dnswalk
SUBDIR+= docbook-xsl-ko
SUBDIR+= docker
SUBDIR+= doorman
SUBDIR+= dotproject
SUBDIR+= dpic

View file

@ -1,10 +0,0 @@
Docker is a docking application (WindowMaker dock app) which acts as a system
tray for KDE and GNOME2. It can be used to replace the panel in either
environment, allowing you to have a system tray without running the KDE/GNOME
panel or environment.
Docker is designed to work with Openbox 2, but it should work fine in any
window manager that supports WindowMaker dock apps.
If you running WindowMaker or otherwise and experiencing problems, you should
try using the -wmaker option to make docker keep a fixed size.

View file

@ -1,26 +0,0 @@
# $NetBSD: Makefile,v 1.1.1.1 2008/06/28 11:36:22 hoka_adam Exp $
#
DISTNAME= docker-1.5
CATEGORIES= x11
MASTER_SITES= http://offload1.icculus.org/openbox/2/docker/
PKG_DESTDIR_SUPPORT= user-destdir
MAINTAINER= adam.hoka@gmail.com
HOMEPAGE= http://icculus.org/openbox/2/docker/
COMMENT= WindowMaker dock app which acts as a system tray
USE_TOOLS+= pkg-config gmake
MAKE_ENV+= PREFIX=${DESTDIR}${PREFIX}
MAKE_ENV+= XLIBPATH=${X11BASE}
INSTALLATION_DIRS+= bin
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/docker ${DESTDIR}${PREFIX}/bin/
.include "../../devel/glib2/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,2 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2008/06/28 11:36:22 hoka_adam Exp $
bin/docker

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2008/06/28 11:36:22 hoka_adam Exp $
SHA1 (docker-1.5.tar.gz) = aff3e0c6103a7b1f190d4207868ae7c28d267304
RMD160 (docker-1.5.tar.gz) = d36883acf4de5c2e97d478a7d29cb66645189748
Size (docker-1.5.tar.gz) = 14863 bytes
SHA1 (patch-aa) = be91c68b6b9e16434e11b0567338ee9fa2b040eb

View file

@ -1,16 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2008/06/28 11:36:22 hoka_adam Exp $
--- Makefile.orig 2002-11-20 11:20:49.000000000 +0100
+++ Makefile
@@ -5,9 +5,9 @@
#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
# Change this PREFIX to where you want docker to be installed
-PREFIX=/usr/local
+PREFIX?=/usr/local
# Change this XLIBPATH to point to your X11 development package's installation
-XLIBPATH=/usr/X11R6/lib
+XLIBPATH?=/usr/X11R6/lib
# Sets some flags for stricter compiling
CFLAGS=-pedantic -Wall -W -O