Changes in FS-UAE 2.5.27dev:
Implemented prefix expansion for screenshots_output_dir. Implemented joystick_port_0_autoswitch = 0 for the relatively new automatic mouse mode switching feature (in order to disable it). Updated emulation core from WinUAE 3100b6.
This commit is contained in:
parent
3948feb05b
commit
c9823a1058
5 changed files with 24 additions and 85 deletions
|
@ -1,56 +1,33 @@
|
|||
# $NetBSD: Makefile,v 1.7 2014/12/24 20:17:47 rhialto Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2015/02/10 13:59:53 moubctez Exp $
|
||||
|
||||
VERSION= 2.5.22dev
|
||||
DISTNAME= fs-uae-${VERSION}
|
||||
DISTNAME= fs-uae-2.5.27dev
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://fs-uae.net/fs-uae/devel/${VERSION}/
|
||||
MASTER_SITES= http://fs-uae.net/fs-uae/devel/${PKGVERSION_NOREV}/
|
||||
|
||||
MAINTAINER= rhialto@falu.nl
|
||||
HOMEPAGE= http://fs-uae.net/
|
||||
COMMENT= FS-UAE Amiga Emulator
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
#USE_TOOLS+= gmake
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_TOOLS+= autoheader automake autoconf
|
||||
USE_LANGUAGES+= c c++
|
||||
GNU_CONFIGURE= yes
|
||||
#MAKE_JOBS_SAFE= no
|
||||
#WRKSRC= ${WRKDIR}/fs-uae-2.5.8dev
|
||||
# The default value of WRKSRC is ${WRKDIR}/${DISTNAME}.
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= pkg-config zip
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
PKG_CFLAGS= -I${BUILDLINK_PREFIX.openal}/include
|
||||
PKG_LDFLAGS= ${COMPILER_RPATH_FLAG}${BUILDLINK_PREFIX.openal}/lib
|
||||
PKG_LDFLAGS+= -L${BUILDLINK_PREFIX.openal}/lib
|
||||
|
||||
BUILD_ENV+= X11_CFLAGS=-I${BUILDLINK_PREFIX.libX11}/include
|
||||
BUILD_ENV+= X11_LDFLAGS=${X11_LDFLAGS}
|
||||
BUILD_ENV+= PKG_CFLAGS=${PKG_CFLAGS}
|
||||
BUILD_ENV+= PKG_LDFLAGS=${PKG_LDFLAGS}
|
||||
|
||||
INSTALL_ENV+= prefix=${PREFIX}
|
||||
INSTALL_ENV+= DESTDIR=${DESTDIR}
|
||||
|
||||
#pre-configure:
|
||||
# cd ${WRKSRC} && ./bootstrap.sh
|
||||
|
||||
# My notes say that building fails on NetBSD 6.0 and that 6.1 headers
|
||||
# are required.
|
||||
|
||||
#BUILD_DEPENDS+= python34>=3:../../lang/python34
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.if ${OPSYS} != "Darwin"
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../graphics/glu/buildlink3.mk"
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../x11/libXi/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
.include "../../audio/openal/buildlink3.mk"
|
||||
.include "../../devel/SDL2/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../graphics/freetype2/buildlink3.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
#.include "../../multimedia/libmpeg2/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
|
||||
# This does not include fs-uae-launcher any more.
|
||||
# See its own pkgsrc/wip entry.
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2014/12/24 20:17:47 rhialto Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2015/02/10 13:59:53 moubctez Exp $
|
||||
bin/fs-uae
|
||||
bin/fs-uae-device-helper
|
||||
share/applications/fs-uae.desktop
|
||||
|
@ -96,8 +96,10 @@ share/fs-uae/input/p880_12_4_1_0_windows.conf
|
|||
share/fs-uae/input/playstation_r_3_controller_19_4_0_0_macosx.conf
|
||||
share/fs-uae/input/ps3_usb_cordless_gamepad_13_4_1_0_macosx.conf
|
||||
share/fs-uae/input/ps3_usb_cordless_gamepad_13_4_1_0_windows.conf
|
||||
share/fs-uae/input/retrolink/usb_gamepad_10_2_0_0_linux.ini
|
||||
share/fs-uae/input/saitek/dual_analog_gamepad.ini
|
||||
share/fs-uae/input/saitek/p880.ini
|
||||
share/fs-uae/input/saitek/x52_flight_control_system.ini
|
||||
share/fs-uae/input/sony/computer_entertainment_wireless_inputdevice.ini
|
||||
share/fs-uae/input/sony/playstation_r_3_controller.ini
|
||||
share/fs-uae/input/sony/playstation_r_3_inputdevice.ini
|
||||
|
@ -106,15 +108,17 @@ share/fs-uae/input/speed_link_competition_pro_4_2_0_0_windows.conf
|
|||
share/fs-uae/input/speedlink_strike_2_gamepad_12_5_1_0_windows.conf
|
||||
share/fs-uae/input/thrustmaster/2_in_1_dt.ini
|
||||
share/fs-uae/input/thrustmaster/t_mini_wireless.ini
|
||||
share/fs-uae/input/thrustmaster/top_gun_fox_2_pro.ini
|
||||
share/fs-uae/input/universal_gamepad.ini
|
||||
share/fs-uae/input/unknown.ini
|
||||
share/fs-uae/input/wireless_controller_14_6_1_0_macosx.conf
|
||||
share/fs-uae/input/wisegroup_ltd/mp_8866_dual_usb_joypad.ini
|
||||
share/fs-uae/input/wisegroup_ltd/tigergame_ps_ps2_game_controller_adapter.ini
|
||||
share/fs-uae/input/xgaming/x_arcade.ini
|
||||
share/fs-uae/input/xgaming/x_arcade_right.ini
|
||||
share/fs-uae/input/xinput_controller_15_6_0_0_windows.conf
|
||||
share/fs-uae/input/zeemote/steelseries_free.ini
|
||||
share/fs-uae/item_background.png
|
||||
share/fs-uae/input/wireless_controller_14_6_1_0_macosx.conf
|
||||
share/fs-uae/led-bars-edge/audio_led_1.png
|
||||
share/fs-uae/led-bars-edge/audio_led_2.png
|
||||
share/fs-uae/led-bars-edge/audio_led_3.png
|
||||
|
|
|
@ -1,10 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.7 2014/12/24 20:17:47 rhialto Exp $
|
||||
$NetBSD: distinfo,v 1.8 2015/02/10 13:59:54 moubctez Exp $
|
||||
|
||||
SHA1 (fs-uae-2.5.22dev.tar.gz) = f4df95118b09f0ab1d1e8e6142cf1efa6ec2e366
|
||||
RMD160 (fs-uae-2.5.22dev.tar.gz) = 1accc77fea573e5051f3b19c59b2ae7a3b31383a
|
||||
Size (fs-uae-2.5.22dev.tar.gz) = 4737085 bytes
|
||||
SHA1 (patch-libfsemu_src_emu_video.c) = 963291a9f539d5a0fe2ea99cc0414a8d60423277
|
||||
SHA1 (fs-uae-2.5.27dev.tar.gz) = 47e8876ed0b575f53262d33c639f7640b8f9f244
|
||||
RMD160 (fs-uae-2.5.27dev.tar.gz) = 5903a0cd88b5addcb90349fdd22b91e2d02c5a48
|
||||
Size (fs-uae-2.5.27dev.tar.gz) = 4767573 bytes
|
||||
SHA1 (patch-libfsemu_src_ml_x11.c) = c491fd844b08d23744a138890c0b370307dd84c2
|
||||
SHA1 (patch-manymouse_x11__xinput2.c) = 9b2891d1ce62affb694ac11b2386115799ed6fa9
|
||||
SHA1 (patch-src_fs-uae_video.c) = 283386487d1c78dfef31e3a2a675f4f24f6ceda4
|
||||
SHA1 (patch-src_od-fs_bsdsocket__posix.cpp) = 78ecdd2efe903fdebfb0e144a4fc775296b73048
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-libfsemu_src_emu_video.c,v 1.1 2014/12/24 20:17:47 rhialto Exp $
|
||||
|
||||
NetBSD has no `long double roundl(long double)'. Fortunately these calls
|
||||
don't need such precision.
|
||||
|
||||
--- libfsemu/src/emu/video.c.orig 2014-09-27 12:00:45.000000000 +0000
|
||||
+++ libfsemu/src/emu/video.c
|
||||
@@ -112,7 +112,7 @@ void fs_emu_set_video_frame_rate(double
|
||||
last_frame_rate = frame_rate;
|
||||
last_frame_rate_host = g_fs_emu_video_frame_rate_host;
|
||||
|
||||
- int frame_rate_i = roundl(frame_rate);
|
||||
+ int frame_rate_i = round(frame_rate);
|
||||
fs_log("fs_emu_set_video_frame_rate: %0.2f (%d)\n",
|
||||
frame_rate, frame_rate_i);
|
||||
g_video_frame_rate = frame_rate;
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-src_fs-uae_video.c,v 1.1 2014/12/24 20:17:47 rhialto Exp $
|
||||
|
||||
NetBSD has no `long double roundl(long double)'. Fortunately these calls
|
||||
don't need such precision.
|
||||
|
||||
--- src/fs-uae/video.c.orig 2014-10-20 10:07:57.000000000 +0000
|
||||
+++ src/fs-uae/video.c
|
||||
@@ -581,13 +581,13 @@ static void display_screen()
|
||||
}
|
||||
#endif
|
||||
fs_emu_video_buffer_set_current(g_buffer);
|
||||
- if (roundl(g_last_refresh_rate) == -1) {
|
||||
- if (roundl(fs_emu_get_video_frame_rate()) != TURBO_FRAME_RATE) {
|
||||
+ if (round(g_last_refresh_rate) == -1) {
|
||||
+ if (round(fs_emu_get_video_frame_rate()) != TURBO_FRAME_RATE) {
|
||||
fs_emu_notification(45194412, _("Warp mode enabled"));
|
||||
}
|
||||
fs_emu_set_video_frame_rate(TURBO_FRAME_RATE);
|
||||
} else {
|
||||
- if (roundl(fs_emu_get_video_frame_rate()) == TURBO_FRAME_RATE) {
|
||||
+ if (round(fs_emu_get_video_frame_rate()) == TURBO_FRAME_RATE) {
|
||||
fs_emu_notification(45194412, _("Warp mode disabled"));
|
||||
}
|
||||
fs_emu_set_video_frame_rate(g_last_refresh_rate);
|
Loading…
Reference in a new issue