Update to firefox-4.0b8

Current development seems to focus on WebGL, but sadly not for our platform.
This commit is contained in:
Tobias Nygren 2010-12-22 21:09:40 +00:00 committed by Thomas Klausner
parent 7b7ea67a11
commit cd246fd925
11 changed files with 95 additions and 70 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.45 2010/06/30 08:19:59 tnn2 Exp $
# $NetBSD: Makefile,v 1.46 2010/12/22 21:09:40 tnn2 Exp $
.include "../../wip/xulrunner/dist.mk"
PKGNAME= firefox-${FIREFOX_VER}
@ -14,6 +14,8 @@ MOZILLA_DIR= # empty
CONFIGURE_ARGS+= --enable-application=browser
CONFIGURE_ARGS+= --with-libxul-sdk=${PREFIX}/lib/xulrunner-sdk
CONFIGURE_ARGS+= --with-system-libxul
# XXX tnn with omnijar enabled it just doesn't start
CONFIGURE_ARGS+= --enable-chrome-format=flat
ALL_ENV+= MOZILLA_PKG_NAME=firefox
@ -31,6 +33,8 @@ MOZILLA_ICON= ${WRKSRC}/browser/branding/unofficial/default48.png
pre-configure:
cd ${WRKSRC} && autoconf
# XXX not built here, just to make check-portability.awk shut up.
cd ${WRKSRC}/js/src && autoconf
post-build:
${SED} -e 's|@MOZILLA@|${MOZILLA}|g' \

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.25 2010/11/11 14:11:54 tnn2 Exp $
@comment $NetBSD: PLIST,v 1.26 2010/12/22 21:09:40 tnn2 Exp $
bin/firefox
lib/firefox/README.txt
lib/firefox/application.ini
@ -52,7 +52,6 @@ lib/firefox/chrome/browser/content/browser/migration/migration.xul
lib/firefox/chrome/browser/content/browser/nsContextMenu.js
lib/firefox/chrome/browser/content/browser/openLocation.js
lib/firefox/chrome/browser/content/browser/openLocation.xul
lib/firefox/chrome/browser/content/browser/pageReportFirstTime.xul
lib/firefox/chrome/browser/content/browser/pageinfo/feeds.js
lib/firefox/chrome/browser/content/browser/pageinfo/feeds.xml
lib/firefox/chrome/browser/content/browser/pageinfo/pageInfo.css
@ -131,6 +130,8 @@ lib/firefox/chrome/browser/content/browser/search/search.xml
lib/firefox/chrome/browser/content/browser/search/searchbarBindings.css
lib/firefox/chrome/browser/content/browser/setDesktopBackground.js
lib/firefox/chrome/browser/content/browser/setDesktopBackground.xul
lib/firefox/chrome/browser/content/browser/syncAddDevice.js
lib/firefox/chrome/browser/content/browser/syncAddDevice.xul
lib/firefox/chrome/browser/content/browser/syncGenericChange.js
lib/firefox/chrome/browser/content/browser/syncGenericChange.xul
lib/firefox/chrome/browser/content/browser/syncKey.xhtml
@ -268,7 +269,6 @@ lib/firefox/chrome/en-US/locale/browser/openLocation.dtd
lib/firefox/chrome/en-US/locale/browser/openLocation.properties
lib/firefox/chrome/en-US/locale/browser/pageInfo.dtd
lib/firefox/chrome/en-US/locale/browser/pageInfo.properties
lib/firefox/chrome/en-US/locale/browser/pageReportFirstTime.dtd
lib/firefox/chrome/en-US/locale/browser/places/bookmarkProperties.properties
lib/firefox/chrome/en-US/locale/browser/places/editBookmarkOverlay.dtd
lib/firefox/chrome/en-US/locale/browser/places/moveBookmarks.dtd
@ -359,17 +359,16 @@ lib/firefox/firefox
lib/firefox/icons/document.png
lib/firefox/icons/mozicon128.png
lib/firefox/modules/HUDService.jsm
lib/firefox/modules/NetworkHelper.jsm
lib/firefox/modules/NetworkPrioritizer.jsm
lib/firefox/modules/PlacesUIUtils.jsm
lib/firefox/modules/PropertyPanel.jsm
lib/firefox/modules/distribution.js
lib/firefox/modules/domplate.jsm
lib/firefox/modules/openLocationLastURL.jsm
lib/firefox/modules/services-crypto/WeaveCrypto.js
lib/firefox/modules/services-sync/auth.js
lib/firefox/modules/services-sync/base_records/collection.js
lib/firefox/modules/services-sync/base_records/crypto.js
lib/firefox/modules/services-sync/base_records/keys.js
lib/firefox/modules/services-sync/base_records/wbo.js
lib/firefox/modules/services-sync/constants.js
lib/firefox/modules/services-sync/engines.js
@ -385,6 +384,7 @@ lib/firefox/modules/services-sync/ext/Preferences.js
lib/firefox/modules/services-sync/ext/StringBundle.js
lib/firefox/modules/services-sync/ext/Sync.js
lib/firefox/modules/services-sync/identity.js
lib/firefox/modules/services-sync/jpakeclient.js
lib/firefox/modules/services-sync/log4moz.js
lib/firefox/modules/services-sync/main.js
lib/firefox/modules/services-sync/notifications.js

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.27 2010/11/11 14:11:54 tnn2 Exp $
@comment $NetBSD: PLIST,v 1.28 2010/12/22 21:09:40 tnn2 Exp $
bin/xulrunner
${PLIST.jit}include/xulrunner/Allocator.h
${PLIST.jit}include/xulrunner/Assembler.h
@ -98,7 +98,6 @@ include/xulrunner/gfxRect.h
include/xulrunner/gfxSkipChars.h
include/xulrunner/gfxTextRunCache.h
include/xulrunner/gfxTextRunWordCache.h
include/xulrunner/gfxThebesUtils.h
include/xulrunner/gfxTypes.h
include/xulrunner/gfxUserFontSet.h
include/xulrunner/gfxUtils.h
@ -298,6 +297,7 @@ include/xulrunner/mozilla/FileUtils.h
include/xulrunner/mozilla/FunctionTimer.h
include/xulrunner/mozilla/GenericFactory.h
include/xulrunner/mozilla/IHistory.h
include/xulrunner/mozilla/IntentionalCrash.h
include/xulrunner/mozilla/Module.h
include/xulrunner/mozilla/ModuleLoader.h
include/xulrunner/mozilla/ModuleUtils.h
@ -332,6 +332,7 @@ include/xulrunner/mozilla/dom/indexedDB/IDBRequest.h
include/xulrunner/mozilla/dom/indexedDB/IDBTransaction.h
include/xulrunner/mozilla/dom/indexedDB/IndexedDatabase.h
include/xulrunner/mozilla/dom/indexedDB/IndexedDatabaseManager.h
include/xulrunner/mozilla/dom/indexedDB/Key.h
include/xulrunner/mozilla/dom/indexedDB/LazyIdleThread.h
include/xulrunner/mozilla/ipc/DocumentRendererChild.h
include/xulrunner/mozilla/ipc/DocumentRendererNativeIDChild.h
@ -352,6 +353,7 @@ include/xulrunner/mozilla/scache/StartupCacheUtils.h
include/xulrunner/mozilla/storage.h
include/xulrunner/mozilla/storage/Variant.h
include/xulrunner/mozilla/storage/Variant_inl.h
include/xulrunner/mozilla/threads/nsThreadIDs.h
include/xulrunner/mozilla/unused.h
include/xulrunner/mozpngconf.h
${PLIST.jit}include/xulrunner/nanojit.h
@ -365,7 +367,9 @@ include/xulrunner/npapi.h
include/xulrunner/npfunctions.h
include/xulrunner/npruntime.h
include/xulrunner/nptypes.h
include/xulrunner/nsAHtml5FragmentParser.h
include/xulrunner/nsARIAGridAccessibleWrap.h
include/xulrunner/nsARIAMap.h
include/xulrunner/nsASocketHandler.h
include/xulrunner/nsAString.h
include/xulrunner/nsAXPCNativeCallContext.h
@ -466,6 +470,7 @@ include/xulrunner/nsCoreAnimationSupport.h
include/xulrunner/nsCppSharedAllocator.h
include/xulrunner/nsCycleCollectionParticipant.h
include/xulrunner/nsCycleCollector.h
include/xulrunner/nsCycleCollectorUtils.h
include/xulrunner/nsDOMCID.h
include/xulrunner/nsDOMCSSAttrDeclaration.h
include/xulrunner/nsDOMCSSDeclaration.h
@ -663,7 +668,6 @@ include/xulrunner/nsICancelable.h
include/xulrunner/nsICanvasElementExternal.h
include/xulrunner/nsICanvasGLPrivate.h
include/xulrunner/nsICanvasRenderingContextInternal.h
include/xulrunner/nsICanvasRenderingContextWebGL.h
include/xulrunner/nsICapturePicker.h
include/xulrunner/nsICaseConversion.h
include/xulrunner/nsICategoryManager.h
@ -845,6 +849,7 @@ include/xulrunner/nsIDOMGeoPositionError.h
include/xulrunner/nsIDOMGeoPositionErrorCallback.h
include/xulrunner/nsIDOMGeoPositionOptions.h
include/xulrunner/nsIDOMGetSVGDocument.h
include/xulrunner/nsIDOMGlobalPropertyInitializer.h
include/xulrunner/nsIDOMHTMLAnchorElement.h
include/xulrunner/nsIDOMHTMLAppletElement.h
include/xulrunner/nsIDOMHTMLAreaElement.h
@ -1098,6 +1103,7 @@ include/xulrunner/nsIDOMUIListener.h
include/xulrunner/nsIDOMUserDataHandler.h
include/xulrunner/nsIDOMValidityState.h
include/xulrunner/nsIDOMViewCSS.h
include/xulrunner/nsIDOMWebGLRenderingContext.h
include/xulrunner/nsIDOMWindow.h
include/xulrunner/nsIDOMWindow2.h
include/xulrunner/nsIDOMWindowCollection.h
@ -1264,6 +1270,7 @@ include/xulrunner/nsIHTMLCollection.h
include/xulrunner/nsIHTMLContentSink.h
include/xulrunner/nsIHTMLDocument.h
include/xulrunner/nsIHTMLEditor.h
include/xulrunner/nsIHTMLEditor_MOZILLA_2_0_BRANCH.h
include/xulrunner/nsIHTMLInlineTableEditor.h
include/xulrunner/nsIHTMLObjectResizeListener.h
include/xulrunner/nsIHTMLObjectResizer.h
@ -1271,6 +1278,7 @@ include/xulrunner/nsIHTMLToTextSink.h
include/xulrunner/nsIHTTPHeaderListener.h
include/xulrunner/nsIHTTPIndex.h
include/xulrunner/nsIHandlerService.h
include/xulrunner/nsIHapticFeedback.h
include/xulrunner/nsIHashable.h
include/xulrunner/nsIHelperAppLauncherDialog.h
include/xulrunner/nsIHistoryEntry.h
@ -1280,6 +1288,7 @@ include/xulrunner/nsIHttpAuthenticableChannel.h
include/xulrunner/nsIHttpAuthenticator.h
include/xulrunner/nsIHttpChannel.h
include/xulrunner/nsIHttpChannelAuthProvider.h
include/xulrunner/nsIHttpChannelChild.h
include/xulrunner/nsIHttpChannelInternal.h
include/xulrunner/nsIHttpEventSink.h
include/xulrunner/nsIHttpHeaderVisitor.h
@ -1302,6 +1311,7 @@ include/xulrunner/nsIIDBVersionChangeEvent.h
include/xulrunner/nsIIDBVersionChangeRequest.h
include/xulrunner/nsIIDNService.h
include/xulrunner/nsIIFrameBoxObject.h
include/xulrunner/nsIIMEPicker.h
include/xulrunner/nsIINIParser.h
include/xulrunner/nsIIOService.h
include/xulrunner/nsIIOService2.h
@ -1933,8 +1943,6 @@ include/xulrunner/nsSVGFilterInstance.h
include/xulrunner/nsSVGForeignObjectFrame.h
include/xulrunner/nsSVGIntegrationUtils.h
include/xulrunner/nsSVGMatrix.h
include/xulrunner/nsSVGNumber.h
include/xulrunner/nsSVGPoint.h
include/xulrunner/nsSVGRect.h
include/xulrunner/nsSVGUtils.h
include/xulrunner/nsScannerString.h
@ -1977,6 +1985,7 @@ include/xulrunner/nsSupportsArray.h
include/xulrunner/nsSupportsPrimitives.h
include/xulrunner/nsSystemPrefLog.h
include/xulrunner/nsSystemPrefService.h
include/xulrunner/nsTArray-inl.h
include/xulrunner/nsTArray.h
include/xulrunner/nsTDependentString.h
include/xulrunner/nsTDependentSubstring.h
@ -2290,6 +2299,7 @@ include/xulrunner/txIXPathObject.h
include/xulrunner/uconvutil.h
include/xulrunner/utilrename.h
include/xulrunner/vorbis/codec.h
include/xulrunner/vpx/arm.h
include/xulrunner/vpx/config.h
include/xulrunner/vpx/mem.h
include/xulrunner/vpx/scale_mode.h
@ -2373,6 +2383,8 @@ lib/xulrunner/chrome/pippki.jar
lib/xulrunner/chrome/pippki.manifest
lib/xulrunner/chrome/toolkit.jar
lib/xulrunner/chrome/toolkit.manifest
lib/xulrunner/components/ConsoleAPI.js
lib/xulrunner/components/ConsoleAPI.manifest
lib/xulrunner/components/FeedProcessor.js
lib/xulrunner/components/FeedProcessor.manifest
lib/xulrunner/components/GPSDGeolocationProvider.js
@ -2725,7 +2737,6 @@ share/idl/xulrunner/nsICacheVisitor.idl
share/idl/xulrunner/nsICachingChannel.idl
share/idl/xulrunner/nsICancelable.idl
share/idl/xulrunner/nsICanvasGLPrivate.idl
share/idl/xulrunner/nsICanvasRenderingContextWebGL.idl
share/idl/xulrunner/nsICapturePicker.idl
share/idl/xulrunner/nsICategoryManager.idl
share/idl/xulrunner/nsICertOverrideService.idl
@ -2888,6 +2899,7 @@ share/idl/xulrunner/nsIDOMGeoPositionError.idl
share/idl/xulrunner/nsIDOMGeoPositionErrorCallback.idl
share/idl/xulrunner/nsIDOMGeoPositionOptions.idl
share/idl/xulrunner/nsIDOMGetSVGDocument.idl
share/idl/xulrunner/nsIDOMGlobalPropertyInitializer.idl
share/idl/xulrunner/nsIDOMHTMLAnchorElement.idl
share/idl/xulrunner/nsIDOMHTMLAppletElement.idl
share/idl/xulrunner/nsIDOMHTMLAreaElement.idl
@ -3134,6 +3146,7 @@ share/idl/xulrunner/nsIDOMUIEvent.idl
share/idl/xulrunner/nsIDOMUserDataHandler.idl
share/idl/xulrunner/nsIDOMValidityState.idl
share/idl/xulrunner/nsIDOMViewCSS.idl
share/idl/xulrunner/nsIDOMWebGLRenderingContext.idl
share/idl/xulrunner/nsIDOMWindow.idl
share/idl/xulrunner/nsIDOMWindow2.idl
share/idl/xulrunner/nsIDOMWindowCollection.idl
@ -3274,12 +3287,14 @@ share/idl/xulrunner/nsIGlobalHistory3.idl
share/idl/xulrunner/nsIGnomeVFSService.idl
share/idl/xulrunner/nsIHTMLAbsPosEditor.idl
share/idl/xulrunner/nsIHTMLEditor.idl
share/idl/xulrunner/nsIHTMLEditor_MOZILLA_2_0_BRANCH.idl
share/idl/xulrunner/nsIHTMLInlineTableEditor.idl
share/idl/xulrunner/nsIHTMLObjectResizeListener.idl
share/idl/xulrunner/nsIHTMLObjectResizer.idl
share/idl/xulrunner/nsIHTTPHeaderListener.idl
share/idl/xulrunner/nsIHTTPIndex.idl
share/idl/xulrunner/nsIHandlerService.idl
share/idl/xulrunner/nsIHapticFeedback.idl
share/idl/xulrunner/nsIHashable.idl
share/idl/xulrunner/nsIHelperAppLauncherDialog.idl
share/idl/xulrunner/nsIHistoryEntry.idl
@ -3289,6 +3304,7 @@ share/idl/xulrunner/nsIHttpAuthenticableChannel.idl
share/idl/xulrunner/nsIHttpAuthenticator.idl
share/idl/xulrunner/nsIHttpChannel.idl
share/idl/xulrunner/nsIHttpChannelAuthProvider.idl
share/idl/xulrunner/nsIHttpChannelChild.idl
share/idl/xulrunner/nsIHttpChannelInternal.idl
share/idl/xulrunner/nsIHttpEventSink.idl
share/idl/xulrunner/nsIHttpHeaderVisitor.idl
@ -3310,6 +3326,7 @@ share/idl/xulrunner/nsIIDBVersionChangeEvent.idl
share/idl/xulrunner/nsIIDBVersionChangeRequest.idl
share/idl/xulrunner/nsIIDNService.idl
share/idl/xulrunner/nsIIFrameBoxObject.idl
share/idl/xulrunner/nsIIMEPicker.idl
share/idl/xulrunner/nsIINIParser.idl
share/idl/xulrunner/nsIIOService.idl
share/idl/xulrunner/nsIIOService2.idl

View file

@ -1,11 +1,11 @@
# $NetBSD: dist.mk,v 1.22 2010/11/11 14:11:54 tnn2 Exp $
# $NetBSD: dist.mk,v 1.23 2010/12/22 21:09:40 tnn2 Exp $
#
# used by wip/xulrunner/Makefile
# used by wip/firefox/Makefile
DISTNAME= firefox-${FIREFOX_VER}.source
FIREFOX_VER= 4.0b7${MOZ_BRANCH_MINOR}
MOZ_BRANCH= 2.0b7
FIREFOX_VER= 4.0b8${MOZ_BRANCH_MINOR}
MOZ_BRANCH= 2.0b8
MOZ_BRANCH_MINOR= # empty
MASTER_SITES= ${MASTER_SITE_MOZILLA:=firefox/releases/${FIREFOX_VER}/source/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.40 2010/11/11 14:11:54 tnn2 Exp $
$NetBSD: distinfo,v 1.41 2010/12/22 21:09:40 tnn2 Exp $
SHA1 (firefox-4.0b7.source.tar.bz2) = 57d4a079e639289ffd09a5779a5514c09889a6b8
RMD160 (firefox-4.0b7.source.tar.bz2) = dc74a11272e9bdb1b94e3f42cd2e50fdace141c1
Size (firefox-4.0b7.source.tar.bz2) = 63865025 bytes
SHA1 (patch-aa) = 2a76e59189da097cc63382ff0ebddd30bd1e84bd
SHA1 (firefox-4.0b8.source.tar.bz2) = 40ba6915d736d69e3bcc64365002eedf4a02c8d3
RMD160 (firefox-4.0b8.source.tar.bz2) = b2d2faed1a3b71a1e0a605e66dbf63df0180b8c3
Size (firefox-4.0b8.source.tar.bz2) = 64222944 bytes
SHA1 (patch-aa) = cbf636b05f5bb2165fa335dab83d25e78053cdb2
SHA1 (patch-ab) = 5d4b7512f8bbdc9e2e05709cec5b36dc12c25997
SHA1 (patch-ac) = e50356963fd235ea11fa45baae356fcf21c6669d
SHA1 (patch-ad) = 7afb960af4e4a311481e7a7b25008ca9b9f7fba1
@ -12,18 +12,18 @@ SHA1 (patch-af) = 13a9617cd2894cf342487d2a9cfe8cf3066ba0df
SHA1 (patch-ag) = a924296e6a569eba4229d661fbe5290eeeb999e0
SHA1 (patch-ah) = 5f8bf19d5ac5ea7e263366a56d10d2eeeee61bac
SHA1 (patch-ai) = 3444882b0f7f4b63273d8888af88be35ae60933a
SHA1 (patch-aj) = 0fec43ca6494cf4270767a3a42afaf5d7f56bd96
SHA1 (patch-aj) = 78803641532203f878fc99ead9a440b8bf425aeb
SHA1 (patch-ak) = 5c08fcfa1eeecb7c7f33c8fe21f8bb48feb001c8
SHA1 (patch-al) = 7f369b954c413bd52f89236c5dfcc237d72150a5
SHA1 (patch-am) = 75eb92d1941309ffc13f01d7f1946a2f09170220
SHA1 (patch-an) = e975941955b578f1d3336d546e99f0c464cdd9d7
SHA1 (patch-ao) = 353d2098564c7b29849b6f5f4f80d9ac393b23f3
SHA1 (patch-as) = fb6230d3b7dc18713fc914627afee6209634716d
SHA1 (patch-as) = 899485d9d92bbf646c2f5bb475ce502058cc5da7
SHA1 (patch-at) = 957fe2024b96bea83d8e833feb8c1f0c03d0dd0a
SHA1 (patch-au) = 0dd9b816379adb98c10e65db9635da891a991495
SHA1 (patch-av) = e22c544894123a6ab8fc428067716b9e68685771
SHA1 (patch-aw) = eed2f98b732fa776d2ca64d2b82e88677a207657
SHA1 (patch-ax) = 579041ecba36dfa0d42d3ab576e79ecf2321749d
SHA1 (patch-ax) = e3a07dcb1bb3195e35673f9d0b43b67b4c66a04e
SHA1 (patch-ay) = 6ddcbbd3f0197fb88622fc32d6d0fd602ec4ad34
SHA1 (patch-az) = 5a09ccfa14fab962c4e2916f00669a1fa4a8ade4
SHA1 (patch-ba) = 9d4058f2a3a290429b26cb8335dd5b188bccc96d
@ -32,6 +32,7 @@ SHA1 (patch-be) = 723d74807830632ecd3b88e8271d91d73ac81be4
SHA1 (patch-bf) = 8d8b2868040ff043ebdbb09fc37d9ae2b598d70d
SHA1 (patch-bg) = 85d82348c43257eded6426ac84af9815619eb759
SHA1 (patch-bh) = 00af1e223524fe96876cca5910ff09e93a54c60b
SHA1 (patch-bi) = a79369cf0c7370a8655fe414cdb7c8ddb4c2d495
SHA1 (patch-ma) = a20b263ff14c841fd0ae1634962b90a41173b524
SHA1 (patch-mb) = 97e2b454f190ebc639908ee93c9f1217e0c147db
SHA1 (patch-md) = 6bf5242245b17fbd868a6a978eb5849726f81393
@ -42,7 +43,7 @@ SHA1 (patch-mi) = 787cb043bb7e687936afaf8f0c67b6b3a7b03e5b
SHA1 (patch-mj) = 197fab0e00256dedc8a5f181ee0d0d6e42d8177f
SHA1 (patch-mk) = 793dfa16e19e213d78995c893a28bc0d514135d9
SHA1 (patch-ml) = 9003af056e5b671b2345d0a75e99836746369c00
SHA1 (patch-mm) = 3fd57c47db4b543eb917f20c95bbf3dffd6a3eb9
SHA1 (patch-mm) = 17568bdd87d36dbd020d6148bbe245a1a43b2296
SHA1 (patch-mn) = a59f31b58547657b96a45a2753aab93866940203
SHA1 (patch-mp) = 18d2490b6bcd4f017cbf2734a920c3830bfe8856
SHA1 (patch-pa) = 11d8ec21533250a962d846e1d06b6a61722fcd60

View file

@ -1,17 +1,8 @@
$NetBSD: patch-aa,v 1.12 2010/11/11 14:11:54 tnn2 Exp $
$NetBSD: patch-aa,v 1.13 2010/12/22 21:09:40 tnn2 Exp $
--- configure.in.orig 2010-11-04 19:20:39.000000000 +0000
--- configure.in.orig 2010-12-15 01:02:33.000000000 +0000
+++ configure.in
@@ -801,7 +801,7 @@ EOF
AC_LANG_RESTORE
])
- if test "$ac_cv_have_std__Throw" == "yes"; then
+ if test "$ac_cv_have_std__Throw" = "yes"; then
AC_CACHE_CHECK(for |class __declspec(dllimport) exception| bug,
ac_cv_have_dllimport_exception_bug,
[
@@ -2084,7 +2084,7 @@ case "$target" in
@@ -2076,7 +2076,7 @@ case "$target" in
MOZ_FIX_LINK_PATHS='-Wl,-executable_path,$(LIBXUL_DIST)/bin'
;;
@ -20,7 +11,7 @@ $NetBSD: patch-aa,v 1.12 2010/11/11 14:11:54 tnn2 Exp $
if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo elf` != "elf"; then
DLL_SUFFIX=".so.1.0"
DSO_LDOPTS="-shared"
@@ -2092,6 +2092,9 @@ case "$target" in
@@ -2084,6 +2084,9 @@ case "$target" in
if test ! "$GNU_CC"; then
DSO_LDOPTS="-Bshareable $DSO_LDOPTS"
fi
@ -30,7 +21,7 @@ $NetBSD: patch-aa,v 1.12 2010/11/11 14:11:54 tnn2 Exp $
;;
ia64*-hpux*)
@@ -3389,6 +3392,9 @@ dnl ====================================
@@ -3380,6 +3383,9 @@ dnl ====================================
case $target in
*-hpux11.*)
;;
@ -40,7 +31,7 @@ $NetBSD: patch-aa,v 1.12 2010/11/11 14:11:54 tnn2 Exp $
*)
AC_CHECK_LIB(c_r, gethostbyname_r)
;;
@@ -4738,6 +4744,14 @@ if test -n "$YASM"; then
@@ -4727,6 +4733,14 @@ if test -n "$YASM"; then
_YASM_BUILD=` echo ${YASM_VERSION} | $AWK -F\. '{ print $4 }'`
fi
@ -55,16 +46,7 @@ $NetBSD: patch-aa,v 1.12 2010/11/11 14:11:54 tnn2 Exp $
if test -z "$SKIP_LIBRARY_CHECKS"; then
dnl system JPEG support
dnl ========================================================
@@ -6532,7 +6546,7 @@ if test -n "$MOZ_INSTALLER" -a "$OS_ARCH
changequote(,)
MAKENSISU_VER=`"$MAKENSISU" -version 2>/dev/null | sed -e '/-Unicode/!s/.*//g' -e 's/^v\([0-9]\+\.[0-9]\+\)\-Unicode$/\1/g'`
changequote([,])
- if test ! "$MAKENSISU_VER" == ""; then
+ if test ! "$MAKENSISU_VER" = ""; then
MAKENSISU_MAJOR_VER=`echo $MAKENSISU_VER | $AWK -F\. '{ print $1 }'`
MAKENSISU_MINOR_VER=`echo $MAKENSISU_VER | $AWK -F\. '{ print $2 }'`
fi
@@ -9299,7 +9313,8 @@ rm -f confdefs.h.save
@@ -9383,7 +9397,8 @@ rm -f confdefs.h.save
mv confdefs.h confdefs.h.save
egrep -v "$_EGREP_PATTERN" confdefs.h.save > confdefs.h
AC_OUTPUT_MAKE_DEFS()
@ -74,7 +56,7 @@ $NetBSD: patch-aa,v 1.12 2010/11/11 14:11:54 tnn2 Exp $
AC_SUBST(MOZ_DEFINES)
rm -f confdefs.h
mv confdefs.h.save confdefs.h
@@ -9397,6 +9412,8 @@ if test -z "$MOZ_NATIVE_NSPR"; then
@@ -9493,6 +9508,8 @@ if test -z "$MOZ_NATIVE_NSPR"; then
AC_MSG_WARN([Recreating autoconf.mk with updated nspr-config output])
if test "$OS_ARCH" != "WINNT" -a "$OS_ARCH" != "WINCE"; then
NSPR_LIBS=`./nsprpub/config/nspr-config --prefix=$LIBXUL_DIST --exec-prefix=$MOZ_BUILD_ROOT/dist --libdir=$LIBXUL_DIST/lib --libs`

View file

@ -1,16 +1,16 @@
$NetBSD: patch-aj,v 1.5 2010/03/16 20:12:06 tnn2 Exp $
$NetBSD: patch-aj,v 1.6 2010/12/22 21:09:40 tnn2 Exp $
--- profile/dirserviceprovider/src/nsProfileLock.cpp.orig 2010-03-16 01:02:50.000000000 +0000
--- profile/dirserviceprovider/src/nsProfileLock.cpp.orig 2010-12-15 01:03:34.000000000 +0000
+++ profile/dirserviceprovider/src/nsProfileLock.cpp
@@ -396,6 +396,7 @@ nsresult nsProfileLock::LockWithSymlink(
act.sa_flags = SA_SIGINFO;
@@ -405,6 +405,7 @@ nsresult nsProfileLock::LockWithSymlink(
#endif
sigfillset(&act.sa_mask);
+#ifndef DEBUG
#define CATCH_SIGNAL(signame) \
PR_BEGIN_MACRO \
if (sigaction(signame, NULL, &oldact) == 0 && \
@@ -414,6 +415,7 @@ PR_BEGIN_MACRO
@@ -423,6 +424,7 @@ PR_BEGIN_MACRO
CATCH_SIGNAL(SIGTERM);
#undef CATCH_SIGNAL

View file

@ -1,10 +1,19 @@
$NetBSD: patch-as,v 1.6 2010/05/31 09:24:04 tnn2 Exp $
$NetBSD: patch-as,v 1.7 2010/12/22 21:09:40 tnn2 Exp $
Treat DragonFly like FreeBSD.
--- js/src/configure.in.orig 2010-05-28 13:22:58.000000000 +0000
--- js/src/configure.in.orig 2010-12-15 01:03:04.000000000 +0000
+++ js/src/configure.in
@@ -1764,7 +1764,7 @@ case "$target" in
@@ -769,7 +769,7 @@ EOF
AC_LANG_RESTORE
])
- if test "$ac_cv_have_std__Throw" == "yes"; then
+ if test "$ac_cv_have_std__Throw" = "yes"; then
AC_CACHE_CHECK(for |class __declspec(dllimport) exception| bug,
ac_cv_have_dllimport_exception_bug,
[
@@ -2059,7 +2059,7 @@ case "$target" in
MOZ_FIX_LINK_PATHS='-Wl,-executable_path,$(LIBXUL_DIST)/bin'
;;
@ -13,7 +22,7 @@ Treat DragonFly like FreeBSD.
if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo elf` != "elf"; then
DLL_SUFFIX=".so.1.0"
DSO_LDOPTS="-shared"
@@ -2634,7 +2634,7 @@ case "$target" in
@@ -3018,7 +3018,7 @@ case "$target" in
*-solaris*)
AC_DEFINE(AVMPLUS_UNIX)
;;
@ -22,7 +31,7 @@ Treat DragonFly like FreeBSD.
AC_DEFINE(AVMPLUS_UNIX)
;;
*-gnu*)
@@ -4325,7 +4325,7 @@ if test "$MOZ_MEMORY"; then
@@ -4880,7 +4880,7 @@ if test "$MOZ_MEMORY"; then
*-darwin*)
AC_DEFINE(MOZ_MEMORY_DARWIN)
;;

View file

@ -1,13 +1,12 @@
$NetBSD: patch-ax,v 1.4 2009/12/02 15:03:01 tnn2 Exp $
$NetBSD: patch-ax,v 1.5 2010/12/22 21:09:40 tnn2 Exp $
--- xpcom/base/nsStackWalk.cpp.orig 2009-08-24 17:53:27.000000000 +0200
--- xpcom/base/nsStackWalk.cpp.orig 2010-12-15 01:03:41.000000000 +0000
+++ xpcom/base/nsStackWalk.cpp
@@ -1124,7 +1124,7 @@ NS_FormatCodeAddressDetails(void *aPC, c
#define __USE_GNU
@@ -1138,6 +1138,7 @@ NS_FormatCodeAddressDetails(void *aPC, c
#endif
-#if defined(HAVE_LIBDL) || defined(XP_MACOSX)
+#if defined(HAVE_LIBDL) || defined(XP_MACOSX) || defined(__NetBSD__)
#if defined(HAVE_DLOPEN) || defined(XP_MACOSX)
+#error this patch should be removed
#include <dlfcn.h>
#endif

View file

@ -0,0 +1,13 @@
$NetBSD: patch-bi,v 1.3 2010/12/22 21:09:40 tnn2 Exp $
--- gfx/angle/src/compiler/osinclude.h.orig 2010-12-15 01:02:57.000000000 +0000
+++ gfx/angle/src/compiler/osinclude.h
@@ -16,7 +16,7 @@
#define ANGLE_OS_WIN
#elif defined(__APPLE__) || defined(__linux__) || \
defined(__FreeBSD__) || defined(__OpenBSD__) || \
- defined(__sun)
+ defined(__sun) || defined(__NetBSD__) || defined(__DragonFly__)
#define ANGLE_OS_POSIX
#else
#error Unsupported platform.

View file

@ -1,8 +1,8 @@
$NetBSD: patch-mm,v 1.9 2010/11/11 14:11:54 tnn2 Exp $
$NetBSD: patch-mm,v 1.10 2010/12/22 21:09:40 tnn2 Exp $
--- toolkit/library/Makefile.in.orig 2010-11-04 19:20:39.000000000 +0000
--- toolkit/library/Makefile.in.orig 2010-12-15 01:03:37.000000000 +0000
+++ toolkit/library/Makefile.in
@@ -244,6 +244,13 @@ EXTRA_DSO_LDOPTS += -lelf -ldemangle
@@ -246,6 +246,13 @@ EXTRA_DSO_LDOPTS += -lelf -ldemangle
endif
endif
@ -14,5 +14,5 @@ $NetBSD: patch-mm,v 1.9 2010/11/11 14:11:54 tnn2 Exp $
+endif
+
ifeq ($(OS_ARCH),WINNT)
OS_LIBS += $(call EXPAND_LIBNAME,shell32 ole32 uuid version winspool comdlg32 imm32 winmm wsock32 msimg32 shlwapi psapi)
OS_LIBS += $(call EXPAND_LIBNAME,shell32 ole32 uuid version winspool comdlg32 imm32 winmm wsock32 msimg32 shlwapi psapi Ws2_32)
ifneq (,$(MOZ_DEBUG)$(NS_TRACE_MALLOC))