Update from v0.5.3 to v0.6.3

ChangeLog (after v0.5.3):
-------------------------
v0.6.4	- Do not hardwire localedir in src/Makefile.am, spotted by
	  Charles Clément.
	- A default rule set can be supplied in configuration file.
	- Fix possible segmentation fault if opponent in network play
	  doesn't write anything (division by zero).
	- Don't be so harsh about people with low typing skills:
	  Loser -> Beginner, ADP-Pro -> Learner
	- Status bar can be adjusted by locales.
	- Removed some probably offending words from words.eng.
	- Dropped min10 (cpm, i.e. cps * 60).
	- Replaced tcps with wpm, although it's just cps * 12.
	- Regine Müller spotted a serious typo in high score menu (de_DE).
v0.6.3	- New menu translations:
	  - fr_FR by Charles Clément and Sysyphe GEP
	  - it by Lapo Luchini
	- Typos fixed in french word list, patch by Charles Clément.
	- autotools problems fixed on Cygwin, spotted by Lapo Luchini.
	- Zap the silly dependency of m4 I introduced with 0.6.1.
	- Properly reset terminal if it is too small, patch by Charles Clément.
	- Fixed possibility to enter name with a blank in front of it,
	  spotted by vispi.
	- High score menu is not limited to top 10 anymore.
	- Fixed possible segfault if path names are too long (> MAXPATHLEN).
	- Windows code put into source (WIN32).
	- Wordlist/Ruleset menus can be left by pressing Escape.
	- All parameters supplied to typespeed not in getopt result in
	  usage.
	- Major network code improvements/bugfixes:
	  * closed file descriptor leakage in server code
	  * multiple network games per running session possible
	  * new function called gprint used in network code (better readable)
	  * check return value of ioctl (non-blocking mode OK?)
	  * you can abort while waiting for connections now
	  * a player name can be specified
	  * thin client support, i.e. retrieving word lists from a server
	  * new option --netlog=file logs network traffic; for debugging
	  * new network parameters for better comprehension by developer(s) :)
	  * high score sharing is locale-safe now (1.234 vs. 1,234)
	  * versions are compared in order to prevent version missmatches
v0.6.2	- Used random seed will be actualy saved now.
	- You can feed typespeed with specified random seed.
	- Fixed bug introduced with 0.6.1: enter/space is no longer
	  counted as typo if you have entered a correct word.
	- Do not let other persons flock high score file: this could
	  result in a denial of service.
	- Smoothness takes "yes" and "no" as argument.
	- "No High Scores" will be translated, too.
	- File selection menu is useable with vi-like key strokes (j, k).
	- Removed implementation-defined C-code like:
	     x[i++] = i;
	- Better testsuite framework support included.
	- Compilation of test suite on systems without gettext in libc
	  has been fixed.
	- Translate title of default rule set if selected.
	- Fixed buffer underrun in parseline that occured if a line in
	  configuration file (or game rule file) started with "=".
	- autotools improvements, spotted by Michael Sterrett:
	  * handle --docdir properly
	  * support for different high score dir (--with-highscoredir=DIR)
	- If working with strings, _always_ terminate with '\0' at end
	  of buffer, no matter how obvious it is that string fits anyway.
v0.6.1	- Added copy&paste cheat protection.
	- Added support for gettext.
	- SECURITY FIX: make sure privileges have been dropped.
	- Switched to autoconf and automake.
	- Typo spotted in french word list by David Jeannot.
v0.6.0  - Fixed statistics in case typoratio is 100 %.
	- Do not allow empty names for high score.
	- typespeed forces use of a terminal for stdout/stderr/stdin now.
	- Game rules can be changed by user.
	- setgid() by default - drops privileges as soon as highscore
	  file has been opened.
	- major change in highscores:
	  * switch to csv format
	  * only one highscore file for all wordlists
	  * cannot reset highscores anymore
	  * users can have their own highscore file
	- Use all available space on screen for words (position 0 not 1).
	- New testsuite design
	- wordlists are sorted alphabetically.
	- scandir replaced with opendir; readdir; closedir.
	  No more annoying gcc warnings about that on different systems
	  (like glibc based systems and bsd).
	- ISO-conform clear sequence (fixes warning),
	  by Alessandro Massignan.
	- Fixed bug in function keys.
	- German words are OK for childrens now.
	- Two bad words removed from english word list.
	- Unified wordlist names for languages (iso 639)
	- New C# wordlists by Nicolai Stoy
	- Fixed bug in network code: resulted in an endless loop at end
	  of the game.
This commit is contained in:
Hernani Marques Madeira 2008-02-12 18:22:03 +00:00 committed by Thomas Klausner
parent ece686a17d
commit cf13c4b1be
5 changed files with 59 additions and 41 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.13 2006/10/29 08:32:57 shattered Exp $
# $NetBSD: Makefile,v 1.14 2008/02/12 18:22:03 h2m Exp $
#
DISTNAME= typespeed-0.5.3
DISTNAME= typespeed-0.6.4
PKGREVISION= 1
CATEGORIES= games
MASTER_SITES= http://tobias.eyedacor.org/typespeed/
@ -11,19 +11,15 @@ HOMEPAGE= http://tobias.eyedacor.org/typespeed/
COMMENT= Game to measure your typing speed, with network mode
USE_LANGUAGES= c
GNU_CONFIGURE= YES
CONFIGURE_ARGS+= --prefix=${PREFIX}
SUBST_CLASSES+= man-paths
SUBST_STAGE.man-paths= pre-patch
SUBST_FILES.man-paths= typespeed.6
SUBST_FILES.man-paths= man/typespeed.6
SUBST_SED.man-paths= -e 's|/etc/|${PREFIX}/etc/|g'
SUBST_SED.man-paths+= -e 's|/usr/local|${PREFIX}|g'
SUBST_MESSAGE.man-paths= Adjusting paths in the game's man page
SUBST_CLASSES+= prefixpath
SUBST_STAGE.prefixpath= post-patch
SUBST_FILES.prefixpath= Makefile
SUBST_SED.prefixpath= -e 's|/usr/local|${PREFIX}|g'
SUBST_MESSAGE.prefixpath= Adjusting prefix path
SUBST_MESSAGE.man-paths= Adjusting path in the game's man page
.include "../../devel/ncurses/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,17 +1,27 @@
@comment $NetBSD: PLIST,v 1.3 2006/10/09 14:12:01 h2m Exp $
@comment $NetBSD: PLIST,v 1.4 2008/02/12 18:22:03 h2m Exp $
bin/typespeed
etc/typespeedrc
man/man6/typespeed.6
share/typespeed/words.dos
share/typespeed/words.dut
share/typespeed/words.eng
share/typespeed/words.fin
share/typespeed/words.fra
share/typespeed/words.ger
share/typespeed/words.ita
share/typespeed/words.portuguese
share/typespeed/words.prog
share/typespeed/words.spanish
share/typespeed/words.thai
share/typespeed/words.unix
@dirrm share/typespeed
@unexec echo Please delete var/games/typespeed, which holds the high scores, if you do not need them any longer.
share/doc/typespeed/README
share/typespeed/rules/rule.classic
share/typespeed/rules/rule.training
share/typespeed/rules/template
share/typespeed/words/words.csharp
share/typespeed/words/words.csharp_with_operators
share/typespeed/words/words.dos
share/typespeed/words/words.dut
share/typespeed/words/words.eng
share/typespeed/words/words.esp
share/typespeed/words/words.fin
share/typespeed/words/words.fra
share/typespeed/words/words.ger
share/typespeed/words/words.ita
share/typespeed/words/words.por
share/typespeed/words/words.prog
share/typespeed/words/words.tha
share/typespeed/words/words.unix
var/games/typespeed.score
@dirrm var/games
@dirrm share/typespeed/words
@dirrm share/typespeed/rules
@dirrm share/doc/typespeed

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2006/10/09 14:12:01 h2m Exp $
$NetBSD: distinfo,v 1.3 2008/02/12 18:22:03 h2m Exp $
SHA1 (typespeed-0.5.3.tar.gz) = 9c75b607339afce510127dd72083b6b6fcf4b814
RMD160 (typespeed-0.5.3.tar.gz) = fa34444e70134e4275db9e82ecff0739a341f61a
Size (typespeed-0.5.3.tar.gz) = 57541 bytes
SHA1 (patch-aa) = c8423a03445a3076244aff95be8b752ec2c5748a
SHA1 (typespeed-0.6.4.tar.gz) = e2383b746d20262282b0357a8954c9d3a734a911
RMD160 (typespeed-0.6.4.tar.gz) = b857333a5f9e07e54f49d94eaed66555a17cce0e
Size (typespeed-0.6.4.tar.gz) = 250596 bytes
SHA1 (patch-aa) = 8cba5a6384a01e2d043c2c1110c4d7bf432fc17e
SHA1 (patch-ab) = aaff7a55ff6e166bbd0caec55531c86b03884e36

View file

@ -1,13 +1,12 @@
$NetBSD: patch-aa,v 1.1 2006/10/09 14:12:01 h2m Exp $
$NetBSD: patch-aa,v 1.2 2008/02/12 18:22:03 h2m Exp $
--- Makefile.orig 2006-09-09 12:07:45.000000000 +0200
+++ Makefile
@@ -11,7 +11,7 @@ datarootdir = $(prefix)/share
datadir = $(datarootdir)
sysconfdir = $(prefix)/etc
localstatedir = $(prefix)/var
-mandir = $(datarootdir)/man
+mandir = $(prefix)/man
man6dir = $(mandir)/man6
srcdir = .
--- src/misc.c.orig 2007-11-29 22:40:09.000000000 +0100
+++ src/misc.c
@@ -38,6 +38,7 @@
#include <curses.h>
#include <ctype.h>
#include <errno.h>
+#include <stdarg.h>
#ifdef HAVE_STDLIB_H
#include <stdlib.h>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1 2008/02/12 18:22:03 h2m Exp $
--- src/network.c.orig 2007-11-29 22:40:09.000000000 +0100
+++ src/network.c
@@ -53,6 +53,7 @@
#include <ctype.h>
#include <curses.h>
#include <errno.h>
+#include <stdarg.h>
#ifdef HAVE_LIMITS_H
#include <limits.h>