Patches to help rubinius find llvm on netbsd

This commit is contained in:
Jaime Fournier 2011-05-29 07:06:55 +00:00 committed by Thomas Klausner
parent 79e86deeab
commit cf6a3afac4
5 changed files with 54 additions and 2 deletions

View file

@ -2,7 +2,9 @@ What is Rubinius
Rubinius is an implementation of the Ruby programming language.
Rubinius includes a bytecode virtual machine, Ruby syntax parser, bytecode compiler, generational garbage collector, just-in-time (JIT) native machine code compiler, and Ruby Core and Standard libraries.
Rubinius includes a bytecode virtual machine, Ruby syntax parser,
bytecode compiler, generational garbage collector, just-in-time (JIT)
native machine code compiler, and Ruby Core and Standard libraries.
Rubinius currently implements Ruby version 1.8.7.
License

View file

@ -1,5 +1,8 @@
$NetBSD: distinfo,v 1.3 2011/04/16 23:45:55 jafour1 Exp $
$NetBSD: distinfo,v 1.4 2011/05/29 07:06:55 jafour1 Exp $
SHA1 (rubinius-1.2.3-20110315.tar.gz) = 7326e27f459e299dd0c2905de9b54034cc70ccbe
RMD160 (rubinius-1.2.3-20110315.tar.gz) = eb4f7c304cfa3592dc8f75096a38d67c0e7530b5
Size (rubinius-1.2.3-20110315.tar.gz) = 9485259 bytes
SHA1 (patch-aa) = 3398c8f66c83b7a96a42497cf1dee3d3b11fb462
SHA1 (patch-ab) = 73a5b3bcc9831e881b00f6f98e5d2578c9cec158
SHA1 (patch-ac) = 4dad7fc47158ca39d86b6da6ff05281412ad0148

19
rubinius/patches/patch-aa Normal file
View file

@ -0,0 +1,19 @@
$NetBSD: patch-aa,v 1.1 2011/05/29 07:06:55 jafour1 Exp $
--- configure.orig 2011-05-28 16:16:24.000000000 -0500
+++ configure 2011-05-28 16:16:48.000000000 -0500
@@ -569,12 +569,9 @@
def c_includes
str = []
- if File.exists? "/usr/local/include"
- str << "-I/usr/local/include"
- end
- if File.exists? "/opt/local/include"
- str << "-I/opt/local/include"
+ if File.exists? "/usr/pkg/include"
+ str << "-I/usr/pkg/include"
end
return str.join(" ")

13
rubinius/patches/patch-ab Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2011/05/29 07:06:55 jafour1 Exp $
--- rakelib/blueprint.rb.orig 2011-05-28 16:31:20.000000000 -0500
+++ rakelib/blueprint.rb 2011-05-28 16:31:36.000000000 -0500
@@ -1,7 +1,7 @@
Daedalus.blueprint do |i|
gcc = i.gcc!
- gcc.cflags << "-Ivm -Ivm/test/cxxtest -I. -I/usr/local/include -I/opt/local/include "
+ gcc.cflags << "-Ivm -Ivm/test/cxxtest -I. -I/usr/pkg/include "
gcc.cflags << "-pipe -Wall -fno-omit-frame-pointer"
gcc.cflags << "-ggdb3 -Werror"
gcc.cflags << "-DRBX_PROFILER"

15
rubinius/patches/patch-ac Normal file
View file

@ -0,0 +1,15 @@
$NetBSD: patch-ac,v 1.1 2011/05/29 07:06:55 jafour1 Exp $
--- lib/ext/gdbm/extconf.rb.orig 2011-05-28 16:58:34.000000000 -0500
+++ lib/ext/gdbm/extconf.rb 2011-05-28 16:59:01.000000000 -0500
@@ -1,8 +1,8 @@
require 'mkmf'
dir_config("gdbm")
-find_header("gdbm.h", "/usr/local/include", "/opt/local/include")
-find_library("gdbm", "gdbm_open", "/usr/local/lib", "/opt/local/lib")
+find_header("gdbm.h", "/usr/pkg/include")
+find_library("gdbm", "gdbm_open", "/usr/pkg/lib")
if have_library("gdbm", "gdbm_open") and
have_header("gdbm.h")
create_makefile("gdbm")