added: missed things for heirloom-xxx packages

This commit is contained in:
Aleksey Cheusov 2006-12-17 22:49:55 +00:00 committed by Thomas Klausner
parent eb7084e6a6
commit d05a97eb8e
16 changed files with 470 additions and 0 deletions

20
heirloom-dirs/distinfo Normal file
View file

@ -0,0 +1,20 @@
$NetBSD: distinfo,v 1.1 2006/12/17 22:49:55 cheusov Exp $
SHA1 (heirloom-060122.tar.bz2) = 824c8687150485c7822cadaf0d6af84f931369cb
RMD160 (heirloom-060122.tar.bz2) = 0a555c2605a7df4f1ae9f702a5641e3f4e7d60bb
Size (heirloom-060122.tar.bz2) = 991655 bytes
SHA1 (patch-aa) = ad43f1b88ddc3a8f321b015c8e417262bf4022bd
SHA1 (patch-ab) = 82a3331fd2acf26f92a3c5fcb44fa839a72702d0
SHA1 (patch-ac) = ac7f1572d4d71aeb0f315a22c0ab79b34fc55c0d
SHA1 (patch-ad) = 6aa975552566ec78f8d51817124f44850feeaf6e
SHA1 (patch-ae) = 4036b9d336b31a0f9853dacbe29cb5912f4fc38a
SHA1 (patch-af) = 69db46b67f76bd7aca8b834c4a5c84c1fcdfb2e7
SHA1 (patch-ag) = 84a67d889c8d7fc39722b67af3293fa2b3e7a146
SHA1 (patch-ah) = c4f0dd6dbd591b008e113e0f126250e587a5279d
SHA1 (patch-ai) = fad102e45c43eb04f7db5b4dc0841f50fd376a57
SHA1 (patch-aj) = deb8a42640363db00b9002bf627b04e53fae362b
SHA1 (patch-ak) = 9424f6b7f73dec686752164df6a0396b6c1593d0
SHA1 (patch-al) = 0ba2b8fcb876ca60f219ffb75dd255a5cea8f8cd
SHA1 (patch-am) = 425479d071b3cca4a43529b3d06dd8536df57b42
SHA1 (patch-an) = 02cc11f13954e1b2848606f838d20a0a9bdcb247
SHA1 (patch-ao) = dbba0492718bdc1b782226aa393dc459ccf45437

View file

@ -0,0 +1,24 @@
$NetBSD: patch-aa,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- df/df.c.orig 2006-01-22 20:42:39.000000000 +0200
+++ df/df.c
@@ -50,10 +50,18 @@ typedef unsigned long long ull;
#include <pwd.h>
#include <sys/types.h>
#include <sys/stat.h>
-#if defined (__dietlibc__) || defined (__NetBSD__) || defined (__OpenBSD__)
+#if defined (__dietlibc__) || defined (__OpenBSD__)
#include "statvfs.c"
#elif defined (__FreeBSD__) && (__FreeBSD__) < 5
#include "statvfs.c"
+#elif defined (__NetBSD__)
+#include <sys/param.h>
+#if __NetBSD_Version__ < 300000000
+#include "statvfs.c"
+#else
+#include <sys/statvfs.h>
+#define statfs statvfs
+#endif
#else
#include <sys/statvfs.h>
#endif

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- find/find.c.orig 2006-01-22 20:44:03.000000000 +0200
+++ find/find.c
@@ -86,6 +86,10 @@ static const char sccsid[] USED = "@(#)f
#ifndef major
#include <sys/mkdev.h>
#endif
+#if __NetBSD_Version__>= 300000000
+#include <sys/statvfs.h>
+#define statfs statvfs
+#endif
#include "getdir.h"
#include "atoll.h"
#define A_DAY 86400L /* a day full of seconds */

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ac,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- ls/ls.c.orig 2005-05-29 15:55:42.000000000 +0300
+++ ls/ls.c
@@ -81,12 +81,6 @@ static char ifmt_c[] = "-pc-d-b--nl-SD--
#define ifmt(mode) ifmt_c[((mode) >> 12) & 0xF]
-#ifndef USE_TERMCAP
-#ifdef sun
-#include <curses.h>
-#include <term.h>
-#endif
-#endif
#define nil 0
#include <sys/types.h>
#include <sys/stat.h>

View file

@ -0,0 +1,186 @@
$NetBSD: patch-ad,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- build/mk.config.orig 2006-01-22 23:48:04.000000000 +0200
+++ build/mk.config
@@ -19,72 +19,72 @@ POSIX_SHELL = /bin/sh
# Root directory. Mainly useful for package building; leave empty for
# normal installation.
#
-ROOT =
+#ROOT =
#
# Location for binaries that have no special personality. This location
# may be identical to that of one of the first three personalities below.
#
-DEFBIN = /usr/5bin
+DEFBIN = ${DESTDIR}${PREFIX}/bin
#
# Location for SVID3/SVR4-style binaries.
#
-SV3BIN = /usr/5bin
+SV3BIN = ${DESTDIR}${PREFIX}/bin
#
# Location for SVID4/SVR4.2-style binaries.
#
-S42BIN = /usr/5bin/s42
+S42BIN = ${DESTDIR}${PREFIX}/bin/s42
#
# Location for POSIX.2/SUS-style binaries.
#
-SUSBIN = /usr/5bin/posix
+SUSBIN = ${DESTDIR}${PREFIX}/bin/posix
#
# Location for POSIX.1-2001/SUSv3-style binaries.
-SU3BIN = /usr/5bin/posix2001
+SU3BIN = ${DESTDIR}${PREFIX}/bin/posix2001
#
# Location for SVR4 UCB-style binaries. These do not form a complete
# personality, and the binary path must not be identical to the default
# one.
#
-UCBBIN = /usr/ucb
+UCBBIN = ${DESTDIR}${PREFIX}/ucb
#
# Location for library files.
#
-DEFLIB = /usr/5lib
+DEFLIB = ${DESTDIR}${PREFIX}/lib
#
# Location for superuser-only binaries. May be identical to the
# default binary directory.
#
-DEFSBIN = /usr/5bin
+DEFSBIN = ${DESTDIR}${PREFIX}/sbin
#
# Location for manual pages (with man1, man1b ... man8 below).
#
-MANDIR = /usr/share/man/5man
+MANDIR = ${DESTDIR}${PREFIX}/man
#
# Location for default files. Make sure that this directory is accessible
# to all users.
#
-DFLDIR = /etc/default
+DFLDIR = ${DESTDIR}${PREFIX}/etc/default
#
# Location for the spell history file (contains misspelled words for
# all users; set to /dev/null to disable).
#
-SPELLHIST = /var/adm/spellhist
+SPELLHIST = ${DESTDIR}${PREFIX}/var/adm/spellhist
#
# Location for the su logfile.
#
-SULOG = /var/log/sulog
+SULOG = ${DESTDIR}${PREFIX}/var/log/sulog
#
# Where to store the file command's magic. Note that the existing
@@ -113,7 +113,7 @@ TTYGRP = -g utmp
# does not supply our needs. Use -ltermcap instead and add -DUSE_TERMCAP
# to CPPFLAGS.
#
-LCURS = -lcurses
+#LCURS = -lcurses
#
# Socket library, necessary on Solaris and Open UNIX. If your system has
@@ -135,7 +135,8 @@ LCURS = -lcurses
# zlib or don't want to use it; you need it only if you want to use inflate
# compression when creating zip files with cpio.
#
-LIBZ = -Wl,-Bstatic -lz -Wl,-Bdynamic
+#LIBZ = -Wl,-Bstatic -lz -Wl,-Bdynamic
+LIBZ = -lz
USE_ZLIB = 1
#
@@ -143,7 +144,8 @@ USE_ZLIB = 1
# needed to read and write bzip2 compressed parts of zip files with cpio.
#
#LIBBZ2 = -Wl,-Bstatic -lbz2 -Wl,-Bdynamic
-USE_BZLIB = 0
+LIBBZ2 = -lbz2
+USE_BZLIB = 1
#
# Compiler and linker flags. HOSTCC is for cross compiling.
@@ -164,7 +166,7 @@ WARN = -Wchar-subscripts -Wformat -Wno-f
WARN=
LD = $(CC)
-LDFLAGS =
+#LDFLAGS =
#
# Flags for the C preprocessor.
@@ -175,7 +177,7 @@ LDFLAGS =
# On AIX, -D_MTEXTEND_H should be added if mtextend.h is not found.
# On NetBSD, add -DUSE_TERMCAP.
#
-CPPFLAGS = -D_GNU_SOURCE
+#CPPFLAGS = -D_GNU_SOURCE
#
# CFLAGS, CFLAGS2, CFLAGSS, and CFLAGSU make it possible to give special
@@ -196,10 +198,10 @@ CPPFLAGS = -D_GNU_SOURCE
# compiler mode (which is the default) until this issue is properly
# handled by the system vendor.
#
-CFLAGS = -O -fomit-frame-pointer $(WARN)
-CFLAGS2 = -O2 -fomit-frame-pointer $(WARN)
-CFLAGSS = -Os -fomit-frame-pointer $(WARN)
-CFLAGSU = -O2 -fomit-frame-pointer -funroll-loops $(WARN)
+#CFLAGS = -O -fomit-frame-pointer $(WARN)
+#CFLAGS2 = -O2 -fomit-frame-pointer $(WARN)
+#CFLAGSS = -Os -fomit-frame-pointer $(WARN)
+#CFLAGSU = -O2 -fomit-frame-pointer -funroll-loops $(WARN)
#
# Binaries are stripped with this command after installation.
@@ -218,7 +220,7 @@ STRIP = strip -s -R .comment -R .note
#
# On FreeBSD, NetBSD, and OpenBSD, no such define is necessary.
#
-LARGEF = -D_FILE_OFFSET_BITS=64L
+#LARGEF = -D_FILE_OFFSET_BITS=64L
#
# Use this if you prefer symbolic links between installed files.
@@ -257,7 +259,7 @@ LEX = lex
# Crypt library. -lcrypt is okay for everything except HP-UX, AIX, NetBSD,
# and old versions of diet libc.
#
-LCRYPT=-lcrypt
+#LCRYPT=-lcrypt
#
# Run ranlib if it is in the current path. This should take care
@@ -277,12 +279,12 @@ RANLIB=(hash ranlib) >/dev/null 2>&1 ||
########################################################################
########################################################################
-UCBINST = $(ROOT)$(UCBBIN)/install
+#UCBINST = $(ROOT)$(UCBBIN)/install
ICOMMON = -I../libcommon
LCOMMON = -L../libcommon -lcommon
-IUXRE = -I../libuxre -DUXRE
-LUXRE = -L../libuxre -luxre
+#IUXRE = -I../libuxre -DUXRE
+#LUXRE = -L../libuxre -luxre
MANINST = $(SHELL) ../build/maninst

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ae,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- ps/ps.c.orig 2006-01-22 20:54:07.000000000 +0200
+++ ps/ps.c
@@ -156,6 +156,11 @@ static const char cacheid[] = "@(#)/tmp/
#include <sys/ioctl.h>
#endif
+#if __NetBSD_Version__ >= 300000000
+#include <sys/statvfs.h>
+#define statfs statvfs
+#endif
+
#include <mbtowi.h>
#ifdef __linux__

View file

@ -0,0 +1,34 @@
$NetBSD: patch-af,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- libcommon/getdir.c.orig 2006-01-22 21:06:14.000000000 +0200
+++ libcommon/getdir.c
@@ -143,8 +143,11 @@ getdir(struct getdb *db, int *err)
&& !defined (__DragonFly__) && !defined (__APPLE__)
db->g_dirp->d_ino == 0
#else /* __FreeBSD__, __NetBSD__, __OpenBSD__, __DragonFly__, __APPLE__ */
- (db->g_dirp->d_fileno == 0 ||
- db->g_dirp->d_type == DT_WHT)
+ (db->g_dirp->d_fileno == 0
+#ifdef DT_WHT
+ || db->g_dirp->d_type == DT_WHT
+#endif
+ )
#endif /* __FreeBSD__, __NetBSD__, __OpenBSD__, __DragonFly__, __APPLE__ */
)
{
@@ -169,8 +172,14 @@ getdir(struct getdb *db, int *err)
goto next;
db->g_dic.d_ino = db->g_dirp->d_ino;
#else /* __FreeBSD__, __NetBSD__, __OpenBSD__, __DragonFly__, __APPLE__ */
- if (db->g_dirp->d_fileno == 0 || db->g_dirp->d_type == DT_WHT)
+ if (db->g_dirp->d_fileno == 0
+#ifdef DT_WHT
+ || db->g_dirp->d_type == DT_WHT
+#endif
+ )
+ {
goto next;
+ }
db->g_dic.d_ino = db->g_dirp->d_fileno;
#endif /* __FreeBSD__, __NetBSD__, __OpenBSD__, __DragonFly__, __APPLE__ */
db->g_dic.d_name = db->g_dirp->d_name;

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ag,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- mail/doopen.c.orig 2005-06-18 17:09:15.000000000 +0300
+++ mail/doopen.c
@@ -46,7 +46,11 @@ doopen(char *file, char *type, int errnu
FILE *fptr = NULL;
struct stat st;
- if ((stat(file, &st) < 0 && errno == EOVERFLOW) ||
+ if ((stat(file, &st) < 0
+#ifdef EOVERFLOW
+ && errno == EOVERFLOW
+#endif
+ ) ||
(fptr = fopen(file, type)) == NULL) {
fprintf(stderr,
"%s: Can't open '%s' type: %s\n",program,file,type);

View file

@ -0,0 +1,18 @@
$NetBSD: patch-ah,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- mail/mkdead.c.orig 2005-06-22 06:12:19.000000000 +0300
+++ mail/mkdead.c
@@ -65,8 +65,11 @@ mkdead(void)
try to create in $HOME
*/
cat(&hmdead, &hmdeadsize, home, dead);
- if ((aret=legal(hmdead)) && !(stat(hmdead, &st) < 0 &&
- errno == EOVERFLOW))
+ if ((aret=legal(hmdead)) && !(stat(hmdead, &st) < 0
+#ifdef EOVERFLOW
+ && errno == EOVERFLOW
+#endif
+ ))
malf = fopen(hmdead, "a");
if ((malf == NULL) || (aret == 0)) {
fprintf(stderr,

View file

@ -0,0 +1,17 @@
$NetBSD: patch-ai,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- mail/sendmail.c.orig 2005-07-03 02:11:41.000000000 +0300
+++ mail/sendmail.c
@@ -150,10 +150,12 @@ sendmail(int argc, char **argv)
cpy(&fromS, &fromSsize, "");
input = stdin;
if (fstat(fileno(input), &sbuf) < 0) {
+#ifdef EOVERFLOW
if (errno == EOVERFLOW) {
perror("stdin");
exit(1);
}
+#endif
}
while ((n = getline (&line, &linesize, stdin)) > 0) {

View file

@ -0,0 +1,16 @@
$NetBSD: patch-aj,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- nawk/awk.g.y.orig 2005-02-06 14:19:22.000000000 +0200
+++ nawk/awk.g.y
@@ -29,6 +29,11 @@
%{
#include "awk.h"
#include <unistd.h>
+
+#ifdef __OpenBSD__
+#include <inttypes.h>
+#endif
+
#include <pfmt.h>
int yywrap(void) { return(1); }
#ifndef DEBUG

View file

@ -0,0 +1,26 @@
$NetBSD: patch-ak,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- spell/spellin.c.orig 2005-06-22 06:10:39.000000000 +0300
+++ spell/spellin.c
@@ -76,7 +76,8 @@ append(register uint32_t w1, register in
int
main(int argc, char **argv)
{
- int32_t h, k, d;
+ unsigned h;
+ int32_t k, d;
int32_t i;
int32_t count;
int32_t w1;
@@ -103,8 +104,9 @@ main(int argc, char **argv)
z = huff((1L<<HASHWIDTH)/atof(argv[1]));
fprintf(stderr, "%s: expected code widths = %f\n",
argv[0], z);
- for (count = 0; scanf("%lo", (long *)&h) == 1; ++count) {
- if ((t = h >> (HASHWIDTH - INDEXWIDTH)) != u) {
+ for (count = 0; scanf("%o", &h) == 1; ++count) {
+ t = ((int32_t) h) >> (HASHWIDTH - INDEXWIDTH);
+ if (t != u) {
if (bp != B)
wp++;
bp = B;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-al,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- whodo/whodo.c.orig 2006-01-22 21:02:10.000000000 +0200
+++ whodo/whodo.c
@@ -60,7 +60,7 @@ static const char sccsid[] USED = "@(#)w
#include <sys/sysctl.h>
#endif
-#if defined (__NetBSD__) || defined (__NetBSD__) || defined (__APPLE__)
+#if defined (__NetBSD__) || defined (__OpenBSD__) || defined (__APPLE__)
#if defined (__APPLE__)
#include <mach/mach_types.h>
#include <mach/task_info.h>

View file

@ -0,0 +1,22 @@
$NetBSD: patch-am,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- ul/ul.c.orig 2005-05-29 15:55:46.000000000 +0300
+++ ul/ul.c
@@ -130,13 +130,16 @@ static void putchr(wchar_t);
static void setmod(int);
static void obaccs(long);
+#ifdef USE_TERMCAP
+static void initcap(void);
+#endif
+
int
main(int argc, char **argv)
{
int c;
char *termtype;
#ifdef USE_TERMCAP
- static void initcap(void);
char termcap[2048];
#endif
struct iblok *f;

View file

@ -0,0 +1,17 @@
$NetBSD: patch-an,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- build/crossln.sh.orig 2005-03-10 18:33:13.000000000 +0200
+++ build/crossln.sh
@@ -10,6 +10,12 @@ usage() {
}
doit() {
+ if echo "$1" | grep '^[^/]' > /dev/null; then
+ src="`dirname $2`/$1"
+ else
+ src="$1"
+ fi
+ test -f "$src" -o -h "$src" || return 0
rm -f -- "$2" || exit
exec @LNS@ -- "$1" "$2" || exit
}

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ao,v 1.1 2006/12/17 22:49:55 cheusov Exp $
--- Makefile.mk.orig 2005-07-17 15:02:39.000000000 +0300
+++ Makefile.mk
@@ -88,4 +88,6 @@ links:
else \
sh build/crossln $(ROOT)$(MANDIR)/man1/oawk.1 $(ROOT)$(MANDIR)/man1/awk.1 $(ROOT); \
fi
- $(SHELL) build/maninst -c -m 644 intro.1 $(ROOT)$(MANDIR)/man1/intro.1
+ if test -z "${NO_INSTALL_INTRO}"; then \
+ $(SHELL) build/maninst -c -m 644 intro.1 $(ROOT)$(MANDIR)/man1/intro.1; \
+ fi