Break into the scsh-install-lib installation procedure and hack configure

This commit is contained in:
Peter Bex 2005-02-16 21:39:47 +00:00 committed by Thomas Klausner
parent 80c3128219
commit d1169f58c4
5 changed files with 73 additions and 4 deletions

View file

@ -1,5 +1,5 @@
#
# $NetBSD: Makefile,v 1.2 2005/02/16 00:00:36 airhead Exp $
# $NetBSD: Makefile,v 1.3 2005/02/16 21:39:47 airhead Exp $
#
DISTNAME= scx-0.2
@ -10,6 +10,27 @@ MAINTAINER= airhead@users.sf.net
HOMEPAGE= http://www.scsh.net/resources/graphics.html
COMMENT= Scx - a GUI library for scsh and Scheme 48
.include "../../wip/scsh-install-lib/Makefile.common"
USE_LIBTOOL= yes
USE_X11= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-scsh-includes=${PREFIX}/include
SCSH_VERSION?= 0.6
#
# XXX Nasty quick hack. so sue me for wanting to get orion to work asap ;)
#
BUILD_DEPENDS+= scsh-${SCSH_VERSION}.[0-9]:../../shells/scsh
BUILD_DEPENDS+= scsh-install-lib>=1:../../wip/scsh-install-lib
SCSH_LIBPATH= ${PREFIX}/share/scsh-${SCSH_VERSION}/modules
do-install:
cd ${WRKSRC}; \
env SCSH_LIB_DIRS=\"${SCSH_LIBPATH}\" \
scsh-install-pkg --prefix=${PREFIX} \
--layout fhs \
--verbose
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2005/02/15 23:56:48 airhead Exp $
@comment $NetBSD: PLIST,v 1.3 2005/02/16 21:39:48 airhead Exp $
lib/scsh-0.6/modules/${PKGNAME}/${MACHINE_GNU_PLATFORM}/libscx.la
share/scsh-0.6/modules/scx
share/scsh-0.6/modules/${PKGNAME}/load.scm
@ -49,3 +49,5 @@ share/scsh-0.6/modules/${PKGNAME}/scheme/xt/widget.scm
@dirrm share/scsh-0.6/modules/${PKGNAME}
@dirrm lib/scsh-0.6/modules/${PKGNAME}/${MACHINE_GNU_PLATFORM}
@dirrm lib/scsh-0.6/modules/${PKGNAME}
@dirrm lib/scsh-0.6/modules
@dirrm lib/scsh-0.6

View file

@ -1,4 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2005/02/15 23:25:09 airhead Exp $
$NetBSD: distinfo,v 1.2 2005/02/16 21:39:48 airhead Exp $
SHA1 (scx-0.2.tar.gz) = 63bd3456e9c04fcfaa885dab9257f7d6cee7472d
Size (scx-0.2.tar.gz) = 378340 bytes
SHA1 (patch-aa) = 85c9e0d274510c3dde0f597ac64153ee62ce6363
SHA1 (patch-ab) = 7700432ace3340b2ff50c8d6a86578e6792d7695

13
scx/patches/patch-aa Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1 2005/02/16 21:39:48 airhead Exp $
--- configure.in.orig 2004-05-22 19:26:23.000000000 +0200
+++ configure.in
@@ -34,7 +34,7 @@
SCX_PREPEND(`xft-config --libs`, x_libraries)
SCX_PREPEND(`xft-config --cflags`, x_includes)
else
- LIBS="$LIBS -L${x_libraries}"
+ LIBS="$LIBS -Wl,-R${x_libraries} -Wl,-L${x_libraries}"
AC_CHECK_LIB(Xrender, XRenderQueryExtension, SCX_PREPEND(-lXrender, x_libraries))
AC_CHECK_LIB(Xft, XftFontOpen, SCX_PREPEND(-lXft, x_libraries))
fi

31
scx/patches/patch-ab Normal file
View file

@ -0,0 +1,31 @@
$NetBSD: patch-ab,v 1.1 2005/02/16 21:39:48 airhead Exp $
--- configure.orig 2004-05-22 19:30:15.000000000 +0200
+++ configure
@@ -20092,7 +20092,7 @@ else
# It would also be nice to do this for all -L options, not just this one.
if test -n "$x_libraries"; then
- X_LIBS="$X_LIBS -L$x_libraries"
+ X_LIBS="$X_LIBS -Wl,-R$x_libraries -Wl,-L$x_libraries"
# For Solaris; some versions of Sun CC require a space after -R and
# others require no space. Words are not sufficient . . . .
case `(uname -sr) 2>/dev/null` in
@@ -21152,7 +21152,7 @@ fi
# Check for libraries that X11R6 Xt/Xaw programs need.
ac_save_LDFLAGS=$LDFLAGS
- test -n "$x_libraries" && LDFLAGS="$LDFLAGS -L$x_libraries"
+ test -n "$x_libraries" && LDFLAGS="$LDFLAGS -Wl,-R$x_libraries -Wl,-L$x_libraries"
# SM needs ICE to (dynamically) link under SunOS 4.x (so we have to
# check for ICE first), but we must link in the order -lSM -lICE or
# we get undefined symbols. So assume we have SM if we have ICE.
@@ -21293,7 +21293,7 @@ fi
x_libraries="$x_libraries `xft-config --libs`"
x_includes="$x_includes `xft-config --cflags`"
else
- LIBS="$LIBS -L${x_libraries}"
+ LIBS="$LIBS -Wl,-R${x_libraries} -Wl,-L${x_libraries}"
echo "$as_me:$LINENO: checking for XRenderQueryExtension in -lXrender" >&5
echo $ECHO_N "checking for XRenderQueryExtension in -lXrender... $ECHO_C" >&6
if test "${ac_cv_lib_Xrender_XRenderQueryExtension+set}" = set; then