Remove patches that were accepted upstream.
Help more test cases to succeed.
This commit is contained in:
parent
82d1273e65
commit
d1527e4ce9
5 changed files with 9 additions and 59 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.4 2013/11/03 01:33:07 thomasklausner Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2013/11/05 16:17:35 thomasklausner Exp $
|
||||
|
||||
DISTNAME= bup-0.25rc3
|
||||
CATEGORIES= sysutils
|
||||
|
@ -89,6 +89,13 @@ REPLACE_PYTHON+= t/mksock
|
|||
REPLACE_PYTHON+= t/root-status
|
||||
REPLACE_PYTHON+= t/unknown-owner
|
||||
|
||||
SUBST_CLASSES+= python-c
|
||||
SUBST_SED.python-c+= -e 's,python -c,${PYTHONBIN} -c,'
|
||||
SUBST_STAGE.python-c+= pre-configure
|
||||
SUBST_FILES.python-c+= t/lib.sh
|
||||
SUBST_FILES.python-c+= t/test-meta.sh
|
||||
SUBST_MSG.python-c+= Fixing python executable in tests.
|
||||
|
||||
REPLACE_BASH+= cmd/import-rdiff-backup-cmd.sh
|
||||
REPLACE_BASH+= t/compare-trees
|
||||
REPLACE_BASH+= t/configure-sampledata
|
||||
|
|
|
@ -1,7 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.4 2013/11/03 01:33:07 thomasklausner Exp $
|
||||
$NetBSD: distinfo,v 1.5 2013/11/05 16:17:35 thomasklausner Exp $
|
||||
|
||||
SHA1 (patch-Makefile) = 7f1da7136af04cb4de2acbc9396ac16fcc7684a7
|
||||
SHA1 (patch-cmd_import-rdiff-backup-cmd.sh) = 3094cf88fe9f4feb522b9c2f33805f4471337711
|
||||
SHA1 (patch-config_configure) = a7d4dcdda0a712ac18f0edab91f7fe972f1db53b
|
||||
SHA1 (patch-t_test-meta.sh) = 557526fb562bfff8e3911b0cf071108ff621c612
|
||||
SHA1 (patch-t_test.sh) = 1185d64ff164aa2175a650d63417a713e2471437
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-cmd_import-rdiff-backup-cmd.sh,v 1.2 2013/11/03 01:33:07 thomasklausner Exp $
|
||||
|
||||
Use -d instead of --date for date(1), since it's more portable.
|
||||
|
||||
--- cmd/import-rdiff-backup-cmd.sh.orig 2013-11-03 01:29:44.000000000 +0000
|
||||
+++ cmd/import-rdiff-backup-cmd.sh
|
||||
@@ -55,7 +55,7 @@ echo "$backups" |
|
||||
while read timestamp type; do
|
||||
tmpdir=$(must mktemp -d) || exit $?
|
||||
|
||||
- echo "Importing backup from $(date --date=@$timestamp +%c) " \
|
||||
+ echo "Importing backup from $(date -d @$timestamp +%c) " \
|
||||
"($counter / $backups_count)" 1>&2
|
||||
echo 1>&2
|
||||
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-t_test-meta.sh,v 1.2 2013/11/03 01:33:07 thomasklausner Exp $
|
||||
|
||||
Use more portable test(1) = comparison operator.
|
||||
|
||||
--- t/test-meta.sh.orig 2013-11-03 01:29:44.000000000 +0000
|
||||
+++ t/test-meta.sh
|
||||
@@ -478,7 +478,7 @@ src/foo/3"
|
||||
|
||||
# Test ownership restoration (when root or fakeroot).
|
||||
(
|
||||
- if [ $(t/root-status) == none ]; then
|
||||
+ if [ $(t/root-status) = none ]; then
|
||||
exit 0
|
||||
fi
|
||||
|
||||
@@ -589,7 +589,7 @@ src/foo/3"
|
||||
|
||||
# Root-only tests that require an FS with all the trimmings: ACLs,
|
||||
# Linux attr, Linux xattr, etc.
|
||||
-if [ $(t/root-status) == root ]; then
|
||||
+if [ $(t/root-status) = root ]; then
|
||||
(
|
||||
# Some cleanup handled in universal-cleanup() above.
|
||||
# These tests are only likely to work under Linux for now
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-t_test.sh,v 1.2 2013/11/03 01:33:07 thomasklausner Exp $
|
||||
|
||||
NetBSD's wc -l has whitespace at the start -- strip it out.
|
||||
|
||||
--- t/test.sh.orig 2013-11-03 01:29:44.000000000 +0000
|
||||
+++ t/test.sh
|
||||
@@ -617,7 +617,7 @@ if [ "$(which rdiff-backup)" != "" ]; th
|
||||
WVPASS bup tick
|
||||
WVPASS rdiff-backup $TOP/Documentation $D/rdiff-backup
|
||||
WVPASS bup import-rdiff-backup $D/rdiff-backup import-rdiff-backup
|
||||
- WVPASSEQ "$(bup ls import-rdiff-backup/ | wc -l)" "3"
|
||||
+ WVPASSEQ "$(bup ls import-rdiff-backup/ | wc -l | sed "s/[ ]*//")" "3"
|
||||
WVPASSEQ "$(bup ls import-rdiff-backup/latest/ | sort)" "$(ls $TOP/Documentation | sort)"
|
||||
fi
|
||||
|
Loading…
Reference in a new issue