Perl module implementing client API for Dictionary protocol (RFC-2229)

This commit is contained in:
Aleksey Cheusov 2006-11-29 14:16:39 +00:00 committed by Thomas Klausner
parent 27ab61bebe
commit d1973e32bc
5 changed files with 46 additions and 0 deletions

3
p5-Net-Dict/DESCR Normal file
View file

@ -0,0 +1,3 @@
This distribution contains the Net::Dict module for Perl.
Net::Dict is a class implementing a simple client API
for the DICT protocol defined in RFC2229.

21
p5-Net-Dict/Makefile Normal file
View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1 2006/11/29 14:16:39 cheusov Exp $
#
DISTNAME= Net-Dict-2.07
PKGNAME= p5-${DISTNAME}
CATEGORIES= net textproc
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Net/}
MAINTAINER= cheusov@tut.by
HOMEPAGE= http://www.cpan.org/modules/by-module/Net/
COMMENT= Client API for the DICT protocol defined in RFC2229.
NO_BUILD= yes
PKG_INSTALLATION_TYPES= overwrite pkgviews
PERL5_PACKLIST= auto/Net/Dict/.packlist
DEPENDS+= p5-AppConfig-[0-9]*:../../devel/p5-AppConfig
DEPENDS+= p5-Tk-[0-9]*:../../x11/p5-Tk
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

1
p5-Net-Dict/PLIST Normal file
View file

@ -0,0 +1 @@
@comment $NetBSD: PLIST,v 1.1 2006/11/29 14:16:39 cheusov Exp $

6
p5-Net-Dict/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2006/11/29 14:16:39 cheusov Exp $
SHA1 (Net-Dict-2.07.tar.gz) = e96735711be9704b83f165470813bd23f1be7ca5
RMD160 (Net-Dict-2.07.tar.gz) = 417d440c7278e6ebb5a778e5483dc409846aaa70
Size (Net-Dict-2.07.tar.gz) = 30284 bytes
SHA1 (patch-aa) = ed579c715c33e158d51bbf0cfd03021eaed476e7

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1 2006/11/29 14:16:39 cheusov Exp $
--- Makefile.PL.orig 2003-05-06 02:56:17.000000000 +0300
+++ Makefile.PL
@@ -48,8 +48,8 @@ to skip "make test", then just hit retur
EOF
- $host = prompt('what is the hostname for the DICT server?', $DEFAULT_HOST);
- $port = prompt('what is the port for the DICT server?', $DEFAULT_PORT);
+ $host = "test.dict.org";
+ $port = 2628;
print "\nWriting test config $test_config_file\n\n";
open(CFGFILE, "> $test_config_file")