xmule moved to pkgsrc/net/xmule.

This commit is contained in:
Julio Merino 2003-06-03 09:27:06 +00:00
parent a04ed96d68
commit d2a6e3be4b
9 changed files with 2 additions and 175 deletions

View file

@ -1,5 +1,5 @@
# $Id: Makefile,v 1.209 2003/06/03 04:44:46 xtraeme Exp $
# $NetBSD: Makefile,v 1.209 2003/06/03 04:44:46 xtraeme Exp $
# $Id: Makefile,v 1.210 2003/06/03 09:27:06 jmmv Exp $
# $NetBSD: Makefile,v 1.210 2003/06/03 09:27:06 jmmv Exp $
COMMENT= WIP pkgsrc packages
@ -177,7 +177,6 @@ SUBDIR+= words
SUBDIR+= xawtv
SUBDIR+= xevil
SUBDIR+= xml2doc
SUBDIR+= xmule
SUBDIR+= xplore
SUBDIR+= zebra-pj

View file

@ -1,12 +0,0 @@
Port of the eMule (and fork of LMule) for Windows eDonkey2000, which uses the
wxWindows class library and runs on several Unix-like systems.
Features:
* Download/Upload works
* You can search and add ed2k-links
* Statistics
* Shared files tab works
* Messages tab is now implemented
* You can manage friends
* xMule can be minimized to systray
* You can set nearly all preferences

View file

@ -1,30 +0,0 @@
# $NetBSD: Makefile,v 1.2 2003/06/02 07:59:41 marc Exp $
#
DISTNAME= xmule-1.4.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xmule/}
MAINTAINER= marc@informatik.uni-bremen.de
HOMEPAGE= http://www.xmule.org/
COMMENT= eDonkey2000 client based on eMule
BUILD_USES_MSGFMT= YES
DEPENDS= gnome2-dirs>=1.1:../../misc/gnome2-dirs
DEPENDS+= wget>=1.8.2:../../net/wget
GNU_CONFIGURE= YES
USE_BUILDLINK2= YES
USE_GMAKE= YES
USE_PKGLOCALEDIR= YES
USE_X11= YES
CONFIGURE_ARGS+= --without-included-gettext
.include "../../converters/libiconv/buildlink2.mk"
.include "../../devel/gettext-lib/buildlink2.mk"
.include "../../textproc/expat/buildlink2.mk"
.include "../../x11/wxGTK/buildlink2.mk"
.include "../../mk/pthread.buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,16 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/06/01 10:24:49 marc Exp $
bin/xmule
share/applications/xmule.desktop
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/xmule.mo
${PKGLOCALEDIR}/locale/ee/LC_MESSAGES/xmule.mo
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/xmule.mo
${PKGLOCALEDIR}/locale/es_MX/LC_MESSAGES/xmule.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/xmule.mo
${PKGLOCALEDIR}/locale/it/LC_MESSAGES/xmule.mo
${PKGLOCALEDIR}/locale/ko/LC_MESSAGES/xmule.mo
${PKGLOCALEDIR}/locale/pl/LC_MESSAGES/xmule.mo
${PKGLOCALEDIR}/locale/tr/LC_MESSAGES/xmule.mo
share/pixmaps/xmule.xpm
@dirrm ${PKGLOCALEDIR}/locale/ee/LC_MESSAGES
@dirrm ${PKGLOCALEDIR}/locale/ee
@comment in gnome2-dirs: @dirrm share/applications

View file

@ -1,8 +0,0 @@
$NetBSD: distinfo,v 1.1.1.1 2003/06/01 10:24:49 marc Exp $
SHA1 (xmule-1.4.0.tar.gz) = c42971babe4f771c512b53324b5bff64209d0de2
Size (xmule-1.4.0.tar.gz) = 1773772 bytes
SHA1 (patch-aa) = 3cc3631e7259e759df8d685a473586da82025837
SHA1 (patch-ab) = dfa3b579fcd17f7768369a7b7abb84e4da64adff
SHA1 (patch-ac) = 81c53bbe3cb585351892f19c64d410a251285fdc
SHA1 (patch-ad) = 3a14fc689adc2a9f46958bc6d881b8d14163dbc8

View file

@ -1,20 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/06/01 10:24:49 marc Exp $
--- src/gsocket.c.orig 2003-05-31 21:53:44.000000000 +0200
+++ src/gsocket.c 2003-05-31 21:54:24.000000000 +0200
@@ -363,6 +363,7 @@
GSocketError GSocket_SetServer(GSocket *sck)
{
int arg = 1;
+ int intYes = 1;
assert(sck != NULL);
@@ -400,7 +401,6 @@
/* Added by Un-Thesis 2003-05-15 */
/* Allows socket reuse */
/* Code contributed by McCabe and arkanes */
-int intYes = 1;
if(setsockopt(sck->m_fd, SOL_SOCKET, SO_REUSEADDR, &intYes, sizeof(int))) {
return GSOCK_IOERR;
}

View file

@ -1,41 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/06/01 10:24:49 marc Exp $
--- src/xmule.cpp.orig 2003-05-27 00:02:47.000000000 +0200
+++ src/xmule.cpp 2003-06-01 01:54:07.000000000 +0200
@@ -103,8 +103,13 @@
delete clientlist;
#endif
+ if (hashing_mut.TryLock() == wxMUTEX_NO_ERROR) {
hashing_mut.Unlock();
+ }
+
+ if (pendingMutex.TryLock() == wxMUTEX_NO_ERROR) {
pendingMutex.Unlock();
+ }
printf("xMule shutdown completed.\n");
}
@@ -641,11 +646,13 @@
} //End Added By Bouc7
-
+#if defined(linux)
#include <execinfo.h>
+#endif
void CxmuleApp::OnFatalException()
{
+#if defined(linux)
// (stkn) create backtrace
void * bt_array[100]; // 100 should be enough ?!?
char ** bt_strings;
@@ -666,6 +673,7 @@
fprintf(stderr, "[%d] %s\n", i, bt_strings[i]);
free(bt_strings);
+#endif
}
#define wxGTK_WINDOW 1

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ac,v 1.1.1.1 2003/06/01 10:24:49 marc Exp $
--- src/KnownFileList.cpp.orig 2003-05-25 16:00:07.000000000 +0200
+++ src/KnownFileList.cpp 2003-06-01 01:55:06.000000000 +0200
@@ -34,7 +34,9 @@
}
CKnownFileList::~CKnownFileList() {
+ if (list_mut.TryLock() == wxMUTEX_NO_ERROR) {
list_mut.Unlock();
+ }
Clear();
}

View file

@ -1,31 +0,0 @@
$NetBSD: patch-ad,v 1.1.1.1 2003/06/01 10:24:49 marc Exp $
--- src/UDPSocket.cpp.orig 2003-05-26 05:30:05.000000000 +0200
+++ src/UDPSocket.cpp 2003-06-01 11:36:08.000000000 +0200
@@ -25,7 +25,7 @@
static pthread_attr_t attr;//=PTHREAD_CREATE_DETACHED;
#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
- static wxMutex *s_mutexProtectingGetHostByName;
+ static wxMutex s_mutexProtectingGetHostByName;
static int
convert (struct hostent *host, struct hostent *result,
@@ -131,7 +131,7 @@
{
struct hostent *host;
- s_mutexProtectingGetHostByName->Lock();
+ s_mutexProtectingGetHostByName.Lock();
host = gethostbyname (name);
if (!host ||
@@ -140,7 +140,7 @@
result = NULL;
}
- s_mutexProtectingGetHostByName->Unlock();
+ s_mutexProtectingGetHostByName.Unlock();
return result;
}