Import py27-rebound-2.3.0 as wip/py-rebound.
REBOUND is an N-body integrator, i.e. a software package that can integrate the motion of particles under the influence of gravity. The particles can represent stars, planets, moons, ring or dust particlesCVS: ----------------------------------------------------------------------
This commit is contained in:
parent
7b4d4f2065
commit
d34dcba620
5 changed files with 67 additions and 0 deletions
3
py-rebound/DESCR
Normal file
3
py-rebound/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
REBOUND is an N-body integrator, i.e. a software package that can integrate
|
||||
the motion of particles under the influence of gravity. The particles can
|
||||
represent stars, planets, moons, ring or dust particles
|
14
py-rebound/Makefile
Normal file
14
py-rebound/Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
# $NetBSD: Makefile,v 1.1 2015/08/01 22:31:16 jihbed Exp $
|
||||
|
||||
DISTNAME= rebound-2.3.0
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= https://pypi.python.org/packages/source/r/rebound/
|
||||
|
||||
MAINTAINER= jihbed.research@gmail.com
|
||||
HOMEPAGE= http://github.com/hannorein/rebound
|
||||
COMMENT= Open-source multi-purpose N-body code
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
31
py-rebound/PLIST
Normal file
31
py-rebound/PLIST
Normal file
|
@ -0,0 +1,31 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2015/08/01 22:31:16 jihbed Exp $
|
||||
${PYSITELIB}/librebound.so
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
|
||||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
||||
${PYSITELIB}/rebound/__init__.py
|
||||
${PYSITELIB}/rebound/__init__.pyc
|
||||
${PYSITELIB}/rebound/__init__.pyo
|
||||
${PYSITELIB}/rebound/data.py
|
||||
${PYSITELIB}/rebound/data.pyc
|
||||
${PYSITELIB}/rebound/data.pyo
|
||||
${PYSITELIB}/rebound/debug.py
|
||||
${PYSITELIB}/rebound/debug.pyc
|
||||
${PYSITELIB}/rebound/debug.pyo
|
||||
${PYSITELIB}/rebound/horizons.py
|
||||
${PYSITELIB}/rebound/horizons.pyc
|
||||
${PYSITELIB}/rebound/horizons.pyo
|
||||
${PYSITELIB}/rebound/interruptible_pool.py
|
||||
${PYSITELIB}/rebound/interruptible_pool.pyc
|
||||
${PYSITELIB}/rebound/interruptible_pool.pyo
|
||||
${PYSITELIB}/rebound/particle.py
|
||||
${PYSITELIB}/rebound/particle.pyc
|
||||
${PYSITELIB}/rebound/particle.pyo
|
||||
${PYSITELIB}/rebound/simulation.py
|
||||
${PYSITELIB}/rebound/simulation.pyc
|
||||
${PYSITELIB}/rebound/simulation.pyo
|
||||
${PYSITELIB}/rebound/units.py
|
||||
${PYSITELIB}/rebound/units.pyc
|
||||
${PYSITELIB}/rebound/units.pyo
|
6
py-rebound/distinfo
Normal file
6
py-rebound/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2015/08/01 22:31:16 jihbed Exp $
|
||||
|
||||
SHA1 (rebound-2.3.0.tar.gz) = baf58214e15f4766faf6dc51a38bde5071652034
|
||||
RMD160 (rebound-2.3.0.tar.gz) = 6df07a2d0a64a6238f0cca4b67388a0d19d81456
|
||||
Size (rebound-2.3.0.tar.gz) = 89705 bytes
|
||||
SHA1 (patch-setup.py) = d7192cda8e8264a9b063c28c3d663371ea7ba33a
|
13
py-rebound/patches/patch-setup.py
Normal file
13
py-rebound/patches/patch-setup.py
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-setup.py,v 1.1 2015/08/01 22:31:16 jihbed Exp $
|
||||
|
||||
--- setup.py.orig 2015-07-30 16:44:56.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -25,7 +25,7 @@ libreboundmodule = Extension('librebound
|
||||
],
|
||||
include_dirs = ['src'],
|
||||
define_macros=[ ('LIBREBOUND', None) ],
|
||||
- extra_compile_args=['-fstrict-aliasing', '-O3','-std=c99','-march=native','-Wno-unknown-pragmas', '-DLIBREBOUND', '-D_GNU_SOURCE', '-fPIC'],
|
||||
+ extra_compile_args=['-fstrict-aliasing', '-O3','-std=c99','-Wno-unknown-pragmas', '-DLIBREBOUND', '-D_GNU_SOURCE', '-fPIC'],
|
||||
)
|
||||
|
||||
here = os.path.abspath(os.path.dirname(__file__))
|
Loading…
Reference in a new issue