Added patches to fix build on FreeBSD.
This commit is contained in:
parent
43b77a64a4
commit
d44d3e80d2
4 changed files with 61 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2015/02/11 12:03:53 nros Exp $
|
||||
$NetBSD: distinfo,v 1.3 2015/03/04 13:54:26 nros Exp $
|
||||
|
||||
SHA1 (gtkmathview-0.8.0.tar.gz) = dc6db75a64b8dcde05185c3c54eec310dd7b14d6
|
||||
RMD160 (gtkmathview-0.8.0.tar.gz) = 6ed60ee9253fd0fdd9bc595a9178ede5100e1644
|
||||
|
@ -7,7 +7,10 @@ SHA1 (patch-config_Makefile.in) = 9dd3300ec88c1b7643d66bf74ada6c8e9243731e
|
|||
SHA1 (patch-mathmlps_main.cc) = fc0de9ae0a931ce4e23f40505e60e29f30883cb8
|
||||
SHA1 (patch-mathmlsvg_SMS.cc) = 3ac8cfba0faa2a4b908f04458694d2929f6f051f
|
||||
SHA1 (patch-mathmlsvg_main.cc) = 14c53ea91835ac3028a8178a7dd9e7815ee3edf7
|
||||
SHA1 (patch-src_Makefile.in) = 33fc6917ec6a8961401da8b93190773c0f08ebe3
|
||||
SHA1 (patch-src_backend_common_t1lib__T1FontManager.cc) = 1693e499558a582484f511db2f5d4c1b3477198c
|
||||
SHA1 (patch-src_backend_ps_T1__FontDataBase.cc) = fdfc8da5f15159a6ecebcf19381e4eb5169836b8
|
||||
SHA1 (patch-src_engine_mathml_mathVariantAux.cc) = cdd58ece5651b0d0b82389f1c17bb6902e84d7b9
|
||||
SHA1 (patch-src_frontend_common_TemplateBuilder.hh) = 9012c3add8978cec5c6177a0191c0e1da1f2f894
|
||||
SHA1 (patch-src_frontend_common_TemplateElementIterator.hh) = 3d40d650ab6f20bf7beb2b1adbca2ae2e206c538
|
||||
SHA1 (patch-src_view_Makefile.in) = 331bef2dc217ceea19f16fda9c16b1fc26f24abb
|
||||
|
|
12
gtkmathview/patches/patch-src_Makefile.in
Normal file
12
gtkmathview/patches/patch-src_Makefile.in
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-src_Makefile.in,v 1.1 2015/03/04 13:54:26 nros Exp $
|
||||
Don't link stdc++ (this is done anyway). Fixes build on Freebsd with clang.
|
||||
--- src/Makefile.in.orig 2007-10-15 07:06:05.000000000 +0000
|
||||
+++ src/Makefile.in
|
||||
@@ -285,7 +285,6 @@ libmathview_la_LIBADD = \
|
||||
$(MAYBE_BOXML_LIBADD) \
|
||||
$(top_builddir)/src/engine/common/libengine_common.la \
|
||||
$(top_builddir)/src/common/libcommon.la \
|
||||
- -lstdc++ \
|
||||
$(NULL)
|
||||
|
||||
all: all-recursive
|
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-src_backend_common_t1lib__T1FontManager.cc,v 1.1 2015/03/04 13:54:26 nros Exp $
|
||||
getenv needs cstdlib
|
||||
--- src/backend/common/t1lib_T1FontManager.cc.orig 2007-08-17 10:02:44.000000000 +0000
|
||||
+++ src/backend/common/t1lib_T1FontManager.cc
|
||||
@@ -18,6 +18,7 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <cstdlib>
|
||||
#include <t1lib.h>
|
||||
|
||||
#include "AbstractLogger.hh"
|
33
gtkmathview/patches/patch-src_view_Makefile.in
Normal file
33
gtkmathview/patches/patch-src_view_Makefile.in
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-src_view_Makefile.in,v 1.1 2015/03/04 13:54:26 nros Exp $
|
||||
Don't link stdc++ (this is done anyway). Fixes build on FreeBSD with clang.
|
||||
--- src/view/Makefile.in.orig 2007-10-15 07:06:24.000000000 +0000
|
||||
+++ src/view/Makefile.in
|
||||
@@ -305,28 +305,24 @@ libmathview_frontend_custom_reader_la_LI
|
||||
$(top_builddir)/src/frontend/libxml2_reader/libfrontend_libxml2_reader.la \
|
||||
$(top_builddir)/src/frontend/custom_reader/libfrontend_custom_reader.la \
|
||||
$(top_builddir)/src/libmathview.la \
|
||||
- -lstdc++ \
|
||||
$(NULL)
|
||||
|
||||
libmathview_frontend_libxml2_reader_la_LIBADD = \
|
||||
$(XML_LIBS) \
|
||||
$(top_builddir)/src/frontend/libxml2_reader/libfrontend_libxml2_reader.la \
|
||||
$(top_builddir)/src/libmathview.la \
|
||||
- -lstdc++ \
|
||||
$(NULL)
|
||||
|
||||
libmathview_frontend_libxml2_la_LIBADD = \
|
||||
$(XML_LIBS) \
|
||||
$(top_builddir)/src/frontend/libxml2/libfrontend_libxml2.la \
|
||||
$(top_builddir)/src/libmathview.la \
|
||||
- -lstdc++ \
|
||||
$(NULL)
|
||||
|
||||
libmathview_frontend_gmetadom_la_LIBADD = \
|
||||
$(DOM_LIBS) \
|
||||
$(top_builddir)/src/frontend/gmetadom/libfrontend_gmetadom.la \
|
||||
$(top_builddir)/src/libmathview.la \
|
||||
- -lstdc++ \
|
||||
$(NULL)
|
||||
|
||||
libmathview_frontend_custom_reader_la_CPPFLAGS = -DGMV_FrontEnd_DLL
|
Loading…
Reference in a new issue