Import py25-ibus-anthy-1.1.0.20090814 as wip/ibus-anthy.

Japanse input engine for IBus.
This commit is contained in:
OBATA Akio 2009-08-30 08:30:16 +00:00 committed by Thomas Klausner
parent 437b21cef8
commit d4b82808f2
6 changed files with 116 additions and 0 deletions

1
ibus-anthy/DESCR Normal file
View file

@ -0,0 +1 @@
Japanse input engine for IBus.

29
ibus-anthy/Makefile Normal file
View file

@ -0,0 +1,29 @@
# $NetBSD: Makefile,v 1.1.1.1 2009/08/30 08:30:16 obache Exp $
#
DISTNAME= ibus-anthy-1.1.0.20090814
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= inputmethod japanese
MASTER_SITES= http://ibus.googlecode.com/files/
MAINTAINER= obache@NetBSD.org
HOMEPAGE= http://code.google.com/p/ibus/
COMMENT= Japanese input engine for IBus
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
CONFLICTS+= py[0-9]*-ibus-anthy-[0-9]*
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
USE_LANGUAGES= c
USE_TOOLS+= pkg-config msgfmt gmake
.include "../../devel/swig/buildlink3.mk"
PY_PATCHPLIST= yes
.include "../../lang/python/extension.mk"
.include "../../inputmethod/anthy/buildlink3.mk"
.include "../../wip/ibus/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

44
ibus-anthy/PLIST Normal file
View file

@ -0,0 +1,44 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2009/08/30 08:30:16 obache Exp $
${PYSITELIB}/_anthy.la
${PYSITELIB}/anthy.py
libexec/ibus-engine-anthy
libexec/ibus-setup-anthy
share/ibus-anthy/engine/engine.py
share/ibus-anthy/engine/engine.pyc
share/ibus-anthy/engine/engine.pyo
share/ibus-anthy/engine/factory.py
share/ibus-anthy/engine/factory.pyc
share/ibus-anthy/engine/factory.pyo
share/ibus-anthy/engine/jastring.py
share/ibus-anthy/engine/jastring.pyc
share/ibus-anthy/engine/jastring.pyo
share/ibus-anthy/engine/kana.py
share/ibus-anthy/engine/kana.pyc
share/ibus-anthy/engine/kana.pyo
share/ibus-anthy/engine/main.py
share/ibus-anthy/engine/main.pyc
share/ibus-anthy/engine/main.pyo
share/ibus-anthy/engine/romaji.py
share/ibus-anthy/engine/romaji.pyc
share/ibus-anthy/engine/romaji.pyo
share/ibus-anthy/engine/segment.py
share/ibus-anthy/engine/segment.pyc
share/ibus-anthy/engine/segment.pyo
share/ibus-anthy/engine/tables.py
share/ibus-anthy/engine/tables.pyc
share/ibus-anthy/engine/tables.pyo
share/ibus-anthy/icons/ibus-anthy.png
share/ibus-anthy/setup/anthyprefs.py
share/ibus-anthy/setup/anthyprefs.pyc
share/ibus-anthy/setup/anthyprefs.pyo
share/ibus-anthy/setup/main.py
share/ibus-anthy/setup/main.pyc
share/ibus-anthy/setup/main.pyo
share/ibus-anthy/setup/prefs.py
share/ibus-anthy/setup/prefs.pyc
share/ibus-anthy/setup/prefs.pyo
share/ibus-anthy/setup/setup.glade
share/ibus/component/anthy.xml
share/locale/fr/LC_MESSAGES/ibus-anthy.mo
share/locale/ja/LC_MESSAGES/ibus-anthy.mo
share/locale/zh_CN/LC_MESSAGES/ibus-anthy.mo

7
ibus-anthy/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2009/08/30 08:30:16 obache Exp $
SHA1 (ibus-anthy-1.1.0.20090814.tar.gz) = 11d0fe8f56fabf07cebaa808d0af40aa52b2c780
RMD160 (ibus-anthy-1.1.0.20090814.tar.gz) = ebf7bf66178ad23581bcee32990582b519655782
Size (ibus-anthy-1.1.0.20090814.tar.gz) = 421965 bytes
SHA1 (patch-aa) = dbe016c97426577d081937b9d1759081a03673db
SHA1 (patch-ab) = 672f78ecb1f898c2585550a863f085ddf370a658

View file

@ -0,0 +1,22 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/08/30 08:30:16 obache Exp $
--- configure.orig 2009-06-03 03:54:35.000000000 +0000
+++ configure
@@ -17027,7 +17027,7 @@ $as_echo "no" >&6; }
fi
-if test x"$SWIG" == x""; then
+if test x"$SWIG" = x""; then
{ { $as_echo "$as_me:$LINENO: error: can not find swig" >&5
$as_echo "$as_me: error: can not find swig" >&2;}
{ (exit 1); exit 1; }; }
@@ -17305,7 +17305,7 @@ $as_echo "no" >&6; }
fi
-if test x"$PYTHON_CONFIG" == x""; then
+if test x"$PYTHON_CONFIG" = x""; then
# Extract the first word of "python-config", so it can be a program name with args.
set dummy python-config; ac_word=$2
{ $as_echo "$as_me:$LINENO: checking for $ac_word" >&5

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2009/08/30 08:30:16 obache Exp $
--- engine/Makefile.in.orig 2009-06-03 03:54:34.000000000 +0000
+++ engine/Makefile.in
@@ -705,7 +705,7 @@ uninstall-am: uninstall-anthyDATA uninst
anthy.py anthy_wrap.c: anthy.i
- $(SWIG) -python -I/usr/include -o anthy_wrap.c $(srcdir)/anthy.i
+ $(SWIG) -python -I/usr/include ${ANTHY_CFLAGS} -o anthy_wrap.c $(srcdir)/anthy.i
anthy.xml: anthy.xml.in
( \