Initial import of ogmrip-0.12.3:

OGMRip is an application and a set of libraries for ripping and
encoding DVD into AVI, OGM, MP4, or Matroska files using a wide
variety of codecs. It relies on mplayer, mencoder, ogmtools,
mkvtoolnix, mp4box, oggenc, lame, and faac to perform its tasks.

The GUI features a clean HIG-compliant GNOME 2 interface and tries
to minimize as much as possible esoteric settings.

A CLI client is also available.

TODO:
Heavily dependent on Linux/FreeBSD features.
Might be possible to make it work there without much effort.

0.13.0 out.
This commit is contained in:
Thomas Klausner 2009-07-18 15:27:40 +00:00
parent 41a71ba285
commit d4d5c63199
6 changed files with 144 additions and 0 deletions

9
ogmrip/DESCR Normal file
View file

@ -0,0 +1,9 @@
OGMRip is an application and a set of libraries for ripping and
encoding DVD into AVI, OGM, MP4, or Matroska files using a wide
variety of codecs. It relies on mplayer, mencoder, ogmtools,
mkvtoolnix, mp4box, oggenc, lame, and faac to perform its tasks.
The GUI features a clean HIG-compliant GNOME 2 interface and tries
to minimize as much as possible esoteric settings.
A CLI client is also available.

57
ogmrip/Makefile Normal file
View file

@ -0,0 +1,57 @@
# $NetBSD: Makefile,v 1.1.1.1 2009/07/18 15:27:40 thomasklausner Exp $
#
DISTNAME= ogmrip-0.12.3
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ogmrip/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://ogmrip.sourceforge.net/
COMMENT= Application for ripping and encoding DVD into DivX/OGM files
DEPENDS+= mencoder-[0-9]*:../../multimedia/mencoder
DEPENDS+= mkvtoolnix-[0-9]*:../../multimedia/mkvtoolnix
DEPENDS+= mplayer-[0-9]*:../../multimedia/mplayer
DEPENDS+= ogmtools-[0-9]*:../../multimedia/ogmtools
DEPENDS+= vorbis-tools-[0-9]*:../../audio/vorbis-tools
DEPENDS+= gocr-[0-9]*:../../graphics/gocr
BUILD_DEPENDS+= gtk-doc-[0-9]*:../../textproc/gtk-doc
BUILD_DEPENDS+= gsed-[0-9]*:../../textproc/gsed
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= SED_PROG=${LOCALBASE}/bin/gsed
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
USE_TOOLS+= gmake intltool pkg-config gsed
PKGCONFIG_OVERRIDE+= ${WRKSRC}/data/ogmspawn.pc.in
PKGCONFIG_OVERRIDE+= ${WRKSRC}/data/ogmdvd.pc.in
PKGCONFIG_OVERRIDE+= ${WRKSRC}/data/ogmrip.pc.in
GCONF_SCHEMAS+= ogmrip.schemas
BUILDLINK_TRANSFORM+= rm:-Werror
.include "../../devel/GConf/schemas.mk"
.include "../../audio/faac/buildlink3.mk"
.include "../../audio/lame/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
#.include "../../devel/libgnome/buildlink3.mk"
#.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../devel/libglade/buildlink3.mk"
.include "../../multimedia/libdvdread/buildlink3.mk"
.include "../../multimedia/libtheora/buildlink3.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../sysutils/hal/buildlink3.mk"
.include "../../sysutils/libnotify/buildlink3.mk"
# subtitle spell checking
.include "../../textproc/enchant/buildlink3.mk"
.include "../../textproc/enca/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

48
ogmrip/PLIST Normal file
View file

@ -0,0 +1,48 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2009/07/18 15:27:40 thomasklausner Exp $
bin/ogmrip
bin/srttool
bin/subp2pgm
include/ogmdvd.h
include/ogmrip/ogmrip-acopy.h
include/ogmrip/ogmrip-audio.h
include/ogmrip/ogmrip-avi.h
include/ogmrip/ogmrip-codec.h
include/ogmrip/ogmrip-lavc.h
include/ogmrip/ogmrip-merge.h
include/ogmrip/ogmrip-misc.h
include/ogmrip/ogmrip-mp3.h
include/ogmrip/ogmrip-mux.h
include/ogmrip/ogmrip-split.h
include/ogmrip/ogmrip-subp.h
include/ogmrip/ogmrip-tools.h
include/ogmrip/ogmrip-video.h
include/ogmrip/ogmrip-vobsub.h
include/ogmrip/ogmrip-vorbis.h
include/ogmrip/ogmrip-wav.h
include/ogmrip/ogmrip-xvid.h
include/ogmrip/ogmrip.h
include/ogmspawn/ogmsp-bin.h
include/ogmspawn/ogmsp-container.h
include/ogmspawn/ogmsp-enums.h
include/ogmspawn/ogmsp-exec.h
include/ogmspawn/ogmsp-list.h
include/ogmspawn/ogmsp-marshal.h
include/ogmspawn/ogmsp-pipeline.h
include/ogmspawn/ogmsp-queue.h
include/ogmspawn/ogmsp-spawn.h
include/ogmspawn/ogmspawn.h
lib/libogmdvd.la
lib/libogmrip.la
lib/libogmspawn.la
lib/pkgconfig/ogmdvd.pc
lib/pkgconfig/ogmrip.pc
lib/pkgconfig/ogmspawn.pc
share/applications/ogmrip.desktop
share/gconf/schemas/ogmrip.schemas
${PKGLOCALEDIR}/locale/en/LC_MESSAGES/ogmrip.mo
${PKGLOCALEDIR}/locale/fr/LC_MESSAGES/ogmrip.mo
share/ogmrip/ogmrip-main.glade
share/ogmrip/ogmrip-pref.glade
share/ogmrip/ogmrip-progress.glade
share/ogmrip/ogmrip-spell.glade
share/pixmaps/ogmrip.png

4
ogmrip/TODO Normal file
View file

@ -0,0 +1,4 @@
Heavily dependent on Linux/FreeBSD features.
Might be possible to make it work there without much effort.
0.13.0 out.

6
ogmrip/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2009/07/18 15:27:40 thomasklausner Exp $
SHA1 (ogmrip-0.12.3.tar.gz) = 237a9d59acb6d45189dd31613898ff4ffd09bc43
RMD160 (ogmrip-0.12.3.tar.gz) = 7f91b5bb763646a67b2f50080f8a3bb36acd13ff
Size (ogmrip-0.12.3.tar.gz) = 2883021 bytes
SHA1 (patch-aa) = 7d4daa19a44df2657f2bd28994126fe264ff144c

20
ogmrip/patches/patch-aa Normal file
View file

@ -0,0 +1,20 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/07/18 15:27:40 thomasklausner Exp $
--- libbacon/transport.hxx.orig 2007-10-07 19:03:55.000000000 +0000
+++ libbacon/transport.hxx
@@ -6,6 +6,15 @@
// For further details see http://fy.chalmers.se/~appro/linux/DVD+RW/
//
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
+
+#ifdef HAVE_STATVFS
+#include <sys/statvfs.h>
+#define statfs statvfs
+#endif
+
#if defined(__unix) || defined(__unix__)
#include <stdio.h>
#include <stdlib.h>